RDPCrystalEDILibrary Namespace

RDPCrystal EDI Library API
RDPCrystalEDILibrary Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary
RDPCrystal EDI Library
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary
Namespace RDPCrystalEDILibrary
namespace RDPCrystalEDILibrary
Types
All Types Classes Enumerations Delegates
Icon | Type | Description
 | Ack997Generator | Resonsible for generating a 997 Acknowledgement EDI File
 | Ack999Generator | Resonsible for generating an 999 Acknowledgement EDI File
 | Author | Author
 | HTTPS..::..CertificateValidationDelegate |
 | CertificationEventArgs | CertificationEventArgs
 | Characters | Regularly used characters within library
 | Code | Class used by EDIRulesCreator to create a code object
 | CodeList | Represents a set of codes that a DataElement can contain
 | DataElement | A DataElement Object
 | DataElements | A collection of DataElement Objects
 | DataSegment | A DataSegment Object
 | DataSegments | Summary description for DataSegments.
 | Delimiters | Represents the delimiters of X12 and EDIFACT standards
 | DocumentCreator |
 | HTTP..::..DownloadFileCompletedDelegate |
 | HTTP..::..DownloadFileProgressChangedDelegate |
 | EDIDocument | Creates EDI X12 and EDIFACT document files
 | EDIDocumentException | Exception thrown when an exception occurred while generating an EDI document
 | EDIError | Represents a general EDI error. Errors are available after validation
 | EDIFACTStrings |
 | EDIFileJoiner | Component used to join EDI files
 | EDIFileLoader | Parses and loads EDI files without any rules
 | EDIFileLoader..::..EDIFileLoadingCompletedEvent | Delegate used for raising and event after EDI file loading has completed
 | EDIFileParser |
 | EDIFileScrubber | Parses and scrubs EDI files
 | EDIFileScrubber..::..EDIFileScrubbingCompletedEvent | Delegate used for raising and event after EDI file scrubbing has completed
 | EDIFileSplitter | Component used to split EDI files
 | EDILightWeightDocument | A light weight version of the EDIDocument used to creates EDI X12 and EDIFACT document files
 | EDIRulesCreator | Allows EDI Rules to be created
 | EDIRulesReader | Reader that reads and loads EDI rules from an EDI file
 | EDIRulesReaderEventArg | Represents an general error that may occur while parsing an EDI rules file
 | EDISource | Represents the source of the EDI data to validate
 | EDISpecification | Reponsible for retrieving EDI message specific data
 | EDIValidationMessage | Represents different EDI messages
 | EDIValidator | Validates and loads EDI X12 and EDIFACT files
 | EDIWarning | Represents a general EDI warning. Warnings are available after validation
 | EDIXmlConverter | Class responsible for generating XML data from EDI data
 | Element | Basic element used by EDI Rules Reader
 | ElementCodeList | Represents a list of values that an element can contain
 | ElementConditionalConstraint | Represents a conditional constraint for a segment
 | ElementCounterDisplay | Used by EDIRuleCreator
 | ElementDataType | Represents the possible element types
 | ElementEqualityDisplay | Used by EDIRuleCreator
 | ElementExclusionConstraint | Object that holds a exclusiong constraint for a segment
 | ElementFormat | Used when creating EDI Rules rules
 | ElementFormatInfo | Represents format information for an Element
 | ElementFormatting | Used by EDI Rules Reader for element formatting
 | ElementListConditionalConstraint | Represents a list conditional contraints
 | ElementPairConstraint | Represents a element pair relationship
 | ElementPosition | Represents the position of an element with the EDI file
 | ElementRequiredConstraint | Represents a required constraint for a segment
 | ElementSchema | Represents an element schema used by EDI Rules Reader
 | ElementValueInfo | Represents an element and its possible values at a specific location
 | EDIRulesReader..::..ErrorEvent |
 | FileJoinLevel | Enum to specify where file joining should occur at the Header level(ST) or the Functional Group level (GS). Used by EDIFileJoiner
 | FileLoadingEventArgs | Represents data pertaining to the time it took to load an EDI file
 | FileLoadingException | An exception that represents an errors that occur while loading an EDI file with the EDIFileLoader component
 | FileOperationCompletedEventArgs | FileOperationCompletedEventArgs
 | FileOperationStatus |
 | EDIFileParser..::..FileProgress |
 | FileSplitLevel | Enum to specify where file splitting should occur at the Header level(ST) or the Functional Group level (GS). Used by EDIFileSplitter
 | FileType | EDI File Type
 | Format | Represents a regular expression format that a data element's value must conform to
 | FormCell | An object used to encapulate the data of a cell and formatting
 | FormPrinter | Summary description for Form.
 | FoundSegmentCollection |
 | GeneralEvent | General event delegate
 | EDIRulesReader..::..GeneralEvent |
 | EDIValidator..::..GeneralEvent | Delegate used for raising general events relating to progress
 | GeneralEventArgs |
 | GeneralTypeConverter |
 | HTTP | HTTP component
 | HTTPS | HTTPS Component
 | LicenseException | Exception thrown when a license is invalid
 | LightWeightElement | Represents a lightweight data element
 | LightWeightElements |
 | LightWeightLoop | A light weight version of the Loop class
 | LightWeightLoops | A collection of LightWeightLoops objects
 | LightWeightSegment | A DataSegment Object
 | LightWeightSegments |
 | Log | Contains library specific error messages
 | Loop | Summary description for Loop.
 | Loops |
 | LoopSchema |
 | Mask | Represents a mask that segment's use to decide how their elements are used
 | MaximumErrorLimitReachedException | Maximum number of errors reached event
 | PackageLicense | Responsible for checking that a valid license exist
 | RuleDisplay | Used by EDIRuleCreator
 | RuleOperator |
 | ScrubPosition |
 | ScrubRule |
 | Segment |
 | SegmentSchema | Represent basic segment information used by EDIRulesReader and EDIRulesCreator
 | SelfRule | Represents a rule that a segment uses to check itself
 | SemanticRule | Represents a rule that a segment or element must conform to
 | SemanticsProcessor | This class is resonsible for taking a string and extracting the rules from it
 | SnipTestLevel | Snip Levels
 | SummaryDisplay | Used by EDIRuleCreator
 | TrialLicenseProvider | Summary description for CrystalLabelsLicenseProvider.
 | HTTP..::..UploadFileCompletedDelegate |
 | HTTP..::..UploadFileProgressChangedDelegate |
 | Usage | Represents how a segment/element usage requirements
 | EDIValidator..::..ValidationCompletedEvent | Delegate used for raising an event while validation is being performed
 | ValidationEventsArgs | Represents data pertaining to the time it took to validate a file and if the file has passed validation
 | ValidationException | An exception that represents an errors that occur while validation is taking place
 | EDIValidator..::..ValidationStartedEvent | Delegate used for raising an event when validation begins
 | X12Strings |
 | XmlConfigOptions | Xml Configuration Options


Ack997Generator Class

Ack997Generator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator
Resonsible for generating a 997 Acknowledgement EDI File
Declaration Syntax
C# Visual Basic Visual C++
public class Ack997Generator
Public Class Ack997Generator
public ref class Ack997Generator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ack997Generator()()()() | Initializes a new instance of the Ack997Generator class.
 | Delimiters | Segment and element delimiters
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Generate997Acknowledgement(EDIValidator) | Generate a 997 Acknowledgement EDI file.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaddingChar | Char used to pad empty spaces
 | SegmentSeparatorString | String to insert between segments for formatting
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Ack997Generator

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Ack997Generator Constructor

Ack997Generator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► Ack997Generator()()()()
Initializes a new instance of the Ack997Generator class.
Declaration Syntax
C# Visual Basic Visual C++
public Ack997Generator()
Public Sub New
public:
Ack997Generator()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► Delimiters
Segment and element delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Generate997Acknowledgement Method (ediValidator)

Generate997Acknowledgement Method (ediValidator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► Generate997Acknowledgement(EDIValidator)
Generate a 997 Acknowledgement EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument Generate997Acknowledgement(
    EDIValidator ediValidator
)
Public Function Generate997Acknowledgement ( _
    ediValidator As EDIValidator _
) As EDIDocument
public:
EDIDocument^ Generate997Acknowledgement(
    EDIValidator^ ediValidator
)
Parameters
ediValidator (EDIValidator)
The edivalidator
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PaddingChar Property

PaddingChar Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► PaddingChar
Char used to pad empty spaces
Declaration Syntax
C# Visual Basic Visual C++
public char PaddingChar { get; set; }
Public Property PaddingChar As Char
    Get
    Set
public:
property wchar_t PaddingChar {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSeparatorString Property

SegmentSeparatorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack997Generator ► SegmentSeparatorString
String to insert between segments for formatting
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentSeparatorString { get; set; }
Public Property SegmentSeparatorString As String
    Get
    Set
public:
property String^ SegmentSeparatorString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Ack999Generator Class

Ack999Generator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator
Resonsible for generating an 999 Acknowledgement EDI File
Declaration Syntax
C# Visual Basic Visual C++
public class Ack999Generator
Public Class Ack999Generator
public ref class Ack999Generator
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Ack999Generator()()()() | Initializes a new instance of the Ack997Generator class.
 | Delimiters | Segment and element delimiters
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Generate999Acknowledgement(EDIValidator) | Generate a 999 Acknowledgement EDI file.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaddingChar | Char used to pad empty spaces
 | SegmentSeparatorString | String to insert between segments for formatting
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Ack999Generator

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Ack999Generator Constructor

Ack999Generator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► Ack999Generator()()()()
Initializes a new instance of the Ack997Generator class.
Declaration Syntax
C# Visual Basic Visual C++
public Ack999Generator()
Public Sub New
public:
Ack999Generator()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► Delimiters
Segment and element delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Generate999Acknowledgement Method (ediValidator)

Generate999Acknowledgement Method (ediValidator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► Generate999Acknowledgement(EDIValidator)
Generate a 999 Acknowledgement EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument Generate999Acknowledgement(
    EDIValidator ediValidator
)
Public Function Generate999Acknowledgement ( _
    ediValidator As EDIValidator _
) As EDIDocument
public:
EDIDocument^ Generate999Acknowledgement(
    EDIValidator^ ediValidator
)
Parameters
ediValidator (EDIValidator)
The edivalidator
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PaddingChar Property

PaddingChar Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► PaddingChar
Char used to pad empty spaces
Declaration Syntax
C# Visual Basic Visual C++
public char PaddingChar { get; set; }
Public Property PaddingChar As Char
    Get
    Set
public:
property wchar_t PaddingChar {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSeparatorString Property

SegmentSeparatorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Ack999Generator ► SegmentSeparatorString
String to insert between segments for formatting
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentSeparatorString { get; set; }
Public Property SegmentSeparatorString As String
    Get
    Set
public:
property String^ SegmentSeparatorString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Author Class

Author Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Author
Author
Declaration Syntax
C# Visual Basic Visual C++
public class Author : Attribute
Public Class Author _
    Inherits Attribute
public ref class Author : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Author()()()() | Initializes a new instance of the Author class.
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
 | Version | Gets the version.
Inheritance Hierarchy
Object
 | Attribute
 |  | Author

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Author Constructor

Author Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Author ► Author()()()()
Initializes a new instance of the Author class.
Declaration Syntax
C# Visual Basic Visual C++
public Author()
Public Sub New
public:
Author()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Author ► Name
Gets or sets the name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
Value
The name.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Version Property

Version Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Author ► Version
Gets the version.
Declaration Syntax
C# Visual Basic Visual C++
public double Version { get; }
Public ReadOnly Property Version As Double
    Get
public:
property double Version {
    double get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CertificationEventArgs Class

CertificationEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs
CertificationEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class CertificationEventArgs : EventArgs
Public Class CertificationEventArgs _
    Inherits EventArgs
public ref class CertificationEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CertificationEventArgs()()()() | Initializes a new instance of the CertificationEventArgs class
 | Cancel | Gets or sets a value indicating whether this CertificationEventArgs is cancel.
 | Certificate | Gets or sets the certificate.
 | Chain | Gets or sets the chain.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SslPolicyErrors | Gets or sets the SSL policy errors.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | CertificationEventArgs

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CertificationEventArgs Constructor

CertificationEventArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► CertificationEventArgs()()()()
Initializes a new instance of the CertificationEventArgs class
Declaration Syntax
C# Visual Basic Visual C++
public CertificationEventArgs()
Public Sub New
public:
CertificationEventArgs()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Cancel Property

Cancel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► Cancel
Gets or sets a value indicating whether this CertificationEventArgs is cancel.
Declaration Syntax
C# Visual Basic Visual C++
public bool Cancel { get; set; }
Public Property Cancel As Boolean
    Get
    Set
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}
Value
true if cancel; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Certificate Property

Certificate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► Certificate
Gets or sets the certificate.
Declaration Syntax
C# Visual Basic Visual C++
public X509Certificate Certificate { get; set; }
Public Property Certificate As X509Certificate
    Get
    Set
public:
property X509Certificate^ Certificate {
    X509Certificate^ get ();
    void set (X509Certificate^ value);
}
Value
The certificate.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Chain Property

Chain Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► Chain
Gets or sets the chain.
Declaration Syntax
C# Visual Basic Visual C++
public X509Chain Chain { get; set; }
Public Property Chain As X509Chain
    Get
    Set
public:
property X509Chain^ Chain {
    X509Chain^ get ();
    void set (X509Chain^ value);
}
Value
The chain.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SslPolicyErrors Property

SslPolicyErrors Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CertificationEventArgs ► SslPolicyErrors
Gets or sets the SSL policy errors.
Declaration Syntax
C# Visual Basic Visual C++
public SslPolicyErrors SslPolicyErrors { get; set; }
Public Property SslPolicyErrors As SslPolicyErrors
    Get
    Set
public:
property SslPolicyErrors SslPolicyErrors {
    SslPolicyErrors get ();
    void set (SslPolicyErrors value);
}
Value
The SSL policy errors.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Characters Class

Characters Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters
Regularly used characters within library
Declaration Syntax
C# Visual Basic Visual C++
public class Characters
Public Class Characters
public ref class Characters
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Characters()()()() | Initializes a new instance of the Characters class
 | APOSTROPHE |
 | ASTERISK |
 | ASTERISK_STR |
 | ATSIGN |
 | CARRET |
 | CARRIAGE_RETURN |
 | COMMA |
 | COMPOSITE_CHAR |
 | CONDITIONAL_CHAR |
 | DASH |
 | DASH_STR |
 | DEPENDENT |
 | DOT |
 | EDIFACT_SERVICE_CHAR |
 | EQUAL |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EXCLAMATION_CHAR |
 | EXCLUSION_CONDITIONAL_CHAR |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FORWARD_SLASH |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LEFT_BRACKET |
 | LEFT_CURLY_BRACES |
 | LEFT_CURLY_BRACES_STR |
 | LIST_CONDITIONAL_CHAR |
 | MANDATORY |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NOTUSED |
 | NUMBER_SIGN |
 | OPTIONAL |
 | PAIR_CHAR |
 | PLUS |
 | REQUIREMENT_CHAR |
 | RETURN_CHAR |
 | RIGHT_BRACKET |
 | RIGHT_CURLY_BRACES |
 | RIGHT_CURLY_BRACES_STR |
 | SEMICOLON |
 | SPACE_CHAR |
 | SPACE_STR |
 | TILDA |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | USAGE_MANDATORY |
 | USAGE_NOTUSED |
 | USAGE_OPTIONAL |
Inheritance Hierarchy
Object
Characters

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Characters Constructor

Characters Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► Characters()()()()
Initializes a new instance of the Characters class
Declaration Syntax
C# Visual Basic Visual C++
public Characters()
Public Sub New
public:
Characters()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


APOSTROPHE Field

APOSTROPHE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► APOSTROPHE
Declaration Syntax
C# Visual Basic Visual C++
public const char APOSTROPHE
Public Const APOSTROPHE As Char
public:
literal wchar_t APOSTROPHE

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ASTERISK Field

ASTERISK Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► ASTERISK
Declaration Syntax
C# Visual Basic Visual C++
public const char ASTERISK
Public Const ASTERISK As Char
public:
literal wchar_t ASTERISK

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ASTERISK_STR Field

ASTERISK_STR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► ASTERISK_STR
Declaration Syntax
C# Visual Basic Visual C++
public const string ASTERISK_STR
Public Const ASTERISK_STR As String
public:
literal String^ ASTERISK_STR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ATSIGN Field

ATSIGN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► ATSIGN
Declaration Syntax
C# Visual Basic Visual C++
public const char ATSIGN
Public Const ATSIGN As Char
public:
literal wchar_t ATSIGN

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CARRET Field

CARRET Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► CARRET
Declaration Syntax
C# Visual Basic Visual C++
public const char CARRET
Public Const CARRET As Char
public:
literal wchar_t CARRET

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CARRIAGE_RETURN Field

CARRIAGE_RETURN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► CARRIAGE_RETURN
Declaration Syntax
C# Visual Basic Visual C++
public const char CARRIAGE_RETURN
Public Const CARRIAGE_RETURN As Char
public:
literal wchar_t CARRIAGE_RETURN

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


COMMA Field

COMMA Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► COMMA
Declaration Syntax
C# Visual Basic Visual C++
public const char COMMA
Public Const COMMA As Char
public:
literal wchar_t COMMA

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


COMPOSITE_CHAR Field

COMPOSITE_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► COMPOSITE_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char COMPOSITE_CHAR
Public Const COMPOSITE_CHAR As Char
public:
literal wchar_t COMPOSITE_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CONDITIONAL_CHAR Field

CONDITIONAL_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► CONDITIONAL_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char CONDITIONAL_CHAR
Public Const CONDITIONAL_CHAR As Char
public:
literal wchar_t CONDITIONAL_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DASH Field

DASH Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► DASH
Declaration Syntax
C# Visual Basic Visual C++
public const char DASH
Public Const DASH As Char
public:
literal wchar_t DASH

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DASH_STR Field

DASH_STR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► DASH_STR
Declaration Syntax
C# Visual Basic Visual C++
public const string DASH_STR
Public Const DASH_STR As String
public:
literal String^ DASH_STR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DEPENDENT Field

DEPENDENT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► DEPENDENT
Declaration Syntax
C# Visual Basic Visual C++
public const string DEPENDENT
Public Const DEPENDENT As String
public:
literal String^ DEPENDENT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DOT Field

DOT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► DOT
Declaration Syntax
C# Visual Basic Visual C++
public const char DOT
Public Const DOT As Char
public:
literal wchar_t DOT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFACT_SERVICE_CHAR Field

EDIFACT_SERVICE_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► EDIFACT_SERVICE_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char EDIFACT_SERVICE_CHAR
Public Const EDIFACT_SERVICE_CHAR As Char
public:
literal wchar_t EDIFACT_SERVICE_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EQUAL Field

EQUAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► EQUAL
Declaration Syntax
C# Visual Basic Visual C++
public const char EQUAL
Public Const EQUAL As Char
public:
literal wchar_t EQUAL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EXCLAMATION_CHAR Field

EXCLAMATION_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► EXCLAMATION_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char EXCLAMATION_CHAR
Public Const EXCLAMATION_CHAR As Char
public:
literal wchar_t EXCLAMATION_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EXCLUSION_CONDITIONAL_CHAR Field

EXCLUSION_CONDITIONAL_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► EXCLUSION_CONDITIONAL_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char EXCLUSION_CONDITIONAL_CHAR
Public Const EXCLUSION_CONDITIONAL_CHAR As Char
public:
literal wchar_t EXCLUSION_CONDITIONAL_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FORWARD_SLASH Field

FORWARD_SLASH Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► FORWARD_SLASH
Declaration Syntax
C# Visual Basic Visual C++
public const char FORWARD_SLASH
Public Const FORWARD_SLASH As Char
public:
literal wchar_t FORWARD_SLASH

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LEFT_BRACKET Field

LEFT_BRACKET Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► LEFT_BRACKET
Declaration Syntax
C# Visual Basic Visual C++
public const char LEFT_BRACKET
Public Const LEFT_BRACKET As Char
public:
literal wchar_t LEFT_BRACKET

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LEFT_CURLY_BRACES Field

LEFT_CURLY_BRACES Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► LEFT_CURLY_BRACES
Declaration Syntax
C# Visual Basic Visual C++
public const char LEFT_CURLY_BRACES
Public Const LEFT_CURLY_BRACES As Char
public:
literal wchar_t LEFT_CURLY_BRACES

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LEFT_CURLY_BRACES_STR Field

LEFT_CURLY_BRACES_STR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► LEFT_CURLY_BRACES_STR
Declaration Syntax
C# Visual Basic Visual C++
public const string LEFT_CURLY_BRACES_STR
Public Const LEFT_CURLY_BRACES_STR As String
public:
literal String^ LEFT_CURLY_BRACES_STR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LIST_CONDITIONAL_CHAR Field

LIST_CONDITIONAL_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► LIST_CONDITIONAL_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char LIST_CONDITIONAL_CHAR
Public Const LIST_CONDITIONAL_CHAR As Char
public:
literal wchar_t LIST_CONDITIONAL_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MANDATORY Field

MANDATORY Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► MANDATORY
Declaration Syntax
C# Visual Basic Visual C++
public const string MANDATORY
Public Const MANDATORY As String
public:
literal String^ MANDATORY

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NOTUSED Field

NOTUSED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► NOTUSED
Declaration Syntax
C# Visual Basic Visual C++
public const string NOTUSED
Public Const NOTUSED As String
public:
literal String^ NOTUSED

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NUMBER_SIGN Field

NUMBER_SIGN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► NUMBER_SIGN
Declaration Syntax
C# Visual Basic Visual C++
public const char NUMBER_SIGN
Public Const NUMBER_SIGN As Char
public:
literal wchar_t NUMBER_SIGN

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OPTIONAL Field

OPTIONAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► OPTIONAL
Declaration Syntax
C# Visual Basic Visual C++
public const string OPTIONAL
Public Const OPTIONAL As String
public:
literal String^ OPTIONAL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PAIR_CHAR Field

PAIR_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► PAIR_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char PAIR_CHAR
Public Const PAIR_CHAR As Char
public:
literal wchar_t PAIR_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PLUS Field

PLUS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► PLUS
Declaration Syntax
C# Visual Basic Visual C++
public const char PLUS
Public Const PLUS As Char
public:
literal wchar_t PLUS

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


REQUIREMENT_CHAR Field

REQUIREMENT_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► REQUIREMENT_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char REQUIREMENT_CHAR
Public Const REQUIREMENT_CHAR As Char
public:
literal wchar_t REQUIREMENT_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RETURN_CHAR Field

RETURN_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► RETURN_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char RETURN_CHAR
Public Const RETURN_CHAR As Char
public:
literal wchar_t RETURN_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RIGHT_BRACKET Field

RIGHT_BRACKET Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► RIGHT_BRACKET
Declaration Syntax
C# Visual Basic Visual C++
public const char RIGHT_BRACKET
Public Const RIGHT_BRACKET As Char
public:
literal wchar_t RIGHT_BRACKET

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RIGHT_CURLY_BRACES Field

RIGHT_CURLY_BRACES Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► RIGHT_CURLY_BRACES
Declaration Syntax
C# Visual Basic Visual C++
public const char RIGHT_CURLY_BRACES
Public Const RIGHT_CURLY_BRACES As Char
public:
literal wchar_t RIGHT_CURLY_BRACES

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RIGHT_CURLY_BRACES_STR Field

RIGHT_CURLY_BRACES_STR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► RIGHT_CURLY_BRACES_STR
Declaration Syntax
C# Visual Basic Visual C++
public const string RIGHT_CURLY_BRACES_STR
Public Const RIGHT_CURLY_BRACES_STR As String
public:
literal String^ RIGHT_CURLY_BRACES_STR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SEMICOLON Field

SEMICOLON Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► SEMICOLON
Declaration Syntax
C# Visual Basic Visual C++
public const char SEMICOLON
Public Const SEMICOLON As Char
public:
literal wchar_t SEMICOLON

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SPACE_CHAR Field

SPACE_CHAR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► SPACE_CHAR
Declaration Syntax
C# Visual Basic Visual C++
public const char SPACE_CHAR
Public Const SPACE_CHAR As Char
public:
literal wchar_t SPACE_CHAR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SPACE_STR Field

SPACE_STR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► SPACE_STR
Declaration Syntax
C# Visual Basic Visual C++
public const string SPACE_STR
Public Const SPACE_STR As String
public:
literal String^ SPACE_STR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TILDA Field

TILDA Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► TILDA
Declaration Syntax
C# Visual Basic Visual C++
public const char TILDA
Public Const TILDA As Char
public:
literal wchar_t TILDA

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


USAGE_MANDATORY Field

USAGE_MANDATORY Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► USAGE_MANDATORY
Declaration Syntax
C# Visual Basic Visual C++
public const char USAGE_MANDATORY
Public Const USAGE_MANDATORY As Char
public:
literal wchar_t USAGE_MANDATORY

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


USAGE_NOTUSED Field

USAGE_NOTUSED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► USAGE_NOTUSED
Declaration Syntax
C# Visual Basic Visual C++
public const char USAGE_NOTUSED
Public Const USAGE_NOTUSED As Char
public:
literal wchar_t USAGE_NOTUSED

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


USAGE_OPTIONAL Field

USAGE_OPTIONAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Characters ► USAGE_OPTIONAL
Declaration Syntax
C# Visual Basic Visual C++
public const char USAGE_OPTIONAL
Public Const USAGE_OPTIONAL As Char
public:
literal wchar_t USAGE_OPTIONAL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Code Class

Code Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Code
Class used by EDIRulesCreator to create a code object
Declaration Syntax
C# Visual Basic Visual C++
public class Code
Public Class Code
public ref class Code
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Code()()()() | Create a new Code object
 | Description | Get/Set the description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Value | Get/Set the value
Inheritance Hierarchy
Object
Code

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Code Constructor

Code Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Code ► Code()()()()
Create a new Code object
Declaration Syntax
C# Visual Basic Visual C++
public Code()
Public Sub New
public:
Code()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Code ► Description
Get/Set the description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Value Property

Value Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Code ► Value
Get/Set the value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeList Class

CodeList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList
Represents a set of codes that a DataElement can contain
Declaration Syntax
C# Visual Basic Visual C++
public class CodeList
Public Class CodeList
public ref class CodeList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CodeList()()()() | Create a new CodeList object
 | Codes | Codes that a DataElement can contain
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExternalCodeList | Get/Set whether this is an internal codelist (codes included in the rules files) or external (codes are in their separate file)
 | ExternalDelimiter | Get/Set the character that delimits code list values from their description
 | ExternalFilename | Get/Set the external file that contains code list data
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Name of code list
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
CodeList

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeList Constructor

CodeList Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► CodeList()()()()
Create a new CodeList object
Declaration Syntax
C# Visual Basic Visual C++
public CodeList()
Public Sub New
public:
CodeList()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Codes Property

Codes Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► Codes
Codes that a DataElement can contain
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, Code> Codes { get; set; }
Public Property Codes As Dictionary(Of String, Code)
    Get
    Set
public:
property Dictionary<String^, Code^>^ Codes {
    Dictionary<String^, Code^>^ get ();
    void set (Dictionary<String^, Code^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ExternalCodeList Property

ExternalCodeList Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► ExternalCodeList
Get/Set whether this is an internal codelist (codes included in the rules files) or external (codes are in their separate file)
Declaration Syntax
C# Visual Basic Visual C++
public bool ExternalCodeList { get; set; }
Public Property ExternalCodeList As Boolean
    Get
    Set
public:
property bool ExternalCodeList {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ExternalDelimiter Property

ExternalDelimiter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► ExternalDelimiter
Get/Set the character that delimits code list values from their description
Declaration Syntax
C# Visual Basic Visual C++
public char ExternalDelimiter { get; set; }
Public Property ExternalDelimiter As Char
    Get
    Set
public:
property wchar_t ExternalDelimiter {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ExternalFilename Property

ExternalFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► ExternalFilename
Get/Set the external file that contains code list data
Declaration Syntax
C# Visual Basic Visual C++
public string ExternalFilename { get; set; }
Public Property ExternalFilename As String
    Get
    Set
public:
property String^ ExternalFilename {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► CodeList ► Name
Name of code list
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Class

DataElement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement
A DataElement Object
Declaration Syntax
C# Visual Basic Visual C++
public class DataElement : LightWeightElement
Public Class DataElement _
    Inherits LightWeightElement
public ref class DataElement : public LightWeightElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataElement()()()() | Creates a new DataElement object
 | DataElement(String, String) | Creates a new DataElement object
 | DataElement(String, Int32) | Creates a new DataElement object
 | DataElement(Int32, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, Int32, Usage, Boolean, array<String>[]()[][]) | Creates a new DataElement object
 | DataElement(String, Int32, Usage, array<String>[]()[][]) | Creates a new DataElement object
 | DataElement(String, Int32, String) | Creates a new DataElement object
 | DataElement(String, Int32, String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String) | Creates a new DataElement object
 | DataElement(String, ElementDataType) | Creates a new DataElement object
 | DataElement(Boolean) | Creates a new DataElement object
 | DataElement(String, ElementDataType, String) | Creates a new DataElement object
 | AcceptedValues | Get/Set accepted values for this DataElement
 | Clone()()()() | Deep clones this instance.
 | CodeList | Get/Set codelist for this DataElement
 | CodeListName | Get/Set the name of the codelist that DataElement must get its values from
 | Codes | Get/Set codes for this DataElement
 | Composite | Returns whether this is a composite data element (Inherited from LightWeightElement.)
 | ContainsData()()()() | Checks whether there is data in DataElement (Inherited from LightWeightElement.)
 | ContainsNoData()()()() | Checks whether there is data in DataElement (Inherited from LightWeightElement.)
 | DataType | Get/Set the type of data
 | DataValue | Get/Set the actual data in DataElement (Inherited from LightWeightElement.)
 | Description | Get/Set the description
 | ElementNumber | Get/Set the position of this DataElement in the containing DataSegment (Inherited from LightWeightElement.)
 | Elements | Get/Set the child elements if this is a composite data element
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatCollection | Get/Set element formats for this DataElement
 | GetAcceptedValues()()()() | Returns a list of accepted values for this data element
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasAcceptedValues()()()() | Checks whether this data element has a list of accepted values
 | HasRepeatingCompositeElements | (Inherited from LightWeightElement.)
 | HasRepeatingElements | (Inherited from LightWeightElement.)
 | ImplicitWideningImplicitImplicitImplicit(String to DataElement) | Overides the asignment operator to directly convert a string to a DataElement
 | InAcceptedValues(String) | Checks whether the supplied paramater value exists in the DataElement's accepted values list
 | MaximumLength | Get/Set the maximum length of the data value
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumLength | Get/Set the minimum length of the data value
 | Name | Get/Set the name of DataElement
 | PaddingCharacter | Get/Set the padding character used to meet maximum lengths
 | RepeatingCompositeElements | Gets or sets the repeating composite elements. (Inherited from LightWeightElement.)
 | RepeatingElementsValues | Gets or sets the repeating elements values. This is only set when this element does not represent a composite element (Inherited from LightWeightElement.)
 | Tag | Used for any reason at all
 | ToString()()()() | Returns a String that represents this instance. (Inherited from LightWeightElement.)
 | UniqueValueOnRepetition | Get/Set whether everytime this DataElement repeats a new value must be present
 | Usage | Returns the usage of this dataelement
Inheritance Hierarchy
Object
 | LightWeightElement
 |  | DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor

DataElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement()()()()
Members
Icon | Member | Description
 | DataElement()()()() | Creates a new DataElement object
 | DataElement(String, String) | Creates a new DataElement object
 | DataElement(String, Int32) | Creates a new DataElement object
 | DataElement(Int32, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String, Int32, Usage, Boolean, array<String>[]()[][]) | Creates a new DataElement object
 | DataElement(String, Int32, Usage, array<String>[]()[][]) | Creates a new DataElement object
 | DataElement(String, Int32, String) | Creates a new DataElement object
 | DataElement(String, Int32, String, Int32, Int32) | Creates a new DataElement object
 | DataElement(String) | Creates a new DataElement object
 | DataElement(String, ElementDataType) | Creates a new DataElement object
 | DataElement(Boolean) | Creates a new DataElement object
 | DataElement(String, ElementDataType, String) | Creates a new DataElement object

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor

DataElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement()()()()
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement()
Public Sub New
public:
DataElement()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (composite)

DataElement Constructor (composite)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(Boolean)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    bool composite
)
Public Sub New ( _
    composite As Boolean _
)
public:
DataElement(
    bool composite
)
Parameters
composite (Boolean)
true if this is a composite dataelement, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (elementNumber, min, max)

DataElement Constructor (elementNumber, min, max)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(Int32, Int32, Int32)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    int elementNumber,
    int min,
    int max
)
Public Sub New ( _
    elementNumber As Integer, _
    min As Integer, _
    max As Integer _
)
public:
DataElement(
    int elementNumber,
    int min,
    int max
)
Parameters
elementNumber (Int32)
position of DataElement in the containing DataSegment
min (Int32)
minimum length of data value
max (Int32)
maximum length of data value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (dataValue)

DataElement Constructor (dataValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue
)
Public Sub New ( _
    dataValue As String _
)
public:
DataElement(
    String^ dataValue
)
Parameters
dataValue (String)
value of DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (name, dataType)

DataElement Constructor (name, dataType)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, ElementDataType)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string name,
    ElementDataType dataType
)
Public Sub New ( _
    name As String, _
    dataType As ElementDataType _
)
public:
DataElement(
    String^ name,
    ElementDataType dataType
)
Parameters
name (String)
name of DataElement
dataType (ElementDataType)
type of data stored in this DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (name, dataType, dataValue)

DataElement Constructor (name, dataType, dataValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, ElementDataType, String)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string name,
    ElementDataType dataType,
    string dataValue
)
Public Sub New ( _
    name As String, _
    dataType As ElementDataType, _
    dataValue As String _
)
public:
DataElement(
    String^ name,
    ElementDataType dataType,
    String^ dataValue
)
Parameters
name (String)
name of the DataElement
dataType (ElementDataType)
type of data stored in this DataElement
dataValue (String)
value of the DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (dataValue, elementNumber)

DataElement Constructor (dataValue, elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    int elementNumber
)
Public Sub New ( _
    dataValue As String, _
    elementNumber As Integer _
)
public:
DataElement(
    String^ dataValue,
    int elementNumber
)
Parameters
dataValue (String)
value of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (elementName, elementNumber, usage, uniqueValueOnRepetition, acceptedValues)

DataElement Constructor (elementName, elementNumber, usage, uniqueValueOnRepetition, acceptedValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, Usage, Boolean, array<String>[]()[][])
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string elementName,
    int elementNumber,
    Usage usage,
    bool uniqueValueOnRepetition,
    params string[] acceptedValues
)
Public Sub New ( _
    elementName As String, _
    elementNumber As Integer, _
    usage As Usage, _
    uniqueValueOnRepetition As Boolean, _
    ParamArray acceptedValues As String() _
)
public:
DataElement(
    String^ elementName,
    int elementNumber,
    Usage usage,
    bool uniqueValueOnRepetition,
    ... array<String^>^ acceptedValues
)
Parameters
elementName (String)
name of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment
usage (Usage)
usage of DataElement
uniqueValueOnRepetition (Boolean)
if true then everytime this DataElement repeats a new value must be present
acceptedValues (array< String >[]()[][])
accepted values of DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (elementName, elementNumber, usage, acceptedValues)

DataElement Constructor (elementName, elementNumber, usage, acceptedValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, Usage, array<String>[]()[][])
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string elementName,
    int elementNumber,
    Usage usage,
    params string[] acceptedValues
)
Public Sub New ( _
    elementName As String, _
    elementNumber As Integer, _
    usage As Usage, _
    ParamArray acceptedValues As String() _
)
public:
DataElement(
    String^ elementName,
    int elementNumber,
    Usage usage,
    ... array<String^>^ acceptedValues
)
Parameters
elementName (String)
name of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment
usage (Usage)
usage of DataElement
acceptedValues (array< String >[]()[][])
accepted values of DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (dataValue, min, max)

DataElement Constructor (dataValue, min, max)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, Int32)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    int min,
    int max
)
Public Sub New ( _
    dataValue As String, _
    min As Integer, _
    max As Integer _
)
public:
DataElement(
    String^ dataValue,
    int min,
    int max
)
Parameters
dataValue (String)
value of DataElement
min (Int32)
minimum length of data value
max (Int32)
maximum length of data value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (dataValue, elementNumber, description)

DataElement Constructor (dataValue, elementNumber, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, String)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    int elementNumber,
    string description
)
Public Sub New ( _
    dataValue As String, _
    elementNumber As Integer, _
    description As String _
)
public:
DataElement(
    String^ dataValue,
    int elementNumber,
    String^ description
)
Parameters
dataValue (String)
value of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment
description (String)
description of DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (dataValue, elementNumber, description, minLength, maxLength)

DataElement Constructor (dataValue, elementNumber, description, minLength, maxLength)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, Int32, String, Int32, Int32)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    int elementNumber,
    string description,
    int minLength,
    int maxLength
)
Public Sub New ( _
    dataValue As String, _
    elementNumber As Integer, _
    description As String, _
    minLength As Integer, _
    maxLength As Integer _
)
public:
DataElement(
    String^ dataValue,
    int elementNumber,
    String^ description,
    int minLength,
    int maxLength
)
Parameters
dataValue (String)
value of DataElement
elementNumber (Int32)
position of DataElement in the containing DataSegment
description (String)
description of DataElement
minLength (Int32)
minimum length of data value
maxLength (Int32)
maximum length of data value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (dataValue, description)

DataElement Constructor (dataValue, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, String)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string dataValue,
    string description
)
Public Sub New ( _
    dataValue As String, _
    description As String _
)
public:
DataElement(
    String^ dataValue,
    String^ description
)
Parameters
dataValue (String)
value of DataElement
description (String)
description of DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElement Constructor (name, dataValue, min, max)

DataElement Constructor (name, dataValue, min, max)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataElement(String, String, Int32, Int32)
Creates a new DataElement object
Declaration Syntax
C# Visual Basic Visual C++
public DataElement(
    string name,
    string dataValue,
    int min,
    int max
)
Public Sub New ( _
    name As String, _
    dataValue As String, _
    min As Integer, _
    max As Integer _
)
public:
DataElement(
    String^ name,
    String^ dataValue,
    int min,
    int max
)
Parameters
name (String)
name of DataElement
dataValue (String)
value of DataElement
min (Int32)
minimum length of data value
max (Int32)
maximum length of data value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AcceptedValues Property

AcceptedValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► AcceptedValues
Get/Set accepted values for this DataElement
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> AcceptedValues { get; set; }
Public Property AcceptedValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ AcceptedValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Clone Method

Clone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Clone()()()()
Deep clones this instance.
Declaration Syntax
C# Visual Basic Visual C++
public DataElement Clone()
Public Function Clone As DataElement
public:
DataElement^ Clone()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeList Property

CodeList Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► CodeList
Get/Set codelist for this DataElement
Declaration Syntax
C# Visual Basic Visual C++
public CodeList CodeList { get; set; }
Public Property CodeList As CodeList
    Get
    Set
public:
property CodeList^ CodeList {
    CodeList^ get ();
    void set (CodeList^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeListName Property

CodeListName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► CodeListName
Get/Set the name of the codelist that DataElement must get its values from
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListName { get; set; }
Public Property CodeListName As String
    Get
    Set
public:
property String^ CodeListName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Codes Property

Codes Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Codes
Get/Set codes for this DataElement
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> Codes { get; set; }
Public Property Codes As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ Codes {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataType Property

DataType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► DataType
Get/Set the type of data
Declaration Syntax
C# Visual Basic Visual C++
public ElementDataType DataType { get; set; }
Public Property DataType As ElementDataType
    Get
    Set
public:
property ElementDataType DataType {
    ElementDataType get ();
    void set (ElementDataType value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Description
Get/Set the description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Elements
Get/Set the child elements if this is a composite data element
Declaration Syntax
C# Visual Basic Visual C++
public DataElements Elements { get; set; }
Public Property Elements As DataElements
    Get
    Set
public:
property DataElements^ Elements {
    DataElements^ get ();
    void set (DataElements^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormatCollection Property

FormatCollection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► FormatCollection
Get/Set element formats for this DataElement
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementFormat> FormatCollection { get; set; }
Public Property FormatCollection As Collection(Of ElementFormat)
    Get
    Set
public:
property Collection<ElementFormat^>^ FormatCollection {
    Collection<ElementFormat^>^ get ();
    void set (Collection<ElementFormat^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetAcceptedValues Method

GetAcceptedValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► GetAcceptedValues()()()()
Returns a list of accepted values for this data element
Declaration Syntax
C# Visual Basic Visual C++
public string GetAcceptedValues()
Public Function GetAcceptedValues As String
public:
String^ GetAcceptedValues()
Return Value
list of accepted values separated by a comma

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HasAcceptedValues Method

HasAcceptedValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► HasAcceptedValues()()()()
Checks whether this data element has a list of accepted values
Declaration Syntax
C# Visual Basic Visual C++
public bool HasAcceptedValues()
Public Function HasAcceptedValues As Boolean
public:
bool HasAcceptedValues()
Return Value
true if a list exists, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► ImplicitWideningImplicitImplicitImplicit(String to DataElement)
Overides the asignment operator to directly convert a string to a DataElement
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator DataElement (
    string elementValue
)
Public Shared Widening Operator CType ( _
    elementValue As String _
) As DataElement
static implicit operator DataElement^ (
    String^ elementValue
)
Parameters
elementValue (String)
string to convert to a DataElement
Return Value
a new DataElement with the supplied value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


InAcceptedValues Method (value)

InAcceptedValues Method (value)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► InAcceptedValues(String)
Checks whether the supplied paramater value exists in the DataElement's accepted values list
Declaration Syntax
C# Visual Basic Visual C++
public bool InAcceptedValues(
    string value
)
Public Function InAcceptedValues ( _
    value As String _
) As Boolean
public:
bool InAcceptedValues(
    String^ value
)
Parameters
value (String)
value to check
Return Value
true if the value exists, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaximumLength Property

MaximumLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► MaximumLength
Get/Set the maximum length of the data value
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumLength { get; set; }
Public Property MaximumLength As Integer
    Get
    Set
public:
property int MaximumLength {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MinimumLength Property

MinimumLength Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► MinimumLength
Get/Set the minimum length of the data value
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumLength { get; set; }
Public Property MinimumLength As Integer
    Get
    Set
public:
property int MinimumLength {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Name
Get/Set the name of DataElement
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PaddingCharacter Property

PaddingCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► PaddingCharacter
Get/Set the padding character used to meet maximum lengths
Declaration Syntax
C# Visual Basic Visual C++
public char PaddingCharacter { get; set; }
Public Property PaddingCharacter As Char
    Get
    Set
public:
property wchar_t PaddingCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Tag Property

Tag Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Tag
Used for any reason at all
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UniqueValueOnRepetition Property

UniqueValueOnRepetition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► UniqueValueOnRepetition
Get/Set whether everytime this DataElement repeats a new value must be present
Declaration Syntax
C# Visual Basic Visual C++
public bool UniqueValueOnRepetition { get; set; }
Public Property UniqueValueOnRepetition As Boolean
    Get
    Set
public:
property bool UniqueValueOnRepetition {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElement ► Usage
Returns the usage of this dataelement
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElements Class

DataElements Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements
A collection of DataElement Objects
Declaration Syntax
C# Visual Basic Visual C++
public class DataElements : Collection<DataElement>
Public Class DataElements _
    Inherits Collection(Of DataElement)
public ref class DataElements : public Collection<DataElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataElements()()()() | Creates a new DataElements Collection
 | Add(String) | Creates and adds a new DataElement with a value
 | Add(Int32) | Adds the specified element value.
 | Add(Double) | Adds the specified element value.
 | Add(Decimal) | Adds the specified element value.
 | Add(Single) | Adds the specified element value.
 | Add(Byte) | Adds the specified element value.
 | Add(Char) | Adds the specified element value.
 | Add(array<String>[]()[][]) | Creates and adds a series of data elements
 | Add(String, String) | Creates and adds a new DataElement with a value and description
 | Add(String, Int32) | Creates and adds a new DataElement with a value and element number
 | Add(String, Int32, Int32) | Creates and adds a new DataElement to collection with a value and a minimum and maximum value length
 | Add(String, Int32, String) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Int32, Int32, String) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Usage, array<String>[]()[][]) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Usage, Boolean, array<String>[]()[][]) | Creates and adds a new DataElement to collection
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' DataElement >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' DataElement >)>)>
 |  | DataElements

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataElements Constructor

DataElements Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► DataElements()()()()
Creates a new DataElements Collection
Declaration Syntax
C# Visual Basic Visual C++
public DataElements()
Public Sub New
public:
DataElements()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method

Add Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add()()()()
Members
Icon | Member | Description
 | Add(String) | Creates and adds a new DataElement with a value
 | Add(Int32) | Adds the specified element value.
 | Add(Double) | Adds the specified element value.
 | Add(Decimal) | Adds the specified element value.
 | Add(Single) | Adds the specified element value.
 | Add(Byte) | Adds the specified element value.
 | Add(Char) | Adds the specified element value.
 | Add(array<String>[]()[][]) | Creates and adds a series of data elements
 | Add(String, String) | Creates and adds a new DataElement with a value and description
 | Add(String, Int32) | Creates and adds a new DataElement with a value and element number
 | Add(String, Int32, Int32) | Creates and adds a new DataElement to collection with a value and a minimum and maximum value length
 | Add(String, Int32, String) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Int32, Int32, String) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Usage, array<String>[]()[][]) | Creates and adds a new DataElement to collection
 | Add(String, Int32, Usage, Boolean, array<String>[]()[][]) | Creates and adds a new DataElement to collection
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Byte)
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    byte elementValue
)
Public Sub Add ( _
    elementValue As Byte _
)
public:
void Add(
    unsigned char elementValue
)
Parameters
elementValue (Byte)
The element value.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Char)
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    char elementValue
)
Public Sub Add ( _
    elementValue As Char _
)
public:
void Add(
    wchar_t elementValue
)
Parameters
elementValue (Char)
The element value.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Decimal)
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    decimal elementValue
)
Public Sub Add ( _
    elementValue As Decimal _
)
public:
void Add(
    Decimal elementValue
)
Parameters
elementValue (Decimal)
The element value.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Double)
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double elementValue
)
Public Sub Add ( _
    elementValue As Double _
)
public:
void Add(
    double elementValue
)
Parameters
elementValue (Double)
The element value.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Int32)
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    int elementValue
)
Public Sub Add ( _
    elementValue As Integer _
)
public:
void Add(
    int elementValue
)
Parameters
elementValue (Int32)
The element value.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(Single)
Adds the specified element value.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    float elementValue
)
Public Sub Add ( _
    elementValue As Single _
)
public:
void Add(
    float elementValue
)
Parameters
elementValue (Single)
The element value.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue)

Add Method (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String)
Creates and adds a new DataElement with a value
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue
)
Public Sub Add ( _
    elementValue As String _
)
public:
void Add(
    String^ elementValue
)
Parameters
elementValue (String)
value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue, elementNumber)

Add Method (elementValue, elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32)
Creates and adds a new DataElement with a value and element number
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    int elementNumber
)
Public Sub Add ( _
    elementValue As String, _
    elementNumber As Integer _
)
public:
void Add(
    String^ elementValue,
    int elementNumber
)
Parameters
elementValue (String)
value
elementNumber (Int32)
element number

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementName, elementNumber, usage, uniqueValueOnRepetition, acceptedValues)

Add Method (elementName, elementNumber, usage, uniqueValueOnRepetition, acceptedValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, Usage, Boolean, array<String>[]()[][])
Creates and adds a new DataElement to collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementName,
    int elementNumber,
    Usage usage,
    bool uniqueValueOnRepetition,
    params string[] acceptedValues
)
Public Sub Add ( _
    elementName As String, _
    elementNumber As Integer, _
    usage As Usage, _
    uniqueValueOnRepetition As Boolean, _
    ParamArray acceptedValues As String() _
)
public:
void Add(
    String^ elementName,
    int elementNumber,
    Usage usage,
    bool uniqueValueOnRepetition,
    ... array<String^>^ acceptedValues
)
Parameters
elementName (String)
name of data element
elementNumber (Int32)
element number
usage (Usage)
usage of data element
uniqueValueOnRepetition (Boolean)
whether everytime this DataElement repeats a new value must be present
acceptedValues (array< String >[]()[][])
list of accepted values for this data element

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementName, elementNumber, usage, acceptedValues)

Add Method (elementName, elementNumber, usage, acceptedValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, Usage, array<String>[]()[][])
Creates and adds a new DataElement to collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementName,
    int elementNumber,
    Usage usage,
    params string[] acceptedValues
)
Public Sub Add ( _
    elementName As String, _
    elementNumber As Integer, _
    usage As Usage, _
    ParamArray acceptedValues As String() _
)
public:
void Add(
    String^ elementName,
    int elementNumber,
    Usage usage,
    ... array<String^>^ acceptedValues
)
Parameters
elementName (String)
name of data element
elementNumber (Int32)
element number
usage (Usage)
usage of data element
acceptedValues (array< String >[]()[][])
list of accepted values for this data element

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue, min, max)

Add Method (elementValue, min, max)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, Int32)
Creates and adds a new DataElement to collection with a value and a minimum and maximum value length
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    int min,
    int max
)
Public Sub Add ( _
    elementValue As String, _
    min As Integer, _
    max As Integer _
)
public:
void Add(
    String^ elementValue,
    int min,
    int max
)
Parameters
elementValue (String)
value
min (Int32)
minimum length for value
max (Int32)
maximum length for value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue, elementNumber, minLength, maxLength, description)

Add Method (elementValue, elementNumber, minLength, maxLength, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, Int32, Int32, String)
Creates and adds a new DataElement to collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    int elementNumber,
    int minLength,
    int maxLength,
    string description
)
Public Sub Add ( _
    elementValue As String, _
    elementNumber As Integer, _
    minLength As Integer, _
    maxLength As Integer, _
    description As String _
)
public:
void Add(
    String^ elementValue,
    int elementNumber,
    int minLength,
    int maxLength,
    String^ description
)
Parameters
elementValue (String)
data element value
elementNumber (Int32)
element number
minLength (Int32)
minimum length for value
maxLength (Int32)
maximum length for value
description (String)
description of data element

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue, elementNumber, description)

Add Method (elementValue, elementNumber, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, Int32, String)
Creates and adds a new DataElement to collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    int elementNumber,
    string description
)
Public Sub Add ( _
    elementValue As String, _
    elementNumber As Integer, _
    description As String _
)
public:
void Add(
    String^ elementValue,
    int elementNumber,
    String^ description
)
Parameters
elementValue (String)
data element value
elementNumber (Int32)
element number
description (String)
description

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValue, description)

Add Method (elementValue, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(String, String)
Creates and adds a new DataElement with a value and description
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    string elementValue,
    string description
)
Public Sub Add ( _
    elementValue As String, _
    description As String _
)
public:
void Add(
    String^ elementValue,
    String^ description
)
Parameters
elementValue (String)
value
description (String)
description

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Add Method (elementValues)

Add Method (elementValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataElements ► Add(array<String>[]()[][])
Creates and adds a series of data elements
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    params string[] elementValues
)
Public Sub Add ( _
    ParamArray elementValues As String() _
)
public:
void Add(
    ... array<String^>^ elementValues
)
Parameters
elementValues (array< String >[]()[][])
value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataSegment Class

DataSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment
A DataSegment Object
Declaration Syntax
C# Visual Basic Visual C++
public class DataSegment : LightWeightSegment
Public Class DataSegment _
    Inherits LightWeightSegment
public ref class DataSegment : public LightWeightSegment
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataSegment(String, String) | Creates a new DataSegment
 | DataSegment(String, Int32, Int32, Usage, String) | Creates a new DataSegment
 | DataSegment(String) | Creates a new DataSegment
 | ContainsElement(Int32) | Checks whether an element exist in the segment (Overrides LightWeightSegment.ContainsElement(Int32).)
 | CreateDataElement(Boolean) | Creates and add a default DataElement to this DataSegment
 | Description | Get/Set the description for this segment
 | ElementConditionalConstraints | Element Conditional Constraints List
 | ElementExclusionConstraints | Element Exclusion Constraints List
 | ElementListConditionConstraints | Element List Condition Constraints List
 | ElementPairConstraints | Element Pair Constraints List
 | ElementRequiredConstraint | Element Required Constraints List
 | Elements | Get/Set a list of DataElements
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstElement | Returns the first data element in this segment
 | GeneralRules |
 | GeneralSelfRules |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasElementPairConstraints()()()() | Returns whether this DataSegment has any contraints
 | ImplicitWideningImplicitImplicitImplicit(String to DataSegment) | Performs an implicit conversion from String to DataSegment.
 | LastElement | Returns the last data element in this segment
 | LoopValidationIndex | Gets or sets the index of the loop validation. Default is 0
 | MaskNumber | For Rules Reader
 | MaximumOccurrences | Get/Set the maximum amount of times this segment can repeat
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumOccurrences | Get/Set the minimum amount of times this segment can repeat
 | Name | Get/Set the name of this segment (Inherited from LightWeightSegment.)
 | NumberCreated | Tracks the total number of segments created
 | OnlySegmentInLoop | Get/Set if this is the only segment in a loop
 | OrdinalNumber | Get/Set the actual position of this segment in an EDIDocument (Inherited from LightWeightSegment.)
 | OwningLoop | Get/Set the name of the loop that this segment belongs to
 | Populate(array<String>[]()[][]) | Obsolete. Use PopulateElements(params string[] elementValues) instead
 | PopulateElements(array<String>[]()[][]) | Populates the DataElements of this DataSegment from a params array
 | Position | Gets or sets the position.
 | RepeatIndefinite | Get/Set if this segment repeats indefinitely
 | Rules | Get/Set the rules for this segment
 | SegmentID | Use this to store any id necessary
 | SegmentLoop |
 | SelfRules | Get/Set the self rules for this segment
 | Tag | Used for any purpose
 | ToEDIString(Delimiters) | (Inherited from LightWeightSegment.)
 | ToString()()()() | Returns a string representation of this DataSegment (Overrides LightWeightSegment.ToString()()()().)
 | Usage | Get/Set the usage requirements of segment
Inheritance Hierarchy
Object
 | LightWeightSegment
 |  | DataSegment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataSegment Constructor

DataSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► DataSegment()()()()
Members
Icon | Member | Description
 | DataSegment(String, String) | Creates a new DataSegment
 | DataSegment(String, Int32, Int32, Usage, String) | Creates a new DataSegment
 | DataSegment(String) | Creates a new DataSegment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataSegment Constructor (segmentName)

DataSegment Constructor (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► DataSegment(String)
Creates a new DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment(
    string segmentName
)
Public Sub New ( _
    segmentName As String _
)
public:
DataSegment(
    String^ segmentName
)
Parameters
segmentName (String)
segment name

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataSegment Constructor (segmentName, min, max, usage, description)

DataSegment Constructor (segmentName, min, max, usage, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► DataSegment(String, Int32, Int32, Usage, String)
Creates a new DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment(
    string segmentName,
    int min,
    int max,
    Usage usage,
    string description
)
Public Sub New ( _
    segmentName As String, _
    min As Integer, _
    max As Integer, _
    usage As Usage, _
    description As String _
)
public:
DataSegment(
    String^ segmentName,
    int min,
    int max,
    Usage usage,
    String^ description
)
Parameters
segmentName (String)
segment name
min (Int32)
minimum amount of time segment should repeat
max (Int32)
maximum amount of time segment should repeat
usage (Usage)
usage for segment
description (String)
description for segment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataSegment Constructor (segmentName, description)

DataSegment Constructor (segmentName, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► DataSegment(String, String)
Creates a new DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment(
    string segmentName,
    string description
)
Public Sub New ( _
    segmentName As String, _
    description As String _
)
public:
DataSegment(
    String^ segmentName,
    String^ description
)
Parameters
segmentName (String)
name
description (String)
description for segment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ContainsElement Method (elementIndex)

ContainsElement Method (elementIndex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ContainsElement(Int32)
Checks whether an element exist in the segment
Declaration Syntax
C# Visual Basic Visual C++
public override bool ContainsElement(
    int elementIndex
)
Public Overrides Function ContainsElement ( _
    elementIndex As Integer _
) As Boolean
public:
virtual bool ContainsElement(
    int elementIndex
) override
Parameters
elementIndex (Int32)
index of the element
Return Value
true if element exists, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateDataElement Method (composite)

CreateDataElement Method (composite)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► CreateDataElement(Boolean)
Creates and add a default DataElement to this DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public DataElement CreateDataElement(
    bool composite
)
Public Function CreateDataElement ( _
    composite As Boolean _
) As DataElement
public:
DataElement^ CreateDataElement(
    bool composite
)
Parameters
composite (Boolean)
specifies whether DataElement should be a composite
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Description
Get/Set the description for this segment
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementConditionalConstraints Property

ElementConditionalConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementConditionalConstraints
Element Conditional Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementConditionalConstraint> ElementConditionalConstraints { get; set; }
Public Property ElementConditionalConstraints As Collection(Of ElementConditionalConstraint)
    Get
    Set
public:
property Collection<ElementConditionalConstraint^>^ ElementConditionalConstraints {
    Collection<ElementConditionalConstraint^>^ get ();
    void set (Collection<ElementConditionalConstraint^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementExclusionConstraints Property

ElementExclusionConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementExclusionConstraints
Element Exclusion Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementExclusionConstraint> ElementExclusionConstraints { get; set; }
Public Property ElementExclusionConstraints As Collection(Of ElementExclusionConstraint)
    Get
    Set
public:
property Collection<ElementExclusionConstraint^>^ ElementExclusionConstraints {
    Collection<ElementExclusionConstraint^>^ get ();
    void set (Collection<ElementExclusionConstraint^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementListConditionConstraints Property

ElementListConditionConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementListConditionConstraints
Element List Condition Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementListConditionalConstraint> ElementListConditionConstraints { get; set; }
Public Property ElementListConditionConstraints As Collection(Of ElementListConditionalConstraint)
    Get
    Set
public:
property Collection<ElementListConditionalConstraint^>^ ElementListConditionConstraints {
    Collection<ElementListConditionalConstraint^>^ get ();
    void set (Collection<ElementListConditionalConstraint^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPairConstraints Property

ElementPairConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementPairConstraints
Element Pair Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementPairConstraint> ElementPairConstraints { get; set; }
Public Property ElementPairConstraints As Collection(Of ElementPairConstraint)
    Get
    Set
public:
property Collection<ElementPairConstraint^>^ ElementPairConstraints {
    Collection<ElementPairConstraint^>^ get ();
    void set (Collection<ElementPairConstraint^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementRequiredConstraint Property

ElementRequiredConstraint Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ElementRequiredConstraint
Element Required Constraints List
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementRequiredConstraint> ElementRequiredConstraint { get; set; }
Public Property ElementRequiredConstraint As Collection(Of ElementRequiredConstraint)
    Get
    Set
public:
property Collection<ElementRequiredConstraint^>^ ElementRequiredConstraint {
    Collection<ElementRequiredConstraint^>^ get ();
    void set (Collection<ElementRequiredConstraint^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Elements
Get/Set a list of DataElements
Declaration Syntax
C# Visual Basic Visual C++
public DataElements Elements { get; set; }
Public Property Elements As DataElements
    Get
    Set
public:
property DataElements^ Elements {
    DataElements^ get ();
    void set (DataElements^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FirstElement Property

FirstElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► FirstElement
Returns the first data element in this segment
Declaration Syntax
C# Visual Basic Visual C++
public DataElement FirstElement { get; }
Public ReadOnly Property FirstElement As DataElement
    Get
public:
property DataElement^ FirstElement {
    DataElement^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralRules Property

GeneralRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► GeneralRules
Declaration Syntax
C# Visual Basic Visual C++
public Collection<GeneralRule> GeneralRules { get; set; }
Public Property GeneralRules As Collection(Of GeneralRule)
    Get
    Set
public:
property Collection<GeneralRule^>^ GeneralRules {
    Collection<GeneralRule^>^ get ();
    void set (Collection<GeneralRule^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralSelfRules Property

GeneralSelfRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► GeneralSelfRules
Declaration Syntax
C# Visual Basic Visual C++
public Collection<GeneralSelfRule> GeneralSelfRules { get; set; }
Public Property GeneralSelfRules As Collection(Of GeneralSelfRule)
    Get
    Set
public:
property Collection<GeneralSelfRule^>^ GeneralSelfRules {
    Collection<GeneralSelfRule^>^ get ();
    void set (Collection<GeneralSelfRule^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HasElementPairConstraints Method

HasElementPairConstraints Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► HasElementPairConstraints()()()()
Returns whether this DataSegment has any contraints
Declaration Syntax
C# Visual Basic Visual C++
public bool HasElementPairConstraints()
Public Function HasElementPairConstraints As Boolean
public:
bool HasElementPairConstraints()
Return Value
true if contraints exist, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ImplicitWideningImplicitImplicitImplicit(String to DataSegment)
Performs an implicit conversion from String to DataSegment.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator DataSegment (
    string segmentName
)
Public Shared Widening Operator CType ( _
    segmentName As String _
) As DataSegment
static implicit operator DataSegment^ (
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value
The result of the conversion.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LastElement Property

LastElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► LastElement
Returns the last data element in this segment
Declaration Syntax
C# Visual Basic Visual C++
public DataElement LastElement { get; }
Public ReadOnly Property LastElement As DataElement
    Get
public:
property DataElement^ LastElement {
    DataElement^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopValidationIndex Property

LoopValidationIndex Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► LoopValidationIndex
Gets or sets the index of the loop validation. Default is 0
Declaration Syntax
C# Visual Basic Visual C++
public int LoopValidationIndex { get; set; }
Public Property LoopValidationIndex As Integer
    Get
    Set
public:
property int LoopValidationIndex {
    int get ();
    void set (int value);
}
Value
The index of the loop validation.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaskNumber Property

MaskNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► MaskNumber
For Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public int MaskNumber { get; set; }
Public Property MaskNumber As Integer
    Get
    Set
public:
property int MaskNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaximumOccurrences Property

MaximumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► MaximumOccurrences
Get/Set the maximum amount of times this segment can repeat
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumOccurrences { get; set; }
Public Property MaximumOccurrences As Integer
    Get
    Set
public:
property int MaximumOccurrences {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MinimumOccurrences Property

MinimumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► MinimumOccurrences
Get/Set the minimum amount of times this segment can repeat
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumOccurrences { get; set; }
Public Property MinimumOccurrences As Integer
    Get
    Set
public:
property int MinimumOccurrences {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NumberCreated Field

NumberCreated Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► NumberCreated
Tracks the total number of segments created
Declaration Syntax
C# Visual Basic Visual C++
public static int NumberCreated
Public Shared NumberCreated As Integer
public:
static int NumberCreated

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OnlySegmentInLoop Property

OnlySegmentInLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► OnlySegmentInLoop
Get/Set if this is the only segment in a loop
Declaration Syntax
C# Visual Basic Visual C++
public bool OnlySegmentInLoop { get; set; }
Public Property OnlySegmentInLoop As Boolean
    Get
    Set
public:
property bool OnlySegmentInLoop {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OwningLoop Property

OwningLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► OwningLoop
Get/Set the name of the loop that this segment belongs to
Declaration Syntax
C# Visual Basic Visual C++
public string OwningLoop { get; set; }
Public Property OwningLoop As String
    Get
    Set
public:
property String^ OwningLoop {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Populate Method (elementValues)

Populate Method (elementValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Populate(array<String>[]()[][])
Use PopulateElements(params string[] elementValues) instead
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use PopulateElements(params string[] elementValues) instead")]
public void Populate(
    params string[] elementValues
)
<ObsoleteAttribute("Use PopulateElements(params string[] elementValues) instead")> _
Public Sub Populate ( _
    ParamArray elementValues As String() _
)
[ObsoleteAttribute(L"Use PopulateElements(params string[] elementValues) instead")]
public:
void Populate(
    ... array<String^>^ elementValues
)
Parameters
elementValues (array< String >[]()[][])
data values for the new DataElements

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PopulateElements Method (elementValues)

PopulateElements Method (elementValues)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► PopulateElements(array<String>[]()[][])
Populates the DataElements of this DataSegment from a params array
Declaration Syntax
C# Visual Basic Visual C++
public void PopulateElements(
    params string[] elementValues
)
Public Sub PopulateElements ( _
    ParamArray elementValues As String() _
)
public:
void PopulateElements(
    ... array<String^>^ elementValues
)
Parameters
elementValues (array< String >[]()[][])
data values for the new DataElements

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Position
Gets or sets the position.
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}
Value
The position.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RepeatIndefinite Property

RepeatIndefinite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► RepeatIndefinite
Get/Set if this segment repeats indefinitely
Declaration Syntax
C# Visual Basic Visual C++
public bool RepeatIndefinite { get; set; }
Public Property RepeatIndefinite As Boolean
    Get
    Set
public:
property bool RepeatIndefinite {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Rules Property

Rules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Rules
Get/Set the rules for this segment
Declaration Syntax
C# Visual Basic Visual C++
public Collection<SemanticRule> Rules { get; set; }
Public Property Rules As Collection(Of SemanticRule)
    Get
    Set
public:
property Collection<SemanticRule^>^ Rules {
    Collection<SemanticRule^>^ get ();
    void set (Collection<SemanticRule^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentID Property

SegmentID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► SegmentID
Use this to store any id necessary
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentID { get; set; }
Public Property SegmentID As String
    Get
    Set
public:
property String^ SegmentID {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentLoop Property

SegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► SegmentLoop
Declaration Syntax
C# Visual Basic Visual C++
public Loop SegmentLoop { get; set; }
Public Property SegmentLoop As Loop
    Get
    Set
public:
property Loop^ SegmentLoop {
    Loop^ get ();
    void set (Loop^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SelfRules Property

SelfRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► SelfRules
Get/Set the self rules for this segment
Declaration Syntax
C# Visual Basic Visual C++
public Collection<SelfRule> SelfRules { get; set; }
Public Property SelfRules As Collection(Of SelfRule)
    Get
    Set
public:
property Collection<SelfRule^>^ SelfRules {
    Collection<SelfRule^>^ get ();
    void set (Collection<SelfRule^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Tag Property

Tag Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Tag
Used for any purpose
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► ToString()()()()
Returns a string representation of this DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
string representation of this DataSegment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegment ► Usage
Get/Set the usage requirements of segment
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataSegments Class

DataSegments Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegments
Summary description for DataSegments.
Declaration Syntax
C# Visual Basic Visual C++
public class DataSegments : Collection<DataSegment>
Public Class DataSegments _
    Inherits Collection(Of DataSegment)
public ref class DataSegments : public Collection<DataSegment^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataSegments()()()() | Create a new DataSegments collection
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' DataSegment >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' DataSegment >)>)>
 |  | DataSegments

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataSegments Constructor

DataSegments Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DataSegments ► DataSegments()()()()
Create a new DataSegments collection
Declaration Syntax
C# Visual Basic Visual C++
public DataSegments()
Public Sub New
public:
DataSegments()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Class

Delimiters Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters
Represents the delimiters of X12 and EDIFACT standards
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Delimiters
<SerializableAttribute> _
Public Class Delimiters
[SerializableAttribute]
public ref class Delimiters
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Delimiters()()()() | Creates a new Delimiters object
 | CompositeTerminatorCharacter | Composite element terminator character
 | ElementTerminatorCharacter | Element terminator charactor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReleaseCharacter | Release character (EDIFACT)
 | RepetitionCharacter | Repetition character
 | SegmentTerminatorCharacter | Segment terminator charactor
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UsingDefault | When false the delimiters for an EDI file could be be determined
Inheritance Hierarchy
Object
Delimiters

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Constructor

Delimiters Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► Delimiters()()()()
Creates a new Delimiters object
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters()
Public Sub New
public:
Delimiters()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeTerminatorCharacter Property

CompositeTerminatorCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► CompositeTerminatorCharacter
Composite element terminator character
Declaration Syntax
C# Visual Basic Visual C++
public char CompositeTerminatorCharacter { get; set; }
Public Property CompositeTerminatorCharacter As Char
    Get
    Set
public:
property wchar_t CompositeTerminatorCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementTerminatorCharacter Property

ElementTerminatorCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► ElementTerminatorCharacter
Element terminator charactor
Declaration Syntax
C# Visual Basic Visual C++
public char ElementTerminatorCharacter { get; set; }
Public Property ElementTerminatorCharacter As Char
    Get
    Set
public:
property wchar_t ElementTerminatorCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ReleaseCharacter Property

ReleaseCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► ReleaseCharacter
Release character (EDIFACT)
Declaration Syntax
C# Visual Basic Visual C++
public char ReleaseCharacter { get; set; }
Public Property ReleaseCharacter As Char
    Get
    Set
public:
property wchar_t ReleaseCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RepetitionCharacter Property

RepetitionCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► RepetitionCharacter
Repetition character
Declaration Syntax
C# Visual Basic Visual C++
public char RepetitionCharacter { get; set; }
Public Property RepetitionCharacter As Char
    Get
    Set
public:
property wchar_t RepetitionCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentTerminatorCharacter Property

SegmentTerminatorCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► SegmentTerminatorCharacter
Segment terminator charactor
Declaration Syntax
C# Visual Basic Visual C++
public char SegmentTerminatorCharacter { get; set; }
Public Property SegmentTerminatorCharacter As Char
    Get
    Set
public:
property wchar_t SegmentTerminatorCharacter {
    wchar_t get ();
    void set (wchar_t value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UsingDefault Property

UsingDefault Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Delimiters ► UsingDefault
When false the delimiters for an EDI file could be be determined
Declaration Syntax
C# Visual Basic Visual C++
public bool UsingDefault { get; internal set; }
Public Property UsingDefault As Boolean
    Get
    Friend Set
public:
property bool UsingDefault {
    bool get ();
    internal: void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DocumentCreator Enumeration

DocumentCreator Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► DocumentCreator
Declaration Syntax
C# Visual Basic Visual C++
public enum DocumentCreator
Public Enumeration DocumentCreator
public enum class DocumentCreator
Members
Member | Description
None |
EDIFileLoader |
EDIValidator |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocument Class

EDIDocument Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument
Creates EDI X12 and EDIFACT document files
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIDocument : Component
Public NotInheritable Class EDIDocument _
    Inherits Component
public ref class EDIDocument sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIDocument(IContainer) | Creates a new EDIDocument component
 | EDIDocument()()()() | Creates a new EDIDocument component
 | EDIDocument(String) | Creates a new EDIDocument component specifying the path of the output file
 | EDIDocument(FileStream) | Creates a new EDIDocument component specifying the path of the output file
 | AutoPlaceCorrectNumOfGT | Places the correct number of GS Functional Groups in the IEA segment element 1
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) or UNT segment (EDIFACT)
 | AutoPlaceCorrectNumOfST | Places the correct number of ST Headers in the GE segment element 1
 | AutoTrimElements | Trims blank spaces from the beginning and ending of element data
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Delimiters | Segment and element delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDocumentFinished | Event raised when EDI document creation process has completed
 | EDIFilePath | Full path including file name of EDI file to create. If the file already exists it is overwritten
 | EDIFileString | A string representation of the EDI file created
 | EDIXMLFileString | A string representation of the EDI XML file created
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBufferSize | Initial file buffer size when generating EDI files
 | FileStream | Optional filestream to save EDI document to
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GenerateEDIData()()()() | Generate EDI Data without writing to a filestream
 | GenerateEDIFile(Boolean) | Generate EDI file. By setting testing to true, a detailed EDI file will be created complete with loop names. This is for debugging purposes only
 | GenerateEDIFile()()()() | Generate EDI file
 | GenerateEDIFile(String) | Generate EDI file
 | GenerateEDIFileWithBatchWrite()()()() | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GenerateEDIFileWithBatchWrite(String) | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GenerateEDIFileWithBatchWrite(String, Int32, Char) | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Loops | Main EDI loop. All other loops will be added to this loop
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PadDataValues | Pad or trims element data to reach mininum and maximum element length requirements
 | SegmentSeparatorString | String to insert between segments for formatting
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | ToXml()()()() | Converts this EDIDocument into an XMLDocument
 | ToXml(XmlConfigOptions) | Converts this EDILightWeightDOcument to an XMLDocument
 | ToXml(String) | Converts this EDIDocument to Xml
 | ToXml(String, XmlConfigOptions) | Converts this EDIDocument to Xml
 | TruncateEmptyCompositeElements | Removes empty trailing composites elements
 | TruncateEmptyElements | Removes empty trailing elements
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIDocument

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocument Constructor

EDIDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument()()()()
Members
Icon | Member | Description
 | EDIDocument(IContainer) | Creates a new EDIDocument component
 | EDIDocument()()()() | Creates a new EDIDocument component
 | EDIDocument(String) | Creates a new EDIDocument component specifying the path of the output file
 | EDIDocument(FileStream) | Creates a new EDIDocument component specifying the path of the output file

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocument Constructor

EDIDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument()()()()
Creates a new EDIDocument component
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument()
Public Sub New
public:
EDIDocument()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocument Constructor (container)

EDIDocument Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument(IContainer)
Creates a new EDIDocument component
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIDocument(
    IContainer^ container
)
Parameters
container (IContainer)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocument Constructor (fileStream)

EDIDocument Constructor (fileStream)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument(FileStream)
Creates a new EDIDocument component specifying the path of the output file
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument(
    FileStream fileStream
)
Public Sub New ( _
    fileStream As FileStream _
)
public:
EDIDocument(
    FileStream^ fileStream
)
Parameters
fileStream (FileStream)
stream to write EDI data to

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocument Constructor (outputFileName)

EDIDocument Constructor (outputFileName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocument(String)
Creates a new EDIDocument component specifying the path of the output file
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocument(
    string outputFileName
)
Public Sub New ( _
    outputFileName As String _
)
public:
EDIDocument(
    String^ outputFileName
)
Parameters
outputFileName (String)
path of the output file

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceCorrectNumOfGT Property

AutoPlaceCorrectNumOfGT Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► AutoPlaceCorrectNumOfGT
Places the correct number of GS Functional Groups in the IEA segment element 1
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfGT { get; set; }
Public Property AutoPlaceCorrectNumOfGT As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfGT {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceCorrectNumOfSegments Property

AutoPlaceCorrectNumOfSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► AutoPlaceCorrectNumOfSegments
Places the correct number of segments in the SE segment (X12) or UNT segment (EDIFACT)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfSegments { get; set; }
Public Property AutoPlaceCorrectNumOfSegments As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfSegments {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceCorrectNumOfST Property

AutoPlaceCorrectNumOfST Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► AutoPlaceCorrectNumOfST
Places the correct number of ST Headers in the GE segment element 1
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfST { get; set; }
Public Property AutoPlaceCorrectNumOfST As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfST {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoTrimElements Property

AutoTrimElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► AutoTrimElements
Trims blank spaces from the beginning and ending of element data
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoTrimElements { get; set; }
Public Property AutoTrimElements As Boolean
    Get
    Set
public:
property bool AutoTrimElements {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► Delimiters
Segment and element delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocumentFinished Event

EDIDocumentFinished Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIDocumentFinished
Event raised when EDI document creation process has completed
Declaration Syntax
C# Visual Basic Visual C++
public event GeneralEvent EDIDocumentFinished
Public Event EDIDocumentFinished As GeneralEvent
public:
 event GeneralEvent^ EDIDocumentFinished {
    void add (GeneralEvent^ value);
    void remove (GeneralEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFilePath Property

EDIFilePath Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIFilePath
Full path including file name of EDI file to create. If the file already exists it is overwritten
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFilePath { get; set; }
Public Property EDIFilePath As String
    Get
    Set
public:
property String^ EDIFilePath {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileString Property

EDIFileString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIFileString
A string representation of the EDI file created
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFileString { get; internal set; }
Public Property EDIFileString As String
    Get
    Friend Set
public:
property String^ EDIFileString {
    String^ get ();
    internal: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIXMLFileString Property

EDIXMLFileString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► EDIXMLFileString
A string representation of the EDI XML file created
Declaration Syntax
C# Visual Basic Visual C++
public string EDIXMLFileString { get; internal set; }
Public Property EDIXMLFileString As String
    Get
    Friend Set
public:
property String^ EDIXMLFileString {
    String^ get ();
    internal: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileBufferSize Property

FileBufferSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► FileBufferSize
Initial file buffer size when generating EDI files
Declaration Syntax
C# Visual Basic Visual C++
public int FileBufferSize { get; set; }
Public Property FileBufferSize As Integer
    Get
    Set
public:
property int FileBufferSize {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileStream Property

FileStream Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► FileStream
Optional filestream to save EDI document to
Declaration Syntax
C# Visual Basic Visual C++
public FileStream FileStream { get; set; }
Public Property FileStream As FileStream
    Get
    Set
public:
property FileStream^ FileStream {
    FileStream^ get ();
    void set (FileStream^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIData Method

GenerateEDIData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIData()()()()
Generate EDI Data without writing to a filestream
Declaration Syntax
C# Visual Basic Visual C++
public string GenerateEDIData()
Public Function GenerateEDIData As String
public:
String^ GenerateEDIData()
Return Value
EDI data as string

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFile()()()()
Members
Icon | Member | Description
 | GenerateEDIFile(Boolean) | Generate EDI file. By setting testing to true, a detailed EDI file will be created complete with loop names. This is for debugging purposes only
 | GenerateEDIFile()()()() | Generate EDI file
 | GenerateEDIFile(String) | Generate EDI file

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFile()()()()
Generate EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile()
Public Sub GenerateEDIFile
public:
void GenerateEDIFile()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method (testing)

GenerateEDIFile Method (testing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFile(Boolean)
Generate EDI file. By setting testing to true, a detailed EDI file will be created complete with loop names. This is for debugging purposes only
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    bool testing
)
Public Sub GenerateEDIFile ( _
    testing As Boolean _
)
public:
void GenerateEDIFile(
    bool testing
)
Parameters
testing (Boolean)
for debugging purposes true is used, else false

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method (outputFile)

GenerateEDIFile Method (outputFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFile(String)
Generate EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    string outputFile
)
Public Sub GenerateEDIFile ( _
    outputFile As String _
)
public:
void GenerateEDIFile(
    String^ outputFile
)
Parameters
outputFile (String)
file path (including name of file) of EDI file to create

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFileWithBatchWrite Method

GenerateEDIFileWithBatchWrite Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFileWithBatchWrite()()()()
Members
Icon | Member | Description
 | GenerateEDIFileWithBatchWrite()()()() | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GenerateEDIFileWithBatchWrite(String) | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GenerateEDIFileWithBatchWrite(String, Int32, Char) | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFileWithBatchWrite Method

GenerateEDIFileWithBatchWrite Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFileWithBatchWrite()()()()
Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFileWithBatchWrite()
Public Sub GenerateEDIFileWithBatchWrite
public:
void GenerateEDIFileWithBatchWrite()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFileWithBatchWrite Method (outputFile)

GenerateEDIFileWithBatchWrite Method (outputFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFileWithBatchWrite(String)
Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFileWithBatchWrite(
    string outputFile
)
Public Sub GenerateEDIFileWithBatchWrite ( _
    outputFile As String _
)
public:
void GenerateEDIFileWithBatchWrite(
    String^ outputFile
)
Parameters
outputFile (String)
path of outputfile

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFileWithBatchWrite Method (outputFile, insertInterval, insertChar)

GenerateEDIFileWithBatchWrite Method (outputFile, insertInterval, insertChar)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► GenerateEDIFileWithBatchWrite(String, Int32, Char)
Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFileWithBatchWrite(
    string outputFile,
    int insertInterval,
    char insertChar
)
Public Sub GenerateEDIFileWithBatchWrite ( _
    outputFile As String, _
    insertInterval As Integer, _
    insertChar As Char _
)
public:
void GenerateEDIFileWithBatchWrite(
    String^ outputFile,
    int insertInterval,
    wchar_t insertChar
)
Parameters
outputFile (String)
path of outputfile
insertInterval (Int32)
the insert interval
insertChar (Char)
Char to insert every interval

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► Loops
Main EDI loop. All other loops will be added to this loop
Declaration Syntax
C# Visual Basic Visual C++
public Loops Loops { get; set; }
Public Property Loops As Loops
    Get
    Set
public:
property Loops^ Loops {
    Loops^ get ();
    void set (Loops^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PadDataValues Property

PadDataValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► PadDataValues
Pad or trims element data to reach mininum and maximum element length requirements
Declaration Syntax
C# Visual Basic Visual C++
public bool PadDataValues { get; set; }
Public Property PadDataValues As Boolean
    Get
    Set
public:
property bool PadDataValues {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSeparatorString Property

SegmentSeparatorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► SegmentSeparatorString
String to insert between segments for formatting
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentSeparatorString { get; set; }
Public Property SegmentSeparatorString As String
    Get
    Set
public:
property String^ SegmentSeparatorString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml()()()()
Members
Icon | Member | Description
 | ToXml()()()() | Converts this EDIDocument into an XMLDocument
 | ToXml(XmlConfigOptions) | Converts this EDILightWeightDOcument to an XMLDocument
 | ToXml(String) | Converts this EDIDocument to Xml
 | ToXml(String, XmlConfigOptions) | Converts this EDIDocument to Xml

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml()()()()
Converts this EDIDocument into an XMLDocument
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml()
Public Function ToXml As XmlDocument
public:
XmlDocument^ ToXml()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method (options)

ToXml Method (options)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml(XmlConfigOptions)
Converts this EDILightWeightDOcument to an XMLDocument
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml(
    XmlConfigOptions options
)
Public Function ToXml ( _
    options As XmlConfigOptions _
) As XmlDocument
public:
XmlDocument^ ToXml(
    XmlConfigOptions^ options
)
Parameters
options (XmlConfigOptions)
Configuration options
Return Value
XmlDocument

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method (filename)

ToXml Method (filename)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml(String)
Converts this EDIDocument to Xml
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string filename
)
Public Sub ToXml ( _
    filename As String _
)
public:
void ToXml(
    String^ filename
)
Parameters
filename (String)
The file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method (file, options)

ToXml Method (file, options)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► ToXml(String, XmlConfigOptions)
Converts this EDIDocument to Xml
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string file,
    XmlConfigOptions options
)
Public Sub ToXml ( _
    file As String, _
    options As XmlConfigOptions _
)
public:
void ToXml(
    String^ file,
    XmlConfigOptions^ options
)
Parameters
file (String)
The file.
options (XmlConfigOptions)
Xml options.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TruncateEmptyCompositeElements Property

TruncateEmptyCompositeElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► TruncateEmptyCompositeElements
Removes empty trailing composites elements
Declaration Syntax
C# Visual Basic Visual C++
public bool TruncateEmptyCompositeElements { get; set; }
Public Property TruncateEmptyCompositeElements As Boolean
    Get
    Set
public:
property bool TruncateEmptyCompositeElements {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TruncateEmptyElements Property

TruncateEmptyElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► TruncateEmptyElements
Removes empty trailing elements
Declaration Syntax
C# Visual Basic Visual C++
public bool TruncateEmptyElements { get; set; }
Public Property TruncateEmptyElements As Boolean
    Get
    Set
public:
property bool TruncateEmptyElements {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocumentException Class

EDIDocumentException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocumentException
Exception thrown when an exception occurred while generating an EDI document
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EDIDocumentException : Exception
<SerializableAttribute> _
Public Class EDIDocumentException _
    Inherits Exception
[SerializableAttribute]
public ref class EDIDocumentException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | EDIDocumentException

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIError Class

EDIError Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError
Represents a general EDI error. Errors are available after validation
Declaration Syntax
C# Visual Basic Visual C++
public class EDIError
Public Class EDIError
public ref class EDIError
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CompositeElementOrdinal | Get the composite element number that contains the error
 | Description | Get the description of the error
 | ElementOrdinal | Get the element number that contains the error
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GSSegment | Gets the GS segment.
 | LineNumber | Get the line number of the error in the EDI file
 | Loop | Get the name of the loop that contains the error
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | General error message type
 | Segment | Get the name of the segment that contains the error
 | SegmentPositionInTransaction | Gets or sets the segment position in transaction.
 | SegmentSchema | The schema of the segment that was being validated while the error/warning occurred
 | SetSnipLevel()()()() | Sets the snip level.
 | SnipLevel | Snip level
 | StackTrace | Gets the stack trace if this is an unexpected error
 | STSegment | Gets the ST segment.
 | ToString()()()() | Get a string represenation of the error (Overrides Object.ToString()()()().)
 | ValidatingSegment | The actual segment that was being evaluated while the error/warning occurred
Inheritance Hierarchy
Object
 | EDIError
 |  | EDIWarning

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementOrdinal Property

CompositeElementOrdinal Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► CompositeElementOrdinal
Get the composite element number that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public int CompositeElementOrdinal { get; internal set; }
Public Property CompositeElementOrdinal As Integer
    Get
    Friend Set
public:
property int CompositeElementOrdinal {
    int get ();
    internal: void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► Description
Get the description of the error
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; internal set; }
Public Property Description As String
    Get
    Friend Set
public:
property String^ Description {
    String^ get ();
    internal: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementOrdinal Property

ElementOrdinal Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► ElementOrdinal
Get the element number that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinal { get; internal set; }
Public Property ElementOrdinal As Integer
    Get
    Friend Set
public:
property int ElementOrdinal {
    int get ();
    internal: void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GSSegment Property

GSSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► GSSegment
Gets the GS segment.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment GSSegment { get; internal set; }
Public Property GSSegment As LightWeightSegment
    Get
    Friend Set
public:
property LightWeightSegment^ GSSegment {
    LightWeightSegment^ get ();
    internal: void set (LightWeightSegment^ value);
}
Value
The ST segment.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LineNumber Property

LineNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► LineNumber
Get the line number of the error in the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public int LineNumber { get; internal set; }
Public Property LineNumber As Integer
    Get
    Friend Set
public:
property int LineNumber {
    int get ();
    internal: void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loop Property

Loop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► Loop
Get the name of the loop that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public string Loop { get; internal set; }
Public Property Loop As String
    Get
    Friend Set
public:
property String^ Loop {
    String^ get ();
    internal: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Message Property

Message Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► Message
General error message type
Declaration Syntax
C# Visual Basic Visual C++
public EDIValidationMessage Message { get; internal set; }
Public Property Message As EDIValidationMessage
    Get
    Friend Set
public:
property EDIValidationMessage Message {
    EDIValidationMessage get ();
    internal: void set (EDIValidationMessage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segment Property

Segment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► Segment
Get the name of the segment that contains the error
Declaration Syntax
C# Visual Basic Visual C++
public string Segment { get; internal set; }
Public Property Segment As String
    Get
    Friend Set
public:
property String^ Segment {
    String^ get ();
    internal: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentPositionInTransaction Property

SegmentPositionInTransaction Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SegmentPositionInTransaction
Gets or sets the segment position in transaction.
Declaration Syntax
C# Visual Basic Visual C++
public long SegmentPositionInTransaction { get; internal set; }
Public Property SegmentPositionInTransaction As Long
    Get
    Friend Set
public:
property long long SegmentPositionInTransaction {
    long long get ();
    internal: void set (long long value);
}
Value
The segment position in transaction.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchema Property

SegmentSchema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SegmentSchema
The schema of the segment that was being validated while the error/warning occurred
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment SegmentSchema { get; internal set; }
Public Property SegmentSchema As DataSegment
    Get
    Friend Set
public:
property DataSegment^ SegmentSchema {
    DataSegment^ get ();
    internal: void set (DataSegment^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SetSnipLevel Method

SetSnipLevel Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SetSnipLevel()()()()
Sets the snip level.
Declaration Syntax
C# Visual Basic Visual C++
protected void SetSnipLevel()
Protected Sub SetSnipLevel
protected:
void SetSnipLevel()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SnipLevel Property

SnipLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► SnipLevel
Snip level
Declaration Syntax
C# Visual Basic Visual C++
public SnipTestLevel SnipLevel { get; internal set; }
Public Property SnipLevel As SnipTestLevel
    Get
    Friend Set
public:
property SnipTestLevel SnipLevel {
    SnipTestLevel get ();
    internal: void set (SnipTestLevel value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


StackTrace Property

StackTrace Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► StackTrace
Gets the stack trace if this is an unexpected error
Declaration Syntax
C# Visual Basic Visual C++
public string StackTrace { get; internal set; }
Public Property StackTrace As String
    Get
    Friend Set
public:
property String^ StackTrace {
    String^ get ();
    internal: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


STSegment Property

STSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► STSegment
Gets the ST segment.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment STSegment { get; internal set; }
Public Property STSegment As LightWeightSegment
    Get
    Friend Set
public:
property LightWeightSegment^ STSegment {
    LightWeightSegment^ get ();
    internal: void set (LightWeightSegment^ value);
}
Value
The ST segment.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► ToString()()()()
Get a string represenation of the error
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidatingSegment Property

ValidatingSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIError ► ValidatingSegment
The actual segment that was being evaluated while the error/warning occurred
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment ValidatingSegment { get; internal set; }
Public Property ValidatingSegment As LightWeightSegment
    Get
    Friend Set
public:
property LightWeightSegment^ ValidatingSegment {
    LightWeightSegment^ get ();
    internal: void set (LightWeightSegment^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFACTStrings Class

EDIFACTStrings Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings
Declaration Syntax
C# Visual Basic Visual C++
public class EDIFACTStrings
Public Class EDIFACTStrings
public ref class EDIFACTStrings
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFACTStrings()()()() | Initializes a new instance of the EDIFACTStrings class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UNA |
 | UNB |
 | UNE |
 | UNG |
 | UNH |
 | UNT |
 | UNZ |
Inheritance Hierarchy
Object
EDIFACTStrings

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFACTStrings Constructor

EDIFACTStrings Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings ► EDIFACTStrings()()()()
Initializes a new instance of the EDIFACTStrings class
Declaration Syntax
C# Visual Basic Visual C++
public EDIFACTStrings()
Public Sub New
public:
EDIFACTStrings()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UNA Field

UNA Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings ► UNA
Declaration Syntax
C# Visual Basic Visual C++
public const string UNA
Public Const UNA As String
public:
literal String^ UNA

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UNB Field

UNB Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings ► UNB
Declaration Syntax
C# Visual Basic Visual C++
public const string UNB
Public Const UNB As String
public:
literal String^ UNB

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UNE Field

UNE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings ► UNE
Declaration Syntax
C# Visual Basic Visual C++
public const string UNE
Public Const UNE As String
public:
literal String^ UNE

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UNG Field

UNG Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings ► UNG
Declaration Syntax
C# Visual Basic Visual C++
public const string UNG
Public Const UNG As String
public:
literal String^ UNG

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UNH Field

UNH Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings ► UNH
Declaration Syntax
C# Visual Basic Visual C++
public const string UNH
Public Const UNH As String
public:
literal String^ UNH

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UNT Field

UNT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings ► UNT
Declaration Syntax
C# Visual Basic Visual C++
public const string UNT
Public Const UNT As String
public:
literal String^ UNT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UNZ Field

UNZ Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFACTStrings ► UNZ
Declaration Syntax
C# Visual Basic Visual C++
public const string UNZ
Public Const UNZ As String
public:
literal String^ UNZ

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileJoiner Class

EDIFileJoiner Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner
Component used to join EDI files
Declaration Syntax
C# Visual Basic Visual C++
public class EDIFileJoiner : Component
Public Class EDIFileJoiner _
    Inherits Component
public ref class EDIFileJoiner : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileJoiner()()()() | Initializes a new instance of the EDIFileJoiner class.
 | EDIFileJoiner(IContainer) | Initializes a new instance of the EDIFileJoiner class.
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | AutoGenerateSTControlNumber | Gets or sets whether to generate ST control number
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Delimiters |
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EachSegmentInNewLine | Gets or sets a value indicating whether each segment should be in a new line.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileJoinLevel | Gets or sets the file join level where file joining should occur, at the Header level(ST) or the Functional Group level (GS)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Join(List<(Of <<'(String>)>>), String, Object) | Obsolete. Joins the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
 | Join(List<(Of <<'(String>)>>), String) | Joins the specified files.
 | JoinAsync(List<(Of <<'(String>)>>), String, Object) | Joins the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
 | JoinStrings(List<(Of <<'(String>)>>)) | Join EDI data from strings
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewFileBufferSize | Gets or sets the file buffer size for the output file
 | OnFileOperationCompleted | Raised when file joining operations are completed
 | ReadBlockSize | Gets or sets the size of the block.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrimString | Gets or sets the trim string. Trim string are used to remove formatting characters from edi data
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIFileJoiner

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileJoiner Constructor

EDIFileJoiner Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► EDIFileJoiner()()()()
Members
Icon | Member | Description
 | EDIFileJoiner()()()() | Initializes a new instance of the EDIFileJoiner class.
 | EDIFileJoiner(IContainer) | Initializes a new instance of the EDIFileJoiner class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileJoiner Constructor

EDIFileJoiner Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► EDIFileJoiner()()()()
Initializes a new instance of the EDIFileJoiner class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileJoiner()
Public Sub New
public:
EDIFileJoiner()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileJoiner Constructor (container)

EDIFileJoiner Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► EDIFileJoiner(IContainer)
Initializes a new instance of the EDIFileJoiner class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileJoiner(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIFileJoiner(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► AutoDetectDelimiters
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoGenerateSTControlNumber Property

AutoGenerateSTControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► AutoGenerateSTControlNumber
Gets or sets whether to generate ST control number
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoGenerateSTControlNumber { get; set; }
Public Property AutoGenerateSTControlNumber As Boolean
    Get
    Set
public:
property bool AutoGenerateSTControlNumber {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EachSegmentInNewLine Property

EachSegmentInNewLine Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► EachSegmentInNewLine
Gets or sets a value indicating whether each segment should be in a new line.
Declaration Syntax
C# Visual Basic Visual C++
public bool EachSegmentInNewLine { get; set; }
Public Property EachSegmentInNewLine As Boolean
    Get
    Set
public:
property bool EachSegmentInNewLine {
    bool get ();
    void set (bool value);
}
Value
true if [each segment in new line]; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileJoinLevel Property

FileJoinLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► FileJoinLevel
Gets or sets the file join level where file joining should occur, at the Header level(ST) or the Functional Group level (GS)
Declaration Syntax
C# Visual Basic Visual C++
public FileJoinLevel FileJoinLevel { get; set; }
Public Property FileJoinLevel As FileJoinLevel
    Get
    Set
public:
property FileJoinLevel FileJoinLevel {
    FileJoinLevel get ();
    void set (FileJoinLevel value);
}
Value
The file join level.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Join Method

Join Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Join()()()()
Members
Icon | Member | Description
 | Join(List<(Of <<'(String>)>>), String, Object) | Obsolete. Joins the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
 | Join(List<(Of <<'(String>)>>), String) | Joins the specified files.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Join Method (files, outputFile)

Join Method (files, outputFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Join(List<(Of <<'(String>)>>), String)
Joins the specified files.
Declaration Syntax
C# Visual Basic Visual C++
public void Join(
    List<string> files,
    string outputFile
)
Public Sub Join ( _
    files As List(Of String), _
    outputFile As String _
)
public:
void Join(
    List<String^>^ files,
    String^ outputFile
)
Parameters
files (List <(Of <(<' String >)>)>)
The files.
outputFile (String)
The output file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Join Method (files, outputFile, state)

Join Method (files, outputFile, state)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Join(List<(Of <<'(String>)>>), String, Object)
Joins the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use JoinAsync(List<string> files, string outputFile, object state = null) instead ")]
public void Join(
    List<string> files,
    string outputFile,
    Object state
)
<ObsoleteAttribute("Use JoinAsync(List<string> files, string outputFile, object state = null) instead ")> _
Public Sub Join ( _
    files As List(Of String), _
    outputFile As String, _
    state As Object _
)
[ObsoleteAttribute(L"Use JoinAsync(List<string> files, string outputFile, object state = null) instead ")]
public:
void Join(
    List<String^>^ files,
    String^ outputFile,
    Object^ state
)
Parameters
files (List <(Of <(<' String >)>)>)
The files.
outputFile (String)
The new file.
state (Object)
Any state that should be returned in the OnFileOperationCompleted event

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


JoinAsync Method (files, outputFile, state)

JoinAsync Method (files, outputFile, state)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► JoinAsync(List<(Of <<'(String>)>>), String, Object)
Joins the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
Declaration Syntax
C# Visual Basic Visual C++
public void JoinAsync(
    List<string> files,
    string outputFile,
    Object state
)
Public Sub JoinAsync ( _
    files As List(Of String), _
    outputFile As String, _
    state As Object _
)
public:
void JoinAsync(
    List<String^>^ files,
    String^ outputFile,
    Object^ state
)
Parameters
files (List <(Of <(<' String >)>)>)
The files.
outputFile (String)
The new file.
state (Object)
Any state that should be returned in the OnFileOperationCompleted event

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


JoinStrings Method (ediDataStrings)

JoinStrings Method (ediDataStrings)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► JoinStrings(List<(Of <<'(String>)>>))
Join EDI data from strings
Declaration Syntax
C# Visual Basic Visual C++
public string JoinStrings(
    List<string> ediDataStrings
)
Public Function JoinStrings ( _
    ediDataStrings As List(Of String) _
) As String
public:
String^ JoinStrings(
    List<String^>^ ediDataStrings
)
Parameters
ediDataStrings (List <(Of <(<' String >)>)>)
list of EDI strings to join
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NewFileBufferSize Property

NewFileBufferSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► NewFileBufferSize
Gets or sets the file buffer size for the output file
Declaration Syntax
C# Visual Basic Visual C++
public int NewFileBufferSize { get; set; }
Public Property NewFileBufferSize As Integer
    Get
    Set
public:
property int NewFileBufferSize {
    int get ();
    void set (int value);
}
Value
The new size of the file buffer.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OnFileOperationCompleted Event

OnFileOperationCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► OnFileOperationCompleted
Raised when file joining operations are completed
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<FileOperationCompletedEventArgs> OnFileOperationCompleted
Public Event OnFileOperationCompleted As EventHandler(Of FileOperationCompletedEventArgs)
public:
 event EventHandler<FileOperationCompletedEventArgs^>^ OnFileOperationCompleted {
    void add (EventHandler<FileOperationCompletedEventArgs^>^ value);
    void remove (EventHandler<FileOperationCompletedEventArgs^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ReadBlockSize Property

ReadBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► ReadBlockSize
Gets or sets the size of the block.
Declaration Syntax
C# Visual Basic Visual C++
public int ReadBlockSize { get; set; }
Public Property ReadBlockSize As Integer
    Get
    Set
public:
property int ReadBlockSize {
    int get ();
    void set (int value);
}
Value
The size of the block.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► TrimString
Gets or sets the trim string. Trim string are used to remove formatting characters from edi data
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}
Value
The trim string.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileLoader Class

EDIFileLoader Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader
Parses and loads EDI files without any rules
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIFileLoader : Component
Public NotInheritable Class EDIFileLoader _
    Inherits Component
public ref class EDIFileLoader sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileLoader()()()() | Initializes a new instance of the EDIFileLoader class.
 | EDIFileLoader(IContainer) | Initializes a new instance of the EDIFileLoader class.
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Delimiters | EDI file delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDataString | EDI data to load. EDI data can also be specified from a file using the EDIFile property
 | EDIFile | Full path of EDI file to load
 | EDIFileType | Used to specify the type of EDI file to be loaded
 | EDISource | Used to specify if validation is for an in-memory string or a file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorString | Used to report any errors encountered during file load
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBlockSize | File chunk size when validating EDI data from a file
 | FileLoadingCompleted | Event fired when file loading is complete
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FlatStructure | Get/Set whether or not a separate loop is created whenever an ISA segment is encountered
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Load(String) | Loads EDI data from a string
 | Load()()()() | Load EDI File. This is result in only one loop with all DataSegments
 | LoadFile(String) | Load an EDI file without rules. This is result in only one loop with all data segments
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | TimeElapsed | Time elapsed in milliseconds while loading
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrimString | String to ignore at between segment delimiters
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIFileLoader

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileLoader Constructor

EDIFileLoader Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileLoader()()()()
Members
Icon | Member | Description
 | EDIFileLoader()()()() | Initializes a new instance of the EDIFileLoader class.
 | EDIFileLoader(IContainer) | Initializes a new instance of the EDIFileLoader class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileLoader Constructor

EDIFileLoader Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileLoader()()()()
Initializes a new instance of the EDIFileLoader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileLoader()
Public Sub New
public:
EDIFileLoader()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileLoader Constructor (container)

EDIFileLoader Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileLoader(IContainer)
Initializes a new instance of the EDIFileLoader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileLoader(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIFileLoader(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► AutoDetectDelimiters
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Delimiters
EDI file delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDataString Property

EDIDataString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIDataString
EDI data to load. EDI data can also be specified from a file using the EDIFile property
Declaration Syntax
C# Visual Basic Visual C++
public string EDIDataString { get; set; }
Public Property EDIDataString As String
    Get
    Set
public:
property String^ EDIDataString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFile Property

EDIFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFile
Full path of EDI file to load
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFile { get; set; }
Public Property EDIFile As String
    Get
    Set
public:
property String^ EDIFile {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileType
Used to specify the type of EDI file to be loaded
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDISource Property

EDISource Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDISource
Used to specify if validation is for an in-memory string or a file
Declaration Syntax
C# Visual Basic Visual C++
public EDISource EDISource { get; set; }
Public Property EDISource As EDISource
    Get
    Set
public:
property EDISource EDISource {
    EDISource get ();
    void set (EDISource value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ErrorString Property

ErrorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► ErrorString
Used to report any errors encountered during file load
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorString { get; }
Public ReadOnly Property ErrorString As String
    Get
public:
property String^ ErrorString {
    String^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileBlockSize Property

FileBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► FileBlockSize
File chunk size when validating EDI data from a file
Declaration Syntax
C# Visual Basic Visual C++
public int FileBlockSize { get; set; }
Public Property FileBlockSize As Integer
    Get
    Set
public:
property int FileBlockSize {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileLoadingCompleted Event

FileLoadingCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► FileLoadingCompleted
Event fired when file loading is complete
Declaration Syntax
C# Visual Basic Visual C++
public event EDIFileLoader..::..EDIFileLoadingCompletedEvent FileLoadingCompleted
Public Event FileLoadingCompleted As EDIFileLoader..::..EDIFileLoadingCompletedEvent
public:
 event EDIFileLoader..::..EDIFileLoadingCompletedEvent^ FileLoadingCompleted {
    void add (EDIFileLoader..::..EDIFileLoadingCompletedEvent^ value);
    void remove (EDIFileLoader..::..EDIFileLoadingCompletedEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FlatStructure Property

FlatStructure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► FlatStructure
Get/Set whether or not a separate loop is created whenever an ISA segment is encountered
Declaration Syntax
C# Visual Basic Visual C++
public bool FlatStructure { get; set; }
Public Property FlatStructure As Boolean
    Get
    Set
public:
property bool FlatStructure {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Load Method

Load Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Load()()()()
Members
Icon | Member | Description
 | Load(String) | Loads EDI data from a string
 | Load()()()() | Load EDI File. This is result in only one loop with all DataSegments

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Load Method

Load Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Load()()()()
Load EDI File. This is result in only one loop with all DataSegments
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument Load()
Public Function Load As EDILightWeightDocument
public:
EDILightWeightDocument^ Load()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Load Method (ediData)

Load Method (ediData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Load(String)
Loads EDI data from a string
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument Load(
    string ediData
)
Public Function Load ( _
    ediData As String _
) As EDILightWeightDocument
public:
EDILightWeightDocument^ Load(
    String^ ediData
)
Parameters
ediData (String)
EDILightWeightDocument
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoadFile Method (ediFilePath)

LoadFile Method (ediFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► LoadFile(String)
Load an EDI file without rules. This is result in only one loop with all data segments
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument LoadFile(
    string ediFilePath
)
Public Function LoadFile ( _
    ediFilePath As String _
) As EDILightWeightDocument
public:
EDILightWeightDocument^ LoadFile(
    String^ ediFilePath
)
Parameters
ediFilePath (String)
path of EDI file
Return Value
EDILightWeightDocument

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TimeElapsed Property

TimeElapsed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► TimeElapsed
Time elapsed in milliseconds while loading
Declaration Syntax
C# Visual Basic Visual C++
public double TimeElapsed { get; }
Public ReadOnly Property TimeElapsed As Double
    Get
public:
property double TimeElapsed {
    double get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► TrimString
String to ignore at between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileLoader.EDIFileLoadingCompletedEvent Delegate

EDIFileLoader..::..EDIFileLoadingCompletedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► EDIFileLoader..::..EDIFileLoadingCompletedEvent
Delegate used for raising and event after EDI file loading has completed
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EDIFileLoadingCompletedEvent(
    Object sender,
    FileLoadingEventArgs e
)
Public Delegate Sub EDIFileLoadingCompletedEvent ( _
    sender As Object, _
    e As FileLoadingEventArgs _
)
public delegate void EDIFileLoadingCompletedEvent(
    Object^ sender,
    FileLoadingEventArgs^ e
)
Parameters
sender (Object)
sender of the event
e (FileLoadingEventArgs)
data relating to file loading

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileParser Class

EDIFileParser Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser
Declaration Syntax
C# Visual Basic Visual C++
public class EDIFileParser
Public Class EDIFileParser
public ref class EDIFileParser
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstChunkLoaded |
 | GetDelimiters(String) |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCompleted()()()() |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberOfSegments |
 | StartLoadingFile(Char) |
 | Take()()()() |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | WAIT_TIME |
Inheritance Hierarchy
Object
EDIFileParser

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FirstChunkLoaded Property

FirstChunkLoaded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► FirstChunkLoaded
Declaration Syntax
C# Visual Basic Visual C++
public bool FirstChunkLoaded { get; }
Public ReadOnly Property FirstChunkLoaded As Boolean
    Get
public:
property bool FirstChunkLoaded {
    bool get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetDelimiters Method (trimString)

GetDelimiters Method (trimString)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► GetDelimiters(String)
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters GetDelimiters(
    string trimString
)
Public Function GetDelimiters ( _
    trimString As String _
) As Delimiters
public:
Delimiters^ GetDelimiters(
    String^ trimString
)
Parameters
trimString (String)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsCompleted Method

IsCompleted Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► IsCompleted()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCompleted()
Public Function IsCompleted As Boolean
public:
bool IsCompleted()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NumberOfSegments Property

NumberOfSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► NumberOfSegments
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfSegments { get; private set; }
Public Property NumberOfSegments As Integer
    Get
    Private Set
public:
property int NumberOfSegments {
    int get ();
    private: void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


StartLoadingFile Method (delimiter)

StartLoadingFile Method (delimiter)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► StartLoadingFile(Char)
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileParser..::..FileProgress StartLoadingFile(
    char delimiter
)
Public Function StartLoadingFile ( _
    delimiter As Char _
) As EDIFileParser..::..FileProgress
public:
EDIFileParser..::..FileProgress^ StartLoadingFile(
    wchar_t delimiter
)
Parameters
delimiter (Char)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Take Method

Take Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► Take()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string Take()
Public Function Take As String
public:
String^ Take()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


WAIT_TIME Field

WAIT_TIME Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► WAIT_TIME
Declaration Syntax
C# Visual Basic Visual C++
public static int WAIT_TIME
Public Shared WAIT_TIME As Integer
public:
static int WAIT_TIME

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileParser.FileProgress Class

EDIFileParser..::..FileProgress Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser ► EDIFileParser..::..FileProgress
Declaration Syntax
C# Visual Basic Visual C++
public class FileProgress
Public Class FileProgress
public ref class FileProgress
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EDIFileParser..::..FileProgress(Int64) | Initializes a new instance of the EDIFileParser..::..FileProgress class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Update(Int64) |
Inheritance Hierarchy
Object
EDIFileParser..::..FileProgress

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileParser.FileProgress Constructor (initialSize)

EDIFileParser..::..FileProgress Constructor (initialSize)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser..::..FileProgress ► EDIFileParser..::..FileProgress(Int64)
Initializes a new instance of the EDIFileParser..::..FileProgress class
Declaration Syntax
C# Visual Basic Visual C++
public FileProgress(
    long initialSize
)
Public Sub New ( _
    initialSize As Long _
)
public:
FileProgress(
    long long initialSize
)
Parameters
initialSize (Int64)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Update Method (currentPosition)

Update Method (currentPosition)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileParser..::..FileProgress ► Update(Int64)
Declaration Syntax
C# Visual Basic Visual C++
public void Update(
    long currentPosition
)
Public Sub Update ( _
    currentPosition As Long _
)
public:
void Update(
    long long currentPosition
)
Parameters
currentPosition (Int64)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileScrubber Class

EDIFileScrubber Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber
Parses and scrubs EDI files
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIFileScrubber : Component
Public NotInheritable Class EDIFileScrubber _
    Inherits Component
public ref class EDIFileScrubber sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileScrubber()()()() | Initializes a new instance of the EDIFileScrubber class.
 | EDIFileScrubber(IContainer) | Initializes a new instance of the EDIFileScrubber class.
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Delimiters | EDI file delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDataString | EDI data to scrub. EDI data can also be specified from a file using the EDIFile property
 | EDIFile | Full path of EDI file to scrub
 | EDIFileType | Used to specify the type of EDI file to be scrubbed
 | EDISource | Used to specify if validation is for an in-memory string or a file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorString | Used to report any errors encountered during file scrubbing
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBlockSize | File chunk size when scrubbing EDI data from a file
 | FileScrubbingCompleted | Event fired when file scrubbing is complete
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scrub(String) | Scrubs EDI data from a string
 | Scrub()()()() | Scrub EDI File. This results in only one loop with all DataSegments
 | ScrubFile(String) | Scrubs an EDI file This is result in only one loop with all data segments
 | ScrubRules | Rules used to scrub a file
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | TimeElapsed | Time elapsed in milliseconds while scrubbing
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrimString | String to ignore at between segment delimiters
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIFileScrubber

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileScrubber Constructor

EDIFileScrubber Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileScrubber()()()()
Members
Icon | Member | Description
 | EDIFileScrubber()()()() | Initializes a new instance of the EDIFileScrubber class.
 | EDIFileScrubber(IContainer) | Initializes a new instance of the EDIFileScrubber class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileScrubber Constructor

EDIFileScrubber Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileScrubber()()()()
Initializes a new instance of the EDIFileScrubber class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileScrubber()
Public Sub New
public:
EDIFileScrubber()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileScrubber Constructor (container)

EDIFileScrubber Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileScrubber(IContainer)
Initializes a new instance of the EDIFileScrubber class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileScrubber(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIFileScrubber(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► AutoDetectDelimiters
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Delimiters
EDI file delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDataString Property

EDIDataString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIDataString
EDI data to scrub. EDI data can also be specified from a file using the EDIFile property
Declaration Syntax
C# Visual Basic Visual C++
public string EDIDataString { get; set; }
Public Property EDIDataString As String
    Get
    Set
public:
property String^ EDIDataString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFile Property

EDIFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFile
Full path of EDI file to scrub
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFile { get; set; }
Public Property EDIFile As String
    Get
    Set
public:
property String^ EDIFile {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileType
Used to specify the type of EDI file to be scrubbed
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDISource Property

EDISource Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDISource
Used to specify if validation is for an in-memory string or a file
Declaration Syntax
C# Visual Basic Visual C++
public EDISource EDISource { get; set; }
Public Property EDISource As EDISource
    Get
    Set
public:
property EDISource EDISource {
    EDISource get ();
    void set (EDISource value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ErrorString Property

ErrorString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► ErrorString
Used to report any errors encountered during file scrubbing
Declaration Syntax
C# Visual Basic Visual C++
public string ErrorString { get; }
Public ReadOnly Property ErrorString As String
    Get
public:
property String^ ErrorString {
    String^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileBlockSize Property

FileBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► FileBlockSize
File chunk size when scrubbing EDI data from a file
Declaration Syntax
C# Visual Basic Visual C++
public int FileBlockSize { get; set; }
Public Property FileBlockSize As Integer
    Get
    Set
public:
property int FileBlockSize {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileScrubbingCompleted Event

FileScrubbingCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► FileScrubbingCompleted
Event fired when file scrubbing is complete
Declaration Syntax
C# Visual Basic Visual C++
public event EDIFileScrubber..::..EDIFileScrubbingCompletedEvent FileScrubbingCompleted
Public Event FileScrubbingCompleted As EDIFileScrubber..::..EDIFileScrubbingCompletedEvent
public:
 event EDIFileScrubber..::..EDIFileScrubbingCompletedEvent^ FileScrubbingCompleted {
    void add (EDIFileScrubber..::..EDIFileScrubbingCompletedEvent^ value);
    void remove (EDIFileScrubber..::..EDIFileScrubbingCompletedEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Scrub Method

Scrub Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Scrub()()()()
Members
Icon | Member | Description
 | Scrub(String) | Scrubs EDI data from a string
 | Scrub()()()() | Scrub EDI File. This results in only one loop with all DataSegments

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Scrub Method

Scrub Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Scrub()()()()
Scrub EDI File. This results in only one loop with all DataSegments
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument Scrub()
Public Function Scrub As EDILightWeightDocument
public:
EDILightWeightDocument^ Scrub()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Scrub Method (ediData)

Scrub Method (ediData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Scrub(String)
Scrubs EDI data from a string
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument Scrub(
    string ediData
)
Public Function Scrub ( _
    ediData As String _
) As EDILightWeightDocument
public:
EDILightWeightDocument^ Scrub(
    String^ ediData
)
Parameters
ediData (String)
EDILightWeightDocument
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubFile Method (ediFilePath)

ScrubFile Method (ediFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► ScrubFile(String)
Scrubs an EDI file This is result in only one loop with all data segments
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument ScrubFile(
    string ediFilePath
)
Public Function ScrubFile ( _
    ediFilePath As String _
) As EDILightWeightDocument
public:
EDILightWeightDocument^ ScrubFile(
    String^ ediFilePath
)
Parameters
ediFilePath (String)
path of EDI file
Return Value
EDILightWeightDocument

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubRules Property

ScrubRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► ScrubRules
Rules used to scrub a file
Declaration Syntax
C# Visual Basic Visual C++
public List<ScrubRule> ScrubRules { get; }
Public ReadOnly Property ScrubRules As List(Of ScrubRule)
    Get
public:
property List<ScrubRule^>^ ScrubRules {
    List<ScrubRule^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TimeElapsed Property

TimeElapsed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► TimeElapsed
Time elapsed in milliseconds while scrubbing
Declaration Syntax
C# Visual Basic Visual C++
public double TimeElapsed { get; }
Public ReadOnly Property TimeElapsed As Double
    Get
public:
property double TimeElapsed {
    double get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► TrimString
String to ignore at between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileScrubber.EDIFileScrubbingCompletedEvent Delegate

EDIFileScrubber..::..EDIFileScrubbingCompletedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► EDIFileScrubber..::..EDIFileScrubbingCompletedEvent
Delegate used for raising and event after EDI file scrubbing has completed
Declaration Syntax
C# Visual Basic Visual C++
public delegate void EDIFileScrubbingCompletedEvent(
    Object sender,
    FileLoadingEventArgs e
)
Public Delegate Sub EDIFileScrubbingCompletedEvent ( _
    sender As Object, _
    e As FileLoadingEventArgs _
)
public delegate void EDIFileScrubbingCompletedEvent(
    Object^ sender,
    FileLoadingEventArgs^ e
)
Parameters
sender (Object)
sender of the event
e (FileLoadingEventArgs)
data relating to file scrubbing

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileSplitter Class

EDIFileSplitter Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter
Component used to split EDI files
Declaration Syntax
C# Visual Basic Visual C++
public class EDIFileSplitter : Component
Public Class EDIFileSplitter _
    Inherits Component
public ref class EDIFileSplitter : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIFileSplitter()()()() | Initializes a new instance of the EDIFileSplitter class.
 | EDIFileSplitter(IContainer) | Initializes a new instance of the EDIFileSplitter class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIFileType | Used to specify the type of EDI file to be split
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileSplitLevel | Gets or sets the file split level
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GeneratePseudoRandomNumberInFilename | Used to specify the type of EDI file to be split
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberOfItemsPerFile | Gets or sets the number of ISA Envelopes/ST Headers/GS Functional Groups per file
 | OnFileOperationCompleted | Raised when file splitting operations are completed
 | OutputFilename | Used to specify the name of the output file
 | OutputFilenameFormat | Used to specify the name of the output file
 | ReadBlockSize | Gets or sets the size of the block.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | Split(String, String) | Splits the specified EDI files synchronously.
 | Split(String, String, Object) | Obsolete. Splits the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
 | SplitAsync(String, String, Object) | Splits the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
 | SplitFileExtension | Gets or sets the file extension of the splitted files. The default is .txt
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrimString | Gets or sets the trim string.
 | WriteBlockBuffer | Gets or sets the write block buffer when writing data to spit files
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIFileSplitter

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileSplitter Constructor

EDIFileSplitter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► EDIFileSplitter()()()()
Members
Icon | Member | Description
 | EDIFileSplitter()()()() | Initializes a new instance of the EDIFileSplitter class.
 | EDIFileSplitter(IContainer) | Initializes a new instance of the EDIFileSplitter class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileSplitter Constructor

EDIFileSplitter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► EDIFileSplitter()()()()
Initializes a new instance of the EDIFileSplitter class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileSplitter()
Public Sub New
public:
EDIFileSplitter()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileSplitter Constructor (container)

EDIFileSplitter Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► EDIFileSplitter(IContainer)
Initializes a new instance of the EDIFileSplitter class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIFileSplitter(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIFileSplitter(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► EDIFileType
Used to specify the type of EDI file to be split
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileSplitLevel Property

FileSplitLevel Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► FileSplitLevel
Gets or sets the file split level
Declaration Syntax
C# Visual Basic Visual C++
public FileSplitLevel FileSplitLevel { get; set; }
Public Property FileSplitLevel As FileSplitLevel
    Get
    Set
public:
property FileSplitLevel FileSplitLevel {
    FileSplitLevel get ();
    void set (FileSplitLevel value);
}
Value
The file join level.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneratePseudoRandomNumberInFilename Property

GeneratePseudoRandomNumberInFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► GeneratePseudoRandomNumberInFilename
Used to specify the type of EDI file to be split
Declaration Syntax
C# Visual Basic Visual C++
public bool GeneratePseudoRandomNumberInFilename { get; set; }
Public Property GeneratePseudoRandomNumberInFilename As Boolean
    Get
    Set
public:
property bool GeneratePseudoRandomNumberInFilename {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NumberOfItemsPerFile Property

NumberOfItemsPerFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► NumberOfItemsPerFile
Gets or sets the number of ISA Envelopes/ST Headers/GS Functional Groups per file
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfItemsPerFile { get; set; }
Public Property NumberOfItemsPerFile As Integer
    Get
    Set
public:
property int NumberOfItemsPerFile {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OnFileOperationCompleted Event

OnFileOperationCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► OnFileOperationCompleted
Raised when file splitting operations are completed
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<FileOperationCompletedEventArgs> OnFileOperationCompleted
Public Event OnFileOperationCompleted As EventHandler(Of FileOperationCompletedEventArgs)
public:
 event EventHandler<FileOperationCompletedEventArgs^>^ OnFileOperationCompleted {
    void add (EventHandler<FileOperationCompletedEventArgs^>^ value);
    void remove (EventHandler<FileOperationCompletedEventArgs^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OutputFilename Property

OutputFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► OutputFilename
Used to specify the name of the output file
Declaration Syntax
C# Visual Basic Visual C++
public string OutputFilename { get; set; }
Public Property OutputFilename As String
    Get
    Set
public:
property String^ OutputFilename {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OutputFilenameFormat Property

OutputFilenameFormat Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► OutputFilenameFormat
Used to specify the name of the output file
Declaration Syntax
C# Visual Basic Visual C++
public string OutputFilenameFormat { get; set; }
Public Property OutputFilenameFormat As String
    Get
    Set
public:
property String^ OutputFilenameFormat {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ReadBlockSize Property

ReadBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► ReadBlockSize
Gets or sets the size of the block.
Declaration Syntax
C# Visual Basic Visual C++
public int ReadBlockSize { get; set; }
Public Property ReadBlockSize As Integer
    Get
    Set
public:
property int ReadBlockSize {
    int get ();
    void set (int value);
}
Value
The size of the block.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Split Method

Split Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► Split()()()()
Members
Icon | Member | Description
 | Split(String, String) | Splits the specified EDI files synchronously.
 | Split(String, String, Object) | Obsolete. Splits the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Split Method (file, outputDirectory)

Split Method (file, outputDirectory)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► Split(String, String)
Splits the specified EDI files synchronously.
Declaration Syntax
C# Visual Basic Visual C++
public void Split(
    string file,
    string outputDirectory
)
Public Sub Split ( _
    file As String, _
    outputDirectory As String _
)
public:
void Split(
    String^ file,
    String^ outputDirectory
)
Parameters
file (String)
The file.
outputDirectory (String)
The output directory.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Split Method (file, outputDirectory, state)

Split Method (file, outputDirectory, state)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► Split(String, String, Object)
Splits the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use SplitAsync(string file, string outputDirectory, object state = null) instead ")]
public void Split(
    string file,
    string outputDirectory,
    Object state
)
<ObsoleteAttribute("Use SplitAsync(string file, string outputDirectory, object state = null) instead ")> _
Public Sub Split ( _
    file As String, _
    outputDirectory As String, _
    state As Object _
)
[ObsoleteAttribute(L"Use SplitAsync(string file, string outputDirectory, object state = null) instead ")]
public:
void Split(
    String^ file,
    String^ outputDirectory,
    Object^ state
)
Parameters
file (String)
The file.
outputDirectory (String)
The output directory.
state (Object)
The state.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SplitAsync Method (file, outputDirectory, state)

SplitAsync Method (file, outputDirectory, state)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► SplitAsync(String, String, Object)
Splits the specified EDI files asynchronously. Fires a OnFileOperationCompleted when completed
Declaration Syntax
C# Visual Basic Visual C++
public void SplitAsync(
    string file,
    string outputDirectory,
    Object state
)
Public Sub SplitAsync ( _
    file As String, _
    outputDirectory As String, _
    state As Object _
)
public:
void SplitAsync(
    String^ file,
    String^ outputDirectory,
    Object^ state
)
Parameters
file (String)
The file.
outputDirectory (String)
The output directory.
state (Object)
The state.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SplitFileExtension Property

SplitFileExtension Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► SplitFileExtension
Gets or sets the file extension of the splitted files. The default is .txt
Declaration Syntax
C# Visual Basic Visual C++
public string SplitFileExtension { get; set; }
Public Property SplitFileExtension As String
    Get
    Set
public:
property String^ SplitFileExtension {
    String^ get ();
    void set (String^ value);
}
Value
The split file extension.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► TrimString
Gets or sets the trim string.
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}
Value
The trim string.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


WriteBlockBuffer Property

WriteBlockBuffer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► WriteBlockBuffer
Gets or sets the write block buffer when writing data to spit files
Declaration Syntax
C# Visual Basic Visual C++
public int WriteBlockBuffer { get; set; }
Public Property WriteBlockBuffer As Integer
    Get
    Set
public:
property int WriteBlockBuffer {
    int get ();
    void set (int value);
}
Value
The write block buffer.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDILightWeightDocument Class

EDILightWeightDocument Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument
A light weight version of the EDIDocument used to creates EDI X12 and EDIFACT document files
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDILightWeightDocument : Component
Public NotInheritable Class EDILightWeightDocument _
    Inherits Component
public ref class EDILightWeightDocument sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDILightWeightDocument()()()() | Initializes a new instance of the EDILightWeightDocument class.
 | EDILightWeightDocument(IContainer) | Initializes a new instance of the EDILightWeightDocument class.
 | AutoPlaceCorrectNumOfGT | Places the correct number of GS Functional Groups in the IEA segment element 1
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) or UNT segment (EDIFACT)
 | AutoPlaceCorrectNumOfST | Places the correct number of ST Headers in the GE segment element 1
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Creator |
 | Delimiters | Segment and element delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDocumentFinished | Event raised when EDI document creation process has completed
 | EDIFilePath | Full path including file name of EDI file to create. If the file already exists it is overwritten
 | EDIFileString | A string representation of the EDI file created
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBufferSize | Initial file buffer size when generating EDI files
 | FileStream | Optional filestream to save EDI document to
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GenerateEDIData()()()() | Generate EDI Data without writing to a filestream
 | GenerateEDIFile(FileStream) | Generates the EDI file.
 | GenerateEDIFile(String) | Generates the EDI file.
 | GenerateEDIFile()()()() | Generates the EDI file.
 | GenerateEDIFileWithBatchWrite()()()() | Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | Loops | Gets or sets the loops.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLineAfterSegment | Whether or not to insert a new line after every segment
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | ToXml()()()() | Converts this EDILightWeightDOcument to an XMLDocument
 | ToXml(String) | Converts this EDILightWeightDOcument to Xml
 | ToXml(String, XmlConfigOptions) | Converts this EDILightWeightDocument to Xml
 | ToXml(XmlConfigOptions) | Converts this EDILightWeightDOcument to an XMLDocument
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDILightWeightDocument

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDILightWeightDocument Constructor

EDILightWeightDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDILightWeightDocument()()()()
Members
Icon | Member | Description
 | EDILightWeightDocument()()()() | Initializes a new instance of the EDILightWeightDocument class.
 | EDILightWeightDocument(IContainer) | Initializes a new instance of the EDILightWeightDocument class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDILightWeightDocument Constructor

EDILightWeightDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDILightWeightDocument()()()()
Initializes a new instance of the EDILightWeightDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument()
Public Sub New
public:
EDILightWeightDocument()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDILightWeightDocument Constructor (container)

EDILightWeightDocument Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDILightWeightDocument(IContainer)
Initializes a new instance of the EDILightWeightDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDILightWeightDocument(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceCorrectNumOfGT Property

AutoPlaceCorrectNumOfGT Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► AutoPlaceCorrectNumOfGT
Places the correct number of GS Functional Groups in the IEA segment element 1
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfGT { get; set; }
Public Property AutoPlaceCorrectNumOfGT As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfGT {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceCorrectNumOfSegments Property

AutoPlaceCorrectNumOfSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► AutoPlaceCorrectNumOfSegments
Places the correct number of segments in the SE segment (X12) or UNT segment (EDIFACT)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfSegments { get; set; }
Public Property AutoPlaceCorrectNumOfSegments As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfSegments {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceCorrectNumOfST Property

AutoPlaceCorrectNumOfST Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► AutoPlaceCorrectNumOfST
Places the correct number of ST Headers in the GE segment element 1
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfST { get; set; }
Public Property AutoPlaceCorrectNumOfST As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfST {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Creator Property

Creator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Creator
Declaration Syntax
C# Visual Basic Visual C++
public DocumentCreator Creator { get; set; }
Public Property Creator As DocumentCreator
    Get
    Set
public:
property DocumentCreator Creator {
    DocumentCreator get ();
    void set (DocumentCreator value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Delimiters
Segment and element delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDocumentFinished Event

EDIDocumentFinished Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDIDocumentFinished
Event raised when EDI document creation process has completed
Declaration Syntax
C# Visual Basic Visual C++
public event GeneralEvent EDIDocumentFinished
Public Event EDIDocumentFinished As GeneralEvent
public:
 event GeneralEvent^ EDIDocumentFinished {
    void add (GeneralEvent^ value);
    void remove (GeneralEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFilePath Property

EDIFilePath Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDIFilePath
Full path including file name of EDI file to create. If the file already exists it is overwritten
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFilePath { get; set; }
Public Property EDIFilePath As String
    Get
    Set
public:
property String^ EDIFilePath {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileString Property

EDIFileString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► EDIFileString
A string representation of the EDI file created
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFileString { get; internal set; }
Public Property EDIFileString As String
    Get
    Friend Set
public:
property String^ EDIFileString {
    String^ get ();
    internal: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileBufferSize Property

FileBufferSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► FileBufferSize
Initial file buffer size when generating EDI files
Declaration Syntax
C# Visual Basic Visual C++
public int FileBufferSize { get; set; }
Public Property FileBufferSize As Integer
    Get
    Set
public:
property int FileBufferSize {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileStream Property

FileStream Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► FileStream
Optional filestream to save EDI document to
Declaration Syntax
C# Visual Basic Visual C++
public FileStream FileStream { get; set; }
Public Property FileStream As FileStream
    Get
    Set
public:
property FileStream^ FileStream {
    FileStream^ get ();
    void set (FileStream^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIData Method

GenerateEDIData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIData()()()()
Generate EDI Data without writing to a filestream
Declaration Syntax
C# Visual Basic Visual C++
public string GenerateEDIData()
Public Function GenerateEDIData As String
public:
String^ GenerateEDIData()
Return Value
EDI data as string

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFile()()()()
Members
Icon | Member | Description
 | GenerateEDIFile(FileStream) | Generates the EDI file.
 | GenerateEDIFile(String) | Generates the EDI file.
 | GenerateEDIFile()()()() | Generates the EDI file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFile()()()()
Generates the EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile()
Public Sub GenerateEDIFile
public:
void GenerateEDIFile()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method (stream)

GenerateEDIFile Method (stream)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFile(FileStream)
Generates the EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    FileStream stream
)
Public Sub GenerateEDIFile ( _
    stream As FileStream _
)
public:
void GenerateEDIFile(
    FileStream^ stream
)
Parameters
stream (FileStream)
The stream.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method (outputFile)

GenerateEDIFile Method (outputFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFile(String)
Generates the EDI file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    string outputFile
)
Public Sub GenerateEDIFile ( _
    outputFile As String _
)
public:
void GenerateEDIFile(
    String^ outputFile
)
Parameters
outputFile (String)
path of the output file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFileWithBatchWrite Method

GenerateEDIFileWithBatchWrite Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► GenerateEDIFileWithBatchWrite()()()()
Generates an EDI file by first acquiring the EDI data and then making one batch write to the output file.
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFileWithBatchWrite()
Public Sub GenerateEDIFileWithBatchWrite
public:
void GenerateEDIFileWithBatchWrite()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Loops
Gets or sets the loops.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoops Loops { get; set; }
Public Property Loops As LightWeightLoops
    Get
    Set
public:
property LightWeightLoops^ Loops {
    LightWeightLoops^ get ();
    void set (LightWeightLoops^ value);
}
Value
The loops.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NewLineAfterSegment Property

NewLineAfterSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► NewLineAfterSegment
Whether or not to insert a new line after every segment
Declaration Syntax
C# Visual Basic Visual C++
public bool NewLineAfterSegment { get; set; }
Public Property NewLineAfterSegment As Boolean
    Get
    Set
public:
property bool NewLineAfterSegment {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml()()()()
Members
Icon | Member | Description
 | ToXml()()()() | Converts this EDILightWeightDOcument to an XMLDocument
 | ToXml(String) | Converts this EDILightWeightDOcument to Xml
 | ToXml(String, XmlConfigOptions) | Converts this EDILightWeightDocument to Xml
 | ToXml(XmlConfigOptions) | Converts this EDILightWeightDOcument to an XMLDocument

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml()()()()
Converts this EDILightWeightDOcument to an XMLDocument
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml()
Public Function ToXml As XmlDocument
public:
XmlDocument^ ToXml()
Return Value
XmlDocument

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method (options)

ToXml Method (options)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml(XmlConfigOptions)
Converts this EDILightWeightDOcument to an XMLDocument
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml(
    XmlConfigOptions options
)
Public Function ToXml ( _
    options As XmlConfigOptions _
) As XmlDocument
public:
XmlDocument^ ToXml(
    XmlConfigOptions^ options
)
Parameters
options (XmlConfigOptions)
Configuration options
Return Value
XmlDocument

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method (file)

ToXml Method (file)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml(String)
Converts this EDILightWeightDOcument to Xml
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string file
)
Public Sub ToXml ( _
    file As String _
)
public:
void ToXml(
    String^ file
)
Parameters
file (String)
The file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method (file, options)

ToXml Method (file, options)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► ToXml(String, XmlConfigOptions)
Converts this EDILightWeightDocument to Xml
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string file,
    XmlConfigOptions options
)
Public Sub ToXml ( _
    file As String, _
    options As XmlConfigOptions _
)
public:
void ToXml(
    String^ file,
    XmlConfigOptions^ options
)
Parameters
file (String)
The file.
options (XmlConfigOptions)
Xml options.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesCreator Class

EDIRulesCreator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator
Allows EDI Rules to be created
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIRulesCreator : Component
Public NotInheritable Class EDIRulesCreator _
    Inherits Component
public ref class EDIRulesCreator sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIRulesCreator()()()() | Initializes a new instance of the EDIRulesCreator class.
 | EDIRulesCreator(IContainer) | Initializes a new instance of the EDIRulesCreator class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CodeLists | Gets or sets the code lists.
 | CompositeSegments | Gets or sets the composite segments.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateFile()()()() | Creates the file.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIRuleFileData | Gets or sets the EDI rule file data.
 | EDIRuleFilename | Gets or sets the EDI rule filename.
 | ElementCounterDisplays | Gets the element counter displays.
 | ElementEqualities | A collection of all element equality read in from EDI rules file
 | ElementFormats | Gets the element formats.
 | Elements | Gets or sets the elements.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LoadFile()()()() | Loads the file.
 | LoadFile(String) | Loads the file.
 | LoopSchema | Gets or sets the loop schema.
 | MainLoop | Gets or sets the main loop.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rules | A collection of all rules read in from EDI rules file
 | SampleData | Data contained in the SAMPLE DATA section of the EDI File
 | SaveFilename | Gets or sets the save filename.
 | Segments | Gets or sets the segments.
 | SegmentSchemas | Gets or sets the segment schemas.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | Summaries | Gets the summaries.
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIRulesCreator

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesCreator Constructor

EDIRulesCreator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRulesCreator()()()()
Members
Icon | Member | Description
 | EDIRulesCreator()()()() | Initializes a new instance of the EDIRulesCreator class.
 | EDIRulesCreator(IContainer) | Initializes a new instance of the EDIRulesCreator class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesCreator Constructor

EDIRulesCreator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRulesCreator()()()()
Initializes a new instance of the EDIRulesCreator class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesCreator()
Public Sub New
public:
EDIRulesCreator()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesCreator Constructor (container)

EDIRulesCreator Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRulesCreator(IContainer)
Initializes a new instance of the EDIRulesCreator class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesCreator(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIRulesCreator(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeLists Property

CodeLists Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► CodeLists
Gets or sets the code lists.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, CodeList> CodeLists { get; set; }
Public Property CodeLists As Dictionary(Of String, CodeList)
    Get
    Set
public:
property Dictionary<String^, CodeList^>^ CodeLists {
    Dictionary<String^, CodeList^>^ get ();
    void set (Dictionary<String^, CodeList^>^ value);
}
Value
The code lists.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeSegments Property

CompositeSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► CompositeSegments
Gets or sets the composite segments.
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<string, Segment> CompositeSegments { get; set; }
Public Property CompositeSegments As SortedDictionary(Of String, Segment)
    Get
    Set
public:
property SortedDictionary<String^, Segment^>^ CompositeSegments {
    SortedDictionary<String^, Segment^>^ get ();
    void set (SortedDictionary<String^, Segment^>^ value);
}
Value
The composite segments.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateFile Method

CreateFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► CreateFile()()()()
Creates the file.
Declaration Syntax
C# Visual Basic Visual C++
public void CreateFile()
Public Sub CreateFile
public:
void CreateFile()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRuleFileData Property

EDIRuleFileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRuleFileData
Gets or sets the EDI rule file data.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> EDIRuleFileData { get; set; }
Public Property EDIRuleFileData As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ EDIRuleFileData {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}
Value
The EDI rule file data.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRuleFilename Property

EDIRuleFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► EDIRuleFilename
Gets or sets the EDI rule filename.
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRuleFilename { get; set; }
Public Property EDIRuleFilename As String
    Get
    Set
public:
property String^ EDIRuleFilename {
    String^ get ();
    void set (String^ value);
}
Value
The EDI rule filename.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementCounterDisplays Property

ElementCounterDisplays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► ElementCounterDisplays
Gets the element counter displays.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementCounterDisplay> ElementCounterDisplays { get; }
Public ReadOnly Property ElementCounterDisplays As List(Of ElementCounterDisplay)
    Get
public:
property List<ElementCounterDisplay^>^ ElementCounterDisplays {
    List<ElementCounterDisplay^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementEqualities Property

ElementEqualities Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► ElementEqualities
A collection of all element equality read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementEqualityDisplay> ElementEqualities { get; }
Public ReadOnly Property ElementEqualities As List(Of ElementEqualityDisplay)
    Get
public:
property List<ElementEqualityDisplay^>^ ElementEqualities {
    List<ElementEqualityDisplay^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormats Property

ElementFormats Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► ElementFormats
Gets the element formats.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> ElementFormats { get; }
Public ReadOnly Property ElementFormats As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ ElementFormats {
    Dictionary<String^, String^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Elements
Gets or sets the elements.
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<int, Element> Elements { get; set; }
Public Property Elements As SortedDictionary(Of Integer, Element)
    Get
    Set
public:
property SortedDictionary<int, Element^>^ Elements {
    SortedDictionary<int, Element^>^ get ();
    void set (SortedDictionary<int, Element^>^ value);
}
Value
The elements.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoadFile Method

LoadFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► LoadFile()()()()
Members
Icon | Member | Description
 | LoadFile()()()() | Loads the file.
 | LoadFile(String) | Loads the file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoadFile Method

LoadFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► LoadFile()()()()
Loads the file.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadFile()
Public Sub LoadFile
public:
void LoadFile()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoadFile Method (EDIRulesFilename)

LoadFile Method (EDIRulesFilename)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► LoadFile(String)
Loads the file.
Declaration Syntax
C# Visual Basic Visual C++
public void LoadFile(
    string EDIRulesFilename
)
Public Sub LoadFile ( _
    EDIRulesFilename As String _
)
public:
void LoadFile(
    String^ EDIRulesFilename
)
Parameters
EDIRulesFilename (String)
The EDI rules filename.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopSchema Property

LoopSchema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► LoopSchema
Gets or sets the loop schema.
Declaration Syntax
C# Visual Basic Visual C++
public LoopSchema LoopSchema { get; set; }
Public Property LoopSchema As LoopSchema
    Get
    Set
public:
property LoopSchema^ LoopSchema {
    LoopSchema^ get ();
    void set (LoopSchema^ value);
}
Value
The loop schema.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MainLoop Property

MainLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► MainLoop
Gets or sets the main loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop MainLoop { get; set; }
Public Property MainLoop As Loop
    Get
    Set
public:
property Loop^ MainLoop {
    Loop^ get ();
    void set (Loop^ value);
}
Value
The main loop.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Rules Property

Rules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Rules
A collection of all rules read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public List<RuleDisplay> Rules { get; }
Public ReadOnly Property Rules As List(Of RuleDisplay)
    Get
public:
property List<RuleDisplay^>^ Rules {
    List<RuleDisplay^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SampleData Property

SampleData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► SampleData
Data contained in the SAMPLE DATA section of the EDI File
Declaration Syntax
C# Visual Basic Visual C++
public List<string> SampleData { get; set; }
Public Property SampleData As List(Of String)
    Get
    Set
public:
property List<String^>^ SampleData {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SaveFilename Property

SaveFilename Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► SaveFilename
Gets or sets the save filename.
Declaration Syntax
C# Visual Basic Visual C++
public string SaveFilename { get; set; }
Public Property SaveFilename As String
    Get
    Set
public:
property String^ SaveFilename {
    String^ get ();
    void set (String^ value);
}
Value
The save filename.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Segments
Gets or sets the segments.
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<string, Segment> Segments { get; set; }
Public Property Segments As SortedDictionary(Of String, Segment)
    Get
    Set
public:
property SortedDictionary<String^, Segment^>^ Segments {
    SortedDictionary<String^, Segment^>^ get ();
    void set (SortedDictionary<String^, Segment^>^ value);
}
Value
The segments.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchemas Property

SegmentSchemas Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► SegmentSchemas
Gets or sets the segment schemas.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<int, SegmentSchema> SegmentSchemas { get; set; }
Public Property SegmentSchemas As Dictionary(Of Integer, SegmentSchema)
    Get
    Set
public:
property Dictionary<int, SegmentSchema^>^ SegmentSchemas {
    Dictionary<int, SegmentSchema^>^ get ();
    void set (Dictionary<int, SegmentSchema^>^ value);
}
Value
The segment schemas.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Summaries Property

Summaries Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Summaries
Gets the summaries.
Declaration Syntax
C# Visual Basic Visual C++
public List<SummaryDisplay> Summaries { get; }
Public ReadOnly Property Summaries As List(Of SummaryDisplay)
    Get
public:
property List<SummaryDisplay^>^ Summaries {
    List<SummaryDisplay^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReader Class

EDIRulesReader Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader
Reader that reads and loads EDI rules from an EDI file
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIRulesReader : Component
Public NotInheritable Class EDIRulesReader _
    Inherits Component
public ref class EDIRulesReader sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIRulesReader(IContainer) | Initializes a new instance of the EDIRulesReader class.
 | EDIRulesReader()()()() | Initializes a new instance of the EDIRulesReader class.
 | EDIRulesReader(String) | Initializes a new instance of the EDIRulesReader class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CodeLists | A collection of all codelists read in from EDI rules file
 | CompositesSegments | A collection of all composite segments read in from EDI rules file
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIRulesFile | Gets or sets the EDI rules file stream
 | EDIRulesFileData | Gets or sets the EDI rules file data. Each line must end with a return character
 | EDIRulesFilePath | Gets or sets the EDI rules file path.
 | ElementCodes | A collection of all element codes read in from EDI rules file
 | ElementCounterDisplays | Gets the element counter displays.
 | ElementEqualities | A collection of all element equality read in from EDI rules file
 | ElementFormats | Gets the element formats.
 | Elements | A collection of all elements read in from EDI rules file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileData | A collection of all custom file data
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LoadDescriptions | Gets/sets whether the [ELEMENT CODE DESCRIPTION, LOOP DESCRIPTION,SEGMENT DESCRIPTION] sections are loaded. Setting this value to false improves loading performance.
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberOfLoopsCreated | Gets the number of loops created.
 | OnErrorOccurred | Occurs when [on error occurred].
 | Parse(String) | Parses a rule file and loads its contents
 | Parse()()()() | Parses a rule file and loads its contents
 | Parsed | Gets a value indicating whether this EDIRulesReader is parsed.
 | ProgressChanged | Occurs when [progress changed].
 | Reset()()()() | Resets this instance.
 | RuleFileData | A collection of file property values specified in the rules file
 | Rules | A collection of all rules read in from EDI rules file
 | SampleData | Data contained in the SAMPLE DATA section of the EDI File
 | Schema | The complete schema of the EDI standard read from the EDI rules file
 | Segments | A collection of all segments read in from EDI rules file
 | SegmentSchemas | A collection of all segments schemas read in from EDI rules file
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | Summaries | Gets the summaries.
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIRulesReader

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReader Constructor

EDIRulesReader Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader()()()()
Members
Icon | Member | Description
 | EDIRulesReader(IContainer) | Initializes a new instance of the EDIRulesReader class.
 | EDIRulesReader()()()() | Initializes a new instance of the EDIRulesReader class.
 | EDIRulesReader(String) | Initializes a new instance of the EDIRulesReader class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReader Constructor

EDIRulesReader Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader()()()()
Initializes a new instance of the EDIRulesReader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesReader()
Public Sub New
public:
EDIRulesReader()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReader Constructor (container)

EDIRulesReader Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader(IContainer)
Initializes a new instance of the EDIRulesReader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesReader(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIRulesReader(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReader Constructor (ediRuleFilePath)

EDIRulesReader Constructor (ediRuleFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader(String)
Initializes a new instance of the EDIRulesReader class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesReader(
    string ediRuleFilePath
)
Public Sub New ( _
    ediRuleFilePath As String _
)
public:
EDIRulesReader(
    String^ ediRuleFilePath
)
Parameters
ediRuleFilePath (String)
The CEF file path.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeLists Property

CodeLists Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► CodeLists
A collection of all codelists read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, CodeList> CodeLists { get; }
Public ReadOnly Property CodeLists As Dictionary(Of String, CodeList)
    Get
public:
property Dictionary<String^, CodeList^>^ CodeLists {
    Dictionary<String^, CodeList^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositesSegments Property

CompositesSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► CompositesSegments
A collection of all composite segments read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<string, Segment> CompositesSegments { get; }
Public ReadOnly Property CompositesSegments As SortedDictionary(Of String, Segment)
    Get
public:
property SortedDictionary<String^, Segment^>^ CompositesSegments {
    SortedDictionary<String^, Segment^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesFile Property

EDIRulesFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesFile
Gets or sets the EDI rules file stream
Declaration Syntax
C# Visual Basic Visual C++
public Stream EDIRulesFile { get; set; }
Public Property EDIRulesFile As Stream
    Get
    Set
public:
property Stream^ EDIRulesFile {
    Stream^ get ();
    void set (Stream^ value);
}
Value
The EDI file file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesFileData Property

EDIRulesFileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesFileData
Gets or sets the EDI rules file data. Each line must end with a return character
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRulesFileData { get; set; }
Public Property EDIRulesFileData As String
    Get
    Set
public:
property String^ EDIRulesFileData {
    String^ get ();
    void set (String^ value);
}
Value
The EDI file data

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesFilePath Property

EDIRulesFilePath Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesFilePath
Gets or sets the EDI rules file path.
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRulesFilePath { get; set; }
Public Property EDIRulesFilePath As String
    Get
    Set
public:
property String^ EDIRulesFilePath {
    String^ get ();
    void set (String^ value);
}
Value
The EDI rules file path.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementCodes Property

ElementCodes Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ElementCodes
A collection of all element codes read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, ElementCodeList> ElementCodes { get; }
Public ReadOnly Property ElementCodes As Dictionary(Of String, ElementCodeList)
    Get
public:
property Dictionary<String^, ElementCodeList^>^ ElementCodes {
    Dictionary<String^, ElementCodeList^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementCounterDisplays Property

ElementCounterDisplays Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ElementCounterDisplays
Gets the element counter displays.
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementCounterDisplay> ElementCounterDisplays { get; }
Public ReadOnly Property ElementCounterDisplays As List(Of ElementCounterDisplay)
    Get
public:
property List<ElementCounterDisplay^>^ ElementCounterDisplays {
    List<ElementCounterDisplay^>^ get ();
}
Value
The element counter displays.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementEqualities Property

ElementEqualities Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ElementEqualities
A collection of all element equality read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public List<ElementEqualityDisplay> ElementEqualities { get; }
Public ReadOnly Property ElementEqualities As List(Of ElementEqualityDisplay)
    Get
public:
property List<ElementEqualityDisplay^>^ ElementEqualities {
    List<ElementEqualityDisplay^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormats Property

ElementFormats Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ElementFormats
Gets the element formats.
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> ElementFormats { get; }
Public ReadOnly Property ElementFormats As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ ElementFormats {
    Dictionary<String^, String^>^ get ();
}
Value
The element formats.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Elements
A collection of all elements read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<int, Element> Elements { get; }
Public ReadOnly Property Elements As SortedDictionary(Of Integer, Element)
    Get
public:
property SortedDictionary<int, Element^>^ Elements {
    SortedDictionary<int, Element^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileData Property

FileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► FileData
A collection of all custom file data
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> FileData { get; }
Public ReadOnly Property FileData As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ FileData {
    Dictionary<String^, String^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoadDescriptions Property

LoadDescriptions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► LoadDescriptions
Gets/sets whether the [ELEMENT CODE DESCRIPTION, LOOP DESCRIPTION,SEGMENT DESCRIPTION] sections are loaded. Setting this value to false improves loading performance.
Declaration Syntax
C# Visual Basic Visual C++
public bool LoadDescriptions { get; set; }
Public Property LoadDescriptions As Boolean
    Get
    Set
public:
property bool LoadDescriptions {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NumberOfLoopsCreated Property

NumberOfLoopsCreated Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► NumberOfLoopsCreated
Gets the number of loops created.
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfLoopsCreated { get; }
Public ReadOnly Property NumberOfLoopsCreated As Integer
    Get
public:
property int NumberOfLoopsCreated {
    int get ();
}
Value
The number of loops created.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OnErrorOccurred Event

OnErrorOccurred Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► OnErrorOccurred
Occurs when [on error occurred].
Declaration Syntax
C# Visual Basic Visual C++
public event EDIRulesReader..::..ErrorEvent OnErrorOccurred
Public Event OnErrorOccurred As EDIRulesReader..::..ErrorEvent
public:
 event EDIRulesReader..::..ErrorEvent^ OnErrorOccurred {
    void add (EDIRulesReader..::..ErrorEvent^ value);
    void remove (EDIRulesReader..::..ErrorEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Parse Method

Parse Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Parse()()()()
Members
Icon | Member | Description
 | Parse(String) | Parses a rule file and loads its contents
 | Parse()()()() | Parses a rule file and loads its contents

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Parse Method

Parse Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Parse()()()()
Parses a rule file and loads its contents
Declaration Syntax
C# Visual Basic Visual C++
public void Parse()
Public Sub Parse
public:
void Parse()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Parse Method (rulesFilePath)

Parse Method (rulesFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Parse(String)
Parses a rule file and loads its contents
Declaration Syntax
C# Visual Basic Visual C++
public void Parse(
    string rulesFilePath
)
Public Sub Parse ( _
    rulesFilePath As String _
)
public:
void Parse(
    String^ rulesFilePath
)
Parameters
rulesFilePath (String)
EDI Rules file to parse

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Parsed Property

Parsed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Parsed
Gets a value indicating whether this EDIRulesReader is parsed.
Declaration Syntax
C# Visual Basic Visual C++
public bool Parsed { get; private set; }
Public Property Parsed As Boolean
    Get
    Private Set
public:
property bool Parsed {
    bool get ();
    private: void set (bool value);
}
Value
true if parsed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ProgressChanged Event

ProgressChanged Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► ProgressChanged
Occurs when [progress changed].
Declaration Syntax
C# Visual Basic Visual C++
public event EDIRulesReader..::..GeneralEvent ProgressChanged
Public Event ProgressChanged As EDIRulesReader..::..GeneralEvent
public:
 event EDIRulesReader..::..GeneralEvent^ ProgressChanged {
    void add (EDIRulesReader..::..GeneralEvent^ value);
    void remove (EDIRulesReader..::..GeneralEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Reset Method

Reset Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Reset()()()()
Resets this instance.
Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
void Reset()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RuleFileData Property

RuleFileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► RuleFileData
A collection of file property values specified in the rules file
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> RuleFileData { get; set; }
Public Property RuleFileData As Dictionary(Of String, String)
    Get
    Set
public:
property Dictionary<String^, String^>^ RuleFileData {
    Dictionary<String^, String^>^ get ();
    void set (Dictionary<String^, String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Rules Property

Rules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Rules
A collection of all rules read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public List<RuleDisplay> Rules { get; }
Public ReadOnly Property Rules As List(Of RuleDisplay)
    Get
public:
property List<RuleDisplay^>^ Rules {
    List<RuleDisplay^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SampleData Property

SampleData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► SampleData
Data contained in the SAMPLE DATA section of the EDI File
Declaration Syntax
C# Visual Basic Visual C++
public List<string> SampleData { get; set; }
Public Property SampleData As List(Of String)
    Get
    Set
public:
property List<String^>^ SampleData {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Schema Property

Schema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Schema
The complete schema of the EDI standard read from the EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public Loop Schema { get; }
Public ReadOnly Property Schema As Loop
    Get
public:
property Loop^ Schema {
    Loop^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Segments
A collection of all segments read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public SortedDictionary<string, Segment> Segments { get; }
Public ReadOnly Property Segments As SortedDictionary(Of String, Segment)
    Get
public:
property SortedDictionary<String^, Segment^>^ Segments {
    SortedDictionary<String^, Segment^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchemas Property

SegmentSchemas Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► SegmentSchemas
A collection of all segments schemas read in from EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<int, SegmentSchema> SegmentSchemas { get; }
Public ReadOnly Property SegmentSchemas As Dictionary(Of Integer, SegmentSchema)
    Get
public:
property Dictionary<int, SegmentSchema^>^ SegmentSchemas {
    Dictionary<int, SegmentSchema^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Summaries Property

Summaries Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Summaries
Gets the summaries.
Declaration Syntax
C# Visual Basic Visual C++
public List<SummaryDisplay> Summaries { get; }
Public ReadOnly Property Summaries As List(Of SummaryDisplay)
    Get
public:
property List<SummaryDisplay^>^ Summaries {
    List<SummaryDisplay^>^ get ();
}
Value
The summaries.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReader.ErrorEvent Delegate

EDIRulesReader..::..ErrorEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader..::..ErrorEvent
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ErrorEvent(
    Object sender,
    EDIRulesReaderEventArg e
)
Public Delegate Sub ErrorEvent ( _
    sender As Object, _
    e As EDIRulesReaderEventArg _
)
public delegate void ErrorEvent(
    Object^ sender,
    EDIRulesReaderEventArg^ e
)
Parameters
sender (Object)
The sender.
e (EDIRulesReaderEventArg)
The e.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReader.GeneralEvent Delegate

EDIRulesReader..::..GeneralEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► EDIRulesReader..::..GeneralEvent
Declaration Syntax
C# Visual Basic Visual C++
public delegate void GeneralEvent(
    int progress
)
Public Delegate Sub GeneralEvent ( _
    progress As Integer _
)
public delegate void GeneralEvent(
    int progress
)
Parameters
progress (Int32)
The progress.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReaderEventArg Class

EDIRulesReaderEventArg Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReaderEventArg
Represents an general error that may occur while parsing an EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public class EDIRulesReaderEventArg : EventArgs
Public Class EDIRulesReaderEventArg _
    Inherits EventArgs
public ref class EDIRulesReaderEventArg : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LineText | Line in the EDI rules file
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | General error message
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EDIRulesReaderEventArg

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LineText Property

LineText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReaderEventArg ► LineText
Line in the EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public string LineText { get; }
Public ReadOnly Property LineText As String
    Get
public:
property String^ LineText {
    String^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Message Property

Message Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReaderEventArg ► Message
General error message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDISource Enumeration

EDISource Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISource
Represents the source of the EDI data to validate
Declaration Syntax
C# Visual Basic Visual C++
public enum EDISource
Public Enumeration EDISource
public enum class EDISource
Members
Member | Description
DataString | EDI data is coming from an in memory string
File | EDI data is coming from a file

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDISpecification Class

EDISpecification Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification
Reponsible for retrieving EDI message specific data
Declaration Syntax
C# Visual Basic Visual C++
public class EDISpecification
Public Class EDISpecification
public ref class EDISpecification
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDISpecification()()()() | Initializes a new instance of the EDISpecification class
 | Delimiters |
 | EDIFACTControllingAgency |
 | EDIFACTMessageType |
 | EDIFACTMessageVersion |
 | EDIFACTReleaseVersion |
 | EDIFileType | Whether this EDI file/data is X12 or EDIFACT standard
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FindFileTypeFromFile(String, Encoding) | Finds the FileType{X12,EDIFACT} from file.
 | FindFileTypeFromString(String) | Finds the FileType{X12,EDIFACT} from a string.
 | FindSpecificationFromFile(String) | Finds the specification from file.
 | FindSpecificationFromFile(String, Encoding) | Finds the specification from file.
 | FindSpecificationFromString(String) | Finds the specification from string.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterchangeReceiverID |
 | InterchangeReceiverIDQualifier |
 | InterchangeSenderID |
 | InterchangeSenderIDQualifier |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | TrimString | String to ignore between segment delimiters
 | X12TransactionSetCode | For X12, the value in the 1st element of a transaction header (ST)
 | X12Version | For X12, the value in the 8th element of a functional group (GS)
 | X12VersionCode | For X12, the value in the 1st element of a functional group (GS)
Inheritance Hierarchy
Object
EDISpecification

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDISpecification Constructor

EDISpecification Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDISpecification()()()()
Initializes a new instance of the EDISpecification class
Declaration Syntax
C# Visual Basic Visual C++
public EDISpecification()
Public Sub New
public:
EDISpecification()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► Delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; private set; }
Public Property Delimiters As Delimiters
    Get
    Private Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    private: void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFACTControllingAgency Property

EDIFACTControllingAgency Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFACTControllingAgency
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFACTControllingAgency { get; private set; }
Public Property EDIFACTControllingAgency As String
    Get
    Private Set
public:
property String^ EDIFACTControllingAgency {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFACTMessageType Property

EDIFACTMessageType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFACTMessageType
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFACTMessageType { get; private set; }
Public Property EDIFACTMessageType As String
    Get
    Private Set
public:
property String^ EDIFACTMessageType {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFACTMessageVersion Property

EDIFACTMessageVersion Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFACTMessageVersion
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFACTMessageVersion { get; private set; }
Public Property EDIFACTMessageVersion As String
    Get
    Private Set
public:
property String^ EDIFACTMessageVersion {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFACTReleaseVersion Property

EDIFACTReleaseVersion Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFACTReleaseVersion
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFACTReleaseVersion { get; private set; }
Public Property EDIFACTReleaseVersion As String
    Get
    Private Set
public:
property String^ EDIFACTReleaseVersion {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► EDIFileType
Whether this EDI file/data is X12 or EDIFACT standard
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; private set; }
Public Property EDIFileType As FileType
    Get
    Private Set
public:
property FileType EDIFileType {
    FileType get ();
    private: void set (FileType value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FindFileTypeFromFile Method (path, encoding)

FindFileTypeFromFile Method (path, encoding)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindFileTypeFromFile(String, Encoding)
Finds the FileType{X12,EDIFACT} from file.
Declaration Syntax
C# Visual Basic Visual C++
public static FileType FindFileTypeFromFile(
    string path,
    Encoding encoding
)
Public Shared Function FindFileTypeFromFile ( _
    path As String, _
    encoding As Encoding _
) As FileType
public:
static FileType FindFileTypeFromFile(
    String^ path,
    Encoding^ encoding
)
Parameters
path (String)
The path.encoding
encoding (Encoding)
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FindFileTypeFromString Method (fileData)

FindFileTypeFromString Method (fileData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindFileTypeFromString(String)
Finds the FileType{X12,EDIFACT} from a string.
Declaration Syntax
C# Visual Basic Visual C++
public static FileType FindFileTypeFromString(
    string fileData
)
Public Shared Function FindFileTypeFromString ( _
    fileData As String _
) As FileType
public:
static FileType FindFileTypeFromString(
    String^ fileData
)
Parameters
fileData (String)
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FindSpecificationFromFile Method

FindSpecificationFromFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindSpecificationFromFile()()()()
Members
Icon | Member | Description
 | FindSpecificationFromFile(String) | Finds the specification from file.
 | FindSpecificationFromFile(String, Encoding) | Finds the specification from file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FindSpecificationFromFile Method (path)

FindSpecificationFromFile Method (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindSpecificationFromFile(String)
Finds the specification from file.
Declaration Syntax
C# Visual Basic Visual C++
public static EDISpecification FindSpecificationFromFile(
    string path
)
Public Shared Function FindSpecificationFromFile ( _
    path As String _
) As EDISpecification
public:
static EDISpecification^ FindSpecificationFromFile(
    String^ path
)
Parameters
path (String)
The path.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FindSpecificationFromFile Method (path, encoding)

FindSpecificationFromFile Method (path, encoding)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindSpecificationFromFile(String, Encoding)
Finds the specification from file.
Declaration Syntax
C# Visual Basic Visual C++
public static EDISpecification FindSpecificationFromFile(
    string path,
    Encoding encoding
)
Public Shared Function FindSpecificationFromFile ( _
    path As String, _
    encoding As Encoding _
) As EDISpecification
public:
static EDISpecification^ FindSpecificationFromFile(
    String^ path,
    Encoding^ encoding
)
Parameters
path (String)
The path
encoding (Encoding)
encoding
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FindSpecificationFromString Method (fileData)

FindSpecificationFromString Method (fileData)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► FindSpecificationFromString(String)
Finds the specification from string.
Declaration Syntax
C# Visual Basic Visual C++
public static EDISpecification FindSpecificationFromString(
    string fileData
)
Public Shared Function FindSpecificationFromString ( _
    fileData As String _
) As EDISpecification
public:
static EDISpecification^ FindSpecificationFromString(
    String^ fileData
)
Parameters
fileData (String)
The file data.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


InterchangeReceiverID Property

InterchangeReceiverID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► InterchangeReceiverID
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeReceiverID { get; private set; }
Public Property InterchangeReceiverID As String
    Get
    Private Set
public:
property String^ InterchangeReceiverID {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


InterchangeReceiverIDQualifier Property

InterchangeReceiverIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► InterchangeReceiverIDQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeReceiverIDQualifier { get; private set; }
Public Property InterchangeReceiverIDQualifier As String
    Get
    Private Set
public:
property String^ InterchangeReceiverIDQualifier {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


InterchangeSenderID Property

InterchangeSenderID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► InterchangeSenderID
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeSenderID { get; private set; }
Public Property InterchangeSenderID As String
    Get
    Private Set
public:
property String^ InterchangeSenderID {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


InterchangeSenderIDQualifier Property

InterchangeSenderIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► InterchangeSenderIDQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeSenderIDQualifier { get; private set; }
Public Property InterchangeSenderIDQualifier As String
    Get
    Private Set
public:
property String^ InterchangeSenderIDQualifier {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrimString Field

TrimString Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► TrimString
String to ignore between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public static string TrimString
Public Shared TrimString As String
public:
static String^ TrimString

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


X12TransactionSetCode Property

X12TransactionSetCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► X12TransactionSetCode
For X12, the value in the 1st element of a transaction header (ST)
Declaration Syntax
C# Visual Basic Visual C++
public string X12TransactionSetCode { get; private set; }
Public Property X12TransactionSetCode As String
    Get
    Private Set
public:
property String^ X12TransactionSetCode {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


X12Version Property

X12Version Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► X12Version
For X12, the value in the 8th element of a functional group (GS)
Declaration Syntax
C# Visual Basic Visual C++
public string X12Version { get; private set; }
Public Property X12Version As String
    Get
    Private Set
public:
property String^ X12Version {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


X12VersionCode Property

X12VersionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDISpecification ► X12VersionCode
For X12, the value in the 1st element of a functional group (GS)
Declaration Syntax
C# Visual Basic Visual C++
public string X12VersionCode { get; private set; }
Public Property X12VersionCode As String
    Get
    Private Set
public:
property String^ X12VersionCode {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIValidationMessage Enumeration

EDIValidationMessage Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidationMessage
Represents different EDI messages
Declaration Syntax
C# Visual Basic Visual C++
public enum EDIValidationMessage
Public Enumeration EDIValidationMessage
public enum class EDIValidationMessage
Members
Member | Description
None |
CompositeElementMissing | Required element missing
CompositeElementNotUsed | Not Used data element present
CompositeElementRecommended |
CompositeElementNotRecommended |
CompositeElementLessThanMinimumLength | Data Element too short
CompositeElementGreaterThanMaximumLength | Data Element too long
CompositeElementHasWrongValue | Invalid code value
CompositeElementValueAlreadyEntered | Invalid code value
DuplicateSegment |
DuplicateLoop |
ElementHasWrongValue | Code value not used in implementation
InternalElementHasWrongValue | Used internally by RDPCrystal EDI Library
ElementLessThanMiniumLength | Data Element too short
ElementGreaterThanMaximumLength | Data Element too long
ElementValueAlreadyEntered | Invalid code value
ElementDataFormatInvalid | Pattern match failure
ElementNotUsed |
ElementRecommended |
ElementNotRecommended |
ElementMissing | Required element missing
EmptyTrailingElements |
EmptyTrailingCompositeElement |
ExtraElementFound |
ExtraCompositeElementFound |
ExtraDataAtEndOfFile |
LoopMissing |
LoopNotUsed |
LoopNotRecommended |
LoopRecommended |
MalformedSegment |
InvalidIntegerValue | Pattern Match Failure
InvalidDateValue | Invalid Date
InvalidTimeValue | Invalid Time
InvalidAlphabeticValue | Pattern Match Failure
InvalidPositiveNumberValue | Pattern Match Failure
InvalidNegativeNumberValue | Pattern Match Failure
InvalidDecimalValue | Pattern Match Failure
SegmentNotRecommended |
SegmentNotUsed | Not Used segment present
SegmentNotInDictionary | Unrecongized segment
SegmentRecommended |
SegmentMissing | Required Segment Missing/Segment not defined in transaction set
SummaryValueMismatch | Invalid code value
UnrecognizedLoop |
UnrecognizedSegment |
IllegalCharactorInFile |
MalformedEDIFile |
MaximumErrorLimitReached |
UnexpectedError |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIValidator Class

EDIValidator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator
Validates and loads EDI X12 and EDIFACT files
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIValidator : Component
Public NotInheritable Class EDIValidator _
    Inherits Component
public ref class EDIValidator sealed : public Component
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIValidator(IContainer) | Create a new EDI Validator
 | EDIValidator()()()() | Create a new EDI Validator
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CheckDataTypeRequirements | Check that elements values are correct for their specified data types
 | CheckForEmptyTrailingElements | Check for trailing empty elements and trailing empty composite elements
 | CheckMinMaxRequirements | Check that elements are within their minimum and maximum required lengths
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CopyElementNumber | If set to true element numbers are copied from the rules schema to DataElements for the validation output
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DataLoop | Data loaded from the EDI file when property LoadValidatedData is set to true. Available after validation
 | DebugMode | Shows detailed information about the validation process. DEBUGGING PURPOSES ONLY, validation will be a slower
 | Delimiters | EDI file delimiters
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | EDIDataString | EDI data to validate. EDI data can also be specified from a file using the EDIFile property
 | EDIFile | Full path of EDI file to validate
 | EDIFileLines | EDI files lines available after validation. Only available when EDISource = DataString
 | EDIFileType | Used to specify the type of EDI file to be validated
 | EDILightWeightDocument | EDI Lite document available after validation. Validation must pass or this object will be null
 | EDIRulesFile | Full path of the EDI rules file that contains EDI rules used for validation
 | EDIRulesFileData | Gets or sets the EDI rules file data. Each line must end with a return character
 | EDIRulesReader | EDI Rules Reader used to read in EDI rules for validation
 | EDISource | Used to specify if validation is for an in-memory string or a file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCount | Numbers of errors in EDI file. Available after validation
 | Errors | Errors encountered while validating EDI file. Available after validation
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileBlockSize | File chunk size when validating EDI data from a file
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | LoadRuleFile(String) | Load the rules file to be used for validation
 | LoadValidatedData | Load EDI data while validating. After validation is complete the EDI data can be accessed the the EDIDocument property
 | MaxErrorsBeforeThrowingException | If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NumberOfLines | Number of lines in the EDI file
 | Passed | Check whether the EDI data or file has passed validation. Use this property after calling the Validate() method
 | PreventInfiniteLoopWhileSearching | If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
 | ProgressChanged | Event fired when the progress changes during validation
 | ProgressMessages | Detailed debug messages after validation. DebugMode must be set to true
 | ResetValidation()()()() | Resets all validation variables. This method is automatically everytime the Validate method is called.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | TimeElapsed | Time elapsed in milliseconds while validating
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrackDownUnrecognizedLoops | If set to true then when a loop is unrecognized a search will be made if to see if a loop like that even exists in the EDI rules, if not an error will be generated
 | TreatWarningsAsErrors | Treat all warnings as errors
 | TrimString | String to ignore at between segment delimiters
 | Validate(EDIDocument) | Validates the contents of an EDI Document
 | Validate(EDILightWeightDocument) | Validates the contents of an EDILightWeightDocument
 | Validate()()()() | Validate the EDI file
 | Validate(String, String) | Validates an EDI file
 | ValidatedTransactions |
 | ValidatedTransactionsDic |
 | ValidationCompleted | Event fired when validation is complete
 | ValidationStarted | Event fired when validation has started
 | WarningCount | Numbers of warnings in EDI file. Available after validation
 | Warnings | Warnings encountered while validating EDI file. Available after validation
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | EDIValidator

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIValidator Constructor

EDIValidator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator()()()()
Members
Icon | Member | Description
 | EDIValidator(IContainer) | Create a new EDI Validator
 | EDIValidator()()()() | Create a new EDI Validator

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIValidator Constructor

EDIValidator Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator()()()()
Create a new EDI Validator
Declaration Syntax
C# Visual Basic Visual C++
public EDIValidator()
Public Sub New
public:
EDIValidator()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIValidator Constructor (container)

EDIValidator Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator(IContainer)
Create a new EDI Validator
Declaration Syntax
C# Visual Basic Visual C++
public EDIValidator(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
EDIValidator(
    IContainer^ container
)
Parameters
container (IContainer)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► AutoDetectDelimiters
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CheckDataTypeRequirements Property

CheckDataTypeRequirements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► CheckDataTypeRequirements
Check that elements values are correct for their specified data types
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckDataTypeRequirements { get; set; }
Public Property CheckDataTypeRequirements As Boolean
    Get
    Set
public:
property bool CheckDataTypeRequirements {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CheckForEmptyTrailingElements Property

CheckForEmptyTrailingElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► CheckForEmptyTrailingElements
Check for trailing empty elements and trailing empty composite elements
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckForEmptyTrailingElements { get; set; }
Public Property CheckForEmptyTrailingElements As Boolean
    Get
    Set
public:
property bool CheckForEmptyTrailingElements {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CheckMinMaxRequirements Property

CheckMinMaxRequirements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► CheckMinMaxRequirements
Check that elements are within their minimum and maximum required lengths
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckMinMaxRequirements { get; set; }
Public Property CheckMinMaxRequirements As Boolean
    Get
    Set
public:
property bool CheckMinMaxRequirements {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CopyElementNumber Property

CopyElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► CopyElementNumber
If set to true element numbers are copied from the rules schema to DataElements for the validation output
Declaration Syntax
C# Visual Basic Visual C++
public bool CopyElementNumber { get; set; }
Public Property CopyElementNumber As Boolean
    Get
    Set
public:
property bool CopyElementNumber {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataLoop Property

DataLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► DataLoop
Data loaded from the EDI file when property LoadValidatedData is set to true. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop DataLoop { get; }
Public ReadOnly Property DataLoop As LightWeightLoop
    Get
public:
property LightWeightLoop^ DataLoop {
    LightWeightLoop^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DebugMode Property

DebugMode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► DebugMode
Shows detailed information about the validation process. DEBUGGING PURPOSES ONLY, validation will be a slower
Declaration Syntax
C# Visual Basic Visual C++
public bool DebugMode { get; set; }
Public Property DebugMode As Boolean
    Get
    Set
public:
property bool DebugMode {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Delimiters
EDI file delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIDataString Property

EDIDataString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIDataString
EDI data to validate. EDI data can also be specified from a file using the EDIFile property
Declaration Syntax
C# Visual Basic Visual C++
public string EDIDataString { get; set; }
Public Property EDIDataString As String
    Get
    Set
public:
property String^ EDIDataString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFile Property

EDIFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIFile
Full path of EDI file to validate
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFile { get; set; }
Public Property EDIFile As String
    Get
    Set
public:
property String^ EDIFile {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileLines Property

EDIFileLines Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIFileLines
EDI files lines available after validation. Only available when EDISource = DataString
Declaration Syntax
C# Visual Basic Visual C++
public string[] EDIFileLines { get; }
Public ReadOnly Property EDIFileLines As String()
    Get
public:
property array<String^>^ EDIFileLines {
    array<String^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIFileType
Used to specify the type of EDI file to be validated
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDILightWeightDocument Property

EDILightWeightDocument Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDILightWeightDocument
EDI Lite document available after validation. Validation must pass or this object will be null
Declaration Syntax
C# Visual Basic Visual C++
public EDILightWeightDocument EDILightWeightDocument { get; }
Public ReadOnly Property EDILightWeightDocument As EDILightWeightDocument
    Get
public:
property EDILightWeightDocument^ EDILightWeightDocument {
    EDILightWeightDocument^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesFile Property

EDIRulesFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIRulesFile
Full path of the EDI rules file that contains EDI rules used for validation
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRulesFile { get; set; }
Public Property EDIRulesFile As String
    Get
    Set
public:
property String^ EDIRulesFile {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesFileData Property

EDIRulesFileData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIRulesFileData
Gets or sets the EDI rules file data. Each line must end with a return character
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRulesFileData { get; set; }
Public Property EDIRulesFileData As String
    Get
    Set
public:
property String^ EDIRulesFileData {
    String^ get ();
    void set (String^ value);
}
Value
The EDI file data

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIRulesReader Property

EDIRulesReader Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIRulesReader
EDI Rules Reader used to read in EDI rules for validation
Declaration Syntax
C# Visual Basic Visual C++
public EDIRulesReader EDIRulesReader { get; set; }
Public Property EDIRulesReader As EDIRulesReader
    Get
    Set
public:
property EDIRulesReader^ EDIRulesReader {
    EDIRulesReader^ get ();
    void set (EDIRulesReader^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDISource Property

EDISource Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDISource
Used to specify if validation is for an in-memory string or a file
Declaration Syntax
C# Visual Basic Visual C++
public EDISource EDISource { get; set; }
Public Property EDISource As EDISource
    Get
    Set
public:
property EDISource EDISource {
    EDISource get ();
    void set (EDISource value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ErrorCount Property

ErrorCount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ErrorCount
Numbers of errors in EDI file. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public int ErrorCount { get; }
Public ReadOnly Property ErrorCount As Integer
    Get
public:
property int ErrorCount {
    int get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Errors Property

Errors Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Errors
Errors encountered while validating EDI file. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public Collection<EDIError> Errors { get; }
Public ReadOnly Property Errors As Collection(Of EDIError)
    Get
public:
property Collection<EDIError^>^ Errors {
    Collection<EDIError^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileBlockSize Property

FileBlockSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► FileBlockSize
File chunk size when validating EDI data from a file
Declaration Syntax
C# Visual Basic Visual C++
public int FileBlockSize { get; set; }
Public Property FileBlockSize As Integer
    Get
    Set
public:
property int FileBlockSize {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoadRuleFile Method (EDIRulesFilePath)

LoadRuleFile Method (EDIRulesFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► LoadRuleFile(String)
Load the rules file to be used for validation
Declaration Syntax
C# Visual Basic Visual C++
public void LoadRuleFile(
    string EDIRulesFilePath
)
Public Sub LoadRuleFile ( _
    EDIRulesFilePath As String _
)
public:
void LoadRuleFile(
    String^ EDIRulesFilePath
)
Parameters
EDIRulesFilePath (String)
full path of the EDI rules file

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoadValidatedData Property

LoadValidatedData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► LoadValidatedData
Load EDI data while validating. After validation is complete the EDI data can be accessed the the EDIDocument property
Declaration Syntax
C# Visual Basic Visual C++
public bool LoadValidatedData { get; set; }
Public Property LoadValidatedData As Boolean
    Get
    Set
public:
property bool LoadValidatedData {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaxErrorsBeforeThrowingException Property

MaxErrorsBeforeThrowingException Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► MaxErrorsBeforeThrowingException
If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
Declaration Syntax
C# Visual Basic Visual C++
public long MaxErrorsBeforeThrowingException { get; set; }
Public Property MaxErrorsBeforeThrowingException As Long
    Get
    Set
public:
property long long MaxErrorsBeforeThrowingException {
    long long get ();
    void set (long long value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NumberOfLines Property

NumberOfLines Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► NumberOfLines
Number of lines in the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfLines { get; }
Public ReadOnly Property NumberOfLines As Integer
    Get
public:
property int NumberOfLines {
    int get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Passed Property

Passed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Passed
Check whether the EDI data or file has passed validation. Use this property after calling the Validate() method
Declaration Syntax
C# Visual Basic Visual C++
public bool Passed { get; }
Public ReadOnly Property Passed As Boolean
    Get
public:
property bool Passed {
    bool get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PreventInfiniteLoopWhileSearching Property

PreventInfiniteLoopWhileSearching Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► PreventInfiniteLoopWhileSearching
If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
Declaration Syntax
C# Visual Basic Visual C++
public bool PreventInfiniteLoopWhileSearching { get; set; }
Public Property PreventInfiniteLoopWhileSearching As Boolean
    Get
    Set
public:
property bool PreventInfiniteLoopWhileSearching {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ProgressChanged Event

ProgressChanged Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ProgressChanged
Event fired when the progress changes during validation
Declaration Syntax
C# Visual Basic Visual C++
public event EDIValidator..::..GeneralEvent ProgressChanged
Public Event ProgressChanged As EDIValidator..::..GeneralEvent
public:
 event EDIValidator..::..GeneralEvent^ ProgressChanged {
    void add (EDIValidator..::..GeneralEvent^ value);
    void remove (EDIValidator..::..GeneralEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ProgressMessages Property

ProgressMessages Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ProgressMessages
Detailed debug messages after validation. DebugMode must be set to true
Declaration Syntax
C# Visual Basic Visual C++
public string ProgressMessages { get; }
Public ReadOnly Property ProgressMessages As String
    Get
public:
property String^ ProgressMessages {
    String^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ResetValidation Method

ResetValidation Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ResetValidation()()()()
Resets all validation variables. This method is automatically everytime the Validate method is called.
Declaration Syntax
C# Visual Basic Visual C++
public void ResetValidation()
Public Sub ResetValidation
public:
void ResetValidation()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TimeElapsed Property

TimeElapsed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► TimeElapsed
Time elapsed in milliseconds while validating
Declaration Syntax
C# Visual Basic Visual C++
public double TimeElapsed { get; }
Public ReadOnly Property TimeElapsed As Double
    Get
public:
property double TimeElapsed {
    double get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrackDownUnrecognizedLoops Property

TrackDownUnrecognizedLoops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► TrackDownUnrecognizedLoops
If set to true then when a loop is unrecognized a search will be made if to see if a loop like that even exists in the EDI rules, if not an error will be generated
Declaration Syntax
C# Visual Basic Visual C++
public bool TrackDownUnrecognizedLoops { get; set; }
Public Property TrackDownUnrecognizedLoops As Boolean
    Get
    Set
public:
property bool TrackDownUnrecognizedLoops {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TreatWarningsAsErrors Property

TreatWarningsAsErrors Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► TreatWarningsAsErrors
Treat all warnings as errors
Declaration Syntax
C# Visual Basic Visual C++
public bool TreatWarningsAsErrors { get; set; }
Public Property TreatWarningsAsErrors As Boolean
    Get
    Set
public:
property bool TreatWarningsAsErrors {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► TrimString
String to ignore at between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Validate Method

Validate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate()()()()
Members
Icon | Member | Description
 | Validate(EDIDocument) | Validates the contents of an EDI Document
 | Validate(EDILightWeightDocument) | Validates the contents of an EDILightWeightDocument
 | Validate()()()() | Validate the EDI file
 | Validate(String, String) | Validates an EDI file

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Validate Method

Validate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate()()()()
Validate the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void Validate()
Public Sub Validate
public:
void Validate()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Validate Method (document)

Validate Method (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate(EDIDocument)
Validates the contents of an EDI Document
Declaration Syntax
C# Visual Basic Visual C++
public void Validate(
    EDIDocument document
)
Public Sub Validate ( _
    document As EDIDocument _
)
public:
void Validate(
    EDIDocument^ document
)
Parameters
document (EDIDocument)
document to validate

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Validate Method (document)

Validate Method (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate(EDILightWeightDocument)
Validates the contents of an EDILightWeightDocument
Declaration Syntax
C# Visual Basic Visual C++
public void Validate(
    EDILightWeightDocument document
)
Public Sub Validate ( _
    document As EDILightWeightDocument _
)
public:
void Validate(
    EDILightWeightDocument^ document
)
Parameters
document (EDILightWeightDocument)
document to validate

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Validate Method (ediFile, ediRuleFile)

Validate Method (ediFile, ediRuleFile)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Validate(String, String)
Validates an EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void Validate(
    string ediFile,
    string ediRuleFile
)
Public Sub Validate ( _
    ediFile As String, _
    ediRuleFile As String _
)
public:
void Validate(
    String^ ediFile,
    String^ ediRuleFile
)
Parameters
ediFile (String)
Full path of EDI file to validate
ediRuleFile (String)
Full path of EDI rules file

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidatedTransactions Field

ValidatedTransactions Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ValidatedTransactions
Declaration Syntax
C# Visual Basic Visual C++
public readonly List<LightWeightSegment> ValidatedTransactions
Public ReadOnly ValidatedTransactions As List(Of LightWeightSegment)
public:
initonly List<LightWeightSegment^>^ ValidatedTransactions

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidatedTransactionsDic Field

ValidatedTransactionsDic Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ValidatedTransactionsDic
Declaration Syntax
C# Visual Basic Visual C++
public readonly Dictionary<LightWeightSegment, List<LightWeightSegment>> ValidatedTransactionsDic
Public ReadOnly ValidatedTransactionsDic As Dictionary(Of LightWeightSegment, List(Of LightWeightSegment))
public:
initonly Dictionary<LightWeightSegment^, List<LightWeightSegment^>^>^ ValidatedTransactionsDic

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidationCompleted Event

ValidationCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ValidationCompleted
Event fired when validation is complete
Declaration Syntax
C# Visual Basic Visual C++
public event EDIValidator..::..ValidationCompletedEvent ValidationCompleted
Public Event ValidationCompleted As EDIValidator..::..ValidationCompletedEvent
public:
 event EDIValidator..::..ValidationCompletedEvent^ ValidationCompleted {
    void add (EDIValidator..::..ValidationCompletedEvent^ value);
    void remove (EDIValidator..::..ValidationCompletedEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidationStarted Event

ValidationStarted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► ValidationStarted
Event fired when validation has started
Declaration Syntax
C# Visual Basic Visual C++
public event EDIValidator..::..ValidationStartedEvent ValidationStarted
Public Event ValidationStarted As EDIValidator..::..ValidationStartedEvent
public:
 event EDIValidator..::..ValidationStartedEvent^ ValidationStarted {
    void add (EDIValidator..::..ValidationStartedEvent^ value);
    void remove (EDIValidator..::..ValidationStartedEvent^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


WarningCount Property

WarningCount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► WarningCount
Numbers of warnings in EDI file. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public int WarningCount { get; }
Public ReadOnly Property WarningCount As Integer
    Get
public:
property int WarningCount {
    int get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Warnings Property

Warnings Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Warnings
Warnings encountered while validating EDI file. Available after validation
Declaration Syntax
C# Visual Basic Visual C++
public Collection<EDIWarning> Warnings { get; }
Public ReadOnly Property Warnings As Collection(Of EDIWarning)
    Get
public:
property Collection<EDIWarning^>^ Warnings {
    Collection<EDIWarning^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIValidator.GeneralEvent Delegate

EDIValidator..::..GeneralEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator..::..GeneralEvent
Delegate used for raising general events relating to progress
Declaration Syntax
C# Visual Basic Visual C++
public delegate void GeneralEvent(
    int progress
)
Public Delegate Sub GeneralEvent ( _
    progress As Integer _
)
public delegate void GeneralEvent(
    int progress
)
Parameters
progress (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIValidator.ValidationCompletedEvent Delegate

EDIValidator..::..ValidationCompletedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator..::..ValidationCompletedEvent
Delegate used for raising an event while validation is being performed
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ValidationCompletedEvent(
    Object sender,
    ValidationEventsArgs e
)
Public Delegate Sub ValidationCompletedEvent ( _
    sender As Object, _
    e As ValidationEventsArgs _
)
public delegate void ValidationCompletedEvent(
    Object^ sender,
    ValidationEventsArgs^ e
)
Parameters
sender (Object)
sender of the event
e (ValidationEventsArgs)
data relating to the validation progress

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIValidator.ValidationStartedEvent Delegate

EDIValidator..::..ValidationStartedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► EDIValidator..::..ValidationStartedEvent
Delegate used for raising an event when validation begins
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ValidationStartedEvent(
    Object sender
)
Public Delegate Sub ValidationStartedEvent ( _
    sender As Object _
)
public delegate void ValidationStartedEvent(
    Object^ sender
)
Parameters
sender (Object)
sender of the event

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIWarning Class

EDIWarning Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIWarning
Represents a general EDI warning. Warnings are available after validation
Declaration Syntax
C# Visual Basic Visual C++
public sealed class EDIWarning : EDIError
Public NotInheritable Class EDIWarning _
    Inherits EDIError
public ref class EDIWarning sealed : public EDIError
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CompositeElementOrdinal | Get the composite element number that contains the error (Inherited from EDIError.)
 | Description | Get the description of the error (Inherited from EDIError.)
 | ElementOrdinal | Get the element number that contains the error (Inherited from EDIError.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GSSegment | Gets the GS segment. (Inherited from EDIError.)
 | LineNumber | Get the line number of the error in the EDI file (Inherited from EDIError.)
 | Loop | Get the name of the loop that contains the error (Inherited from EDIError.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | General error message type (Inherited from EDIError.)
 | Segment | Get the name of the segment that contains the error (Inherited from EDIError.)
 | SegmentPositionInTransaction | Gets or sets the segment position in transaction. (Inherited from EDIError.)
 | SegmentSchema | The schema of the segment that was being validated while the error/warning occurred (Inherited from EDIError.)
 | SetSnipLevel()()()() | Sets the snip level. (Inherited from EDIError.)
 | SnipLevel | Snip level (Inherited from EDIError.)
 | StackTrace | Gets the stack trace if this is an unexpected error (Inherited from EDIError.)
 | STSegment | Gets the ST segment. (Inherited from EDIError.)
 | ToString()()()() | Get a string represenation of the error (Inherited from EDIError.)
 | ValidatingSegment | The actual segment that was being evaluated while the error/warning occurred (Inherited from EDIError.)
Inheritance Hierarchy
Object
 | EDIError
 |  | EDIWarning

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIXmlConverter Class

EDIXmlConverter Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter
Class responsible for generating XML data from EDI data
Declaration Syntax
C# Visual Basic Visual C++
public class EDIXmlConverter
Public Class EDIXmlConverter
public ref class EDIXmlConverter
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIXmlConverter(EDILightWeightDocument) | Initializes a new instance of the EDIXmlConverter class.
 | EDIXmlConverter(EDIDocument) | Initializes a new instance of the EDIXmlConverter class.
 | BufferSize | Gets or sets the size of the buffer.
 | EDIXMLFileString | Gets the EDI XML file string.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | ToXml()()()() | Convert to XML
 | ToXml(String) | Convert to XML and saves to a file
 | XmlConfigOptions | Gets or sets the XML config options.
Inheritance Hierarchy
Object
EDIXmlConverter

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIXmlConverter Constructor

EDIXmlConverter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► EDIXmlConverter()()()()
Members
Icon | Member | Description
 | EDIXmlConverter(EDILightWeightDocument) | Initializes a new instance of the EDIXmlConverter class.
 | EDIXmlConverter(EDIDocument) | Initializes a new instance of the EDIXmlConverter class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIXmlConverter Constructor (ediDocument)

EDIXmlConverter Constructor (ediDocument)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► EDIXmlConverter(EDIDocument)
Initializes a new instance of the EDIXmlConverter class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIXmlConverter(
    EDIDocument ediDocument
)
Public Sub New ( _
    ediDocument As EDIDocument _
)
public:
EDIXmlConverter(
    EDIDocument^ ediDocument
)
Parameters
ediDocument (EDIDocument)
The edi document.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIXmlConverter Constructor (ediDocument)

EDIXmlConverter Constructor (ediDocument)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► EDIXmlConverter(EDILightWeightDocument)
Initializes a new instance of the EDIXmlConverter class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIXmlConverter(
    EDILightWeightDocument ediDocument
)
Public Sub New ( _
    ediDocument As EDILightWeightDocument _
)
public:
EDIXmlConverter(
    EDILightWeightDocument^ ediDocument
)
Parameters
ediDocument (EDILightWeightDocument)
The edi document.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


BufferSize Property

BufferSize Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► BufferSize
Gets or sets the size of the buffer.
Declaration Syntax
C# Visual Basic Visual C++
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
public:
property int BufferSize {
    int get ();
    void set (int value);
}
Value
The size of the buffer.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIXMLFileString Property

EDIXMLFileString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► EDIXMLFileString
Gets the EDI XML file string.
Declaration Syntax
C# Visual Basic Visual C++
public string EDIXMLFileString { get; internal set; }
Public Property EDIXMLFileString As String
    Get
    Friend Set
public:
property String^ EDIXMLFileString {
    String^ get ();
    internal: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► ToXml()()()()
Members
Icon | Member | Description
 | ToXml()()()() | Convert to XML
 | ToXml(String) | Convert to XML and saves to a file

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method

ToXml Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► ToXml()()()()
Convert to XML
Declaration Syntax
C# Visual Basic Visual C++
public XmlDocument ToXml()
Public Function ToXml As XmlDocument
public:
XmlDocument^ ToXml()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToXml Method (file)

ToXml Method (file)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► ToXml(String)
Convert to XML and saves to a file
Declaration Syntax
C# Visual Basic Visual C++
public void ToXml(
    string file
)
Public Sub ToXml ( _
    file As String _
)
public:
void ToXml(
    String^ file
)
Parameters
file (String)
Return Value
file to save XML to

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


XmlConfigOptions Property

XmlConfigOptions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIXmlConverter ► XmlConfigOptions
Gets or sets the XML config options.
Declaration Syntax
C# Visual Basic Visual C++
public XmlConfigOptions XmlConfigOptions { get; set; }
Public Property XmlConfigOptions As XmlConfigOptions
    Get
    Set
public:
property XmlConfigOptions^ XmlConfigOptions {
    XmlConfigOptions^ get ();
    void set (XmlConfigOptions^ value);
}
Value
The XML config options.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Element Class

Element Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element
Basic element used by EDI Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Element
<SerializableAttribute> _
Public Class Element
[SerializableAttribute]
public ref class Element
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Element()()()() | Create a new Element
 | AddCodeValues(String, String) | Adds the code values.
 | Codes | Get/Set the collection of element codes description This is a code value can the element can have and the description of this code
 | DataType | Get/Set the datatype
 | Description | Description of element
 | ElementNumber | Get/Set the element number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Max | Get/Set the maximum string length
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min | Get/Set the minimum string length
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Element

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Element Constructor

Element Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Element()()()()
Create a new Element
Declaration Syntax
C# Visual Basic Visual C++
public Element()
Public Sub New
public:
Element()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AddCodeValues Method (key, value)

AddCodeValues Method (key, value)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► AddCodeValues(String, String)
Adds the code values.
Declaration Syntax
C# Visual Basic Visual C++
public void AddCodeValues(
    string key,
    string value
)
Public Sub AddCodeValues ( _
    key As String, _
    value As String _
)
public:
void AddCodeValues(
    String^ key,
    String^ value
)
Parameters
key (String)
The key.
value (String)
The value.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Codes Property

Codes Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Codes
Get/Set the collection of element codes description This is a code value can the element can have and the description of this code
Declaration Syntax
C# Visual Basic Visual C++
public Dictionary<string, string> Codes { get; private set; }
Public Property Codes As Dictionary(Of String, String)
    Get
    Private Set
public:
property Dictionary<String^, String^>^ Codes {
    Dictionary<String^, String^>^ get ();
    private: void set (Dictionary<String^, String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataType Property

DataType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► DataType
Get/Set the datatype
Declaration Syntax
C# Visual Basic Visual C++
public ElementDataType DataType { get; set; }
Public Property DataType As ElementDataType
    Get
    Set
public:
property ElementDataType DataType {
    ElementDataType get ();
    void set (ElementDataType value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Description
Description of element
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► ElementNumber
Get/Set the element number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Max Property

Max Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Max
Get/Set the maximum string length
Declaration Syntax
C# Visual Basic Visual C++
public int Max { get; set; }
Public Property Max As Integer
    Get
    Set
public:
property int Max {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Min Property

Min Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Element ► Min
Get/Set the minimum string length
Declaration Syntax
C# Visual Basic Visual C++
public int Min { get; set; }
Public Property Min As Integer
    Get
    Set
public:
property int Min {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementCodeList Class

ElementCodeList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCodeList
Represents a list of values that an element can contain
Declaration Syntax
C# Visual Basic Visual C++
public class ElementCodeList
Public Class ElementCodeList
public ref class ElementCodeList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementCodeList()()()() | Creates a new ElementCodeList
 | CodeList | Possible codes that an element can contain
 | ElementNumber | Get/Set the element number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementCodeList

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementCodeList Constructor

ElementCodeList Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCodeList ► ElementCodeList()()()()
Creates a new ElementCodeList
Declaration Syntax
C# Visual Basic Visual C++
public ElementCodeList()
Public Sub New
public:
ElementCodeList()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeList Property

CodeList Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCodeList ► CodeList
Possible codes that an element can contain
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementValueInfo> CodeList { get; set; }
Public Property CodeList As Collection(Of ElementValueInfo)
    Get
    Set
public:
property Collection<ElementValueInfo^>^ CodeList {
    Collection<ElementValueInfo^>^ get ();
    void set (Collection<ElementValueInfo^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCodeList ► ElementNumber
Get/Set the element number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementConditionalConstraint Class

ElementConditionalConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementConditionalConstraint
Represents a conditional constraint for a segment
Declaration Syntax
C# Visual Basic Visual C++
public class ElementConditionalConstraint : ElementPairConstraint
Public Class ElementConditionalConstraint _
    Inherits ElementPairConstraint
public ref class ElementConditionalConstraint : public ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementConditionalConstraint()()()() | Initializes a new instance of the ElementConditionalConstraint class
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint (Inherited from ElementPairConstraint.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementConditionalConstraint

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementConditionalConstraint Constructor

ElementConditionalConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementConditionalConstraint ► ElementConditionalConstraint()()()()
Initializes a new instance of the ElementConditionalConstraint class
Declaration Syntax
C# Visual Basic Visual C++
public ElementConditionalConstraint()
Public Sub New
public:
ElementConditionalConstraint()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementCounterDisplay Class

ElementCounterDisplay Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCounterDisplay
Used by EDIRuleCreator
Declaration Syntax
C# Visual Basic Visual C++
public class ElementCounterDisplay
Public Class ElementCounterDisplay
public ref class ElementCounterDisplay
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementCounterDisplay(String, String) | Initializes a new instance of the ElementCounterDisplay class.
 | Element | Gets or sets the element.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rule | Gets or sets the rule.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementCounterDisplay

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementCounterDisplay Constructor (element, rule)

ElementCounterDisplay Constructor (element, rule)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCounterDisplay ► ElementCounterDisplay(String, String)
Initializes a new instance of the ElementCounterDisplay class.
Declaration Syntax
C# Visual Basic Visual C++
public ElementCounterDisplay(
    string element,
    string rule
)
Public Sub New ( _
    element As String, _
    rule As String _
)
public:
ElementCounterDisplay(
    String^ element,
    String^ rule
)
Parameters
element (String)
The element.
rule (String)
The rule.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Element Property

Element Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCounterDisplay ► Element
Gets or sets the element.
Declaration Syntax
C# Visual Basic Visual C++
public string Element { get; set; }
Public Property Element As String
    Get
    Set
public:
property String^ Element {
    String^ get ();
    void set (String^ value);
}
Value
The element.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Rule Property

Rule Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementCounterDisplay ► Rule
Gets or sets the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}
Value
The rule.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementDataType Enumeration

ElementDataType Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementDataType
Represents the possible element types
Declaration Syntax
C# Visual Basic Visual C++
public enum ElementDataType
Public Enumeration ElementDataType
public enum class ElementDataType
Members
Member | Description
ALPHABETIC |
IDENTIFIER |
STRING |
NUMERIC |
POSITIVE_NUMERIC |
NEGATIVE_NUMERIC |
DECIMAL |
TIME |
DATETIME |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementEqualityDisplay Class

ElementEqualityDisplay Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementEqualityDisplay
Used by EDIRuleCreator
Declaration Syntax
C# Visual Basic Visual C++
public class ElementEqualityDisplay
Public Class ElementEqualityDisplay
public ref class ElementEqualityDisplay
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementEqualityDisplay(String, String) | Initializes a new instance of the ElementEqualityDisplay class.
 | Element | Gets or sets the element.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rule | Gets or sets the rule.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementEqualityDisplay

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementEqualityDisplay Constructor (element, rule)

ElementEqualityDisplay Constructor (element, rule)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementEqualityDisplay ► ElementEqualityDisplay(String, String)
Initializes a new instance of the ElementEqualityDisplay class.
Declaration Syntax
C# Visual Basic Visual C++
public ElementEqualityDisplay(
    string element,
    string rule
)
Public Sub New ( _
    element As String, _
    rule As String _
)
public:
ElementEqualityDisplay(
    String^ element,
    String^ rule
)
Parameters
element (String)
The element.
rule (String)
The rule.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Element Property

Element Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementEqualityDisplay ► Element
Gets or sets the element.
Declaration Syntax
C# Visual Basic Visual C++
public string Element { get; set; }
Public Property Element As String
    Get
    Set
public:
property String^ Element {
    String^ get ();
    void set (String^ value);
}
Value
The element.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Rule Property

Rule Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementEqualityDisplay ► Rule
Gets or sets the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}
Value
The rule.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementExclusionConstraint Class

ElementExclusionConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementExclusionConstraint
Object that holds a exclusiong constraint for a segment
Declaration Syntax
C# Visual Basic Visual C++
public class ElementExclusionConstraint : ElementPairConstraint
Public Class ElementExclusionConstraint _
    Inherits ElementPairConstraint
public ref class ElementExclusionConstraint : public ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementExclusionConstraint()()()() | Initializes a new instance of the ElementExclusionConstraint class
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint (Inherited from ElementPairConstraint.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementExclusionConstraint

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementExclusionConstraint Constructor

ElementExclusionConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementExclusionConstraint ► ElementExclusionConstraint()()()()
Initializes a new instance of the ElementExclusionConstraint class
Declaration Syntax
C# Visual Basic Visual C++
public ElementExclusionConstraint()
Public Sub New
public:
ElementExclusionConstraint()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormat Class

ElementFormat Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat
Used when creating EDI Rules rules
Declaration Syntax
C# Visual Basic Visual C++
public class ElementFormat
Public Class ElementFormat
public ref class ElementFormat
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementFormat()()()() | Create a new ElementFormat object
 | ElementFormat(Int32, String) | Create a new ElementFormat object
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FormatCollection | Collection of regular expression formats that data element's value may be compared against
 | GetElementFormats(Char) | Retreives a list of the element formats
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PivotElementOrdinal | Element ordinal that formats must be applied to
 | PivotElementValue | Value that a DataElement must have before formats can be applied
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementFormat

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormat Constructor

ElementFormat Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► ElementFormat()()()()
Members
Icon | Member | Description
 | ElementFormat()()()() | Create a new ElementFormat object
 | ElementFormat(Int32, String) | Create a new ElementFormat object

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormat Constructor

ElementFormat Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► ElementFormat()()()()
Create a new ElementFormat object
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormat()
Public Sub New
public:
ElementFormat()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormat Constructor (pivotElementOridinal, pivotElementValue)

ElementFormat Constructor (pivotElementOridinal, pivotElementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► ElementFormat(Int32, String)
Create a new ElementFormat object
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormat(
    int pivotElementOridinal,
    string pivotElementValue
)
Public Sub New ( _
    pivotElementOridinal As Integer, _
    pivotElementValue As String _
)
public:
ElementFormat(
    int pivotElementOridinal,
    String^ pivotElementValue
)
Parameters
pivotElementOridinal (Int32)
Element ordinal that formats must be applied to
pivotElementValue (String)
Value that a DataElement must have before formats can be checked

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormatCollection Property

FormatCollection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► FormatCollection
Collection of regular expression formats that data element's value may be compared against
Declaration Syntax
C# Visual Basic Visual C++
public Collection<Format> FormatCollection { get; set; }
Public Property FormatCollection As Collection(Of Format)
    Get
    Set
public:
property Collection<Format^>^ FormatCollection {
    Collection<Format^>^ get ();
    void set (Collection<Format^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetElementFormats Method (separator)

GetElementFormats Method (separator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► GetElementFormats(Char)
Retreives a list of the element formats
Declaration Syntax
C# Visual Basic Visual C++
public string GetElementFormats(
    char separator
)
Public Function GetElementFormats ( _
    separator As Char _
) As String
public:
String^ GetElementFormats(
    wchar_t separator
)
Parameters
separator (Char)
delimiter between format names
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PivotElementOrdinal Property

PivotElementOrdinal Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► PivotElementOrdinal
Element ordinal that formats must be applied to
Declaration Syntax
C# Visual Basic Visual C++
public int PivotElementOrdinal { get; set; }
Public Property PivotElementOrdinal As Integer
    Get
    Set
public:
property int PivotElementOrdinal {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PivotElementValue Property

PivotElementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormat ► PivotElementValue
Value that a DataElement must have before formats can be applied
Declaration Syntax
C# Visual Basic Visual C++
public string PivotElementValue { get; set; }
Public Property PivotElementValue As String
    Get
    Set
public:
property String^ PivotElementValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormatInfo Class

ElementFormatInfo Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo
Represents format information for an Element
Declaration Syntax
C# Visual Basic Visual C++
public class ElementFormatInfo
Public Class ElementFormatInfo
public ref class ElementFormatInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementFormatInfo()()()() | Create a new ElementFormatInfo
 | ElementFormat | Get/Set the format for the element
 | ElementOrdinalNumber | Get/Set the element number that the format will apply to
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SegmentOrdinalNumber | Get/Set the segment number that the format will apply to
 | SubElementOrdinalNumber | Get/Set the composite element number that the format will apply to
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementFormatInfo

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormatInfo Constructor

ElementFormatInfo Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► ElementFormatInfo()()()()
Create a new ElementFormatInfo
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormatInfo()
Public Sub New
public:
ElementFormatInfo()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormat Property

ElementFormat Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► ElementFormat
Get/Set the format for the element
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormat ElementFormat { get; set; }
Public Property ElementFormat As ElementFormat
    Get
    Set
public:
property ElementFormat^ ElementFormat {
    ElementFormat^ get ();
    void set (ElementFormat^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementOrdinalNumber Property

ElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► ElementOrdinalNumber
Get/Set the element number that the format will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinalNumber { get; set; }
Public Property ElementOrdinalNumber As Integer
    Get
    Set
public:
property int ElementOrdinalNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentOrdinalNumber Property

SegmentOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► SegmentOrdinalNumber
Get/Set the segment number that the format will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOrdinalNumber { get; set; }
Public Property SegmentOrdinalNumber As Integer
    Get
    Set
public:
property int SegmentOrdinalNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SubElementOrdinalNumber Property

SubElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatInfo ► SubElementOrdinalNumber
Get/Set the composite element number that the format will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int SubElementOrdinalNumber { get; set; }
Public Property SubElementOrdinalNumber As Integer
    Get
    Set
public:
property int SubElementOrdinalNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormatting Class

ElementFormatting Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatting
Used by EDI Rules Reader for element formatting
Declaration Syntax
C# Visual Basic Visual C++
public class ElementFormatting
Public Class ElementFormatting
public ref class ElementFormatting
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementFormatting()()()() | Create a new ElementFormatting
 | ElementFormatInfos | Get/set collection of formatting information
 | ElementNumber | Get/Set the element number that the formatting will apply to
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementFormatting

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormatting Constructor

ElementFormatting Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatting ► ElementFormatting()()()()
Create a new ElementFormatting
Declaration Syntax
C# Visual Basic Visual C++
public ElementFormatting()
Public Sub New
public:
ElementFormatting()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementFormatInfos Property

ElementFormatInfos Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatting ► ElementFormatInfos
Get/set collection of formatting information
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementFormatInfo> ElementFormatInfos { get; set; }
Public Property ElementFormatInfos As Collection(Of ElementFormatInfo)
    Get
    Set
public:
property Collection<ElementFormatInfo^>^ ElementFormatInfos {
    Collection<ElementFormatInfo^>^ get ();
    void set (Collection<ElementFormatInfo^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementFormatting ► ElementNumber
Get/Set the element number that the formatting will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementListConditionalConstraint Class

ElementListConditionalConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementListConditionalConstraint
Represents a list conditional contraints
Declaration Syntax
C# Visual Basic Visual C++
public class ElementListConditionalConstraint : ElementPairConstraint
Public Class ElementListConditionalConstraint _
    Inherits ElementPairConstraint
public ref class ElementListConditionalConstraint : public ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementListConditionalConstraint()()()() | Initializes a new instance of the ElementListConditionalConstraint class
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint (Inherited from ElementPairConstraint.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementListConditionalConstraint

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementListConditionalConstraint Constructor

ElementListConditionalConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementListConditionalConstraint ► ElementListConditionalConstraint()()()()
Initializes a new instance of the ElementListConditionalConstraint class
Declaration Syntax
C# Visual Basic Visual C++
public ElementListConditionalConstraint()
Public Sub New
public:
ElementListConditionalConstraint()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPairConstraint Class

ElementPairConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint
Represents a element pair relationship
Declaration Syntax
C# Visual Basic Visual C++
public class ElementPairConstraint
Public Class ElementPairConstraint
public ref class ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementPairConstraint()()()() | Create a new ElementPairConstraint object
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementConditionalConstraint
 |  | ElementExclusionConstraint
 |  | ElementListConditionalConstraint
 |  | ElementRequiredConstraint

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPairConstraint Constructor

ElementPairConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► ElementPairConstraint()()()()
Create a new ElementPairConstraint object
Declaration Syntax
C# Visual Basic Visual C++
public ElementPairConstraint()
Public Sub New
public:
ElementPairConstraint()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementOrdinals Property

ElementOrdinals Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► ElementOrdinals
Get/set a list of element ordinals involved in the contraint
Declaration Syntax
C# Visual Basic Visual C++
public Collection<int> ElementOrdinals { get; set; }
Public Property ElementOrdinals As Collection(Of Integer)
    Get
    Set
public:
property Collection<int>^ ElementOrdinals {
    Collection<int>^ get ();
    void set (Collection<int>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► GetElementOrdinalsString()()()()
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► GetElementOrdinalsString()()()()
Get a list of the element ordinals involved in the contraint as a space delimited list
Declaration Syntax
C# Visual Basic Visual C++
public string GetElementOrdinalsString()
Public Function GetElementOrdinalsString As String
public:
String^ GetElementOrdinalsString()
Return Value
space delimited list

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetElementOrdinalsString Method (start)

GetElementOrdinalsString Method (start)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPairConstraint ► GetElementOrdinalsString(Int32)
Get a list of the element ordinals involved in the contraint as a space delimited list
Declaration Syntax
C# Visual Basic Visual C++
public string GetElementOrdinalsString(
    int start
)
Public Function GetElementOrdinalsString ( _
    start As Integer _
) As String
public:
String^ GetElementOrdinalsString(
    int start
)
Parameters
start (Int32)
start position in the collection
Return Value
space delimited list

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPosition Class

ElementPosition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition
Represents the position of an element with the EDI file
Declaration Syntax
C# Visual Basic Visual C++
public class ElementPosition
Public Class ElementPosition
public ref class ElementPosition
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementPosition()()()() | Creates a new Element Position
 | ElementPosition(Int32, Int32, Int32) | Creates a new Element Position
 | CompositeElementPosition | Get/set composite element position
 | ElementOrdinalPosition | Get/set element ordinal position
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCompositeElementPosition()()()() | Checks if this is a composite element position
 | IsElementPosition()()()() | Checks if this is an element position
 | IsSegmentPosition()()()() | Checks if this is a segment position
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SegmentOridinalPosition | Get/set the segment ordinal position
 | ToString()()()() | Returns a string representation of this object (Overrides Object.ToString()()()().)
 | ToSummaryKey()()()() |
Inheritance Hierarchy
Object
ElementPosition

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPosition Constructor

ElementPosition Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ElementPosition()()()()
Members
Icon | Member | Description
 | ElementPosition()()()() | Creates a new Element Position
 | ElementPosition(Int32, Int32, Int32) | Creates a new Element Position

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPosition Constructor

ElementPosition Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ElementPosition()()()()
Creates a new Element Position
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition()
Public Sub New
public:
ElementPosition()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPosition Constructor (segmentOridinalPosition, elementOrdinalPosition, compositeElementPosition)

ElementPosition Constructor (segmentOridinalPosition, elementOrdinalPosition, compositeElementPosition)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ElementPosition(Int32, Int32, Int32)
Creates a new Element Position
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition(
    int segmentOridinalPosition,
    int elementOrdinalPosition,
    int compositeElementPosition
)
Public Sub New ( _
    segmentOridinalPosition As Integer, _
    elementOrdinalPosition As Integer, _
    compositeElementPosition As Integer _
)
public:
ElementPosition(
    int segmentOridinalPosition,
    int elementOrdinalPosition,
    int compositeElementPosition
)
Parameters
segmentOridinalPosition (Int32)
segment ordinal position
elementOrdinalPosition (Int32)
element ordinal position
compositeElementPosition (Int32)
composite ordinal position

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementPosition Property

CompositeElementPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► CompositeElementPosition
Get/set composite element position
Declaration Syntax
C# Visual Basic Visual C++
public int CompositeElementPosition { get; set; }
Public Property CompositeElementPosition As Integer
    Get
    Set
public:
property int CompositeElementPosition {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementOrdinalPosition Property

ElementOrdinalPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ElementOrdinalPosition
Get/set element ordinal position
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinalPosition { get; set; }
Public Property ElementOrdinalPosition As Integer
    Get
    Set
public:
property int ElementOrdinalPosition {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsCompositeElementPosition Method

IsCompositeElementPosition Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► IsCompositeElementPosition()()()()
Checks if this is a composite element position
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCompositeElementPosition()
Public Function IsCompositeElementPosition As Boolean
public:
bool IsCompositeElementPosition()
Return Value
true if a composite element, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsElementPosition Method

IsElementPosition Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► IsElementPosition()()()()
Checks if this is an element position
Declaration Syntax
C# Visual Basic Visual C++
public bool IsElementPosition()
Public Function IsElementPosition As Boolean
public:
bool IsElementPosition()
Return Value
true if a element position, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsSegmentPosition Method

IsSegmentPosition Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► IsSegmentPosition()()()()
Checks if this is a segment position
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSegmentPosition()
Public Function IsSegmentPosition As Boolean
public:
bool IsSegmentPosition()
Return Value
true if a segment position, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentOridinalPosition Property

SegmentOridinalPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► SegmentOridinalPosition
Get/set the segment ordinal position
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOridinalPosition { get; set; }
Public Property SegmentOridinalPosition As Integer
    Get
    Set
public:
property int SegmentOridinalPosition {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ToString()()()()
Returns a string representation of this object
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
string representation of this object

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToSummaryKey Method

ToSummaryKey Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementPosition ► ToSummaryKey()()()()
Declaration Syntax
C# Visual Basic Visual C++
public string ToSummaryKey()
Public Function ToSummaryKey As String
public:
String^ ToSummaryKey()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementRequiredConstraint Class

ElementRequiredConstraint Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementRequiredConstraint
Represents a required constraint for a segment
Declaration Syntax
C# Visual Basic Visual C++
public class ElementRequiredConstraint : ElementPairConstraint
Public Class ElementRequiredConstraint _
    Inherits ElementPairConstraint
public ref class ElementRequiredConstraint : public ElementPairConstraint
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementRequiredConstraint()()()() | Initializes a new instance of the ElementRequiredConstraint class
 | ElementOrdinals | Get/set a list of element ordinals involved in the contraint (Inherited from ElementPairConstraint.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list (Inherited from ElementPairConstraint.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ElementPairConstraint
 |  | ElementRequiredConstraint

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementRequiredConstraint Constructor

ElementRequiredConstraint Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementRequiredConstraint ► ElementRequiredConstraint()()()()
Initializes a new instance of the ElementRequiredConstraint class
Declaration Syntax
C# Visual Basic Visual C++
public ElementRequiredConstraint()
Public Sub New
public:
ElementRequiredConstraint()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementSchema Class

ElementSchema Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema
Represents an element schema used by EDI Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ElementSchema
<SerializableAttribute> _
Public Class ElementSchema
[SerializableAttribute]
public ref class ElementSchema
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementSchema()()()() | Creates a new ElementSchema
 | ElementSchema(Int32, Usage) | Creates a new ElementSchema
 | ElementSchema(Int32) | Creates a new ElementSchema
 | Composite | Get/set whether this is a composite element
 | CompositeElement | Get/set the composite element
 | ElementNumber | Get/set the element number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Usage | Get/set the usage of this element
Inheritance Hierarchy
Object
ElementSchema

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementSchema Constructor

ElementSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementSchema()()()()
Members
Icon | Member | Description
 | ElementSchema()()()() | Creates a new ElementSchema
 | ElementSchema(Int32, Usage) | Creates a new ElementSchema
 | ElementSchema(Int32) | Creates a new ElementSchema

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementSchema Constructor

ElementSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementSchema()()()()
Creates a new ElementSchema
Declaration Syntax
C# Visual Basic Visual C++
public ElementSchema()
Public Sub New
public:
ElementSchema()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementSchema Constructor (elementNumber)

ElementSchema Constructor (elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementSchema(Int32)
Creates a new ElementSchema
Declaration Syntax
C# Visual Basic Visual C++
public ElementSchema(
    int elementNumber
)
Public Sub New ( _
    elementNumber As Integer _
)
public:
ElementSchema(
    int elementNumber
)
Parameters
elementNumber (Int32)
element number

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementSchema Constructor (elementNumber, usage)

ElementSchema Constructor (elementNumber, usage)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementSchema(Int32, Usage)
Creates a new ElementSchema
Declaration Syntax
C# Visual Basic Visual C++
public ElementSchema(
    int elementNumber,
    Usage usage
)
Public Sub New ( _
    elementNumber As Integer, _
    usage As Usage _
)
public:
ElementSchema(
    int elementNumber,
    Usage usage
)
Parameters
elementNumber (Int32)
element number
usage (Usage)
usage for element

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Composite Property

Composite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► Composite
Get/set whether this is a composite element
Declaration Syntax
C# Visual Basic Visual C++
public bool Composite { get; set; }
Public Property Composite As Boolean
    Get
    Set
public:
property bool Composite {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElement Property

CompositeElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► CompositeElement
Get/set the composite element
Declaration Syntax
C# Visual Basic Visual C++
public Segment CompositeElement { get; set; }
Public Property CompositeElement As Segment
    Get
    Set
public:
property Segment^ CompositeElement {
    Segment^ get ();
    void set (Segment^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► ElementNumber
Get/set the element number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementSchema ► Usage
Get/set the usage of this element
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementValueInfo Class

ElementValueInfo Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo
Represents an element and its possible values at a specific location
Declaration Syntax
C# Visual Basic Visual C++
public class ElementValueInfo
Public Class ElementValueInfo
public ref class ElementValueInfo
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementValueInfo()()()() | Creates a new ElementValueInfo
 | CodeList |
 | CodeListName | For EDI Rules Reader
 | ElementOrdinalNumber | Get/set the element ordinal number
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPossibleValues()()()() | Gets the possible value for an element at this specific location separated by a space character
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PossibleValues | Gets the possible value for an element at this specific location
 | SegmentOrdinalNumber | Get/set the segment ordinal number
 | SubElementOrdinalNumber | Get/set the element composite element ordinal number
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ElementValueInfo

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementValueInfo Constructor

ElementValueInfo Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► ElementValueInfo()()()()
Creates a new ElementValueInfo
Declaration Syntax
C# Visual Basic Visual C++
public ElementValueInfo()
Public Sub New
public:
ElementValueInfo()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeList Property

CodeList Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► CodeList
Declaration Syntax
C# Visual Basic Visual C++
public CodeList CodeList { get; set; }
Public Property CodeList As CodeList
    Get
    Set
public:
property CodeList^ CodeList {
    CodeList^ get ();
    void set (CodeList^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CodeListName Property

CodeListName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► CodeListName
For EDI Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListName { get; set; }
Public Property CodeListName As String
    Get
    Set
public:
property String^ CodeListName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementOrdinalNumber Property

ElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► ElementOrdinalNumber
Get/set the element ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int ElementOrdinalNumber { get; set; }
Public Property ElementOrdinalNumber As Integer
    Get
    Set
public:
property int ElementOrdinalNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetPossibleValues Method

GetPossibleValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► GetPossibleValues()()()()
Gets the possible value for an element at this specific location separated by a space character
Declaration Syntax
C# Visual Basic Visual C++
public string GetPossibleValues()
Public Function GetPossibleValues As String
public:
String^ GetPossibleValues()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PossibleValues Property

PossibleValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► PossibleValues
Gets the possible value for an element at this specific location
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> PossibleValues { get; }
Public ReadOnly Property PossibleValues As HashSet(Of String)
    Get
public:
property HashSet<String^>^ PossibleValues {
    HashSet<String^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentOrdinalNumber Property

SegmentOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► SegmentOrdinalNumber
Get/set the segment ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int SegmentOrdinalNumber { get; set; }
Public Property SegmentOrdinalNumber As Integer
    Get
    Set
public:
property int SegmentOrdinalNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SubElementOrdinalNumber Property

SubElementOrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementValueInfo ► SubElementOrdinalNumber
Get/set the element composite element ordinal number
Declaration Syntax
C# Visual Basic Visual C++
public int SubElementOrdinalNumber { get; set; }
Public Property SubElementOrdinalNumber As Integer
    Get
    Set
public:
property int SubElementOrdinalNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileJoinLevel Enumeration

FileJoinLevel Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileJoinLevel
Enum to specify where file joining should occur at the Header level(ST) or the Functional Group level (GS). Used by EDIFileJoiner
Declaration Syntax
C# Visual Basic Visual C++
public enum FileJoinLevel
Public Enumeration FileJoinLevel
public enum class FileJoinLevel
Members
Member | Description
FUNCTIONALGROUP | Join file on functional group level
HEADER | Join file on the header level

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileLoadingEventArgs Class

FileLoadingEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileLoadingEventArgs
Represents data pertaining to the time it took to load an EDI file
Declaration Syntax
C# Visual Basic Visual C++
public class FileLoadingEventArgs
Public Class FileLoadingEventArgs
public ref class FileLoadingEventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Milliseconds | Get the amount of time passed in milliseconds for the validation process
 | NumberOfSegmentsLoaded | Number of segments loaded
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileLoadingEventArgs

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Milliseconds Property

Milliseconds Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileLoadingEventArgs ► Milliseconds
Get the amount of time passed in milliseconds for the validation process
Declaration Syntax
C# Visual Basic Visual C++
public double Milliseconds { get; }
Public ReadOnly Property Milliseconds As Double
    Get
public:
property double Milliseconds {
    double get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NumberOfSegmentsLoaded Property

NumberOfSegmentsLoaded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileLoadingEventArgs ► NumberOfSegmentsLoaded
Number of segments loaded
Declaration Syntax
C# Visual Basic Visual C++
public long NumberOfSegmentsLoaded { get; }
Public ReadOnly Property NumberOfSegmentsLoaded As Long
    Get
public:
property long long NumberOfSegmentsLoaded {
    long long get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileLoadingException Class

FileLoadingException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileLoadingException
An exception that represents an errors that occur while loading an EDI file with the EDIFileLoader component
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FileLoadingException : Exception
<SerializableAttribute> _
Public Class FileLoadingException _
    Inherits Exception
[SerializableAttribute]
public ref class FileLoadingException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | FileLoadingException

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileOperationCompletedEventArgs Class

FileOperationCompletedEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs
FileOperationCompletedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class FileOperationCompletedEventArgs : EventArgs
Public Class FileOperationCompletedEventArgs _
    Inherits EventArgs
public ref class FileOperationCompletedEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception | Gets or sets the exception.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | State | Gets or sets the state.
 | Status | Gets or sets the status.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | FileOperationCompletedEventArgs

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Exception Property

Exception Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs ► Exception
Gets or sets the exception.
Declaration Syntax
C# Visual Basic Visual C++
public Exception Exception { get; set; }
Public Property Exception As Exception
    Get
    Set
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}
Value
The exception.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


State Property

State Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs ► State
Gets or sets the state.
Declaration Syntax
C# Visual Basic Visual C++
public Object State { get; set; }
Public Property State As Object
    Get
    Set
public:
property Object^ State {
    Object^ get ();
    void set (Object^ value);
}
Value
The state.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Status Property

Status Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationCompletedEventArgs ► Status
Gets or sets the status.
Declaration Syntax
C# Visual Basic Visual C++
public FileOperationStatus Status { get; set; }
Public Property Status As FileOperationStatus
    Get
    Set
public:
property FileOperationStatus Status {
    FileOperationStatus get ();
    void set (FileOperationStatus value);
}
Value
The status.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileOperationStatus Enumeration

FileOperationStatus Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileOperationStatus
Declaration Syntax
C# Visual Basic Visual C++
public enum FileOperationStatus
Public Enumeration FileOperationStatus
public enum class FileOperationStatus
Members
Member | Description
NotSet |
Success |
Failure |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileSplitLevel Enumeration

FileSplitLevel Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileSplitLevel
Enum to specify where file splitting should occur at the Header level(ST) or the Functional Group level (GS). Used by EDIFileSplitter
Declaration Syntax
C# Visual Basic Visual C++
public enum FileSplitLevel
Public Enumeration FileSplitLevel
public enum class FileSplitLevel
Members
Member | Description
FUNCTIONALGROUP | Split file on functional group level
HEADER | Split file on the header level
ENVELOPE | Split file on the envelope level

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileType Enumeration

FileType Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FileType
EDI File Type
Declaration Syntax
C# Visual Basic Visual C++
public enum FileType
Public Enumeration FileType
public enum class FileType
Members
Member | Description
X12 |
EDIFACT |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Format Class

Format Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format
Represents a regular expression format that a data element's value must conform to
Declaration Syntax
C# Visual Basic Visual C++
public class Format
Public Class Format
public ref class Format
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Format()()()() | Creates a new format pattern
 | Format(String, String) | Create a new format with a name and pattern
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Name of the pattern
 | Pattern | Regular Expression pattern
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Format

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Format Constructor

Format Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Format()()()()
Members
Icon | Member | Description
 | Format()()()() | Creates a new format pattern
 | Format(String, String) | Create a new format with a name and pattern

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Format Constructor

Format Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Format()()()()
Creates a new format pattern
Declaration Syntax
C# Visual Basic Visual C++
public Format()
Public Sub New
public:
Format()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Format Constructor (name, pattern)

Format Constructor (name, pattern)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Format(String, String)
Create a new format with a name and pattern
Declaration Syntax
C# Visual Basic Visual C++
public Format(
    string name,
    string pattern
)
Public Sub New ( _
    name As String, _
    pattern As String _
)
public:
Format(
    String^ name,
    String^ pattern
)
Parameters
name (String)
name of pattern
pattern (String)
regular expression pattern

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Name
Name of the pattern
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Pattern Property

Pattern Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Format ► Pattern
Regular Expression pattern
Declaration Syntax
C# Visual Basic Visual C++
public string Pattern { get; set; }
Public Property Pattern As String
    Get
    Set
public:
property String^ Pattern {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Class

FormCell Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell
An object used to encapulate the data of a cell and formatting
Declaration Syntax
C# Visual Basic Visual C++
public class FormCell
Public Class FormCell
public ref class FormCell
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormCell()()()() | Initializes a new instance of the FormCell class
 | FormCell(String) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, Double, Double) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, Double, Double, StringAlignment) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, SizeF) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, SizeF, StringAlignment) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, SizeF, StringAlignment, StringAlignment) | Initializes a new instance of the FormCell class
 | Data |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height |
 | LineAlignment |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | RectangleF |
 | StringAlignment |
 | StringFormatFlags |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Width |
 | X |
 | Y |
Inheritance Hierarchy
Object
FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor

FormCell Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell()()()()
Members
Icon | Member | Description
 | FormCell()()()() | Initializes a new instance of the FormCell class
 | FormCell(String) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, Double, Double) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, Double, Double, StringAlignment) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, SizeF) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, SizeF, StringAlignment) | Initializes a new instance of the FormCell class
 | FormCell(String, Double, Double, SizeF, StringAlignment, StringAlignment) | Initializes a new instance of the FormCell class

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor

FormCell Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell()()()()
Initializes a new instance of the FormCell class
Declaration Syntax
C# Visual Basic Visual C++
public FormCell()
Public Sub New
public:
FormCell()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor (data)

FormCell Constructor (data)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell(String)
Initializes a new instance of the FormCell class
Declaration Syntax
C# Visual Basic Visual C++
public FormCell(
    string data
)
Public Sub New ( _
    data As String _
)
public:
FormCell(
    String^ data
)
Parameters
data (String)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor (data, x, y, width, height)

FormCell Constructor (data, x, y, width, height)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell(String, Double, Double, Double, Double)
Initializes a new instance of the FormCell class
Declaration Syntax
C# Visual Basic Visual C++
public FormCell(
    string data,
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
FormCell(
    String^ data,
    double x,
    double y,
    double width,
    double height
)
Parameters
data (String)
x (Double)
y (Double)
width (Double)
height (Double)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor (data, x, y, width, height, sa)

FormCell Constructor (data, x, y, width, height, sa)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell(String, Double, Double, Double, Double, StringAlignment)
Initializes a new instance of the FormCell class
Declaration Syntax
C# Visual Basic Visual C++
public FormCell(
    string data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa
)
Public Sub New ( _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    sa As StringAlignment _
)
public:
FormCell(
    String^ data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa
)
Parameters
data (String)
x (Double)
y (Double)
width (Double)
height (Double)
sa (StringAlignment)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor (data, x, y, width, height, sa, lineAlignment)

FormCell Constructor (data, x, y, width, height, sa, lineAlignment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell(String, Double, Double, Double, Double, StringAlignment, StringAlignment)
Initializes a new instance of the FormCell class
Declaration Syntax
C# Visual Basic Visual C++
public FormCell(
    string data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Public Sub New ( _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    sa As StringAlignment, _
    lineAlignment As StringAlignment _
)
public:
FormCell(
    String^ data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Parameters
data (String)
x (Double)
y (Double)
width (Double)
height (Double)
sa (StringAlignment)
lineAlignment (StringAlignment)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor (data, x, y, size)

FormCell Constructor (data, x, y, size)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell(String, Double, Double, SizeF)
Initializes a new instance of the FormCell class
Declaration Syntax
C# Visual Basic Visual C++
public FormCell(
    string data,
    double x,
    double y,
    SizeF size
)
Public Sub New ( _
    data As String, _
    x As Double, _
    y As Double, _
    size As SizeF _
)
public:
FormCell(
    String^ data,
    double x,
    double y,
    SizeF size
)
Parameters
data (String)
x (Double)
y (Double)
size (SizeF)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor (data, x, y, size, sa)

FormCell Constructor (data, x, y, size, sa)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell(String, Double, Double, SizeF, StringAlignment)
Initializes a new instance of the FormCell class
Declaration Syntax
C# Visual Basic Visual C++
public FormCell(
    string data,
    double x,
    double y,
    SizeF size,
    StringAlignment sa
)
Public Sub New ( _
    data As String, _
    x As Double, _
    y As Double, _
    size As SizeF, _
    sa As StringAlignment _
)
public:
FormCell(
    String^ data,
    double x,
    double y,
    SizeF size,
    StringAlignment sa
)
Parameters
data (String)
x (Double)
y (Double)
size (SizeF)
sa (StringAlignment)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormCell Constructor (data, x, y, size, sa, lineAlignment)

FormCell Constructor (data, x, y, size, sa, lineAlignment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► FormCell(String, Double, Double, SizeF, StringAlignment, StringAlignment)
Initializes a new instance of the FormCell class
Declaration Syntax
C# Visual Basic Visual C++
public FormCell(
    string data,
    double x,
    double y,
    SizeF size,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Public Sub New ( _
    data As String, _
    x As Double, _
    y As Double, _
    size As SizeF, _
    sa As StringAlignment, _
    lineAlignment As StringAlignment _
)
public:
FormCell(
    String^ data,
    double x,
    double y,
    SizeF size,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Parameters
data (String)
x (Double)
y (Double)
size (SizeF)
sa (StringAlignment)
lineAlignment (StringAlignment)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Data Property

Data Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► Data
Declaration Syntax
C# Visual Basic Visual C++
public string Data { get; set; }
Public Property Data As String
    Get
    Set
public:
property String^ Data {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► Height
Declaration Syntax
C# Visual Basic Visual C++
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LineAlignment Property

LineAlignment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► LineAlignment
Declaration Syntax
C# Visual Basic Visual C++
public StringAlignment LineAlignment { get; set; }
Public Property LineAlignment As StringAlignment
    Get
    Set
public:
property StringAlignment LineAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RectangleF Property

RectangleF Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► RectangleF
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF RectangleF { get; }
Public ReadOnly Property RectangleF As RectangleF
    Get
public:
property RectangleF RectangleF {
    RectangleF get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


StringAlignment Property

StringAlignment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► StringAlignment
Declaration Syntax
C# Visual Basic Visual C++
public StringAlignment StringAlignment { get; set; }
Public Property StringAlignment As StringAlignment
    Get
    Set
public:
property StringAlignment StringAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


StringFormatFlags Property

StringFormatFlags Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► StringFormatFlags
Declaration Syntax
C# Visual Basic Visual C++
public StringFormatFlags StringFormatFlags { get; set; }
Public Property StringFormatFlags As StringFormatFlags
    Get
    Set
public:
property StringFormatFlags StringFormatFlags {
    StringFormatFlags get ();
    void set (StringFormatFlags value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Width Property

Width Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► Width
Declaration Syntax
C# Visual Basic Visual C++
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


X Property

X Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► X
Declaration Syntax
C# Visual Basic Visual C++
public double X { get; set; }
Public Property X As Double
    Get
    Set
public:
property double X {
    double get ();
    void set (double value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Y Property

Y Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormCell ► Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y { get; set; }
Public Property Y As Double
    Get
    Set
public:
property double Y {
    double get ();
    void set (double value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormPrinter Class

FormPrinter Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter
Summary description for Form.
Declaration Syntax
C# Visual Basic Visual C++
public class FormPrinter : Component
Public Class FormPrinter _
    Inherits Component
public ref class FormPrinter : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FormPrinter(IContainer) | Initializes a new instance of the FormPrinter class
 | FormPrinter()()()() | Initializes a new instance of the FormPrinter class
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Cells |
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateCell(String, Double, Double, Double, Double) | Creates a FormCell
 | CreateCell(String, Double, Double, Double, Double, StringAlignment) | Creates a FormCell
 | CreateCell(String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a FormCell
 | CreateCell(String) | Creates a FormCell
 | CreateCell(String, Double, Double, SizeF) | Creates a FormCell
 | CreateCell(String, Double, Double, SizeF, StringAlignment) | Creates a FormCell
 | CreateCell(String, Double, Double, SizeF, StringAlignment, StringAlignment) | Creates a FormCell
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | Font |
 | FontColor |
 | FormBitmap |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Image |
 | ImageX |
 | ImageY |
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PageSettings |
 | Print()()()() | Prints form
 | PrintCellRectangle |
 | PrintPreview()()()() | Preview form
 | PrintToImage()()()() | Print form to Image
 | PrintUppercase |
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | FormPrinter

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormPrinter Constructor

FormPrinter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► FormPrinter()()()()
Members
Icon | Member | Description
 | FormPrinter(IContainer) | Initializes a new instance of the FormPrinter class
 | FormPrinter()()()() | Initializes a new instance of the FormPrinter class

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormPrinter Constructor

FormPrinter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► FormPrinter()()()()
Initializes a new instance of the FormPrinter class
Declaration Syntax
C# Visual Basic Visual C++
public FormPrinter()
Public Sub New
public:
FormPrinter()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormPrinter Constructor (container)

FormPrinter Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► FormPrinter(IContainer)
Initializes a new instance of the FormPrinter class
Declaration Syntax
C# Visual Basic Visual C++
public FormPrinter(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
FormPrinter(
    IContainer^ container
)
Parameters
container (IContainer)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Cells Property

Cells Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► Cells
Declaration Syntax
C# Visual Basic Visual C++
public Collection<FormCell> Cells { get; }
Public ReadOnly Property Cells As Collection(Of FormCell)
    Get
public:
property Collection<FormCell^>^ Cells {
    Collection<FormCell^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateCell Method

CreateCell Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► CreateCell()()()()
Members
Icon | Member | Description
 | CreateCell(String, Double, Double, Double, Double) | Creates a FormCell
 | CreateCell(String, Double, Double, Double, Double, StringAlignment) | Creates a FormCell
 | CreateCell(String, Double, Double, Double, Double, StringAlignment, StringAlignment) | Creates a FormCell
 | CreateCell(String) | Creates a FormCell
 | CreateCell(String, Double, Double, SizeF) | Creates a FormCell
 | CreateCell(String, Double, Double, SizeF, StringAlignment) | Creates a FormCell
 | CreateCell(String, Double, Double, SizeF, StringAlignment, StringAlignment) | Creates a FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateCell Method (data)

CreateCell Method (data)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► CreateCell(String)
Creates a FormCell
Declaration Syntax
C# Visual Basic Visual C++
public FormCell CreateCell(
    string data
)
Public Function CreateCell ( _
    data As String _
) As FormCell
public:
FormCell^ CreateCell(
    String^ data
)
Parameters
data (String)
data to print in the cell
Return Value
new FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateCell Method (data, x, y, width, height)

CreateCell Method (data, x, y, width, height)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► CreateCell(String, Double, Double, Double, Double)
Creates a FormCell
Declaration Syntax
C# Visual Basic Visual C++
public FormCell CreateCell(
    string data,
    double x,
    double y,
    double width,
    double height
)
Public Function CreateCell ( _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
) As FormCell
public:
FormCell^ CreateCell(
    String^ data,
    double x,
    double y,
    double width,
    double height
)
Parameters
data (String)
data to print in the cell
x (Double)
x position of cell
y (Double)
y position of cell
width (Double)
width of cell
height (Double)
height of cell
Return Value
new FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateCell Method (data, x, y, width, height, sa)

CreateCell Method (data, x, y, width, height, sa)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► CreateCell(String, Double, Double, Double, Double, StringAlignment)
Creates a FormCell
Declaration Syntax
C# Visual Basic Visual C++
public FormCell CreateCell(
    string data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa
)
Public Function CreateCell ( _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    sa As StringAlignment _
) As FormCell
public:
FormCell^ CreateCell(
    String^ data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa
)
Parameters
data (String)
data to print in the cell
x (Double)
x position of cell
y (Double)
y position of cell
width (Double)
width of cell
height (Double)
height of cell
sa (StringAlignment)
StringAlignment
Return Value
new FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateCell Method (data, x, y, width, height, sa, lineAlignment)

CreateCell Method (data, x, y, width, height, sa, lineAlignment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► CreateCell(String, Double, Double, Double, Double, StringAlignment, StringAlignment)
Creates a FormCell
Declaration Syntax
C# Visual Basic Visual C++
public FormCell CreateCell(
    string data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Public Function CreateCell ( _
    data As String, _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    sa As StringAlignment, _
    lineAlignment As StringAlignment _
) As FormCell
public:
FormCell^ CreateCell(
    String^ data,
    double x,
    double y,
    double width,
    double height,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Parameters
data (String)
data to print in the cell
x (Double)
x position of cell
y (Double)
y position of cell
width (Double)
width of cell
height (Double)
height of cell
sa (StringAlignment)
StringAlignment
lineAlignment (StringAlignment)
LineAlignment
Return Value
new FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateCell Method (data, x, y, size)

CreateCell Method (data, x, y, size)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► CreateCell(String, Double, Double, SizeF)
Creates a FormCell
Declaration Syntax
C# Visual Basic Visual C++
public FormCell CreateCell(
    string data,
    double x,
    double y,
    SizeF size
)
Public Function CreateCell ( _
    data As String, _
    x As Double, _
    y As Double, _
    size As SizeF _
) As FormCell
public:
FormCell^ CreateCell(
    String^ data,
    double x,
    double y,
    SizeF size
)
Parameters
data (String)
data to print in the cell
x (Double)
x position of cell
y (Double)
y position of cell
size (SizeF)
Size of cell
Return Value
new FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateCell Method (data, x, y, size, sa)

CreateCell Method (data, x, y, size, sa)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► CreateCell(String, Double, Double, SizeF, StringAlignment)
Creates a FormCell
Declaration Syntax
C# Visual Basic Visual C++
public FormCell CreateCell(
    string data,
    double x,
    double y,
    SizeF size,
    StringAlignment sa
)
Public Function CreateCell ( _
    data As String, _
    x As Double, _
    y As Double, _
    size As SizeF, _
    sa As StringAlignment _
) As FormCell
public:
FormCell^ CreateCell(
    String^ data,
    double x,
    double y,
    SizeF size,
    StringAlignment sa
)
Parameters
data (String)
data to print in the cell
x (Double)
x position of cell
y (Double)
y position of cell
size (SizeF)
Size of cell
sa (StringAlignment)
StringAlignment
Return Value
new FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateCell Method (data, x, y, size, sa, lineAlignment)

CreateCell Method (data, x, y, size, sa, lineAlignment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► CreateCell(String, Double, Double, SizeF, StringAlignment, StringAlignment)
Creates a FormCell
Declaration Syntax
C# Visual Basic Visual C++
public FormCell CreateCell(
    string data,
    double x,
    double y,
    SizeF size,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Public Function CreateCell ( _
    data As String, _
    x As Double, _
    y As Double, _
    size As SizeF, _
    sa As StringAlignment, _
    lineAlignment As StringAlignment _
) As FormCell
public:
FormCell^ CreateCell(
    String^ data,
    double x,
    double y,
    SizeF size,
    StringAlignment sa,
    StringAlignment lineAlignment
)
Parameters
data (String)
data to print in the cell
x (Double)
x position of cell
y (Double)
y position of cell
size (SizeF)
Size of cell
sa (StringAlignment)
StringAlignment
lineAlignment (StringAlignment)
LineAlignment
Return Value
new FormCell

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
True to release both managed and unmanaged resources; false to release only unmanaged resources

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Font Property

Font Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► Font
Declaration Syntax
C# Visual Basic Visual C++
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FontColor Property

FontColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► FontColor
Declaration Syntax
C# Visual Basic Visual C++
public Color FontColor { get; set; }
Public Property FontColor As Color
    Get
    Set
public:
property Color FontColor {
    Color get ();
    void set (Color value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FormBitmap Property

FormBitmap Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► FormBitmap
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap FormBitmap { get; }
Public ReadOnly Property FormBitmap As Bitmap
    Get
public:
property Bitmap^ FormBitmap {
    Bitmap^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Image Property

Image Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► Image
Declaration Syntax
C# Visual Basic Visual C++
public Image Image { get; set; }
Public Property Image As Image
    Get
    Set
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ImageX Property

ImageX Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► ImageX
Declaration Syntax
C# Visual Basic Visual C++
public float ImageX { get; set; }
Public Property ImageX As Single
    Get
    Set
public:
property float ImageX {
    float get ();
    void set (float value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ImageY Property

ImageY Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► ImageY
Declaration Syntax
C# Visual Basic Visual C++
public float ImageY { get; set; }
Public Property ImageY As Single
    Get
    Set
public:
property float ImageY {
    float get ();
    void set (float value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PageSettings Property

PageSettings Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► PageSettings
Declaration Syntax
C# Visual Basic Visual C++
public PageSettings PageSettings { get; set; }
Public Property PageSettings As PageSettings
    Get
    Set
public:
property PageSettings^ PageSettings {
    PageSettings^ get ();
    void set (PageSettings^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Print Method

Print Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► Print()()()()
Prints form
Declaration Syntax
C# Visual Basic Visual C++
public void Print()
Public Sub Print
public:
void Print()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PrintCellRectangle Property

PrintCellRectangle Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► PrintCellRectangle
Declaration Syntax
C# Visual Basic Visual C++
public bool PrintCellRectangle { get; set; }
Public Property PrintCellRectangle As Boolean
    Get
    Set
public:
property bool PrintCellRectangle {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PrintPreview Method

PrintPreview Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► PrintPreview()()()()
Preview form
Declaration Syntax
C# Visual Basic Visual C++
public void PrintPreview()
Public Sub PrintPreview
public:
void PrintPreview()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PrintToImage Method

PrintToImage Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► PrintToImage()()()()
Print form to Image
Declaration Syntax
C# Visual Basic Visual C++
public void PrintToImage()
Public Sub PrintToImage
public:
void PrintToImage()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PrintUppercase Property

PrintUppercase Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► PrintUppercase
Declaration Syntax
C# Visual Basic Visual C++
public bool PrintUppercase { get; set; }
Public Property PrintUppercase As Boolean
    Get
    Set
public:
property bool PrintUppercase {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FoundSegmentCollection Class

FoundSegmentCollection Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection
Declaration Syntax
C# Visual Basic Visual C++
public class FoundSegmentCollection : Collection<LightWeightSegment>
Public Class FoundSegmentCollection _
    Inherits Collection(Of LightWeightSegment)
public ref class FoundSegmentCollection : public Collection<LightWeightSegment^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FoundSegmentCollection()()()() | Initializes a new instance of the FoundSegmentCollection class
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastDataSegment()()()() |
 | GetLastOccurrence(Int32) |
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | RemoveHLSegment(Int32) |
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | RemoveSegment(Int32) |
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' LightWeightSegment >)>)>
 |  | FoundSegmentCollection

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FoundSegmentCollection Constructor

FoundSegmentCollection Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► FoundSegmentCollection()()()()
Initializes a new instance of the FoundSegmentCollection class
Declaration Syntax
C# Visual Basic Visual C++
public FoundSegmentCollection()
Public Sub New
public:
FoundSegmentCollection()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLastDataSegment Method

GetLastDataSegment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► GetLastDataSegment()()()()
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment GetLastDataSegment()
Public Function GetLastDataSegment As LightWeightSegment
public:
LightWeightSegment^ GetLastDataSegment()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLastOccurrence Method (segmentOrdinalNumber)

GetLastOccurrence Method (segmentOrdinalNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► GetLastOccurrence(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment GetLastOccurrence(
    int segmentOrdinalNumber
)
Public Function GetLastOccurrence ( _
    segmentOrdinalNumber As Integer _
) As LightWeightSegment
public:
LightWeightSegment^ GetLastOccurrence(
    int segmentOrdinalNumber
)
Parameters
segmentOrdinalNumber (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RemoveHLSegment Method (segmentOrdinalNumber)

RemoveHLSegment Method (segmentOrdinalNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► RemoveHLSegment(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveHLSegment(
    int segmentOrdinalNumber
)
Public Sub RemoveHLSegment ( _
    segmentOrdinalNumber As Integer _
)
public:
void RemoveHLSegment(
    int segmentOrdinalNumber
)
Parameters
segmentOrdinalNumber (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RemoveSegment Method (segmentOrdinalNumber)

RemoveSegment Method (segmentOrdinalNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FoundSegmentCollection ► RemoveSegment(Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveSegment(
    int segmentOrdinalNumber
)
Public Sub RemoveSegment ( _
    segmentOrdinalNumber As Integer _
)
public:
void RemoveSegment(
    int segmentOrdinalNumber
)
Parameters
segmentOrdinalNumber (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralEvent Delegate

GeneralEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEvent
General event delegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void GeneralEvent(
    Object sender
)
Public Delegate Sub GeneralEvent ( _
    sender As Object _
)
public delegate void GeneralEvent(
    Object^ sender
)
Parameters
sender (Object)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralEventArgs Class

GeneralEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class GeneralEventArgs : EventArgs
Public Class GeneralEventArgs _
    Inherits EventArgs
public ref class GeneralEventArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeneralEventArgs()()()() | Initializes a new instance of the GeneralEventArgs class.
 | GeneralEventArgs(Exception) | Initializes a new instance of the GeneralEventArgs class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception | Gets the exception.
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | GeneralEventArgs

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralEventArgs Constructor

GeneralEventArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs ► GeneralEventArgs()()()()
Members
Icon | Member | Description
 | GeneralEventArgs()()()() | Initializes a new instance of the GeneralEventArgs class.
 | GeneralEventArgs(Exception) | Initializes a new instance of the GeneralEventArgs class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralEventArgs Constructor

GeneralEventArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs ► GeneralEventArgs()()()()
Initializes a new instance of the GeneralEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public GeneralEventArgs()
Public Sub New
public:
GeneralEventArgs()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralEventArgs Constructor (exception)

GeneralEventArgs Constructor (exception)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs ► GeneralEventArgs(Exception)
Initializes a new instance of the GeneralEventArgs class.
Declaration Syntax
C# Visual Basic Visual C++
public GeneralEventArgs(
    Exception exception
)
Public Sub New ( _
    exception As Exception _
)
public:
GeneralEventArgs(
    Exception^ exception
)
Parameters
exception (Exception)
The exception.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Exception Property

Exception Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralEventArgs ► Exception
Gets the exception.
Declaration Syntax
C# Visual Basic Visual C++
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get
public:
property Exception^ Exception {
    Exception^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralTypeConverter Class

GeneralTypeConverter Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter
Declaration Syntax
C# Visual Basic Visual C++
public class GeneralTypeConverter : TypeConverter
Public Class GeneralTypeConverter _
    Inherits TypeConverter
public ref class GeneralTypeConverter : public TypeConverter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GeneralTypeConverter()()()() | Initializes a new instance of the GeneralTypeConverter class.
 | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
 | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context. (Inherited from TypeConverter.)
 | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
 | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
 | ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information. (Inherited from TypeConverter.)
 | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
 | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)
 | ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
 | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
 | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)
 | ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)
 | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
 | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetConvertFromException(Object) | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
 | GetConvertToException(Object, Type) | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
 | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
 | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)
 | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
 | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
 | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter.GetPropertiesSupported(ITypeDescriptorContext).)
 | GetPropertiesSupported()()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
 | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
 | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)
 | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list. (Inherited from TypeConverter.)
 | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)
 | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
 | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
 | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SortProperties(PropertyDescriptorCollection, array<String>[]()[][]) | Sorts a collection of properties. (Inherited from TypeConverter.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeConverter
 |  | GeneralTypeConverter

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralTypeConverter Constructor

GeneralTypeConverter Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GeneralTypeConverter()()()()
Initializes a new instance of the GeneralTypeConverter class.
Declaration Syntax
C# Visual Basic Visual C++
public GeneralTypeConverter()
Public Sub New
public:
GeneralTypeConverter()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CanConvertTo Method (context, destinationType)

CanConvertTo Method (context, destinationType)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► CanConvertTo(ITypeDescriptorContext, Type)
Returns whether this converter can convert the object to the specified type, using the specified context.
Declaration Syntax
C# Visual Basic Visual C++
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override
Parameters
context (ITypeDescriptorContext)
An ITypeDescriptorContext that provides a format context.
destinationType (Type)
A Type that represents the type you want to convert to.
Return Value
true if this converter can perform the conversion; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ConvertTo Method (context, culture, value, destinationType)

ConvertTo Method (context, culture, value, destinationType)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type)
Converts the given value object to the specified type, using the specified context and culture information.
Declaration Syntax
C# Visual Basic Visual C++
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override
Parameters
context (ITypeDescriptorContext)
An ITypeDescriptorContext that provides a format context.
culture (CultureInfo)
A CultureInfo. If null is passed, the current culture is assumed.
value (Object)
The Object to convert.
destinationType (Type)
The Type to convert the value parameter to.
Return Value
An Object that represents the converted value.
Exceptions
Exception | Condition
ArgumentNullException | The destinationType parameter is null.
NotSupportedException | The conversion cannot be performed.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetProperties Method (context, value, attributes)

GetProperties Method (context, value, attributes)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][])
Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes.
Declaration Syntax
C# Visual Basic Visual C++
public override PropertyDescriptorCollection GetProperties(
    ITypeDescriptorContext context,
    Object value,
    Attribute[] attributes
)
Public Overrides Function GetProperties ( _
    context As ITypeDescriptorContext, _
    value As Object, _
    attributes As Attribute() _
) As PropertyDescriptorCollection
public:
virtual PropertyDescriptorCollection^ GetProperties(
    ITypeDescriptorContext^ context,
    Object^ value,
    array<Attribute^>^ attributes
) override
Parameters
context (ITypeDescriptorContext)
An ITypeDescriptorContext that provides a format context.
value (Object)
An Object that specifies the type of array for which to get properties.
attributes (array< Attribute >[]()[][])
An array of type Attribute that is used as a filter.
Return Value
A PropertyDescriptorCollection with the properties that are exposed for this data type, or null if there are no properties.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetPropertiesSupported Method (context)

GetPropertiesSupported Method (context)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetPropertiesSupported(ITypeDescriptorContext)
Returns whether this object supports properties, using the specified context.
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetPropertiesSupported(
    ITypeDescriptorContext context
)
Public Overrides Function GetPropertiesSupported ( _
    context As ITypeDescriptorContext _
) As Boolean
public:
virtual bool GetPropertiesSupported(
    ITypeDescriptorContext^ context
) override
Parameters
context (ITypeDescriptorContext)
An ITypeDescriptorContext that provides a format context.
Return Value
true if GetProperties(Object) should be called to find the properties of this object; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTP Class

HTTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP
HTTP component
Declaration Syntax
C# Visual Basic Visual C++
public sealed class HTTP : Component
Public NotInheritable Class HTTP _
    Inherits Component
public ref class HTTP sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HTTP()()()() | Initializes a new instance of the HTTP class.
 | HTTP(IContainer) | Initializes a new instance of the HTTP class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | Command | Gets or sets the command.
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | DownloadFile(String) | Download a file from an HTTP Server
 | DownloadFileAsync(String) | Download a file ansynchronously to from an HTTP Server
 | DownloadFileCompleted |
 | DownloadFileProgressChanged |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | FileUploadCompleted |
 | FileUploadProgressChanged |
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hostname | Gets or sets the hostname.
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Password | Gets or sets the password.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | UploadFile(String) | Upload a file to an HTTP Server
 | UploadFileAsync(String) | Asynchronously upload a file to an HTTP Server
 | Username | Gets or sets the username.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | HTTP

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTP Constructor

HTTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP()()()()
Members
Icon | Member | Description
 | HTTP()()()() | Initializes a new instance of the HTTP class.
 | HTTP(IContainer) | Initializes a new instance of the HTTP class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTP Constructor

HTTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP()()()()
Initializes a new instance of the HTTP class.
Declaration Syntax
C# Visual Basic Visual C++
public HTTP()
Public Sub New
public:
HTTP()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTP Constructor (container)

HTTP Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP(IContainer)
Initializes a new instance of the HTTP class.
Declaration Syntax
C# Visual Basic Visual C++
public HTTP(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
HTTP(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Command Property

Command Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Command
Gets or sets the command.
Declaration Syntax
C# Visual Basic Visual C++
public string Command { get; set; }
Public Property Command As String
    Get
    Set
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}
Value
The command.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DownloadFile Method (downloadedFilePath)

DownloadFile Method (downloadedFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► DownloadFile(String)
Download a file from an HTTP Server
Declaration Syntax
C# Visual Basic Visual C++
public void DownloadFile(
    string downloadedFilePath
)
Public Sub DownloadFile ( _
    downloadedFilePath As String _
)
public:
void DownloadFile(
    String^ downloadedFilePath
)
Parameters
downloadedFilePath (String)
Full path and name of file to download

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DownloadFileAsync Method (downloadedFilePath)

DownloadFileAsync Method (downloadedFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► DownloadFileAsync(String)
Download a file ansynchronously to from an HTTP Server
Declaration Syntax
C# Visual Basic Visual C++
public void DownloadFileAsync(
    string downloadedFilePath
)
Public Sub DownloadFileAsync ( _
    downloadedFilePath As String _
)
public:
void DownloadFileAsync(
    String^ downloadedFilePath
)
Parameters
downloadedFilePath (String)
Full path and name of file to download

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DownloadFileCompleted Event

DownloadFileCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► DownloadFileCompleted
Declaration Syntax
C# Visual Basic Visual C++
public event HTTP..::..DownloadFileCompletedDelegate DownloadFileCompleted
Public Event DownloadFileCompleted As HTTP..::..DownloadFileCompletedDelegate
public:
 event HTTP..::..DownloadFileCompletedDelegate^ DownloadFileCompleted {
    void add (HTTP..::..DownloadFileCompletedDelegate^ value);
    void remove (HTTP..::..DownloadFileCompletedDelegate^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DownloadFileProgressChanged Event

DownloadFileProgressChanged Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► DownloadFileProgressChanged
Declaration Syntax
C# Visual Basic Visual C++
public event HTTP..::..DownloadFileProgressChangedDelegate DownloadFileProgressChanged
Public Event DownloadFileProgressChanged As HTTP..::..DownloadFileProgressChangedDelegate
public:
 event HTTP..::..DownloadFileProgressChangedDelegate^ DownloadFileProgressChanged {
    void add (HTTP..::..DownloadFileProgressChangedDelegate^ value);
    void remove (HTTP..::..DownloadFileProgressChangedDelegate^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileUploadCompleted Event

FileUploadCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► FileUploadCompleted
Declaration Syntax
C# Visual Basic Visual C++
public event HTTP..::..UploadFileCompletedDelegate FileUploadCompleted
Public Event FileUploadCompleted As HTTP..::..UploadFileCompletedDelegate
public:
 event HTTP..::..UploadFileCompletedDelegate^ FileUploadCompleted {
    void add (HTTP..::..UploadFileCompletedDelegate^ value);
    void remove (HTTP..::..UploadFileCompletedDelegate^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FileUploadProgressChanged Event

FileUploadProgressChanged Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► FileUploadProgressChanged
Declaration Syntax
C# Visual Basic Visual C++
public event HTTP..::..UploadFileProgressChangedDelegate FileUploadProgressChanged
Public Event FileUploadProgressChanged As HTTP..::..UploadFileProgressChangedDelegate
public:
 event HTTP..::..UploadFileProgressChangedDelegate^ FileUploadProgressChanged {
    void add (HTTP..::..UploadFileProgressChangedDelegate^ value);
    void remove (HTTP..::..UploadFileProgressChangedDelegate^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Hostname Property

Hostname Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Hostname
Gets or sets the hostname.
Declaration Syntax
C# Visual Basic Visual C++
public string Hostname { get; set; }
Public Property Hostname As String
    Get
    Set
public:
property String^ Hostname {
    String^ get ();
    void set (String^ value);
}
Value
The hostname.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Password Property

Password Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Password
Gets or sets the password.
Declaration Syntax
C# Visual Basic Visual C++
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
Value
The password.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UploadFile Method (path)

UploadFile Method (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► UploadFile(String)
Upload a file to an HTTP Server
Declaration Syntax
C# Visual Basic Visual C++
public void UploadFile(
    string path
)
Public Sub UploadFile ( _
    path As String _
)
public:
void UploadFile(
    String^ path
)
Parameters
path (String)
Full path and name of file to upload

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UploadFileAsync Method (path)

UploadFileAsync Method (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► UploadFileAsync(String)
Asynchronously upload a file to an HTTP Server
Declaration Syntax
C# Visual Basic Visual C++
public void UploadFileAsync(
    string path
)
Public Sub UploadFileAsync ( _
    path As String _
)
public:
void UploadFileAsync(
    String^ path
)
Parameters
path (String)
Full path and name of file to upload

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Username Property

Username Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Username
Gets or sets the username.
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; set; }
Public Property Username As String
    Get
    Set
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}
Value
The username.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTP.DownloadFileCompletedDelegate Delegate

HTTP..::..DownloadFileCompletedDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP..::..DownloadFileCompletedDelegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DownloadFileCompletedDelegate(
    Object sender,
    AsyncCompletedEventArgs e
)
Public Delegate Sub DownloadFileCompletedDelegate ( _
    sender As Object, _
    e As AsyncCompletedEventArgs _
)
public delegate void DownloadFileCompletedDelegate(
    Object^ sender,
    AsyncCompletedEventArgs^ e
)
Parameters
sender (Object)
e (AsyncCompletedEventArgs)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTP.DownloadFileProgressChangedDelegate Delegate

HTTP..::..DownloadFileProgressChangedDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP..::..DownloadFileProgressChangedDelegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void DownloadFileProgressChangedDelegate(
    Object sender,
    DownloadProgressChangedEventArgs e
)
Public Delegate Sub DownloadFileProgressChangedDelegate ( _
    sender As Object, _
    e As DownloadProgressChangedEventArgs _
)
public delegate void DownloadFileProgressChangedDelegate(
    Object^ sender,
    DownloadProgressChangedEventArgs^ e
)
Parameters
sender (Object)
e (DownloadProgressChangedEventArgs)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTP.UploadFileCompletedDelegate Delegate

HTTP..::..UploadFileCompletedDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP..::..UploadFileCompletedDelegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void UploadFileCompletedDelegate(
    Object sender,
    UploadFileCompletedEventArgs e
)
Public Delegate Sub UploadFileCompletedDelegate ( _
    sender As Object, _
    e As UploadFileCompletedEventArgs _
)
public delegate void UploadFileCompletedDelegate(
    Object^ sender,
    UploadFileCompletedEventArgs^ e
)
Parameters
sender (Object)
e (UploadFileCompletedEventArgs)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTP.UploadFileProgressChangedDelegate Delegate

HTTP..::..UploadFileProgressChangedDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► HTTP..::..UploadFileProgressChangedDelegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void UploadFileProgressChangedDelegate(
    Object sender,
    UploadProgressChangedEventArgs e
)
Public Delegate Sub UploadFileProgressChangedDelegate ( _
    sender As Object, _
    e As UploadProgressChangedEventArgs _
)
public delegate void UploadFileProgressChangedDelegate(
    Object^ sender,
    UploadProgressChangedEventArgs^ e
)
Parameters
sender (Object)
e (UploadProgressChangedEventArgs)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTPS Class

HTTPS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS
HTTPS Component
Declaration Syntax
C# Visual Basic Visual C++
public sealed class HTTPS : Component
Public NotInheritable Class HTTPS _
    Inherits Component
public ref class HTTPS sealed : public Component
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HTTPS()()()() | Initializes a new instance of the HTTPS class.
 | HTTPS(IContainer) | Initializes a new instance of the HTTPS class.
 | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
 | CertificateValidation |
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | ContentType | Gets or sets the type of the content.
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | DownloadFile(String) | Downloads the file.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Headers | Gets or sets the headers.
 | Hostname | Gets or sets the hostname.
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Password | Gets or sets the password.
 | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | UploadFile(String) | Uploads the file.
 | Username | Gets or sets the username.
 | X509CertificateFile | Gets or sets the X509 certificate file.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | HTTPS

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTPS Constructor

HTTPS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► HTTPS()()()()
Members
Icon | Member | Description
 | HTTPS()()()() | Initializes a new instance of the HTTPS class.
 | HTTPS(IContainer) | Initializes a new instance of the HTTPS class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTPS Constructor

HTTPS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► HTTPS()()()()
Initializes a new instance of the HTTPS class.
Declaration Syntax
C# Visual Basic Visual C++
public HTTPS()
Public Sub New
public:
HTTPS()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTPS Constructor (container)

HTTPS Constructor (container)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► HTTPS(IContainer)
Initializes a new instance of the HTTPS class.
Declaration Syntax
C# Visual Basic Visual C++
public HTTPS(
    IContainer container
)
Public Sub New ( _
    container As IContainer _
)
public:
HTTPS(
    IContainer^ container
)
Parameters
container (IContainer)
The container.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CertificateValidation Event

CertificateValidation Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► CertificateValidation
Declaration Syntax
C# Visual Basic Visual C++
public event HTTPS..::..CertificateValidationDelegate CertificateValidation
Public Event CertificateValidation As HTTPS..::..CertificateValidationDelegate
public:
 event HTTPS..::..CertificateValidationDelegate^ CertificateValidation {
    void add (HTTPS..::..CertificateValidationDelegate^ value);
    void remove (HTTPS..::..CertificateValidationDelegate^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ContentType Property

ContentType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► ContentType
Gets or sets the type of the content.
Declaration Syntax
C# Visual Basic Visual C++
public string ContentType { get; set; }
Public Property ContentType As String
    Get
    Set
public:
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}
Value
The type of the content.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DownloadFile Method (downloadedFilePath)

DownloadFile Method (downloadedFilePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► DownloadFile(String)
Downloads the file.
Declaration Syntax
C# Visual Basic Visual C++
public void DownloadFile(
    string downloadedFilePath
)
Public Sub DownloadFile ( _
    downloadedFilePath As String _
)
public:
void DownloadFile(
    String^ downloadedFilePath
)
Parameters
downloadedFilePath (String)
The downloaded file path.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Headers Property

Headers Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Headers
Gets or sets the headers.
Declaration Syntax
C# Visual Basic Visual C++
public WebHeaderCollection Headers { get; set; }
Public Property Headers As WebHeaderCollection
    Get
    Set
public:
property WebHeaderCollection^ Headers {
    WebHeaderCollection^ get ();
    void set (WebHeaderCollection^ value);
}
Value
The headers.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Hostname Property

Hostname Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Hostname
Gets or sets the hostname.
Declaration Syntax
C# Visual Basic Visual C++
public string Hostname { get; set; }
Public Property Hostname As String
    Get
    Set
public:
property String^ Hostname {
    String^ get ();
    void set (String^ value);
}
Value
The hostname.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Password Property

Password Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Password
Gets or sets the password.
Declaration Syntax
C# Visual Basic Visual C++
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
Value
The password.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UploadFile Method (path)

UploadFile Method (path)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► UploadFile(String)
Uploads the file.
Declaration Syntax
C# Visual Basic Visual C++
public void UploadFile(
    string path
)
Public Sub UploadFile ( _
    path As String _
)
public:
void UploadFile(
    String^ path
)
Parameters
path (String)
The path.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Username Property

Username Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Username
Gets or sets the username.
Declaration Syntax
C# Visual Basic Visual C++
public string Username { get; set; }
Public Property Username As String
    Get
    Set
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}
Value
The username.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


X509CertificateFile Property

X509CertificateFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► X509CertificateFile
Gets or sets the X509 certificate file.
Declaration Syntax
C# Visual Basic Visual C++
public string X509CertificateFile { get; set; }
Public Property X509CertificateFile As String
    Get
    Set
public:
property String^ X509CertificateFile {
    String^ get ();
    void set (String^ value);
}
Value
The X509 certificate file.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HTTPS.CertificateValidationDelegate Delegate

HTTPS..::..CertificateValidationDelegate Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► HTTPS..::..CertificateValidationDelegate
Declaration Syntax
C# Visual Basic Visual C++
public delegate void CertificateValidationDelegate(
    Object sender,
    CertificationEventArgs e
)
Public Delegate Sub CertificateValidationDelegate ( _
    sender As Object, _
    e As CertificationEventArgs _
)
public delegate void CertificateValidationDelegate(
    Object^ sender,
    CertificationEventArgs^ e
)
Parameters
sender (Object)
e (CertificationEventArgs)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LicenseException Class

LicenseException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LicenseException
Exception thrown when a license is invalid
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LicenseException : Exception
<SerializableAttribute> _
Public Class LicenseException _
    Inherits Exception
[SerializableAttribute]
public ref class LicenseException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | LicenseException

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightElement Class

LightWeightElement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement
Represents a lightweight data element
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightElement
<SerializableAttribute> _
Public Class LightWeightElement
[SerializableAttribute]
public ref class LightWeightElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightElement()()()() | Initializes a new instance of the LightWeightElement class.
 | LightWeightElement(String) | Initializes a new instance of the LightWeightElement class.
 | LightWeightElement(Boolean) | Creates a new LightWeigthElement object
 | Composite | Returns whether this is a composite data element
 | ContainsData()()()() | Checks whether there is data in DataElement
 | ContainsNoData()()()() | Checks whether there is data in DataElement
 | DataValue | Get/Set the actual data in DataElement
 | ElementNumber | Get/Set the position of this DataElement in the containing DataSegment
 | Elements | Get/Set the child elements if this is a composite data element
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasRepeatingCompositeElements |
 | HasRepeatingElements |
 | ImplicitWideningImplicitImplicitImplicit(String to LightWeightElement) | Overides the asignment operator to directly convert a string to a LiteDataElement
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RepeatingCompositeElements | Gets or sets the repeating composite elements.
 | RepeatingElementsValues | Gets or sets the repeating elements values. This is only set when this element does not represent a composite element
 | ToString()()()() | Returns a String that represents this instance. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | LightWeightElement
 |  | DataElement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightElement Constructor

LightWeightElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► LightWeightElement()()()()
Members
Icon | Member | Description
 | LightWeightElement()()()() | Initializes a new instance of the LightWeightElement class.
 | LightWeightElement(String) | Initializes a new instance of the LightWeightElement class.
 | LightWeightElement(Boolean) | Creates a new LightWeigthElement object

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightElement Constructor

LightWeightElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► LightWeightElement()()()()
Initializes a new instance of the LightWeightElement class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement()
Public Sub New
public:
LightWeightElement()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightElement Constructor (composite)

LightWeightElement Constructor (composite)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► LightWeightElement(Boolean)
Creates a new LightWeigthElement object
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement(
    bool composite
)
Public Sub New ( _
    composite As Boolean _
)
public:
LightWeightElement(
    bool composite
)
Parameters
composite (Boolean)
true if this is a composite dataelement, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightElement Constructor (elementValue)

LightWeightElement Constructor (elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► LightWeightElement(String)
Initializes a new instance of the LightWeightElement class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement(
    string elementValue
)
Public Sub New ( _
    elementValue As String _
)
public:
LightWeightElement(
    String^ elementValue
)
Parameters
elementValue (String)
The element value.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Composite Property

Composite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► Composite
Returns whether this is a composite data element
Declaration Syntax
C# Visual Basic Visual C++
public bool Composite { get; set; }
Public Property Composite As Boolean
    Get
    Set
public:
property bool Composite {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ContainsData Method

ContainsData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ContainsData()()()()
Checks whether there is data in DataElement
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsData()
Public Function ContainsData As Boolean
public:
bool ContainsData()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ContainsNoData Method

ContainsNoData Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ContainsNoData()()()()
Checks whether there is data in DataElement
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsNoData()
Public Function ContainsNoData As Boolean
public:
bool ContainsNoData()
Return Value
true is there is no data, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DataValue Property

DataValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► DataValue
Get/Set the actual data in DataElement
Declaration Syntax
C# Visual Basic Visual C++
public string DataValue { get; set; }
Public Property DataValue As String
    Get
    Set
public:
property String^ DataValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ElementNumber
Get/Set the position of this DataElement in the containing DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► Elements
Get/Set the child elements if this is a composite data element
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElements Elements { get; set; }
Public Property Elements As LightWeightElements
    Get
    Set
public:
property LightWeightElements^ Elements {
    LightWeightElements^ get ();
    void set (LightWeightElements^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HasRepeatingCompositeElements Property

HasRepeatingCompositeElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► HasRepeatingCompositeElements
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool HasRepeatingCompositeElements { get; }
Public Overridable ReadOnly Property HasRepeatingCompositeElements As Boolean
    Get
public:
virtual property bool HasRepeatingCompositeElements {
    bool get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HasRepeatingElements Property

HasRepeatingElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► HasRepeatingElements
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool HasRepeatingElements { get; }
Public Overridable ReadOnly Property HasRepeatingElements As Boolean
    Get
public:
virtual property bool HasRepeatingElements {
    bool get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ImplicitWideningImplicitImplicitImplicit(String to LightWeightElement)
Overides the asignment operator to directly convert a string to a LiteDataElement
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator LightWeightElement (
    string elementValue
)
Public Shared Widening Operator CType ( _
    elementValue As String _
) As LightWeightElement
static implicit operator LightWeightElement^ (
    String^ elementValue
)
Parameters
elementValue (String)
string to convert to a DataElement
Return Value
a new DataElement with the supplied value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RepeatingCompositeElements Property

RepeatingCompositeElements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► RepeatingCompositeElements
Gets or sets the repeating composite elements.
Declaration Syntax
C# Visual Basic Visual C++
public List<LightWeightElements> RepeatingCompositeElements { get; set; }
Public Property RepeatingCompositeElements As List(Of LightWeightElements)
    Get
    Set
public:
property List<LightWeightElements^>^ RepeatingCompositeElements {
    List<LightWeightElements^>^ get ();
    void set (List<LightWeightElements^>^ value);
}
Value
The repeating composite elements.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RepeatingElementsValues Property

RepeatingElementsValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► RepeatingElementsValues
Gets or sets the repeating elements values. This is only set when this element does not represent a composite element
Declaration Syntax
C# Visual Basic Visual C++
public List<string> RepeatingElementsValues { get; set; }
Public Property RepeatingElementsValues As List(Of String)
    Get
    Set
public:
property List<String^>^ RepeatingElementsValues {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
The repeating elements values.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElement ► ToString()()()()
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightElements Class

LightWeightElements Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElements
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightElements : Collection<LightWeightElement>
<SerializableAttribute> _
Public Class LightWeightElements _
    Inherits Collection(Of LightWeightElement)
[SerializableAttribute]
public ref class LightWeightElements : public Collection<LightWeightElement^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightElements()()()() | Initializes a new instance of the LightWeightElements class.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(Int32) | Returns the element value or an empty string if index is greater than Count
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' LightWeightElement >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' LightWeightElement >)>)>
 |  | LightWeightElements

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightElements Constructor

LightWeightElements Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElements ► LightWeightElements()()()()
Initializes a new instance of the LightWeightElements class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElements()
Public Sub New
public:
LightWeightElements()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetValue Method (index)

GetValue Method (index)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightElements ► GetValue(Int32)
Returns the element value or an empty string if index is greater than Count
Declaration Syntax
C# Visual Basic Visual C++
public string GetValue(
    int index
)
Public Function GetValue ( _
    index As Integer _
) As String
public:
String^ GetValue(
    int index
)
Parameters
index (Int32)
The index.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightLoop Class

LightWeightLoop Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop
A light weight version of the Loop class
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightLoop
<SerializableAttribute> _
Public Class LightWeightLoop
[SerializableAttribute]
public ref class LightWeightLoop
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightLoop()()()() | Initializes a new instance of the Loop class.
 | LightWeightLoop(String) | Initializes a new instance of the Loop class.
 | ContainsSegment(String) | Determines whether this loop contains a segment.
 | CreateLoop(String) | Creates the loop.
 | CreateLoop()()()() | Creates the loop.
 | CreateSegment(String) | Creates the segment.
 | CreateSegmentLoop(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstSegment | Get the first segment in this loop
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastLoop()()()() | Gets the last loop.
 | GetLoop(String) | Gets the loop.
 | GetLoopCollection(String) | Gets the loop collection.
 | GetSegment(String) | Gets the segment.
 | GetSegmentCollection(String) | Gets the segment collection.
 | GetSegments(String, Int32, String) | Gets a segment collection given an element position and value
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImplicitWideningImplicitImplicitImplicit(String to LightWeightLoop) | Performs an implicit conversion from String to Loop.
 | IsSegmentLoop |
 | LastSegment | Get the last segment in this loop
 | Loops | Get/Set the loops contained within this loop
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/Set the name of this loop
 | Parent | Get/Set the parent of this loop:Rules Reader
 | Segments | Get/Set a list of segments in this loop
 | ToEDIString(Delimiters) | Returns all segments in this loop and its sub loops as a string
 | ToString()()()() | Returns a String that represents this instance. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | LightWeightLoop
 |  | Loop

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightLoop Constructor

LightWeightLoop Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► LightWeightLoop()()()()
Members
Icon | Member | Description
 | LightWeightLoop()()()() | Initializes a new instance of the Loop class.
 | LightWeightLoop(String) | Initializes a new instance of the Loop class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightLoop Constructor

LightWeightLoop Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► LightWeightLoop()()()()
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop()
Public Sub New
public:
LightWeightLoop()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightLoop Constructor (name)

LightWeightLoop Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► LightWeightLoop(String)
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop(
    string name
)
Public Sub New ( _
    name As String _
)
public:
LightWeightLoop(
    String^ name
)
Parameters
name (String)
The name of the new loop

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ContainsSegment Method (segmentName)

ContainsSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► ContainsSegment(String)
Determines whether this loop contains a segment.
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsSegment(
    string segmentName
)
Public Function ContainsSegment ( _
    segmentName As String _
) As Boolean
public:
bool ContainsSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value
true if the specified loop contains segment; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateLoop Method

CreateLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateLoop()()()()
Members
Icon | Member | Description
 | CreateLoop(String) | Creates the loop.
 | CreateLoop()()()() | Creates the loop.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateLoop Method

CreateLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateLoop()()()()
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop CreateLoop()
Public Function CreateLoop As LightWeightLoop
public:
LightWeightLoop^ CreateLoop()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateLoop Method (loopName)

CreateLoop Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateLoop(String)
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop CreateLoop(
    string loopName
)
Public Function CreateLoop ( _
    loopName As String _
) As LightWeightLoop
public:
LightWeightLoop^ CreateLoop(
    String^ loopName
)
Parameters
loopName (String)
The name.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateSegment Method (segmentName)

CreateSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateSegment(String)
Creates the segment.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment CreateSegment(
    string segmentName
)
Public Function CreateSegment ( _
    segmentName As String _
) As LightWeightSegment
public:
LightWeightSegment^ CreateSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateSegmentLoop Method (segmentName)

CreateSegmentLoop Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► CreateSegmentLoop(String)
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment CreateSegmentLoop(
    string segmentName
)
Public Function CreateSegmentLoop ( _
    segmentName As String _
) As LightWeightSegment
public:
LightWeightSegment^ CreateSegmentLoop(
    String^ segmentName
)
Parameters
segmentName (String)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FirstSegment Property

FirstSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► FirstSegment
Get the first segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment FirstSegment { get; }
Public ReadOnly Property FirstSegment As LightWeightSegment
    Get
public:
property LightWeightSegment^ FirstSegment {
    LightWeightSegment^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLastLoop Method

GetLastLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetLastLoop()()()()
Gets the last loop.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop GetLastLoop()
Public Function GetLastLoop As LightWeightLoop
public:
LightWeightLoop^ GetLastLoop()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLoop Method (loopName)

GetLoop Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetLoop(String)
Gets the loop.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop GetLoop(
    string loopName
)
Public Function GetLoop ( _
    loopName As String _
) As LightWeightLoop
public:
LightWeightLoop^ GetLoop(
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLoopCollection Method (loopName)

GetLoopCollection Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetLoopCollection(String)
Gets the loop collection.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoops GetLoopCollection(
    string loopName
)
Public Function GetLoopCollection ( _
    loopName As String _
) As LightWeightLoops
public:
LightWeightLoops^ GetLoopCollection(
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegment Method (segmentName)

GetSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetSegment(String)
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment GetSegment(
    string segmentName
)
Public Function GetSegment ( _
    segmentName As String _
) As LightWeightSegment
public:
LightWeightSegment^ GetSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegmentCollection Method (segmentName)

GetSegmentCollection Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetSegmentCollection(String)
Gets the segment collection.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegments GetSegmentCollection(
    string segmentName
)
Public Function GetSegmentCollection ( _
    segmentName As String _
) As LightWeightSegments
public:
LightWeightSegments^ GetSegmentCollection(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegments Method (segmentName, elementPosition, elementValue)

GetSegments Method (segmentName, elementPosition, elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► GetSegments(String, Int32, String)
Gets a segment collection given an element position and value
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegments GetSegments(
    string segmentName,
    int elementPosition,
    string elementValue
)
Public Function GetSegments ( _
    segmentName As String, _
    elementPosition As Integer, _
    elementValue As String _
) As LightWeightSegments
public:
LightWeightSegments^ GetSegments(
    String^ segmentName,
    int elementPosition,
    String^ elementValue
)
Parameters
segmentName (String)
Name of the segment
elementPosition (Int32)
Position of the element in the segment
elementValue (String)
Value of the element to compare against
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► ImplicitWideningImplicitImplicitImplicit(String to LightWeightLoop)
Performs an implicit conversion from String to Loop.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator LightWeightLoop (
    string loopName
)
Public Shared Widening Operator CType ( _
    loopName As String _
) As LightWeightLoop
static implicit operator LightWeightLoop^ (
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value
The result of the conversion.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsSegmentLoop Property

IsSegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► IsSegmentLoop
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSegmentLoop { get; set; }
Public Property IsSegmentLoop As Boolean
    Get
    Set
public:
property bool IsSegmentLoop {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LastSegment Property

LastSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► LastSegment
Get the last segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment LastSegment { get; }
Public ReadOnly Property LastSegment As LightWeightSegment
    Get
public:
property LightWeightSegment^ LastSegment {
    LightWeightSegment^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► Loops
Get/Set the loops contained within this loop
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoops Loops { get; set; }
Public Property Loops As LightWeightLoops
    Get
    Set
public:
property LightWeightLoops^ Loops {
    LightWeightLoops^ get ();
    void set (LightWeightLoops^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► Name
Get/Set the name of this loop
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Parent Property

Parent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► Parent
Get/Set the parent of this loop:Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop Parent { get; set; }
Public Property Parent As LightWeightLoop
    Get
    Set
public:
property LightWeightLoop^ Parent {
    LightWeightLoop^ get ();
    void set (LightWeightLoop^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► Segments
Get/Set a list of segments in this loop
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegments Segments { get; set; }
Public Property Segments As LightWeightSegments
    Get
    Set
public:
property LightWeightSegments^ Segments {
    LightWeightSegments^ get ();
    void set (LightWeightSegments^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToEDIString Method (delimiters)

ToEDIString Method (delimiters)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► ToEDIString(Delimiters)
Returns all segments in this loop and its sub loops as a string
Declaration Syntax
C# Visual Basic Visual C++
public string ToEDIString(
    Delimiters delimiters
)
Public Function ToEDIString ( _
    delimiters As Delimiters _
) As String
public:
String^ ToEDIString(
    Delimiters^ delimiters
)
Parameters
delimiters (Delimiters)
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoop ► ToString()()()()
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightLoops Class

LightWeightLoops Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoops
A collection of LightWeightLoops objects
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightLoops : Collection<LightWeightLoop>
<SerializableAttribute> _
Public Class LightWeightLoops _
    Inherits Collection(Of LightWeightLoop)
[SerializableAttribute]
public ref class LightWeightLoops : public Collection<LightWeightLoop^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightLoops()()()() | Initializes a new instance of the LightWeightLoops class.
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' LightWeightLoop >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' LightWeightLoop >)>)>
 |  | LightWeightLoops

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightLoops Constructor

LightWeightLoops Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightLoops ► LightWeightLoops()()()()
Initializes a new instance of the LightWeightLoops class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoops()
Public Sub New
public:
LightWeightLoops()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightSegment Class

LightWeightSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment
A DataSegment Object
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightSegment
<SerializableAttribute> _
Public Class LightWeightSegment
[SerializableAttribute]
public ref class LightWeightSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightSegment()()()() | Initializes a new instance of the LightWeightSegment class.
 | LightWeightSegment(String) | Initializes a new instance of the LightWeightSegment class.
 | ContainsElement(Int32) | Checks whether an element exist in the segment
 | Elements | Get/Set a list of DataElements
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstElement | Returns the first data element in this segment
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImplicitWideningImplicitImplicitImplicit(String to LightWeightSegment) | Performs an implicit conversion from String to LightWeightSegment.
 | LastElement | Returns the last data element in this segment
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Get/Set the name of this segment
 | OrdinalNumber | Get/Set the actual position of this segment in an EDIDocument
 | SegmentLoop |
 | ToEDIString(Delimiters) |
 | ToString()()()() | Returns a string representation of this DataSegment (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | LightWeightSegment
 |  | DataSegment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightSegment Constructor

LightWeightSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► LightWeightSegment()()()()
Members
Icon | Member | Description
 | LightWeightSegment()()()() | Initializes a new instance of the LightWeightSegment class.
 | LightWeightSegment(String) | Initializes a new instance of the LightWeightSegment class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightSegment Constructor

LightWeightSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► LightWeightSegment()()()()
Initializes a new instance of the LightWeightSegment class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment()
Public Sub New
public:
LightWeightSegment()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightSegment Constructor (segmentName)

LightWeightSegment Constructor (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► LightWeightSegment(String)
Initializes a new instance of the LightWeightSegment class.
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegment(
    string segmentName
)
Public Sub New ( _
    segmentName As String _
)
public:
LightWeightSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ContainsElement Method (elementIndex)

ContainsElement Method (elementIndex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► ContainsElement(Int32)
Checks whether an element exist in the segment
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool ContainsElement(
    int elementIndex
)
Public Overridable Function ContainsElement ( _
    elementIndex As Integer _
) As Boolean
public:
virtual bool ContainsElement(
    int elementIndex
)
Parameters
elementIndex (Int32)
index of the element
Return Value
true if element exists, false otherwise

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Elements Property

Elements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► Elements
Get/Set a list of DataElements
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElements Elements { get; set; }
Public Property Elements As LightWeightElements
    Get
    Set
public:
property LightWeightElements^ Elements {
    LightWeightElements^ get ();
    void set (LightWeightElements^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FirstElement Property

FirstElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► FirstElement
Returns the first data element in this segment
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement FirstElement { get; }
Public ReadOnly Property FirstElement As LightWeightElement
    Get
public:
property LightWeightElement^ FirstElement {
    LightWeightElement^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► ImplicitWideningImplicitImplicitImplicit(String to LightWeightSegment)
Performs an implicit conversion from String to LightWeightSegment.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator LightWeightSegment (
    string segmentName
)
Public Shared Widening Operator CType ( _
    segmentName As String _
) As LightWeightSegment
static implicit operator LightWeightSegment^ (
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value
The result of the conversion.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LastElement Property

LastElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► LastElement
Returns the last data element in this segment
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightElement LastElement { get; }
Public ReadOnly Property LastElement As LightWeightElement
    Get
public:
property LightWeightElement^ LastElement {
    LightWeightElement^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► Name
Get/Set the name of this segment
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OrdinalNumber Property

OrdinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► OrdinalNumber
Get/Set the actual position of this segment in an EDIDocument
Declaration Syntax
C# Visual Basic Visual C++
public int OrdinalNumber { get; set; }
Public Property OrdinalNumber As Integer
    Get
    Set
public:
property int OrdinalNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentLoop Property

SegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► SegmentLoop
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightLoop SegmentLoop { get; set; }
Public Property SegmentLoop As LightWeightLoop
    Get
    Set
public:
property LightWeightLoop^ SegmentLoop {
    LightWeightLoop^ get ();
    void set (LightWeightLoop^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToEDIString Method (delimiters)

ToEDIString Method (delimiters)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► ToEDIString(Delimiters)
Declaration Syntax
C# Visual Basic Visual C++
public string ToEDIString(
    Delimiters delimiters
)
Public Function ToEDIString ( _
    delimiters As Delimiters _
) As String
public:
String^ ToEDIString(
    Delimiters^ delimiters
)
Parameters
delimiters (Delimiters)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegment ► ToString()()()()
Returns a string representation of this DataSegment
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
string representation of this DataSegment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightSegments Class

LightWeightSegments Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegments
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LightWeightSegments : Collection<LightWeightSegment>
<SerializableAttribute> _
Public Class LightWeightSegments _
    Inherits Collection(Of LightWeightSegment)
[SerializableAttribute]
public ref class LightWeightSegments : public Collection<LightWeightSegment^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LightWeightSegments()()()() | Create a new LightWeightSegments collection
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' LightWeightSegment >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' LightWeightSegment >)>)>
 |  | LightWeightSegments

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LightWeightSegments Constructor

LightWeightSegments Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LightWeightSegments ► LightWeightSegments()()()()
Create a new LightWeightSegments collection
Declaration Syntax
C# Visual Basic Visual C++
public LightWeightSegments()
Public Sub New
public:
LightWeightSegments()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Log Class

Log Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Log
Contains library specific error messages
Declaration Syntax
C# Visual Basic Visual C++
public static class Log
Public NotInheritable Class Log
public ref class Log abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear()()()() | Clears log entries
 | Entries | Gets the log entries.
Inheritance Hierarchy
Object
Log

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Clear Method

Clear Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Log ► Clear()()()()
Clears log entries
Declaration Syntax
C# Visual Basic Visual C++
public static void Clear()
Public Shared Sub Clear
public:
static void Clear()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Entries Property

Entries Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Log ► Entries
Gets the log entries.
Declaration Syntax
C# Visual Basic Visual C++
public static ReadOnlyCollection<string> Entries { get; }
Public Shared ReadOnly Property Entries As ReadOnlyCollection(Of String)
    Get
public:
static property ReadOnlyCollection<String^>^ Entries {
    ReadOnlyCollection<String^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loop Class

Loop Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop
Summary description for Loop.
Declaration Syntax
C# Visual Basic Visual C++
public class Loop : LightWeightLoop
Public Class Loop _
    Inherits LightWeightLoop
public ref class Loop : public LightWeightLoop
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Loop()()()() | Initializes a new instance of the Loop class.
 | Loop(String) | Initializes a new instance of the Loop class.
 | Loop(String, String) | Initializes a new instance of the Loop class.
 | ContainsSegment(String) | Determines whether this loop contains a segment.
 | CreateLoop(String) | Creates the loop.
 | CreateLoop()()()() | Creates the loop.
 | CreateLoop(String, String) | Creates the loop.
 | CreateSegment(String) | Creates the segment.
 | CreateSegment(String, Int32, Int32, Usage, String) | Creates the segment.
 | CreateSegmentLoop(String, Int32, Int32, Usage, String) |
 | CreateSegmentLoop(String) | (Inherited from LightWeightLoop.)
 | Description | Get/Set the description of this loop
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstSegment | Get the first segment in this loop
 | GetChildPosition(Loop) | Gets the child position.
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLastLoop()()()() | Gets the last loop.
 | GetLoop(String) | Gets the loop.
 | GetLoopCollection(String) | Gets the loop collection.
 | GetNextSegment(Int32) | Gets the next segment.
 | GetSegment(String) | Gets the segment.
 | GetSegment(Int32) | Gets the segment.
 | GetSegmentCollection(String) | Gets the segment collection.
 | GetSegmentPosition(DataSegment) | Gets the segment position.
 | GetSegments(String, Int32, String) | Gets a segment collection given an element position and value
 | GetSiblingAbove()()()() | Gets the sibling above.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImplicitWideningImplicitImplicitImplicit(String to Loop) | Performs an implicit conversion from String to Loop.
 | IsSegmentLoop | (Inherited from LightWeightLoop.)
 | LastSegment | Get the last segment in this loop
 | Loops | Get/Set the loops contained within this loop
 | MaximumOccurrences | Get/Set the maximum amount of times this loop can repeat
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumOccurrences | Get/Set the minimum amount of times this loop can repeat
 | Name | Get/Set the name of this loop (Inherited from LightWeightLoop.)
 | Occurred | Get/Set if this loop occurred in an EDI File:Rules Reader
 | Parent | Get/Set the parent of this loop:Rules Reader
 | RepetitionIndefinite | Gets or sets a value indicating whether [repetition indefinite].
 | Segments | Get/Set a list of segments in this loop
 | Tag | Gets or sets the tag.
 | ToEDIString(Delimiters) | Returns all segments in this loop and its sub loops as a string (Inherited from LightWeightLoop.)
 | ToString()()()() | Returns a String that represents this instance. (Overrides LightWeightLoop.ToString()()()().)
 | Usage | Obsolete. Get/Set the usage requirements of this loop
Inheritance Hierarchy
Object
 | LightWeightLoop
 |  | Loop

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loop Constructor

Loop Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loop()()()()
Members
Icon | Member | Description
 | Loop()()()() | Initializes a new instance of the Loop class.
 | Loop(String) | Initializes a new instance of the Loop class.
 | Loop(String, String) | Initializes a new instance of the Loop class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loop Constructor

Loop Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loop()()()()
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public Loop()
Public Sub New
public:
Loop()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loop Constructor (name)

Loop Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loop(String)
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public Loop(
    string name
)
Public Sub New ( _
    name As String _
)
public:
Loop(
    String^ name
)
Parameters
name (String)
The name of the new loop

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loop Constructor (name, description)

Loop Constructor (name, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loop(String, String)
Initializes a new instance of the Loop class.
Declaration Syntax
C# Visual Basic Visual C++
public Loop(
    string name,
    string description
)
Public Sub New ( _
    name As String, _
    description As String _
)
public:
Loop(
    String^ name,
    String^ description
)
Parameters
name (String)
The name.
description (String)
The description.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ContainsSegment Method (segmentName)

ContainsSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► ContainsSegment(String)
Determines whether this loop contains a segment.
Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsSegment(
    string segmentName
)
Public Function ContainsSegment ( _
    segmentName As String _
) As Boolean
public:
bool ContainsSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value
true if the specified loop contains segment; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateLoop Method

CreateLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateLoop()()()()
Members
Icon | Member | Description
 | CreateLoop(String) | Creates the loop.
 | CreateLoop()()()() | Creates the loop.
 | CreateLoop(String, String) | Creates the loop.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateLoop Method

CreateLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateLoop()()()()
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop CreateLoop()
Public Function CreateLoop As Loop
public:
Loop^ CreateLoop()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateLoop Method (name)

CreateLoop Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateLoop(String)
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop CreateLoop(
    string name
)
Public Function CreateLoop ( _
    name As String _
) As Loop
public:
Loop^ CreateLoop(
    String^ name
)
Parameters
name (String)
The name.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateLoop Method (name, description)

CreateLoop Method (name, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateLoop(String, String)
Creates the loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop CreateLoop(
    string name,
    string description
)
Public Function CreateLoop ( _
    name As String, _
    description As String _
) As Loop
public:
Loop^ CreateLoop(
    String^ name,
    String^ description
)
Parameters
name (String)
The name.
description (String)
The description.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateSegment Method

CreateSegment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegment()()()()
Members
Icon | Member | Description
 | CreateSegment(String) | Creates the segment.
 | CreateSegment(String, Int32, Int32, Usage, String) | Creates the segment.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateSegment Method (segmentName)

CreateSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegment(String)
Creates the segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment CreateSegment(
    string segmentName
)
Public Function CreateSegment ( _
    segmentName As String _
) As DataSegment
public:
DataSegment^ CreateSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateSegment Method (segmentName, min, max, usage, description)

CreateSegment Method (segmentName, min, max, usage, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegment(String, Int32, Int32, Usage, String)
Creates the segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment CreateSegment(
    string segmentName,
    int min,
    int max,
    Usage usage,
    string description
)
Public Function CreateSegment ( _
    segmentName As String, _
    min As Integer, _
    max As Integer, _
    usage As Usage, _
    description As String _
) As DataSegment
public:
DataSegment^ CreateSegment(
    String^ segmentName,
    int min,
    int max,
    Usage usage,
    String^ description
)
Parameters
segmentName (String)
Name of the segment.
min (Int32)
The min.
max (Int32)
The max.
usage (Usage)
The usage.
description (String)
The description.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateSegmentLoop Method (segmentName, min, max, usage, description)

CreateSegmentLoop Method (segmentName, min, max, usage, description)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegmentLoop(String, Int32, Int32, Usage, String)
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment CreateSegmentLoop(
    string segmentName,
    int min,
    int max,
    Usage usage,
    string description
)
Public Function CreateSegmentLoop ( _
    segmentName As String, _
    min As Integer, _
    max As Integer, _
    usage As Usage, _
    description As String _
) As DataSegment
public:
DataSegment^ CreateSegmentLoop(
    String^ segmentName,
    int min,
    int max,
    Usage usage,
    String^ description
)
Parameters
segmentName (String)
min (Int32)
max (Int32)
usage (Usage)
description (String)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Description
Get/Set the description of this loop
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FirstSegment Property

FirstSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► FirstSegment
Get the first segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment FirstSegment { get; }
Public ReadOnly Property FirstSegment As DataSegment
    Get
public:
property DataSegment^ FirstSegment {
    DataSegment^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetChildPosition Method (childLoop)

GetChildPosition Method (childLoop)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetChildPosition(Loop)
Gets the child position.
Declaration Syntax
C# Visual Basic Visual C++
public int GetChildPosition(
    Loop childLoop
)
Public Function GetChildPosition ( _
    childLoop As Loop _
) As Integer
public:
int GetChildPosition(
    Loop^ childLoop
)
Parameters
childLoop (Loop)
The child loop.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLastLoop Method

GetLastLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetLastLoop()()()()
Gets the last loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop GetLastLoop()
Public Function GetLastLoop As Loop
public:
Loop^ GetLastLoop()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLoop Method (loopName)

GetLoop Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetLoop(String)
Gets the loop.
Declaration Syntax
C# Visual Basic Visual C++
public Loop GetLoop(
    string loopName
)
Public Function GetLoop ( _
    loopName As String _
) As Loop
public:
Loop^ GetLoop(
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLoopCollection Method (loopName)

GetLoopCollection Method (loopName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetLoopCollection(String)
Gets the loop collection.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<Loop> GetLoopCollection(
    string loopName
)
Public Function GetLoopCollection ( _
    loopName As String _
) As Collection(Of Loop)
public:
Collection<Loop^>^ GetLoopCollection(
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetNextSegment Method (currentIndex)

GetNextSegment Method (currentIndex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetNextSegment(Int32)
Gets the next segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment GetNextSegment(
    int currentIndex
)
Public Function GetNextSegment ( _
    currentIndex As Integer _
) As DataSegment
public:
DataSegment^ GetNextSegment(
    int currentIndex
)
Parameters
currentIndex (Int32)
Index of the current.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegment Method

GetSegment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegment()()()()
Members
Icon | Member | Description
 | GetSegment(String) | Gets the segment.
 | GetSegment(Int32) | Gets the segment.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegment Method (segmentOridinalNumber)

GetSegment Method (segmentOridinalNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegment(Int32)
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment GetSegment(
    int segmentOridinalNumber
)
Public Function GetSegment ( _
    segmentOridinalNumber As Integer _
) As DataSegment
public:
DataSegment^ GetSegment(
    int segmentOridinalNumber
)
Parameters
segmentOridinalNumber (Int32)
The segment oridinal number.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegment Method (segmentName)

GetSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegment(String)
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment GetSegment(
    string segmentName
)
Public Function GetSegment ( _
    segmentName As String _
) As DataSegment
public:
DataSegment^ GetSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegmentCollection Method (segmentName)

GetSegmentCollection Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegmentCollection(String)
Gets the segment collection.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<DataSegment> GetSegmentCollection(
    string segmentName
)
Public Function GetSegmentCollection ( _
    segmentName As String _
) As Collection(Of DataSegment)
public:
Collection<DataSegment^>^ GetSegmentCollection(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegmentPosition Method (segment)

GetSegmentPosition Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegmentPosition(DataSegment)
Gets the segment position.
Declaration Syntax
C# Visual Basic Visual C++
public int GetSegmentPosition(
    DataSegment segment
)
Public Function GetSegmentPosition ( _
    segment As DataSegment _
) As Integer
public:
int GetSegmentPosition(
    DataSegment^ segment
)
Parameters
segment (DataSegment)
The segment.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSegments Method (segmentName, elementPosition, elementValue)

GetSegments Method (segmentName, elementPosition, elementValue)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSegments(String, Int32, String)
Gets a segment collection given an element position and value
Declaration Syntax
C# Visual Basic Visual C++
public DataSegments GetSegments(
    string segmentName,
    int elementPosition,
    string elementValue
)
Public Function GetSegments ( _
    segmentName As String, _
    elementPosition As Integer, _
    elementValue As String _
) As DataSegments
public:
DataSegments^ GetSegments(
    String^ segmentName,
    int elementPosition,
    String^ elementValue
)
Parameters
segmentName (String)
Name of the segment
elementPosition (Int32)
Position of the element in the segment
elementValue (String)
Value of the element to compare against
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetSiblingAbove Method

GetSiblingAbove Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► GetSiblingAbove()()()()
Gets the sibling above.
Declaration Syntax
C# Visual Basic Visual C++
public Loop GetSiblingAbove()
Public Function GetSiblingAbove As Loop
public:
Loop^ GetSiblingAbove()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Implicit Operator

Implicit Operator
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► ImplicitWideningImplicitImplicitImplicit(String to Loop)
Performs an implicit conversion from String to Loop.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator Loop (
    string loopName
)
Public Shared Widening Operator CType ( _
    loopName As String _
) As Loop
static implicit operator Loop^ (
    String^ loopName
)
Parameters
loopName (String)
Name of the loop.
Return Value
The result of the conversion.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LastSegment Property

LastSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► LastSegment
Get the last segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public DataSegment LastSegment { get; }
Public ReadOnly Property LastSegment As DataSegment
    Get
public:
property DataSegment^ LastSegment {
    DataSegment^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Loops
Get/Set the loops contained within this loop
Declaration Syntax
C# Visual Basic Visual C++
public Loops Loops { get; set; }
Public Property Loops As Loops
    Get
    Set
public:
property Loops^ Loops {
    Loops^ get ();
    void set (Loops^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaximumOccurrences Property

MaximumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► MaximumOccurrences
Get/Set the maximum amount of times this loop can repeat
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumOccurrences { get; set; }
Public Property MaximumOccurrences As Integer
    Get
    Set
public:
property int MaximumOccurrences {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MinimumOccurrences Property

MinimumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► MinimumOccurrences
Get/Set the minimum amount of times this loop can repeat
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumOccurrences { get; set; }
Public Property MinimumOccurrences As Integer
    Get
    Set
public:
property int MinimumOccurrences {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Occurred Property

Occurred Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Occurred
Get/Set if this loop occurred in an EDI File:Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public bool Occurred { get; set; }
Public Property Occurred As Boolean
    Get
    Set
public:
property bool Occurred {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Parent Property

Parent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Parent
Get/Set the parent of this loop:Rules Reader
Declaration Syntax
C# Visual Basic Visual C++
public Loop Parent { get; set; }
Public Property Parent As Loop
    Get
    Set
public:
property Loop^ Parent {
    Loop^ get ();
    void set (Loop^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RepetitionIndefinite Property

RepetitionIndefinite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► RepetitionIndefinite
Gets or sets a value indicating whether [repetition indefinite].
Declaration Syntax
C# Visual Basic Visual C++
public bool RepetitionIndefinite { get; set; }
Public Property RepetitionIndefinite As Boolean
    Get
    Set
public:
property bool RepetitionIndefinite {
    bool get ();
    void set (bool value);
}
Value
true if [repetition indefinite]; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Segments
Get/Set a list of segments in this loop
Declaration Syntax
C# Visual Basic Visual C++
public DataSegments Segments { get; set; }
Public Property Segments As DataSegments
    Get
    Set
public:
property DataSegments^ Segments {
    DataSegments^ get ();
    void set (DataSegments^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Tag Property

Tag Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Tag
Gets or sets the tag.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
Value
The tag.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► ToString()()()()
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► Usage
Get/Set the usage requirements of this loop
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute]
public Usage Usage { get; set; }
<ObsoleteAttribute> _
Public Property Usage As Usage
    Get
    Set
[ObsoleteAttribute]
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loops Class

Loops Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loops
Declaration Syntax
C# Visual Basic Visual C++
public class Loops : Collection<Loop>
Public Class Loops _
    Inherits Collection(Of Loop)
public ref class Loops : public Collection<Loop^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Loops()()()() | Initializes a new instance of the Loops class
 | Add(T) | Adds an object to the end of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | Clear()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | ClearItems()()()() | Removes all elements from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | Contains(T) | Determines whether an element is in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | CopyTo(array<T>[]()[][], Int32) | Copies the entire Collection<(Of <(<'T>)>)> to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | Count | Gets the number of elements actually contained in the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()()() | Returns an enumerator that iterates through the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | Insert(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | InsertItem(Int32, T) | Inserts an element into the Collection<(Of <(<'T>)>)> at the specified index. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | Item[([( Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | Items | Gets a IList<(Of <(<'T>)>)> wrapper around the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | RemoveItem(Int32) | Removes the element at the specified index of the Collection<(Of <(<'T>)>)>. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | SetItem(Int32, T) | Replaces the element at the specified index. (Inherited from Collection <(Of <(<' Loop >)>)>.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Collection <(Of <(<' Loop >)>)>
 |  | Loops

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loops Constructor

Loops Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loops ► Loops()()()()
Initializes a new instance of the Loops class
Declaration Syntax
C# Visual Basic Visual C++
public Loops()
Public Sub New
public:
Loops()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopSchema Class

LoopSchema Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LoopSchema
<SerializableAttribute> _
Public Class LoopSchema
[SerializableAttribute]
public ref class LoopSchema
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoopSchema()()()() | Initializes a new instance of the LoopSchema class.
 | LoopSchema(String) | Initializes a new instance of the LoopSchema class.
 | Description | Gets or sets the description.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNextSegment(Int32) | Gets the next segment.
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Indefinite | Gets or sets a value indicating whether this LoopSchema is indefinite.
 | IsSegmentLoop |
 | LastSegment | Gets the last segment.
 | LoopID | Gets or sets the loop ID.
 | Loops | Gets or sets the loops.
 | Max | Gets or sets the max.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min | Gets or sets the min.
 | Occurred | Gets or sets a value indicating whether this LoopSchema is occurred.
 | Parent | Gets or sets the parent.
 | Segments | Gets or sets the segments.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Usage | Gets or sets the usage.
Inheritance Hierarchy
Object
LoopSchema

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopSchema Constructor

LoopSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LoopSchema()()()()
Members
Icon | Member | Description
 | LoopSchema()()()() | Initializes a new instance of the LoopSchema class.
 | LoopSchema(String) | Initializes a new instance of the LoopSchema class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopSchema Constructor

LoopSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LoopSchema()()()()
Initializes a new instance of the LoopSchema class.
Declaration Syntax
C# Visual Basic Visual C++
public LoopSchema()
Public Sub New
public:
LoopSchema()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopSchema Constructor (loopID)

LoopSchema Constructor (loopID)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LoopSchema(String)
Initializes a new instance of the LoopSchema class.
Declaration Syntax
C# Visual Basic Visual C++
public LoopSchema(
    string loopID
)
Public Sub New ( _
    loopID As String _
)
public:
LoopSchema(
    String^ loopID
)
Parameters
loopID (String)
The loop ID.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Description
Gets or sets the description.
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
Value
The description.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetNextSegment Method (currentIndex)

GetNextSegment Method (currentIndex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► GetNextSegment(Int32)
Gets the next segment.
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema GetNextSegment(
    int currentIndex
)
Public Function GetNextSegment ( _
    currentIndex As Integer _
) As SegmentSchema
public:
SegmentSchema^ GetNextSegment(
    int currentIndex
)
Parameters
currentIndex (Int32)
Index of the current.
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Indefinite Property

Indefinite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Indefinite
Gets or sets a value indicating whether this LoopSchema is indefinite.
Declaration Syntax
C# Visual Basic Visual C++
public bool Indefinite { get; set; }
Public Property Indefinite As Boolean
    Get
    Set
public:
property bool Indefinite {
    bool get ();
    void set (bool value);
}
Value
true if indefinite; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsSegmentLoop Property

IsSegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► IsSegmentLoop
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSegmentLoop { get; set; }
Public Property IsSegmentLoop As Boolean
    Get
    Set
public:
property bool IsSegmentLoop {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LastSegment Property

LastSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LastSegment
Gets the last segment.
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema LastSegment { get; }
Public ReadOnly Property LastSegment As SegmentSchema
    Get
public:
property SegmentSchema^ LastSegment {
    SegmentSchema^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopID Property

LoopID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► LoopID
Gets or sets the loop ID.
Declaration Syntax
C# Visual Basic Visual C++
public string LoopID { get; set; }
Public Property LoopID As String
    Get
    Set
public:
property String^ LoopID {
    String^ get ();
    void set (String^ value);
}
Value
The loop ID.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Loops
Gets or sets the loops.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<LoopSchema> Loops { get; set; }
Public Property Loops As Collection(Of LoopSchema)
    Get
    Set
public:
property Collection<LoopSchema^>^ Loops {
    Collection<LoopSchema^>^ get ();
    void set (Collection<LoopSchema^>^ value);
}
Value
The loops.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Max Property

Max Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Max
Gets or sets the max.
Declaration Syntax
C# Visual Basic Visual C++
public int Max { get; set; }
Public Property Max As Integer
    Get
    Set
public:
property int Max {
    int get ();
    void set (int value);
}
Value
The max.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Min Property

Min Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Min
Gets or sets the min.
Declaration Syntax
C# Visual Basic Visual C++
public int Min { get; set; }
Public Property Min As Integer
    Get
    Set
public:
property int Min {
    int get ();
    void set (int value);
}
Value
The min.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Occurred Property

Occurred Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Occurred
Gets or sets a value indicating whether this LoopSchema is occurred.
Declaration Syntax
C# Visual Basic Visual C++
public bool Occurred { get; set; }
Public Property Occurred As Boolean
    Get
    Set
public:
property bool Occurred {
    bool get ();
    void set (bool value);
}
Value
true if occurred; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Parent Property

Parent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Parent
Gets or sets the parent.
Declaration Syntax
C# Visual Basic Visual C++
public LoopSchema Parent { get; set; }
Public Property Parent As LoopSchema
    Get
    Set
public:
property LoopSchema^ Parent {
    LoopSchema^ get ();
    void set (LoopSchema^ value);
}
Value
The parent.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segments Property

Segments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Segments
Gets or sets the segments.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<SegmentSchema> Segments { get; set; }
Public Property Segments As Collection(Of SegmentSchema)
    Get
    Set
public:
property Collection<SegmentSchema^>^ Segments {
    Collection<SegmentSchema^>^ get ();
    void set (Collection<SegmentSchema^>^ value);
}
Value
The segments.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► LoopSchema ► Usage
Gets or sets the usage.
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}
Value
The usage.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Mask Class

Mask Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Mask
Represents a mask that segment's use to decide how their elements are used
Declaration Syntax
C# Visual Basic Visual C++
public class Mask
Public Class Mask
public ref class Mask
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Mask()()()() | Initializes a new instance of the Mask class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MaskData | Get the maskData The number of elements in the Usage collection must equal that of the MaskData collection
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Usages | Get the usages. The number of elements in the Usage collection must equal that of the MaskData collection
Inheritance Hierarchy
Object
Mask

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Mask Constructor

Mask Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Mask ► Mask()()()()
Initializes a new instance of the Mask class
Declaration Syntax
C# Visual Basic Visual C++
public Mask()
Public Sub New
public:
Mask()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaskData Property

MaskData Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Mask ► MaskData
Get the maskData The number of elements in the Usage collection must equal that of the MaskData collection
Declaration Syntax
C# Visual Basic Visual C++
public List<string> MaskData { get; }
Public ReadOnly Property MaskData As List(Of String)
    Get
public:
property List<String^>^ MaskData {
    List<String^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usages Property

Usages Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Mask ► Usages
Get the usages. The number of elements in the Usage collection must equal that of the MaskData collection
Declaration Syntax
C# Visual Basic Visual C++
public Collection<Usage> Usages { get; }
Public ReadOnly Property Usages As Collection(Of Usage)
    Get
public:
property Collection<Usage>^ Usages {
    Collection<Usage>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaximumErrorLimitReachedException Class

MaximumErrorLimitReachedException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► MaximumErrorLimitReachedException
Maximum number of errors reached event
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MaximumErrorLimitReachedException : Exception
<SerializableAttribute> _
Public Class MaximumErrorLimitReachedException _
    Inherits Exception
[SerializableAttribute]
public ref class MaximumErrorLimitReachedException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | MaximumErrorLimitReachedException

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PackageLicense Class

PackageLicense Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense
Responsible for checking that a valid license exist
Declaration Syntax
C# Visual Basic Visual C++
public static class PackageLicense
Public NotInheritable Class PackageLicense
public ref class PackageLicense abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsValidLicense<(Of <<'(T>)>>)(Object) |
 | IsValidLicense()()()() |
 | Key | RDPCrystal EDI Library Key
Inheritance Hierarchy
Object
PackageLicense

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsValidLicense Method

IsValidLicense Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense ► IsValidLicense()()()()
Members
Icon | Member | Description
 | IsValidLicense<(Of <<'(T>)>>)(Object) |
 | IsValidLicense()()()() |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsValidLicense Method

IsValidLicense Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense ► IsValidLicense()()()()
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValidLicense()
Public Shared Function IsValidLicense As Boolean
public:
static bool IsValidLicense()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsValidLicense Method (instance)

IsValidLicense<(Of <(<'T>)>)> Method (instance)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense ► IsValidLicense<(Of <<'(T>)>>)(Object)
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValidLicense<T>(
    Object instance
)

Public Shared Function IsValidLicense(Of T) ( _
    instance As Object _
) As Boolean
public:
generic<typename T>
static bool IsValidLicense(
    Object^ instance
)
Generic Template Parameters
T
Parameters
instance (Object)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Key Field

Key Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► PackageLicense ► Key
RDPCrystal EDI Library Key
Declaration Syntax
C# Visual Basic Visual C++
public static string Key
Public Shared Key As String
public:
static String^ Key

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RuleDisplay Class

RuleDisplay Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleDisplay
Used by EDIRuleCreator
Declaration Syntax
C# Visual Basic Visual C++
public class RuleDisplay
Public Class RuleDisplay
public ref class RuleDisplay
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RuleDisplay(String, String) | Initializes a new instance of the RuleDisplay class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Gets or sets the position.
 | Rule | Gets or sets the rule.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
RuleDisplay

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RuleDisplay Constructor (position, rule)

RuleDisplay Constructor (position, rule)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleDisplay ► RuleDisplay(String, String)
Initializes a new instance of the RuleDisplay class.
Declaration Syntax
C# Visual Basic Visual C++
public RuleDisplay(
    string position,
    string rule
)
Public Sub New ( _
    position As String, _
    rule As String _
)
public:
RuleDisplay(
    String^ position,
    String^ rule
)
Parameters
position (String)
The position.
rule (String)
The rule.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleDisplay ► Position
Gets or sets the position.
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}
Value
The position.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Rule Property

Rule Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleDisplay ► Rule
Gets or sets the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}
Value
The rule.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RuleOperator Enumeration

RuleOperator Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► RuleOperator
Declaration Syntax
C# Visual Basic Visual C++
public enum RuleOperator
Public Enumeration RuleOperator
public enum class RuleOperator
Members
Member | Description
EQ |
NE |
GT |
GE |
LT |
LE |
EXISTS |
NEXIST |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubPosition Class

ScrubPosition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition
Declaration Syntax
C# Visual Basic Visual C++
public class ScrubPosition
Public Class ScrubPosition
public ref class ScrubPosition
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScrubPosition()()()() | Initializes a new instance of the ScrubPosition class
 | ScrubPosition(Int32) | Initializes a new instance of the ScrubPosition class
 | ScrubPosition(Int32, Int32) | Initializes a new instance of the ScrubPosition class
 | CompositeElementNumber | Gets or sets the composite element number.
 | ElementNumber | Gets or sets the element number.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ScrubPosition

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubPosition Constructor

ScrubPosition Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ScrubPosition()()()()
Members
Icon | Member | Description
 | ScrubPosition()()()() | Initializes a new instance of the ScrubPosition class
 | ScrubPosition(Int32) | Initializes a new instance of the ScrubPosition class
 | ScrubPosition(Int32, Int32) | Initializes a new instance of the ScrubPosition class

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubPosition Constructor

ScrubPosition Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ScrubPosition()()()()
Initializes a new instance of the ScrubPosition class
Declaration Syntax
C# Visual Basic Visual C++
public ScrubPosition()
Public Sub New
public:
ScrubPosition()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubPosition Constructor (elementNumber)

ScrubPosition Constructor (elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ScrubPosition(Int32)
Initializes a new instance of the ScrubPosition class
Declaration Syntax
C# Visual Basic Visual C++
public ScrubPosition(
    int elementNumber
)
Public Sub New ( _
    elementNumber As Integer _
)
public:
ScrubPosition(
    int elementNumber
)
Parameters
elementNumber (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubPosition Constructor (compositeElementNumber, elementNumber)

ScrubPosition Constructor (compositeElementNumber, elementNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ScrubPosition(Int32, Int32)
Initializes a new instance of the ScrubPosition class
Declaration Syntax
C# Visual Basic Visual C++
public ScrubPosition(
    int compositeElementNumber,
    int elementNumber
)
Public Sub New ( _
    compositeElementNumber As Integer, _
    elementNumber As Integer _
)
public:
ScrubPosition(
    int compositeElementNumber,
    int elementNumber
)
Parameters
compositeElementNumber (Int32)
elementNumber (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementNumber Property

CompositeElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► CompositeElementNumber
Gets or sets the composite element number.
Declaration Syntax
C# Visual Basic Visual C++
public int CompositeElementNumber { get; set; }
Public Property CompositeElementNumber As Integer
    Get
    Set
public:
property int CompositeElementNumber {
    int get ();
    void set (int value);
}
Value
The composite element number.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubPosition ► ElementNumber
Gets or sets the element number.
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}
Value
The element number.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubRule Class

ScrubRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ScrubRule
<SerializableAttribute> _
Public Class ScrubRule
[SerializableAttribute]
public ref class ScrubRule
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScrubRule()()()() | Initializes a new instance of the ScrubRule class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReplaceCharacter | Gets or sets the replace character.
 | ScrubPositions |
 | SegmentName | Gets or sets the name of the segment.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
ScrubRule

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubRule Constructor

ScrubRule Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule ► ScrubRule()()()()
Initializes a new instance of the ScrubRule class.
Declaration Syntax
C# Visual Basic Visual C++
public ScrubRule()
Public Sub New
public:
ScrubRule()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ReplaceCharacter Property

ReplaceCharacter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule ► ReplaceCharacter
Gets or sets the replace character.
Declaration Syntax
C# Visual Basic Visual C++
public char ReplaceCharacter { get; set; }
Public Property ReplaceCharacter As Char
    Get
    Set
public:
property wchar_t ReplaceCharacter {
    wchar_t get ();
    void set (wchar_t value);
}
Value
The replace character.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ScrubPositions Property

ScrubPositions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule ► ScrubPositions
Declaration Syntax
C# Visual Basic Visual C++
public List<ScrubPosition> ScrubPositions { get; }
Public ReadOnly Property ScrubPositions As List(Of ScrubPosition)
    Get
public:
property List<ScrubPosition^>^ ScrubPositions {
    List<ScrubPosition^>^ get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentName Property

SegmentName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ScrubRule ► SegmentName
Gets or sets the name of the segment.
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentName { get; set; }
Public Property SegmentName As String
    Get
    Set
public:
property String^ SegmentName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the segment.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segment Class

Segment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Segment
<SerializableAttribute> _
Public Class Segment
[SerializableAttribute]
public ref class Segment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Segment()()()() | Initializes a new instance of the Segment class.
 | Segment(String) | Initializes a new instance of the Segment class.
 | ElementConditionalConstraints |
 | ElementExclusionConstraints | Gets or sets the element exclusion constraints.
 | ElementListConditionConstraints | Gets or sets the element list condition constraints.
 | ElementPairConstraints | Gets or sets the element pair constraints.
 | ElementRequiredConstraints | Gets or sets the element required constraints.
 | ElementSchema | Gets or sets the element schema.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeneralSelfRules |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoopValidationIndex | Gets or sets the index of the loop validation.
 | Masks | Gets or sets the masks.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Modified | Gets or sets whether this Segment was modified after load. This property is used by the EDI Rules Creator Studio
 | Name | Gets or sets the name.
 | SelfRules | Gets or sets the self rules.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Segment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segment Constructor

Segment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Segment()()()()
Members
Icon | Member | Description
 | Segment()()()() | Initializes a new instance of the Segment class.
 | Segment(String) | Initializes a new instance of the Segment class.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segment Constructor

Segment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Segment()()()()
Initializes a new instance of the Segment class.
Declaration Syntax
C# Visual Basic Visual C++
public Segment()
Public Sub New
public:
Segment()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Segment Constructor (name)

Segment Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Segment(String)
Initializes a new instance of the Segment class.
Declaration Syntax
C# Visual Basic Visual C++
public Segment(
    string name
)
Public Sub New ( _
    name As String _
)
public:
Segment(
    String^ name
)
Parameters
name (String)
The name.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementConditionalConstraints Property

ElementConditionalConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementConditionalConstraints
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementConditionalConstraint> ElementConditionalConstraints { get; set; }
Public Property ElementConditionalConstraints As Collection(Of ElementConditionalConstraint)
    Get
    Set
public:
property Collection<ElementConditionalConstraint^>^ ElementConditionalConstraints {
    Collection<ElementConditionalConstraint^>^ get ();
    void set (Collection<ElementConditionalConstraint^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementExclusionConstraints Property

ElementExclusionConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementExclusionConstraints
Gets or sets the element exclusion constraints.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementExclusionConstraint> ElementExclusionConstraints { get; set; }
Public Property ElementExclusionConstraints As Collection(Of ElementExclusionConstraint)
    Get
    Set
public:
property Collection<ElementExclusionConstraint^>^ ElementExclusionConstraints {
    Collection<ElementExclusionConstraint^>^ get ();
    void set (Collection<ElementExclusionConstraint^>^ value);
}
Value
The element exclusion constraints.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementListConditionConstraints Property

ElementListConditionConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementListConditionConstraints
Gets or sets the element list condition constraints.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementListConditionalConstraint> ElementListConditionConstraints { get; set; }
Public Property ElementListConditionConstraints As Collection(Of ElementListConditionalConstraint)
    Get
    Set
public:
property Collection<ElementListConditionalConstraint^>^ ElementListConditionConstraints {
    Collection<ElementListConditionalConstraint^>^ get ();
    void set (Collection<ElementListConditionalConstraint^>^ value);
}
Value
The element list condition constraints.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPairConstraints Property

ElementPairConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementPairConstraints
Gets or sets the element pair constraints.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementPairConstraint> ElementPairConstraints { get; set; }
Public Property ElementPairConstraints As Collection(Of ElementPairConstraint)
    Get
    Set
public:
property Collection<ElementPairConstraint^>^ ElementPairConstraints {
    Collection<ElementPairConstraint^>^ get ();
    void set (Collection<ElementPairConstraint^>^ value);
}
Value
The element pair constraints.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementRequiredConstraints Property

ElementRequiredConstraints Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementRequiredConstraints
Gets or sets the element required constraints.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementRequiredConstraint> ElementRequiredConstraints { get; set; }
Public Property ElementRequiredConstraints As Collection(Of ElementRequiredConstraint)
    Get
    Set
public:
property Collection<ElementRequiredConstraint^>^ ElementRequiredConstraints {
    Collection<ElementRequiredConstraint^>^ get ();
    void set (Collection<ElementRequiredConstraint^>^ value);
}
Value
The element required constraints.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementSchema Property

ElementSchema Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► ElementSchema
Gets or sets the element schema.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<ElementSchema> ElementSchema { get; set; }
Public Property ElementSchema As Collection(Of ElementSchema)
    Get
    Set
public:
property Collection<ElementSchema^>^ ElementSchema {
    Collection<ElementSchema^>^ get ();
    void set (Collection<ElementSchema^>^ value);
}
Value
The element schema.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralSelfRules Property

GeneralSelfRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► GeneralSelfRules
Declaration Syntax
C# Visual Basic Visual C++
public Collection<GeneralSelfRule> GeneralSelfRules { get; set; }
Public Property GeneralSelfRules As Collection(Of GeneralSelfRule)
    Get
    Set
public:
property Collection<GeneralSelfRule^>^ GeneralSelfRules {
    Collection<GeneralSelfRule^>^ get ();
    void set (Collection<GeneralSelfRule^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopValidationIndex Property

LoopValidationIndex Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► LoopValidationIndex
Gets or sets the index of the loop validation.
Declaration Syntax
C# Visual Basic Visual C++
public int LoopValidationIndex { get; set; }
Public Property LoopValidationIndex As Integer
    Get
    Set
public:
property int LoopValidationIndex {
    int get ();
    void set (int value);
}
Value
The index of the loop validation.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Masks Property

Masks Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Masks
Gets or sets the masks.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<Mask> Masks { get; set; }
Public Property Masks As Collection(Of Mask)
    Get
    Set
public:
property Collection<Mask^>^ Masks {
    Collection<Mask^>^ get ();
    void set (Collection<Mask^>^ value);
}
Value
The masks.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Modified Property

Modified Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Modified
Gets or sets whether this Segment was modified after load. This property is used by the EDI Rules Creator Studio
Declaration Syntax
C# Visual Basic Visual C++
public bool Modified { get; set; }
Public Property Modified As Boolean
    Get
    Set
public:
property bool Modified {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► Name
Gets or sets the name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
The name.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SelfRules Property

SelfRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Segment ► SelfRules
Gets or sets the self rules.
Declaration Syntax
C# Visual Basic Visual C++
public Collection<SelfRule> SelfRules { get; set; }
Public Property SelfRules As Collection(Of SelfRule)
    Get
    Set
public:
property Collection<SelfRule^>^ SelfRules {
    Collection<SelfRule^>^ get ();
    void set (Collection<SelfRule^>^ value);
}
Value
The self rules.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchema Class

SegmentSchema Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema
Represent basic segment information used by EDIRulesReader and EDIRulesCreator
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SegmentSchema
<SerializableAttribute> _
Public Class SegmentSchema
[SerializableAttribute]
public ref class SegmentSchema
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SegmentSchema()()()() | Creates a new SegmentSchema object
 | SegmentSchema(String) | Creates a new SegmentSchema object
 | SegmentSchema(String, Usage) | Creates a new SegmentSchema object
 | SegmentSchema(String, Usage, Int32) | Creates a new SegmentSchema object
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GeneralRules |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSegmentLoop |
 | MaskNumber | Get/set the mask number of the segment
 | MaximumOccurrences | Get/set the maximum amount of times segment will appear in its containing loop
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumOccurrences | Get/set the minimum amount of times segment will appear in its containing loop
 | Name | Get/set the name of segment
 | OnlySegmentInLoop | Get/set whether segment is the only segment in the loop
 | OridinalNumber | Get the orginal number of segment within the EDI rules file
 | Position | Gets or sets the position.
 | RepeatIndefinite | Get/set whether segment repeats indefinitely
 | Rules | Get/set the rules that apply to segment
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Usage | Get/set usage of segment within containing loop
Inheritance Hierarchy
Object
SegmentSchema

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchema Constructor

SegmentSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema()()()()
Members
Icon | Member | Description
 | SegmentSchema()()()() | Creates a new SegmentSchema object
 | SegmentSchema(String) | Creates a new SegmentSchema object
 | SegmentSchema(String, Usage) | Creates a new SegmentSchema object
 | SegmentSchema(String, Usage, Int32) | Creates a new SegmentSchema object

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchema Constructor

SegmentSchema Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema()()()()
Creates a new SegmentSchema object
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema()
Public Sub New
public:
SegmentSchema()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchema Constructor (segmentName)

SegmentSchema Constructor (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema(String)
Creates a new SegmentSchema object
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema(
    string segmentName
)
Public Sub New ( _
    segmentName As String _
)
public:
SegmentSchema(
    String^ segmentName
)
Parameters
segmentName (String)
name of segment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchema Constructor (segmentName, usage)

SegmentSchema Constructor (segmentName, usage)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema(String, Usage)
Creates a new SegmentSchema object
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema(
    string segmentName,
    Usage usage
)
Public Sub New ( _
    segmentName As String, _
    usage As Usage _
)
public:
SegmentSchema(
    String^ segmentName,
    Usage usage
)
Parameters
segmentName (String)
name of segment
usage (Usage)
usage of segment

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentSchema Constructor (segmentName, usage, maskNumber)

SegmentSchema Constructor (segmentName, usage, maskNumber)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► SegmentSchema(String, Usage, Int32)
Creates a new SegmentSchema object
Declaration Syntax
C# Visual Basic Visual C++
public SegmentSchema(
    string segmentName,
    Usage usage,
    int maskNumber
)
Public Sub New ( _
    segmentName As String, _
    usage As Usage, _
    maskNumber As Integer _
)
public:
SegmentSchema(
    String^ segmentName,
    Usage usage,
    int maskNumber
)
Parameters
segmentName (String)
name of segment
usage (Usage)
usage of segment
maskNumber (Int32)
mask number to use

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralRules Property

GeneralRules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► GeneralRules
Declaration Syntax
C# Visual Basic Visual C++
public Collection<GeneralRule> GeneralRules { get; set; }
Public Property GeneralRules As Collection(Of GeneralRule)
    Get
    Set
public:
property Collection<GeneralRule^>^ GeneralRules {
    Collection<GeneralRule^>^ get ();
    void set (Collection<GeneralRule^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsSegmentLoop Property

IsSegmentLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► IsSegmentLoop
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSegmentLoop { get; set; }
Public Property IsSegmentLoop As Boolean
    Get
    Set
public:
property bool IsSegmentLoop {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaskNumber Property

MaskNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► MaskNumber
Get/set the mask number of the segment
Declaration Syntax
C# Visual Basic Visual C++
public int MaskNumber { get; set; }
Public Property MaskNumber As Integer
    Get
    Set
public:
property int MaskNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MaximumOccurrences Property

MaximumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► MaximumOccurrences
Get/set the maximum amount of times segment will appear in its containing loop
Declaration Syntax
C# Visual Basic Visual C++
public int MaximumOccurrences { get; set; }
Public Property MaximumOccurrences As Integer
    Get
    Set
public:
property int MaximumOccurrences {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MinimumOccurrences Property

MinimumOccurrences Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► MinimumOccurrences
Get/set the minimum amount of times segment will appear in its containing loop
Declaration Syntax
C# Visual Basic Visual C++
public int MinimumOccurrences { get; set; }
Public Property MinimumOccurrences As Integer
    Get
    Set
public:
property int MinimumOccurrences {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► Name
Get/set the name of segment
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OnlySegmentInLoop Property

OnlySegmentInLoop Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► OnlySegmentInLoop
Get/set whether segment is the only segment in the loop
Declaration Syntax
C# Visual Basic Visual C++
public bool OnlySegmentInLoop { get; set; }
Public Property OnlySegmentInLoop As Boolean
    Get
    Set
public:
property bool OnlySegmentInLoop {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OridinalNumber Property

OridinalNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► OridinalNumber
Get the orginal number of segment within the EDI rules file
Declaration Syntax
C# Visual Basic Visual C++
public int OridinalNumber { get; internal set; }
Public Property OridinalNumber As Integer
    Get
    Friend Set
public:
property int OridinalNumber {
    int get ();
    internal: void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► Position
Gets or sets the position.
Declaration Syntax
C# Visual Basic Visual C++
public string Position { get; set; }
Public Property Position As String
    Get
    Set
public:
property String^ Position {
    String^ get ();
    void set (String^ value);
}
Value
The position.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RepeatIndefinite Property

RepeatIndefinite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► RepeatIndefinite
Get/set whether segment repeats indefinitely
Declaration Syntax
C# Visual Basic Visual C++
public bool RepeatIndefinite { get; set; }
Public Property RepeatIndefinite As Boolean
    Get
    Set
public:
property bool RepeatIndefinite {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Rules Property

Rules Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► Rules
Get/set the rules that apply to segment
Declaration Syntax
C# Visual Basic Visual C++
public Collection<SemanticRule> Rules { get; set; }
Public Property Rules As Collection(Of SemanticRule)
    Get
    Set
public:
property Collection<SemanticRule^>^ Rules {
    Collection<SemanticRule^>^ get ();
    void set (Collection<SemanticRule^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SegmentSchema ► Usage
Get/set usage of segment within containing loop
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SelfRule Class

SelfRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule
Represents a rule that a segment uses to check itself
Declaration Syntax
C# Visual Basic Visual C++
public class SelfRule
Public Class SelfRule
public ref class SelfRule
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelfRule()()()() | Creates a new SelfRule object
 | ElementNumber | Get/set the element number that the rule will apply to
 | ElementValues | Get/set the possible values that will trigger the rule
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetCommaSeparatedElementValues()()()() | Returns a comma separated list of the element values that will trigger the rule
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNotUsedOrdinalsString()()()() | Returns the not used elements as a string with element number delimited by a space
 | GetNotUsedOrdinalsString(Char) | Returns the not used elements as a string with element number delimited by a the separator character
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUsedOrdinalsString()()()() | Returns the used elements as a string with element number delimited by a space
 | GetUsedOrdinalsString(Char) | Returns the used elements as a string with element number delimited by a the separator character
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotUsedElementCollection | Get/set the elements that must not be used when the rule is applied
 | RuleOperator | Get/set the rule operator
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UsedElementCollection | Get/set the elements that must be used when the rule is applied
Inheritance Hierarchy
Object
SelfRule

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SelfRule Constructor

SelfRule Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► SelfRule()()()()
Creates a new SelfRule object
Declaration Syntax
C# Visual Basic Visual C++
public SelfRule()
Public Sub New
public:
SelfRule()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNumber Property

ElementNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► ElementNumber
Get/set the element number that the rule will apply to
Declaration Syntax
C# Visual Basic Visual C++
public int ElementNumber { get; set; }
Public Property ElementNumber As Integer
    Get
    Set
public:
property int ElementNumber {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementValues Property

ElementValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► ElementValues
Get/set the possible values that will trigger the rule
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> ElementValues { get; set; }
Public Property ElementValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ ElementValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetCommaSeparatedElementValues Method

GetCommaSeparatedElementValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetCommaSeparatedElementValues()()()()
Returns a comma separated list of the element values that will trigger the rule
Declaration Syntax
C# Visual Basic Visual C++
public string GetCommaSeparatedElementValues()
Public Function GetCommaSeparatedElementValues As String
public:
String^ GetCommaSeparatedElementValues()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetNotUsedOrdinalsString Method

GetNotUsedOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetNotUsedOrdinalsString()()()()
Members
Icon | Member | Description
 | GetNotUsedOrdinalsString()()()() | Returns the not used elements as a string with element number delimited by a space
 | GetNotUsedOrdinalsString(Char) | Returns the not used elements as a string with element number delimited by a the separator character

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetNotUsedOrdinalsString Method

GetNotUsedOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetNotUsedOrdinalsString()()()()
Returns the not used elements as a string with element number delimited by a space
Declaration Syntax
C# Visual Basic Visual C++
public string GetNotUsedOrdinalsString()
Public Function GetNotUsedOrdinalsString As String
public:
String^ GetNotUsedOrdinalsString()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetNotUsedOrdinalsString Method (separator)

GetNotUsedOrdinalsString Method (separator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetNotUsedOrdinalsString(Char)
Returns the not used elements as a string with element number delimited by a the separator character
Declaration Syntax
C# Visual Basic Visual C++
public string GetNotUsedOrdinalsString(
    char separator
)
Public Function GetNotUsedOrdinalsString ( _
    separator As Char _
) As String
public:
String^ GetNotUsedOrdinalsString(
    wchar_t separator
)
Parameters
separator (Char)
Return Value
separator character

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetUsedOrdinalsString Method

GetUsedOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetUsedOrdinalsString()()()()
Members
Icon | Member | Description
 | GetUsedOrdinalsString()()()() | Returns the used elements as a string with element number delimited by a space
 | GetUsedOrdinalsString(Char) | Returns the used elements as a string with element number delimited by a the separator character

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetUsedOrdinalsString Method

GetUsedOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetUsedOrdinalsString()()()()
Returns the used elements as a string with element number delimited by a space
Declaration Syntax
C# Visual Basic Visual C++
public string GetUsedOrdinalsString()
Public Function GetUsedOrdinalsString As String
public:
String^ GetUsedOrdinalsString()
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetUsedOrdinalsString Method (separator)

GetUsedOrdinalsString Method (separator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► GetUsedOrdinalsString(Char)
Returns the used elements as a string with element number delimited by a the separator character
Declaration Syntax
C# Visual Basic Visual C++
public string GetUsedOrdinalsString(
    char separator
)
Public Function GetUsedOrdinalsString ( _
    separator As Char _
) As String
public:
String^ GetUsedOrdinalsString(
    wchar_t separator
)
Parameters
separator (Char)
Return Value
separator character

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NotUsedElementCollection Property

NotUsedElementCollection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► NotUsedElementCollection
Get/set the elements that must not be used when the rule is applied
Declaration Syntax
C# Visual Basic Visual C++
public Collection<int> NotUsedElementCollection { get; set; }
Public Property NotUsedElementCollection As Collection(Of Integer)
    Get
    Set
public:
property Collection<int>^ NotUsedElementCollection {
    Collection<int>^ get ();
    void set (Collection<int>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RuleOperator Property

RuleOperator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► RuleOperator
Get/set the rule operator
Declaration Syntax
C# Visual Basic Visual C++
public RuleOperator RuleOperator { get; set; }
Public Property RuleOperator As RuleOperator
    Get
    Set
public:
property RuleOperator RuleOperator {
    RuleOperator get ();
    void set (RuleOperator value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UsedElementCollection Property

UsedElementCollection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SelfRule ► UsedElementCollection
Get/set the elements that must be used when the rule is applied
Declaration Syntax
C# Visual Basic Visual C++
public Collection<int> UsedElementCollection { get; set; }
Public Property UsedElementCollection As Collection(Of Integer)
    Get
    Set
public:
property Collection<int>^ UsedElementCollection {
    Collection<int>^ get ();
    void set (Collection<int>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SemanticRule Class

SemanticRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule
Represents a rule that a segment or element must conform to
Declaration Syntax
C# Visual Basic Visual C++
public class SemanticRule
Public Class SemanticRule
public ref class SemanticRule
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SemanticRule()()()() | Creates a new SemanticRule object
 | AcceptedValues | Get/set the accepted values that the base segment's element must contain when rule is applied
 | BaseSegmentPosition | The segment/element position that this rule is based on
 | ConditionalValues | Get/set the conditional values that the base segment's element should have when rule is applied. The conditional values are values that the base segment's element must contain for the rule to be applied
 | DefaultValues | Get/set the default values that the base segment's element must have when rule is applied
 | DependentSegmentPosition | The segment position of the segment/element that this rule is for
 | ElseUsage | Get/set the usage of the segment or element usage when the rule condition evaluates to false
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RuleOperator | Get/Set the rule operator for rule
 | ToString()()()() | Returns a string representation of this object (Overrides Object.ToString()()()().)
 | Usage | Get/set the usage of the segment or element who holds this rule
Inheritance Hierarchy
Object
SemanticRule

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SemanticRule Constructor

SemanticRule Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► SemanticRule()()()()
Creates a new SemanticRule object
Declaration Syntax
C# Visual Basic Visual C++
public SemanticRule()
Public Sub New
public:
SemanticRule()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AcceptedValues Property

AcceptedValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► AcceptedValues
Get/set the accepted values that the base segment's element must contain when rule is applied
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> AcceptedValues { get; set; }
Public Property AcceptedValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ AcceptedValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


BaseSegmentPosition Property

BaseSegmentPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► BaseSegmentPosition
The segment/element position that this rule is based on
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition BaseSegmentPosition { get; set; }
Public Property BaseSegmentPosition As ElementPosition
    Get
    Set
public:
property ElementPosition^ BaseSegmentPosition {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ConditionalValues Property

ConditionalValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► ConditionalValues
Get/set the conditional values that the base segment's element should have when rule is applied. The conditional values are values that the base segment's element must contain for the rule to be applied
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> ConditionalValues { get; set; }
Public Property ConditionalValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ ConditionalValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DefaultValues Property

DefaultValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► DefaultValues
Get/set the default values that the base segment's element must have when rule is applied
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> DefaultValues { get; set; }
Public Property DefaultValues As HashSet(Of String)
    Get
    Set
public:
property HashSet<String^>^ DefaultValues {
    HashSet<String^>^ get ();
    void set (HashSet<String^>^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DependentSegmentPosition Property

DependentSegmentPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► DependentSegmentPosition
The segment position of the segment/element that this rule is for
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition DependentSegmentPosition { get; set; }
Public Property DependentSegmentPosition As ElementPosition
    Get
    Set
public:
property ElementPosition^ DependentSegmentPosition {
    ElementPosition^ get ();
    void set (ElementPosition^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElseUsage Property

ElseUsage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► ElseUsage
Get/set the usage of the segment or element usage when the rule condition evaluates to false
Declaration Syntax
C# Visual Basic Visual C++
public Usage ElseUsage { get; set; }
Public Property ElseUsage As Usage
    Get
    Set
public:
property Usage ElseUsage {
    Usage get ();
    void set (Usage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RuleOperator Property

RuleOperator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► RuleOperator
Get/Set the rule operator for rule
Declaration Syntax
C# Visual Basic Visual C++
public RuleOperator RuleOperator { get; set; }
Public Property RuleOperator As RuleOperator
    Get
    Set
public:
property RuleOperator RuleOperator {
    RuleOperator get ();
    void set (RuleOperator value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► ToString()()()()
Returns a string representation of this object
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
string representation of this object

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticRule ► Usage
Get/set the usage of the segment or element who holds this rule
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SemanticsProcessor Class

SemanticsProcessor Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticsProcessor
This class is resonsible for taking a string and extracting the rules from it
Declaration Syntax
C# Visual Basic Visual C++
public static class SemanticsProcessor
Public NotInheritable Class SemanticsProcessor
public ref class SemanticsProcessor abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExtractSemanticRule(String, Dictionary<(Of <<'(String, CodeList>)>>)) |
Inheritance Hierarchy
Object
SemanticsProcessor

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ExtractSemanticRule Method (ruleString, codeLists)

ExtractSemanticRule Method (ruleString, codeLists)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SemanticsProcessor ► ExtractSemanticRule(String, Dictionary<(Of <<'(String, CodeList>)>>))
Declaration Syntax
C# Visual Basic Visual C++
public static SemanticRule ExtractSemanticRule(
    string ruleString,
    Dictionary<string, CodeList> codeLists
)
Public Shared Function ExtractSemanticRule ( _
    ruleString As String, _
    codeLists As Dictionary(Of String, CodeList) _
) As SemanticRule
public:
static SemanticRule^ ExtractSemanticRule(
    String^ ruleString,
    Dictionary<String^, CodeList^>^ codeLists
)
Parameters
ruleString (String)
codeLists (Dictionary <(Of <(<' String, CodeList >)>)>)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SnipTestLevel Enumeration

SnipTestLevel Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SnipTestLevel
Snip Levels
Declaration Syntax
C# Visual Basic Visual C++
public enum SnipTestLevel
Public Enumeration SnipTestLevel
public enum class SnipTestLevel
Members
Member | Description
DoesNotApply | Snip Level does not apply
Integrity | Testing for valid EDI syntax for each type of transaction
Requirement | Testing for HIPAA specific syntax. This tests that the transaction sets adhereto the HIPAA implementation guides
Balance | Testing of the transaction for balanced field totals, financial balancing of claims or remittance advice and balancing of summary fields.
Situational | Testing of specific inter-segment situations as defined in the implementation guide, where if A occurs, then B must be populated
CodeSet | Testing correct use of external code sets. Tests that only valid values of external data elements are used

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SummaryDisplay Class

SummaryDisplay Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SummaryDisplay
Used by EDIRuleCreator
Declaration Syntax
C# Visual Basic Visual C++
public class SummaryDisplay
Public Class SummaryDisplay
public ref class SummaryDisplay
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SummaryDisplay(String, String) | Initializes a new instance of the SummaryDisplay class.
 | Element | Gets or sets the element.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rule | Gets or sets the rule.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
SummaryDisplay

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SummaryDisplay Constructor (element, rule)

SummaryDisplay Constructor (element, rule)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SummaryDisplay ► SummaryDisplay(String, String)
Initializes a new instance of the SummaryDisplay class.
Declaration Syntax
C# Visual Basic Visual C++
public SummaryDisplay(
    string element,
    string rule
)
Public Sub New ( _
    element As String, _
    rule As String _
)
public:
SummaryDisplay(
    String^ element,
    String^ rule
)
Parameters
element (String)
The element.
rule (String)
The rule.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Element Property

Element Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SummaryDisplay ► Element
Gets or sets the element.
Declaration Syntax
C# Visual Basic Visual C++
public string Element { get; set; }
Public Property Element As String
    Get
    Set
public:
property String^ Element {
    String^ get ();
    void set (String^ value);
}
Value
The element.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Rule Property

Rule Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► SummaryDisplay ► Rule
Gets or sets the rule.
Declaration Syntax
C# Visual Basic Visual C++
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}
Value
The rule.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrialLicenseProvider Class

TrialLicenseProvider Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TrialLicenseProvider
Summary description for CrystalLabelsLicenseProvider.
Declaration Syntax
C# Visual Basic Visual C++
public class TrialLicenseProvider : LicFileLicenseProvider
Public Class TrialLicenseProvider _
    Inherits LicFileLicenseProvider
public ref class TrialLicenseProvider : public LicFileLicenseProvider
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TrialLicenseProvider()()()() | Initializes a new instance of the TrialLicenseProvider class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey(Type) | Returns a key for the specified type. (Inherited from LicFileLicenseProvider.)
 | GetLicense(LicenseContext, Type, Object, Boolean) | (Overrides LicFileLicenseProvider.GetLicense(LicenseContext, Type, Object, Boolean).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsKeyValid(String, Type) | Determines whether the key that the GetLicense(LicenseContext, Type, Object, Boolean) method retrieves is valid for the specified type. (Inherited from LicFileLicenseProvider.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | LicenseProvider
 |  | LicFileLicenseProvider
 |  |  | TrialLicenseProvider

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TrialLicenseProvider Constructor

TrialLicenseProvider Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TrialLicenseProvider ► TrialLicenseProvider()()()()
Initializes a new instance of the TrialLicenseProvider class
Declaration Syntax
C# Visual Basic Visual C++
public TrialLicenseProvider()
Public Sub New
public:
TrialLicenseProvider()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetLicense Method (context, type, instance, allowExceptions)

GetLicense Method (context, type, instance, allowExceptions)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► TrialLicenseProvider ► GetLicense(LicenseContext, Type, Object, Boolean)
Declaration Syntax
C# Visual Basic Visual C++
public override License GetLicense(
    LicenseContext context,
    Type type,
    Object instance,
    bool allowExceptions
)
Public Overrides Function GetLicense ( _
    context As LicenseContext, _
    type As Type, _
    instance As Object, _
    allowExceptions As Boolean _
) As License
public:
virtual License^ GetLicense(
    LicenseContext^ context,
    Type^ type,
    Object^ instance,
    bool allowExceptions
) override
Parameters
context (LicenseContext)
type (Type)
instance (Object)
allowExceptions (Boolean)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Enumeration

Usage Enumeration
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Usage
Represents how a segment/element usage requirements
Declaration Syntax
C# Visual Basic Visual C++
public enum Usage
Public Enumeration Usage
public enum class Usage
Members
Member | Description
NOTUSED |
REQUIRED |
RECOMMENDED |
NOTRECOMMENDED |
OPTIONAL |
DEPENDENT |
LOCALCODE |
USE_DEFAULT |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidationEventsArgs Class

ValidationEventsArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs
Represents data pertaining to the time it took to validate a file and if the file has passed validation
Declaration Syntax
C# Visual Basic Visual C++
public class ValidationEventsArgs : EventArgs
Public Class ValidationEventsArgs _
    Inherits EventArgs
public ref class ValidationEventsArgs : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidationEventsArgs()()()() | Initializes a new instance of the ValidationEventsArgs class
 | ValidationEventsArgs(Boolean, Double) | Initializes a new instance of the ValidationEventsArgs class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Milliseconds | Get the amount of time passed in milliseconds for the validation process
 | Passed | Check whether a file was successfully validated
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | ValidationEventsArgs

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidationEventsArgs Constructor

ValidationEventsArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► ValidationEventsArgs()()()()
Members
Icon | Member | Description
 | ValidationEventsArgs()()()() | Initializes a new instance of the ValidationEventsArgs class
 | ValidationEventsArgs(Boolean, Double) | Initializes a new instance of the ValidationEventsArgs class

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidationEventsArgs Constructor

ValidationEventsArgs Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► ValidationEventsArgs()()()()
Initializes a new instance of the ValidationEventsArgs class
Declaration Syntax
C# Visual Basic Visual C++
public ValidationEventsArgs()
Public Sub New
public:
ValidationEventsArgs()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidationEventsArgs Constructor (passed, milliseconds)

ValidationEventsArgs Constructor (passed, milliseconds)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► ValidationEventsArgs(Boolean, Double)
Initializes a new instance of the ValidationEventsArgs class
Declaration Syntax
C# Visual Basic Visual C++
public ValidationEventsArgs(
    bool passed,
    double milliseconds
)
Public Sub New ( _
    passed As Boolean, _
    milliseconds As Double _
)
public:
ValidationEventsArgs(
    bool passed,
    double milliseconds
)
Parameters
passed (Boolean)
milliseconds (Double)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Milliseconds Property

Milliseconds Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► Milliseconds
Get the amount of time passed in milliseconds for the validation process
Declaration Syntax
C# Visual Basic Visual C++
public double Milliseconds { get; }
Public ReadOnly Property Milliseconds As Double
    Get
public:
property double Milliseconds {
    double get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Passed Property

Passed Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationEventsArgs ► Passed
Check whether a file was successfully validated
Declaration Syntax
C# Visual Basic Visual C++
public bool Passed { get; }
Public ReadOnly Property Passed As Boolean
    Get
public:
property bool Passed {
    bool get ();
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidationException Class

ValidationException Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ValidationException
An exception that represents an errors that occur while validation is taking place
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ValidationException : Exception
<SerializableAttribute> _
Public Class ValidationException _
    Inherits Exception
[SerializableAttribute]
public ref class ValidationException : public Exception
Members
All Members | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ValidationException

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


X12Strings Class

X12Strings Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► X12Strings
Declaration Syntax
C# Visual Basic Visual C++
public static class X12Strings
Public NotInheritable Class X12Strings
public ref class X12Strings abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GE |
 | GS |
 | HL |
 | IEA |
 | ISA |
 | SE |
 | ST |
Inheritance Hierarchy
Object
X12Strings

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GE Field

GE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► X12Strings ► GE
Declaration Syntax
C# Visual Basic Visual C++
public const string GE
Public Const GE As String
public:
literal String^ GE

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GS Field

GS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► X12Strings ► GS
Declaration Syntax
C# Visual Basic Visual C++
public const string GS
Public Const GS As String
public:
literal String^ GS

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HL Field

HL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► X12Strings ► HL
Declaration Syntax
C# Visual Basic Visual C++
public const string HL
Public Const HL As String
public:
literal String^ HL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IEA Field

IEA Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► X12Strings ► IEA
Declaration Syntax
C# Visual Basic Visual C++
public const string IEA
Public Const IEA As String
public:
literal String^ IEA

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ISA Field

ISA Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► X12Strings ► ISA
Declaration Syntax
C# Visual Basic Visual C++
public const string ISA
Public Const ISA As String
public:
literal String^ ISA

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SE Field

SE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► X12Strings ► SE
Declaration Syntax
C# Visual Basic Visual C++
public const string SE
Public Const SE As String
public:
literal String^ SE

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ST Field

ST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► X12Strings ► ST
Declaration Syntax
C# Visual Basic Visual C++
public const string ST
Public Const ST As String
public:
literal String^ ST

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


XmlConfigOptions Class

XmlConfigOptions Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions
Xml Configuration Options
Declaration Syntax
C# Visual Basic Visual C++
public class XmlConfigOptions
Public Class XmlConfigOptions
public ref class XmlConfigOptions
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlConfigOptions()()()() | Initializes a new instance of the XmlConfigOptions class
 | CompositeElementNodeName | Gets or sets the name of the composite element node.
 | ElementNodeName | Gets or sets the name of the element node.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HeaderNode |
 | Indent | Gets or sets a value indicating whether indentation occurs
 | LoopNodeName | Gets or sets the name of the loop node.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SegmentNodeName | Gets or sets the name of the segment node.
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlConfigOptions

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


XmlConfigOptions Constructor

XmlConfigOptions Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► XmlConfigOptions()()()()
Initializes a new instance of the XmlConfigOptions class
Declaration Syntax
C# Visual Basic Visual C++
public XmlConfigOptions()
Public Sub New
public:
XmlConfigOptions()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementNodeName Property

CompositeElementNodeName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► CompositeElementNodeName
Gets or sets the name of the composite element node.
Declaration Syntax
C# Visual Basic Visual C++
public string CompositeElementNodeName { get; set; }
Public Property CompositeElementNodeName As String
    Get
    Set
public:
property String^ CompositeElementNodeName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the composite element node.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNodeName Property

ElementNodeName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► ElementNodeName
Gets or sets the name of the element node.
Declaration Syntax
C# Visual Basic Visual C++
public string ElementNodeName { get; set; }
Public Property ElementNodeName As String
    Get
    Set
public:
property String^ ElementNodeName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the element node.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


HeaderNode Property

HeaderNode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► HeaderNode
Declaration Syntax
C# Visual Basic Visual C++
public string HeaderNode { get; set; }
Public Property HeaderNode As String
    Get
    Set
public:
property String^ HeaderNode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Indent Property

Indent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► Indent
Gets or sets a value indicating whether indentation occurs
Declaration Syntax
C# Visual Basic Visual C++
public bool Indent { get; set; }
Public Property Indent As Boolean
    Get
    Set
public:
property bool Indent {
    bool get ();
    void set (bool value);
}
Value
true if indent; otherwise, false.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LoopNodeName Property

LoopNodeName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► LoopNodeName
Gets or sets the name of the loop node.
Declaration Syntax
C# Visual Basic Visual C++
public string LoopNodeName { get; set; }
Public Property LoopNodeName As String
    Get
    Set
public:
property String^ LoopNodeName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the loop node.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentNodeName Property

SegmentNodeName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► XmlConfigOptions ► SegmentNodeName
Gets or sets the name of the segment node.
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentNodeName { get; set; }
Public Property SegmentNodeName As String
    Get
    Set
public:
property String^ SegmentNodeName {
    String^ get ();
    void set (String^ value);
}
Value
The name of the segment node.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RDPCrystalEDILibrary.Documents Namespace

RDPCrystalEDILibrary.Documents Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.Documents
Namespace RDPCrystalEDILibrary.Documents
namespace RDPCrystalEDILibrary.Documents
Types
All Types Classes
Icon | Type | Description
 | CompositeElement |
 | DocumentLoop | Represents a loop in an EDI document. For example, FUNCTIONAL GROUP,ST HEADER,1000B etc
 | DocumentSegment | Represents a Segment
 | TypedEDIDocument | Base class of all Typed EDI Document. Subclass this class if you need to create your own typed document that we don't support
 | WriteArguments | Arguments to pass in for EDI file creation


CompositeElement Class

CompositeElement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► CompositeElement
Declaration Syntax
C# Visual Basic Visual C++
public abstract class CompositeElement
Public MustInherit Class CompositeElement
public ref class CompositeElement abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CompositeElement()()()() | Initializes a new instance of the CompositeElement class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) |
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) |
Inheritance Hierarchy
Object
 | CompositeElement
 |  | AdjustmentIdentifier
 |  | CompositeDiagnosticCodePointer
 |  | CompositeMedicalProcedureIdentifier
 |  | CompositeUnitOfMeasure
 |  | ContextIndentification
 |  | HealthCareClaimStatus
 |  | HealthCareCodeInformation
 |  | HealthCareServiceLocation
 |  | OralCavityDesign
 |  | PositionInSegment
 |  | ReferenceInSegment
 |  | RelatedCausesInformation
 |  | ToothSurface

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeElement Constructor

CompositeElement Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► CompositeElement ► CompositeElement()()()()
Initializes a new instance of the CompositeElement class
Declaration Syntax
C# Visual Basic Visual C++
protected CompositeElement()
Protected Sub New
protected:
CompositeElement()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► CompositeElement ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public abstract string GetString(
    char compElemSep
)
Public MustOverride Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) abstract
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (compElemSep, elements)

Write Method (compElemSep, elements)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► CompositeElement ► Write(Char, List<(Of <<'(String>)>>))
Declaration Syntax
C# Visual Basic Visual C++
protected string Write(
    char compElemSep,
    List<string> elements
)
Protected Function Write ( _
    compElemSep As Char, _
    elements As List(Of String) _
) As String
protected:
String^ Write(
    wchar_t compElemSep,
    List<String^>^ elements
)
Parameters
compElemSep (Char)
elements (List <(Of <(<' String >)>)>)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DocumentLoop Class

DocumentLoop Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop
Represents a loop in an EDI document. For example, FUNCTIONAL GROUP,ST HEADER,1000B etc
Declaration Syntax
C# Visual Basic Visual C++
public class DocumentLoop
Public Class DocumentLoop
public ref class DocumentLoop
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocumentLoop(String) | Initializes a new instance of the DocumentLoop class.
 | Add(DocumentSegment) | Adds the specified segment.
 | Add(DocumentLoop) | Adds the specified loop.
 | CreateLoop(String) | Creates a new child loop
 | CreateSegment<(Of <<'(T>)>>)()()()() | Creates a segment in this loop
 | DocumentSegments | Gets the segments in this loop
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLoop(String) | Gets the loop.
 | GetLoops(String) | Gets the loops.
 | GetSegment(String) | Gets the segment by name
 | GetSegment<(Of <<'(T>)>>)()()()() | Gets the segment.
 | GetSegments(String) | Gets the segments by name
 | GetSegments<(Of <<'(T>)>>)(String) | Gets the segments by name and type
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Loops | Gets the loops
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the loop name
 | ToString()()()() | Returns a String that represents this instance. (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
DocumentLoop

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DocumentLoop Constructor (name)

DocumentLoop Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► DocumentLoop(String)
Initializes a new instance of the DocumentLoop class.
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLoop(
    string name
)
Public Sub New ( _
    name As String _
)
public:
DocumentLoop(
    String^ name
)
Parameters
name (String)
Name of the Loop

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Add Method

Add Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► Add()()()()
Members
Icon | Member | Description
 | Add(DocumentSegment) | Adds the specified segment.
 | Add(DocumentLoop) | Adds the specified loop.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Add Method (loop)

Add Method (loop)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► Add(DocumentLoop)
Adds the specified loop.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    DocumentLoop loop
)
Public Sub Add ( _
    loop As DocumentLoop _
)
public:
void Add(
    DocumentLoop^ loop
)
Parameters
loop (DocumentLoop)
The loop.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Add Method (segment)

Add Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► Add(DocumentSegment)
Adds the specified segment.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    DocumentSegment segment
)
Public Sub Add ( _
    segment As DocumentSegment _
)
public:
void Add(
    DocumentSegment^ segment
)
Parameters
segment (DocumentSegment)
The segment.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CreateLoop Method (name)

CreateLoop Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► CreateLoop(String)
Creates a new child loop
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLoop CreateLoop(
    string name
)
Public Function CreateLoop ( _
    name As String _
) As DocumentLoop
public:
DocumentLoop^ CreateLoop(
    String^ name
)
Parameters
name (String)
Name of the child loop
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CreateSegment Method

CreateSegment<(Of <(<'T>)>)> Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► CreateSegment<(Of <<'(T>)>>)()()()()
Creates a segment in this loop
Declaration Syntax
C# Visual Basic Visual C++
public T CreateSegment<T>()
where T : new(), DocumentSegment

Public Function CreateSegment(Of T As {New, DocumentSegment}) As T
public:
generic<typename T>
where T : gcnew(), DocumentSegment
T CreateSegment()
Generic Template Parameters
T
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DocumentSegments Property

DocumentSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► DocumentSegments
Gets the segments in this loop
Declaration Syntax
C# Visual Basic Visual C++
public List<DocumentSegment> DocumentSegments { get; }
Public ReadOnly Property DocumentSegments As List(Of DocumentSegment)
    Get
public:
property List<DocumentSegment^>^ DocumentSegments {
    List<DocumentSegment^>^ get ();
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetLoop Method (name)

GetLoop Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► GetLoop(String)
Gets the loop.
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLoop GetLoop(
    string name
)
Public Function GetLoop ( _
    name As String _
) As DocumentLoop
public:
DocumentLoop^ GetLoop(
    String^ name
)
Parameters
name (String)
Name of the loop.
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetLoops Method (name)

GetLoops Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► GetLoops(String)
Gets the loops.
Declaration Syntax
C# Visual Basic Visual C++
public List<DocumentLoop> GetLoops(
    string name
)
Public Function GetLoops ( _
    name As String _
) As List(Of DocumentLoop)
public:
List<DocumentLoop^>^ GetLoops(
    String^ name
)
Parameters
name (String)
Name of the loop.
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetSegment Method

GetSegment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► GetSegment()()()()
Members
Icon | Member | Description
 | GetSegment(String) | Gets the segment by name
 | GetSegment<(Of <<'(T>)>>)()()()() | Gets the segment.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetSegment Method

GetSegment<(Of <(<'T>)>)> Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► GetSegment<(Of <<'(T>)>>)()()()()
Gets the segment.
Declaration Syntax
C# Visual Basic Visual C++
public T GetSegment<T>()
where T : DocumentSegment

Public Function GetSegment(Of T As DocumentSegment) As T
public:
generic<typename T>
where T : DocumentSegment
T GetSegment()
Generic Template Parameters
T
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetSegment Method (name)

GetSegment Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► GetSegment(String)
Gets the segment by name
Declaration Syntax
C# Visual Basic Visual C++
public DocumentSegment GetSegment(
    string name
)
Public Function GetSegment ( _
    name As String _
) As DocumentSegment
public:
DocumentSegment^ GetSegment(
    String^ name
)
Parameters
name (String)
Name of the segment
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetSegments Method

GetSegments Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► GetSegments()()()()
Members
Icon | Member | Description
 | GetSegments(String) | Gets the segments by name
 | GetSegments<(Of <<'(T>)>>)(String) | Gets the segments by name and type

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetSegments Method (name)

GetSegments<(Of <(<'T>)>)> Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► GetSegments<(Of <<'(T>)>>)(String)
Gets the segments by name and type
Declaration Syntax
C# Visual Basic Visual C++
public List<T> GetSegments<T>(
    string name
)
where T : DocumentSegment

Public Function GetSegments(Of T As DocumentSegment) ( _
    name As String _
) As List(Of T)
public:
generic<typename T>
where T : DocumentSegment
List<T>^ GetSegments(
    String^ name
)
Generic Template Parameters
T
Parameters
name (String)
Name of the segment.
Return Value
A list of segments

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetSegments Method (name)

GetSegments Method (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► GetSegments(String)
Gets the segments by name
Declaration Syntax
C# Visual Basic Visual C++
public List<DocumentSegment> GetSegments(
    string name
)
Public Function GetSegments ( _
    name As String _
) As List(Of DocumentSegment)
public:
List<DocumentSegment^>^ GetSegments(
    String^ name
)
Parameters
name (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Loops Property

Loops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► Loops
Gets the loops
Declaration Syntax
C# Visual Basic Visual C++
public List<DocumentLoop> Loops { get; }
Public ReadOnly Property Loops As List(Of DocumentLoop)
    Get
public:
property List<DocumentLoop^>^ Loops {
    List<DocumentLoop^>^ get ();
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► Name
Gets or sets the loop name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; private set; }
Public Property Name As String
    Get
    Private Set
public:
property String^ Name {
    String^ get ();
    private: void set (String^ value);
}
Value
The name.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentLoop ► ToString()()()()
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DocumentSegment Class

DocumentSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment
Represents a Segment
Declaration Syntax
C# Visual Basic Visual C++
public abstract class DocumentSegment
Public MustInherit Class DocumentSegment
public ref class DocumentSegment abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DocumentSegment()()()() | Initializes a new instance of the DocumentSegment class.
 | DocumentSegment(String) | Initializes a new instance of the DocumentSegment class.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value.
 | Load(LightWeightSegment) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name.
 | PadDataValue(Int32, Int32, String, Char) |
 | ToString()()()() | Returns a String that represents this instance. (Overrides Object.ToString()()()().)
 | Write(WriteArguments) | Writes the specified write args.
 | WriteToBuffer(WriteArguments) | Writes to buffer.
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AAA
 |  | ACT
 |  | AK1
 |  | AK2
 |  | AK9
 |  | AMT
 |  | BGN
 |  | BHT
 |  | BPR
 |  | CAS
 |  | CL1
 |  | CLM
 |  | CLP
 |  | CN1
 |  | COB
 |  | CR1
 |  | CR2
 |  | CR3
 |  | CRC
 |  | CTP
 |  | CTX
 |  | CUR
 |  | DMG
 |  | DN1
 |  | DN2
 |  | DSB
 |  | DTM
 |  | DTP
 |  | EB
 |  | EC
 |  | EQ
 |  | FRM
 |  | GE
 |  | GS
 |  | HCP
 |  | HD
 |  | HI
 |  | HL
 |  | HLH
 |  | HSD
 |  | ICM
 |  | IDC
 |  | IEA
 |  | III
 |  | IK3
 |  | IK4
 |  | IK5
 |  | INS
 |  | ISA
 |  | K3
 |  | LE
 |  | LIN
 |  | LQ
 |  | LS
 |  | LUI
 |  | LX
 |  | MEA
 |  | MIA
 |  | MOA
 |  | MPI
 |  | N1
 |  | N3
 |  | N4
 |  | NM1
 |  | NTE
 |  | OI
 |  | PAT
 |  | PER
 |  | PLA
 |  | PLB
 |  | PRV
 |  | PS1
 |  | PWK
 |  | QTY
 |  | RDM
 |  | REF
 |  | SBR
 |  | SE
 |  | ST
 |  | STC
 |  | SV1
 |  | SV2
 |  | SV3
 |  | SV5
 |  | SVC
 |  | SVD
 |  | TOO
 |  | TRN
 |  | TS2
 |  | TS3

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DocumentSegment Constructor

DocumentSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► DocumentSegment()()()()
Members
Icon | Member | Description
 | DocumentSegment()()()() | Initializes a new instance of the DocumentSegment class.
 | DocumentSegment(String) | Initializes a new instance of the DocumentSegment class.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DocumentSegment Constructor

DocumentSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► DocumentSegment()()()()
Initializes a new instance of the DocumentSegment class.
Declaration Syntax
C# Visual Basic Visual C++
public DocumentSegment()
Public Sub New
public:
DocumentSegment()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DocumentSegment Constructor (name)

DocumentSegment Constructor (name)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► DocumentSegment(String)
Initializes a new instance of the DocumentSegment class.
Declaration Syntax
C# Visual Basic Visual C++
public DocumentSegment(
    string name
)
Public Sub New ( _
    name As String _
)
public:
DocumentSegment(
    String^ name
)
Parameters
name (String)
Name of segment

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetValue Method (element)

GetValue Method (element)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► GetValue(LightWeightElement)
Gets the value.
Declaration Syntax
C# Visual Basic Visual C++
protected string GetValue(
    LightWeightElement element
)
Protected Function GetValue ( _
    element As LightWeightElement _
) As String
protected:
String^ GetValue(
    LightWeightElement^ element
)
Parameters
element (LightWeightElement)
The element.
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Load(
    LightWeightSegment segment
)
Public Overridable Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
)
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► Name
Gets or sets the name.
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
The name.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PadDataValue Method (minLength, maxLength, dataValue, paddingChar)

PadDataValue Method (minLength, maxLength, dataValue, paddingChar)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► PadDataValue(Int32, Int32, String, Char)
Declaration Syntax
C# Visual Basic Visual C++
protected string PadDataValue(
    int minLength,
    int maxLength,
    string dataValue,
    char paddingChar
)
Protected Function PadDataValue ( _
    minLength As Integer, _
    maxLength As Integer, _
    dataValue As String, _
    paddingChar As Char _
) As String
protected:
String^ PadDataValue(
    int minLength,
    int maxLength,
    String^ dataValue,
    wchar_t paddingChar
)
Parameters
minLength (Int32)
maxLength (Int32)
dataValue (String)
paddingChar (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► ToString()()()()
Returns a String that represents this instance.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value
A String that represents this instance.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (writeArgs)

Write Method (writeArgs)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► Write(WriteArguments)
Writes the specified write args.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Write(
    WriteArguments writeArgs
)
Public Overridable Sub Write ( _
    writeArgs As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ writeArgs
)
Parameters
writeArgs (WriteArguments)
The write args.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


WriteToBuffer Method (w)

WriteToBuffer Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► DocumentSegment ► WriteToBuffer(WriteArguments)
Writes to buffer.
Declaration Syntax
C# Visual Basic Visual C++
protected void WriteToBuffer(
    WriteArguments w
)
Protected Sub WriteToBuffer ( _
    w As WriteArguments _
)
protected:
void WriteToBuffer(
    WriteArguments^ w
)
Parameters
w (WriteArguments)
The w.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TypedEDIDocument Class

TypedEDIDocument Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument
Base class of all Typed EDI Document. Subclass this class if you need to create your own typed document that we don't support
Declaration Syntax
C# Visual Basic Visual C++
public abstract class TypedEDIDocument
Public MustInherit Class TypedEDIDocument
public ref class TypedEDIDocument abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TypedEDIDocument()()()() | Initializes a new instance of the TypedEDIDocument class.
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) Element 1 or UNT segment (EDIFACT)
 | AutoPlaceNumOfFunctionalGroups | Places the correct number of functional groups in the IEA segment Element 1(X12)
 | AutoPlaceNumOfTransactions | Places the correct number of transaction in the GE segment Element 1(X12)
 | DestroySegmentsAfter | Gets or sets a value indicating whether a segment should be set to null after it's been loaded from EDILightWeightDocument
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document
 | GetDocumentSegment(String) | Gets the document segment when this document is being loading from an EDILightweightDocument
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(EDILightWeightDocument) | Loads the specified light weight document.
 | MainSection | Gets or sets the main section of the TypedDocument
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PadISAElementValues | Pads or trims the ISA elements to conform to HIPAA
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypedEDIDocument
 |  | X125010Document

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TypedEDIDocument Constructor

TypedEDIDocument Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► TypedEDIDocument()()()()
Initializes a new instance of the TypedEDIDocument class.
Declaration Syntax
C# Visual Basic Visual C++
public TypedEDIDocument()
Public Sub New
public:
TypedEDIDocument()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceCorrectNumOfSegments Property

AutoPlaceCorrectNumOfSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► AutoPlaceCorrectNumOfSegments
Places the correct number of segments in the SE segment (X12) Element 1 or UNT segment (EDIFACT)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceCorrectNumOfSegments { get; set; }
Public Property AutoPlaceCorrectNumOfSegments As Boolean
    Get
    Set
public:
property bool AutoPlaceCorrectNumOfSegments {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceNumOfFunctionalGroups Property

AutoPlaceNumOfFunctionalGroups Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► AutoPlaceNumOfFunctionalGroups
Places the correct number of functional groups in the IEA segment Element 1(X12)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceNumOfFunctionalGroups { get; set; }
Public Property AutoPlaceNumOfFunctionalGroups As Boolean
    Get
    Set
public:
property bool AutoPlaceNumOfFunctionalGroups {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AutoPlaceNumOfTransactions Property

AutoPlaceNumOfTransactions Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► AutoPlaceNumOfTransactions
Places the correct number of transaction in the GE segment Element 1(X12)
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoPlaceNumOfTransactions { get; set; }
Public Property AutoPlaceNumOfTransactions As Boolean
    Get
    Set
public:
property bool AutoPlaceNumOfTransactions {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DestroySegmentsAfter Property

DestroySegmentsAfter Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► DestroySegmentsAfter
Gets or sets a value indicating whether a segment should be set to null after it's been loaded from EDILightWeightDocument
Declaration Syntax
C# Visual Basic Visual C++
public bool DestroySegmentsAfter { get; set; }
Public Property DestroySegmentsAfter As Boolean
    Get
    Set
public:
property bool DestroySegmentsAfter {
    bool get ();
    void set (bool value);
}
Value
true if destroy segments after; otherwise, false.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► GenerateEDIFile()()()()
Members
Icon | Member | Description
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method (delimiters, file)

GenerateEDIFile Method (delimiters, file)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► GenerateEDIFile(Delimiters, String)
Generate EDI data from the underlying document and writes it to a file
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    Delimiters delimiters,
    string file
)
Public Sub GenerateEDIFile ( _
    delimiters As Delimiters, _
    file As String _
)
public:
void GenerateEDIFile(
    Delimiters^ delimiters,
    String^ file
)
Parameters
delimiters (Delimiters)
delimiters
file (String)
filename
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method (writeArguments, file)

GenerateEDIFile Method (writeArguments, file)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► GenerateEDIFile(WriteArguments, String)
Generate EDI data from the underlying document
Declaration Syntax
C# Visual Basic Visual C++
public void GenerateEDIFile(
    WriteArguments writeArguments,
    string file
)
Public Sub GenerateEDIFile ( _
    writeArguments As WriteArguments, _
    file As String _
)
public:
void GenerateEDIFile(
    WriteArguments^ writeArguments,
    String^ file
)
Parameters
writeArguments (WriteArguments)
writeArguments
file (String)
filename

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetDocumentSegment Method (segmentName)

GetDocumentSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► GetDocumentSegment(String)
Gets the document segment when this document is being loading from an EDILightweightDocument
Declaration Syntax
C# Visual Basic Visual C++
protected virtual DocumentSegment GetDocumentSegment(
    string segmentName
)
Protected Overridable Function GetDocumentSegment ( _
    segmentName As String _
) As DocumentSegment
protected:
virtual DocumentSegment^ GetDocumentSegment(
    String^ segmentName
)
Parameters
segmentName (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (lightWeightDocument)

Load Method (lightWeightDocument)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► Load(EDILightWeightDocument)
Loads the specified light weight document.
Declaration Syntax
C# Visual Basic Visual C++
public void Load(
    EDILightWeightDocument lightWeightDocument
)
Public Sub Load ( _
    lightWeightDocument As EDILightWeightDocument _
)
public:
void Load(
    EDILightWeightDocument^ lightWeightDocument
)
Parameters
lightWeightDocument (EDILightWeightDocument)
The light weight document.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MainSection Property

MainSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► MainSection
Gets or sets the main section of the TypedDocument
Declaration Syntax
C# Visual Basic Visual C++
public DocumentLoop MainSection { get; set; }
Public Property MainSection As DocumentLoop
    Get
    Set
public:
property DocumentLoop^ MainSection {
    DocumentLoop^ get ();
    void set (DocumentLoop^ value);
}
Value
The main section.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PadISAElementValues Property

PadISAElementValues Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► PadISAElementValues
Pads or trims the ISA elements to conform to HIPAA
Declaration Syntax
C# Visual Basic Visual C++
public bool PadISAElementValues { get; set; }
Public Property PadISAElementValues As Boolean
    Get
    Set
public:
property bool PadISAElementValues {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToEDIString Method

ToEDIString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► ToEDIString()()()()
Members
Icon | Member | Description
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToEDIString Method (delimiters)

ToEDIString Method (delimiters)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► ToEDIString(Delimiters)
Generate EDI data from the underlying document
Declaration Syntax
C# Visual Basic Visual C++
public string ToEDIString(
    Delimiters delimiters
)
Public Function ToEDIString ( _
    delimiters As Delimiters _
) As String
public:
String^ ToEDIString(
    Delimiters^ delimiters
)
Parameters
delimiters (Delimiters)
delimiters
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToEDIString Method (args)

ToEDIString Method (args)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► TypedEDIDocument ► ToEDIString(WriteArguments)
Generate EDI data from the underlying document
Declaration Syntax
C# Visual Basic Visual C++
public string ToEDIString(
    WriteArguments args
)
Public Function ToEDIString ( _
    args As WriteArguments _
) As String
public:
String^ ToEDIString(
    WriteArguments^ args
)
Parameters
args (WriteArguments)
Write Arguments
Return Value
an EDI string

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


WriteArguments Class

WriteArguments Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► WriteArguments
Arguments to pass in for EDI file creation
Declaration Syntax
C# Visual Basic Visual C++
public class WriteArguments
Public Class WriteArguments
public ref class WriteArguments
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WriteArguments()()()() | Initializes a new instance of the WriteArguments class
 | Delimiters |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLineAfterSegment | Whether or not to insert a new line after every segment
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Values |
Inheritance Hierarchy
Object
WriteArguments

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


WriteArguments Constructor

WriteArguments Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► WriteArguments ► WriteArguments()()()()
Initializes a new instance of the WriteArguments class
Declaration Syntax
C# Visual Basic Visual C++
public WriteArguments()
Public Sub New
public:
WriteArguments()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Delimiters Field

Delimiters Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► WriteArguments ► Delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters
Public Delimiters As Delimiters
public:
Delimiters^ Delimiters

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NewLineAfterSegment Field

NewLineAfterSegment Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► WriteArguments ► NewLineAfterSegment
Whether or not to insert a new line after every segment
Declaration Syntax
C# Visual Basic Visual C++
public bool NewLineAfterSegment
Public NewLineAfterSegment As Boolean
public:
bool NewLineAfterSegment

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents ► WriteArguments ► Values
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Values
Public Values As List(Of String)
public:
List<String^>^ Values

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RDPCrystalEDILibrary.Documents.X12 Namespace

RDPCrystalEDILibrary.Documents.X12 Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.Documents.X12
Namespace RDPCrystalEDILibrary.Documents.X12
namespace RDPCrystalEDILibrary.Documents.X12
Types
All Types Classes
Icon | Type | Description
 | X125010Document | Represents an X12 HIPAA 5010 Document


X125010Document Class

X125010Document Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12 ► X125010Document
Represents an X12 HIPAA 5010 Document
Declaration Syntax
C# Visual Basic Visual C++
public class X125010Document : TypedEDIDocument
Public Class X125010Document _
    Inherits TypedEDIDocument
public ref class X125010Document : public TypedEDIDocument
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | X125010Document()()()() | Initializes a new instance of the X125010Document class.
 | X125010Document(EDILightWeightDocument) | Initializes a new instance of the X125010Document class.
 | AutoPlaceCorrectNumOfSegments | Places the correct number of segments in the SE segment (X12) Element 1 or UNT segment (EDIFACT) (Inherited from TypedEDIDocument.)
 | AutoPlaceNumOfFunctionalGroups | Places the correct number of functional groups in the IEA segment Element 1(X12) (Inherited from TypedEDIDocument.)
 | AutoPlaceNumOfTransactions | Places the correct number of transaction in the GE segment Element 1(X12) (Inherited from TypedEDIDocument.)
 | DestroySegmentsAfter | Gets or sets a value indicating whether a segment should be set to null after it's been loaded from EDILightWeightDocument (Inherited from TypedEDIDocument.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file (Inherited from TypedEDIDocument.)
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document (Inherited from TypedEDIDocument.)
 | GetDocumentSegment(String) | Gets the document item. (Overrides TypedEDIDocument.GetDocumentSegment(String).)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load(EDILightWeightDocument) | Loads the specified light weight document. (Inherited from TypedEDIDocument.)
 | MainSection | Gets or sets the main section of the TypedDocument (Inherited from TypedEDIDocument.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PadISAElementValues | Pads or trims the ISA elements to conform to HIPAA (Inherited from TypedEDIDocument.)
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document (Inherited from TypedEDIDocument.)
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document (Inherited from TypedEDIDocument.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypedEDIDocument
 |  | X125010Document

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


X125010Document Constructor

X125010Document Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12 ► X125010Document ► X125010Document()()()()
Members
Icon | Member | Description
 | X125010Document()()()() | Initializes a new instance of the X125010Document class.
 | X125010Document(EDILightWeightDocument) | Initializes a new instance of the X125010Document class.

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


X125010Document Constructor

X125010Document Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12 ► X125010Document ► X125010Document()()()()
Initializes a new instance of the X125010Document class.
Declaration Syntax
C# Visual Basic Visual C++
public X125010Document()
Public Sub New
public:
X125010Document()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


X125010Document Constructor (document)

X125010Document Constructor (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12 ► X125010Document ► X125010Document(EDILightWeightDocument)
Initializes a new instance of the X125010Document class.
Declaration Syntax
C# Visual Basic Visual C++
public X125010Document(
    EDILightWeightDocument document
)
Public Sub New ( _
    document As EDILightWeightDocument _
)
public:
X125010Document(
    EDILightWeightDocument^ document
)
Parameters
document (EDILightWeightDocument)
The document to initialize from

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetDocumentSegment Method (segmentName)

GetDocumentSegment Method (segmentName)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12 ► X125010Document ► GetDocumentSegment(String)
Gets the document item.
Declaration Syntax
C# Visual Basic Visual C++
protected override DocumentSegment GetDocumentSegment(
    string segmentName
)
Protected Overrides Function GetDocumentSegment ( _
    segmentName As String _
) As DocumentSegment
protected:
virtual DocumentSegment^ GetDocumentSegment(
    String^ segmentName
) override
Parameters
segmentName (String)
Name of the segment.
Return Value

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RDPCrystalEDILibrary.Documents.X12.IG5010.Segments Namespace

RDPCrystalEDILibrary.Documents.X12.IG5010.Segments Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.Documents.X12.IG5010.Segments
Namespace RDPCrystalEDILibrary.Documents.X12.IG5010.Segments
namespace RDPCrystalEDILibrary.Documents.X12.IG5010.Segments
Types
All Types Classes
Icon | Type | Description
 | AAA |
 | ACT |
 | AdjustmentIdentifier |
 | AK1 |
 | AK2 |
 | AK9 |
 | AMT |
 | BGN |
 | BHT |
 | BPR |
 | CAS |
 | CL1 |
 | CLM |
 | CLP |
 | CN1 |
 | COB |
 | CompositeDiagnosticCodePointer |
 | CompositeMedicalProcedureIdentifier |
 | CompositeUnitOfMeasure |
 | ContextIndentification |
 | CR1 |
 | CR2 |
 | CR3 |
 | CRC |
 | CTP |
 | CTX |
 | CUR |
 | DMG |
 | DN1 |
 | DN2 |
 | DSB |
 | DTM |
 | DTP |
 | EB |
 | EC |
 | EQ |
 | FRM |
 | GE |
 | GS |
 | HCP |
 | HD |
 | HealthCareClaimStatus |
 | HealthCareCodeInformation |
 | HealthCareServiceLocation |
 | HI |
 | HL |
 | HLH |
 | HSD |
 | ICM |
 | IDC |
 | IEA |
 | III |
 | IK3 |
 | IK4 |
 | IK5 |
 | INS |
 | ISA |
 | K3 |
 | LE |
 | LIN |
 | LQ |
 | LS |
 | LUI |
 | LX |
 | MEA |
 | MIA |
 | MOA |
 | MPI |
 | N1 |
 | N3 |
 | N4 |
 | NM1 |
 | NTE |
 | OI |
 | OralCavityDesign |
 | PAT |
 | PER |
 | PLA |
 | PLB |
 | PositionInSegment |
 | PRV |
 | PS1 |
 | PWK |
 | QTY |
 | RDM |
 | REF |
 | ReferenceInSegment |
 | RelatedCausesInformation |
 | SBR |
 | SE |
 | ST |
 | STC |
 | SV1 |
 | SV2 |
 | SV3 |
 | SV5 |
 | SVC |
 | SVD |
 | TOO |
 | ToothSurface |
 | TRN |
 | TS2 |
 | TS3 |


AAA Class

AAA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AAA
Declaration Syntax
C# Visual Basic Visual C++
public class AAA : DocumentSegment
Public Class AAA _
    Inherits DocumentSegment
public ref class AAA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AAA()()()() | Initializes a new instance of the AAA class
 | AgencyQualifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FollowupActionCode |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RejectReasonCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AAA

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AAA Constructor

AAA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AAA ► AAA()()()()
Initializes a new instance of the AAA class
Declaration Syntax
C# Visual Basic Visual C++
public AAA()
Public Sub New
public:
AAA()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AgencyQualifierCode Property

AgencyQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AAA ► AgencyQualifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string AgencyQualifierCode { get; set; }
Public Property AgencyQualifierCode As String
    Get
    Set
public:
property String^ AgencyQualifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FollowupActionCode Property

FollowupActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AAA ► FollowupActionCode
Declaration Syntax
C# Visual Basic Visual C++
public string FollowupActionCode { get; set; }
Public Property FollowupActionCode As String
    Get
    Set
public:
property String^ FollowupActionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AAA ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RejectReasonCode Property

RejectReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AAA ► RejectReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string RejectReasonCode { get; set; }
Public Property RejectReasonCode As String
    Get
    Set
public:
property String^ RejectReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AAA ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AAA ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ACT Class

ACT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT
Declaration Syntax
C# Visual Basic Visual C++
public class ACT : DocumentSegment
Public Class ACT _
    Inherits DocumentSegment
public ref class ACT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ACT()()()() | Initializes a new instance of the ACT class
 | AccountNumber1 |
 | AccountNumber2 |
 | AccountNumberQualifier |
 | BenefitStatusCode |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode |
 | IdentificationCodeQualifier |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodTypeCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ACT

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ACT Constructor

ACT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► ACT()()()()
Initializes a new instance of the ACT class
Declaration Syntax
C# Visual Basic Visual C++
public ACT()
Public Sub New
public:
ACT()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumber1 Property

AccountNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► AccountNumber1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber1 { get; set; }
Public Property AccountNumber1 As String
    Get
    Set
public:
property String^ AccountNumber1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumber2 Property

AccountNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► AccountNumber2
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber2 { get; set; }
Public Property AccountNumber2 As String
    Get
    Set
public:
property String^ AccountNumber2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumberQualifier Property

AccountNumberQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► AccountNumberQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier { get; set; }
Public Property AccountNumberQualifier As String
    Get
    Set
public:
property String^ AccountNumberQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BenefitStatusCode Property

BenefitStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► BenefitStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string BenefitStatusCode { get; set; }
Public Property BenefitStatusCode As String
    Get
    Set
public:
property String^ BenefitStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► IdentificationCode
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► IdentificationCodeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PaymentMethodTypeCode Property

PaymentMethodTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► PaymentMethodTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodTypeCode { get; set; }
Public Property PaymentMethodTypeCode As String
    Get
    Set
public:
property String^ PaymentMethodTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ACT ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentIdentifier Class

AdjustmentIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AdjustmentIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public class AdjustmentIdentifier : CompositeElement
Public Class AdjustmentIdentifier _
    Inherits CompositeElement
public ref class AdjustmentIdentifier : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AdjustmentIdentifier()()()() | Initializes a new instance of the AdjustmentIdentifier class
 | AdjustmentReasonCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReferenceIdentification |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | AdjustmentIdentifier

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentIdentifier Constructor

AdjustmentIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AdjustmentIdentifier ► AdjustmentIdentifier()()()()
Initializes a new instance of the AdjustmentIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier()
Public Sub New
public:
AdjustmentIdentifier()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentReasonCode Property

AdjustmentReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AdjustmentIdentifier ► AdjustmentReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string AdjustmentReasonCode { get; set; }
Public Property AdjustmentReasonCode As String
    Get
    Set
public:
property String^ AdjustmentReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AdjustmentIdentifier ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AdjustmentIdentifier ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AK1 Class

AK1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK1
Declaration Syntax
C# Visual Basic Visual C++
public class AK1 : DocumentSegment
Public Class AK1 _
    Inherits DocumentSegment
public ref class AK1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK1()()()() | Initializes a new instance of the AK1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalIdentifierCode |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionReleaseIndustryIdentifierCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AK1 Constructor

AK1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK1 ► AK1()()()()
Initializes a new instance of the AK1 class
Declaration Syntax
C# Visual Basic Visual C++
public AK1()
Public Sub New
public:
AK1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FunctionalIdentifierCode Property

FunctionalIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK1 ► FunctionalIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalIdentifierCode { get; set; }
Public Property FunctionalIdentifierCode As String
    Get
    Set
public:
property String^ FunctionalIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK1 ► GroupControlNumber
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


VersionReleaseIndustryIdentifierCode Property

VersionReleaseIndustryIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK1 ► VersionReleaseIndustryIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string VersionReleaseIndustryIdentifierCode { get; set; }
Public Property VersionReleaseIndustryIdentifierCode As String
    Get
    Set
public:
property String^ VersionReleaseIndustryIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AK2 Class

AK2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK2
Declaration Syntax
C# Visual Basic Visual C++
public class AK2 : DocumentSegment
Public Class AK2 _
    Inherits DocumentSegment
public ref class AK2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK2()()()() | Initializes a new instance of the AK2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationConventionReference |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber |
 | TransactionSetIdentifierCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK2

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AK2 Constructor

AK2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK2 ► AK2()()()()
Initializes a new instance of the AK2 class
Declaration Syntax
C# Visual Basic Visual C++
public AK2()
Public Sub New
public:
AK2()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ImplementationConventionReference Property

ImplementationConventionReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK2 ► ImplementationConventionReference
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationConventionReference { get; set; }
Public Property ImplementationConventionReference As String
    Get
    Set
public:
property String^ ImplementationConventionReference {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK2 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK2 ► TransactionSetControlNumber
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK2 ► TransactionSetIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK2 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AK9 Class

AK9 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9
Declaration Syntax
C# Visual Basic Visual C++
public class AK9 : DocumentSegment
Public Class AK9 _
    Inherits DocumentSegment
public ref class AK9 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AK9()()()() | Initializes a new instance of the AK9 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalGroupAcknowledgmentCode |
 | FunctionalGroupSyntaxErrorCode1 |
 | FunctionalGroupSyntaxErrorCode2 |
 | FunctionalGroupSyntaxErrorCode3 |
 | FunctionalGroupSyntaxErrorCode4 |
 | FunctionalGroupSyntaxErrorCode5 |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfAcceptedTransactionSets |
 | NumberOfReceivedTransactionSets |
 | NumberOfTransactionSetsIncluded |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AK9

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AK9 Constructor

AK9 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► AK9()()()()
Initializes a new instance of the AK9 class
Declaration Syntax
C# Visual Basic Visual C++
public AK9()
Public Sub New
public:
AK9()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FunctionalGroupAcknowledgmentCode Property

FunctionalGroupAcknowledgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► FunctionalGroupAcknowledgmentCode
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupAcknowledgmentCode { get; set; }
Public Property FunctionalGroupAcknowledgmentCode As String
    Get
    Set
public:
property String^ FunctionalGroupAcknowledgmentCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FunctionalGroupSyntaxErrorCode1 Property

FunctionalGroupSyntaxErrorCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► FunctionalGroupSyntaxErrorCode1
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode1 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode1 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FunctionalGroupSyntaxErrorCode2 Property

FunctionalGroupSyntaxErrorCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► FunctionalGroupSyntaxErrorCode2
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode2 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode2 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FunctionalGroupSyntaxErrorCode3 Property

FunctionalGroupSyntaxErrorCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► FunctionalGroupSyntaxErrorCode3
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode3 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode3 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FunctionalGroupSyntaxErrorCode4 Property

FunctionalGroupSyntaxErrorCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► FunctionalGroupSyntaxErrorCode4
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode4 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode4 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FunctionalGroupSyntaxErrorCode5 Property

FunctionalGroupSyntaxErrorCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► FunctionalGroupSyntaxErrorCode5
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalGroupSyntaxErrorCode5 { get; set; }
Public Property FunctionalGroupSyntaxErrorCode5 As String
    Get
    Set
public:
property String^ FunctionalGroupSyntaxErrorCode5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NumberOfAcceptedTransactionSets Property

NumberOfAcceptedTransactionSets Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► NumberOfAcceptedTransactionSets
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfAcceptedTransactionSets { get; set; }
Public Property NumberOfAcceptedTransactionSets As String
    Get
    Set
public:
property String^ NumberOfAcceptedTransactionSets {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NumberOfReceivedTransactionSets Property

NumberOfReceivedTransactionSets Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► NumberOfReceivedTransactionSets
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfReceivedTransactionSets { get; set; }
Public Property NumberOfReceivedTransactionSets As String
    Get
    Set
public:
property String^ NumberOfReceivedTransactionSets {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NumberOfTransactionSetsIncluded Property

NumberOfTransactionSetsIncluded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► NumberOfTransactionSetsIncluded
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTransactionSetsIncluded { get; set; }
Public Property NumberOfTransactionSetsIncluded As String
    Get
    Set
public:
property String^ NumberOfTransactionSetsIncluded {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AK9 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AMT Class

AMT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AMT
Declaration Syntax
C# Visual Basic Visual C++
public class AMT : DocumentSegment
Public Class AMT _
    Inherits DocumentSegment
public ref class AMT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AMT()()()() | Initializes a new instance of the AMT class
 | AmountQualifierCode |
 | CreditDebitFlagCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | AMT

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AMT Constructor

AMT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AMT ► AMT()()()()
Initializes a new instance of the AMT class
Declaration Syntax
C# Visual Basic Visual C++
public AMT()
Public Sub New
public:
AMT()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AmountQualifierCode Property

AmountQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AMT ► AmountQualifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string AmountQualifierCode { get; set; }
Public Property AmountQualifierCode As String
    Get
    Set
public:
property String^ AmountQualifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AMT ► CreditDebitFlagCode
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AMT ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AMT ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► AMT ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BGN Class

BGN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN
Declaration Syntax
C# Visual Basic Visual C++
public class BGN : DocumentSegment
Public Class BGN _
    Inherits DocumentSegment
public ref class BGN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BGN()()()() | Initializes a new instance of the BGN class
 | ActionCode |
 | Date |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification1 |
 | ReferenceIdentification2 |
 | SecurityLevelCode |
 | Time |
 | TimeCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetPurposeCode |
 | TransactionTypeCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BGN

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BGN Constructor

BGN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► BGN()()()()
Initializes a new instance of the BGN class
Declaration Syntax
C# Visual Basic Visual C++
public BGN()
Public Sub New
public:
BGN()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► ActionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► ReferenceIdentification1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► ReferenceIdentification2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SecurityLevelCode Property

SecurityLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► SecurityLevelCode
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityLevelCode { get; set; }
Public Property SecurityLevelCode As String
    Get
    Set
public:
property String^ SecurityLevelCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► Time
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► TimeCode
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► TransactionSetPurposeCode
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► TransactionTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BGN ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BHT Class

BHT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT
Declaration Syntax
C# Visual Basic Visual C++
public class BHT : DocumentSegment
Public Class BHT _
    Inherits DocumentSegment
public ref class BHT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BHT()()()() | Initializes a new instance of the BHT class
 | Date |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchicalStructureCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification |
 | Time |
 | ToString()()()() | (Overrides DocumentSegment.ToString()()()().)
 | TransactionSetPurposeCode |
 | TransactionTypeCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BHT

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BHT Constructor

BHT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► BHT()()()()
Initializes a new instance of the BHT class
Declaration Syntax
C# Visual Basic Visual C++
public BHT()
Public Sub New
public:
BHT()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HierarchicalStructureCode Property

HierarchicalStructureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► HierarchicalStructureCode
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalStructureCode { get; set; }
Public Property HierarchicalStructureCode As String
    Get
    Set
public:
property String^ HierarchicalStructureCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► Time
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionSetPurposeCode Property

TransactionSetPurposeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► TransactionSetPurposeCode
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetPurposeCode { get; set; }
Public Property TransactionSetPurposeCode As String
    Get
    Set
public:
property String^ TransactionSetPurposeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionTypeCode Property

TransactionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► TransactionTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionTypeCode { get; set; }
Public Property TransactionTypeCode As String
    Get
    Set
public:
property String^ TransactionTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BHT ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BPR Class

BPR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR
Declaration Syntax
C# Visual Basic Visual C++
public class BPR : DocumentSegment
Public Class BPR _
    Inherits DocumentSegment
public ref class BPR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BPR()()()() | Initializes a new instance of the BPR class
 | AccountNumber1 |
 | AccountNumber2 |
 | AccountNumber3 |
 | AccountNumberQualifier1 |
 | AccountNumberQualifier2 |
 | AccountNumberQualifier3 |
 | BusinessFunctionCode |
 | CreditDebitFlagCode |
 | Date |
 | DFI_IdentificationNumber1 |
 | DFI_IdentificationNumber2 |
 | DFI_IdentificationNumber3 |
 | DFI_IDNumberQualifier1 |
 | DFI_IDNumberQualifier2 |
 | DFI_IDNumberQualifier3 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OriginatingCompanyIdentifier |
 | OriginatingCompanySupplementalCode |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentFormatCode |
 | PaymentMethodCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionHandlingCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | BPR

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BPR Constructor

BPR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► BPR()()()()
Initializes a new instance of the BPR class
Declaration Syntax
C# Visual Basic Visual C++
public BPR()
Public Sub New
public:
BPR()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumber1 Property

AccountNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► AccountNumber1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber1 { get; set; }
Public Property AccountNumber1 As String
    Get
    Set
public:
property String^ AccountNumber1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumber2 Property

AccountNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► AccountNumber2
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber2 { get; set; }
Public Property AccountNumber2 As String
    Get
    Set
public:
property String^ AccountNumber2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumber3 Property

AccountNumber3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► AccountNumber3
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumber3 { get; set; }
Public Property AccountNumber3 As String
    Get
    Set
public:
property String^ AccountNumber3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumberQualifier1 Property

AccountNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► AccountNumberQualifier1
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier1 { get; set; }
Public Property AccountNumberQualifier1 As String
    Get
    Set
public:
property String^ AccountNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumberQualifier2 Property

AccountNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► AccountNumberQualifier2
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier2 { get; set; }
Public Property AccountNumberQualifier2 As String
    Get
    Set
public:
property String^ AccountNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AccountNumberQualifier3 Property

AccountNumberQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► AccountNumberQualifier3
Declaration Syntax
C# Visual Basic Visual C++
public string AccountNumberQualifier3 { get; set; }
Public Property AccountNumberQualifier3 As String
    Get
    Set
public:
property String^ AccountNumberQualifier3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BusinessFunctionCode Property

BusinessFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► BusinessFunctionCode
Declaration Syntax
C# Visual Basic Visual C++
public string BusinessFunctionCode { get; set; }
Public Property BusinessFunctionCode As String
    Get
    Set
public:
property String^ BusinessFunctionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CreditDebitFlagCode Property

CreditDebitFlagCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► CreditDebitFlagCode
Declaration Syntax
C# Visual Basic Visual C++
public string CreditDebitFlagCode { get; set; }
Public Property CreditDebitFlagCode As String
    Get
    Set
public:
property String^ CreditDebitFlagCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DFI_IdentificationNumber1 Property

DFI_IdentificationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► DFI_IdentificationNumber1
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IdentificationNumber1 { get; set; }
Public Property DFI_IdentificationNumber1 As String
    Get
    Set
public:
property String^ DFI_IdentificationNumber1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DFI_IdentificationNumber2 Property

DFI_IdentificationNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► DFI_IdentificationNumber2
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IdentificationNumber2 { get; set; }
Public Property DFI_IdentificationNumber2 As String
    Get
    Set
public:
property String^ DFI_IdentificationNumber2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DFI_IdentificationNumber3 Property

DFI_IdentificationNumber3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► DFI_IdentificationNumber3
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IdentificationNumber3 { get; set; }
Public Property DFI_IdentificationNumber3 As String
    Get
    Set
public:
property String^ DFI_IdentificationNumber3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DFI_IDNumberQualifier1 Property

DFI_IDNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► DFI_IDNumberQualifier1
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IDNumberQualifier1 { get; set; }
Public Property DFI_IDNumberQualifier1 As String
    Get
    Set
public:
property String^ DFI_IDNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DFI_IDNumberQualifier2 Property

DFI_IDNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► DFI_IDNumberQualifier2
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IDNumberQualifier2 { get; set; }
Public Property DFI_IDNumberQualifier2 As String
    Get
    Set
public:
property String^ DFI_IDNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DFI_IDNumberQualifier3 Property

DFI_IDNumberQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► DFI_IDNumberQualifier3
Declaration Syntax
C# Visual Basic Visual C++
public string DFI_IDNumberQualifier3 { get; set; }
Public Property DFI_IDNumberQualifier3 As String
    Get
    Set
public:
property String^ DFI_IDNumberQualifier3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OriginatingCompanyIdentifier Property

OriginatingCompanyIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► OriginatingCompanyIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanyIdentifier { get; set; }
Public Property OriginatingCompanyIdentifier As String
    Get
    Set
public:
property String^ OriginatingCompanyIdentifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OriginatingCompanySupplementalCode Property

OriginatingCompanySupplementalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► OriginatingCompanySupplementalCode
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanySupplementalCode { get; set; }
Public Property OriginatingCompanySupplementalCode As String
    Get
    Set
public:
property String^ OriginatingCompanySupplementalCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PaymentFormatCode Property

PaymentFormatCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► PaymentFormatCode
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentFormatCode { get; set; }
Public Property PaymentFormatCode As String
    Get
    Set
public:
property String^ PaymentFormatCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► PaymentMethodCode
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionHandlingCode Property

TransactionHandlingCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► TransactionHandlingCode
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionHandlingCode { get; set; }
Public Property TransactionHandlingCode As String
    Get
    Set
public:
property String^ TransactionHandlingCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► BPR ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CAS Class

CAS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS
Declaration Syntax
C# Visual Basic Visual C++
public class CAS : DocumentSegment
Public Class CAS _
    Inherits DocumentSegment
public ref class CAS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CAS()()()() | Initializes a new instance of the CAS class
 | ClaimAdjustmentGroupCode |
 | ClaimAdjustmentReasonCode1 |
 | ClaimAdjustmentReasonCode2 |
 | ClaimAdjustmentReasonCode3 |
 | ClaimAdjustmentReasonCode4 |
 | ClaimAdjustmentReasonCode5 |
 | ClaimAdjustmentReasonCode6 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | MonetaryAmount4 |
 | MonetaryAmount5 |
 | MonetaryAmount6 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 |
 | Quantity2 |
 | Quantity3 |
 | Quantity4 |
 | Quantity5 |
 | Quantity6 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CAS

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CAS Constructor

CAS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► CAS()()()()
Initializes a new instance of the CAS class
Declaration Syntax
C# Visual Basic Visual C++
public CAS()
Public Sub New
public:
CAS()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimAdjustmentGroupCode Property

ClaimAdjustmentGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► ClaimAdjustmentGroupCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentGroupCode { get; set; }
Public Property ClaimAdjustmentGroupCode As String
    Get
    Set
public:
property String^ ClaimAdjustmentGroupCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimAdjustmentReasonCode1 Property

ClaimAdjustmentReasonCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► ClaimAdjustmentReasonCode1
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode1 { get; set; }
Public Property ClaimAdjustmentReasonCode1 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimAdjustmentReasonCode2 Property

ClaimAdjustmentReasonCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► ClaimAdjustmentReasonCode2
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode2 { get; set; }
Public Property ClaimAdjustmentReasonCode2 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimAdjustmentReasonCode3 Property

ClaimAdjustmentReasonCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► ClaimAdjustmentReasonCode3
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode3 { get; set; }
Public Property ClaimAdjustmentReasonCode3 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimAdjustmentReasonCode4 Property

ClaimAdjustmentReasonCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► ClaimAdjustmentReasonCode4
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode4 { get; set; }
Public Property ClaimAdjustmentReasonCode4 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimAdjustmentReasonCode5 Property

ClaimAdjustmentReasonCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► ClaimAdjustmentReasonCode5
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode5 { get; set; }
Public Property ClaimAdjustmentReasonCode5 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimAdjustmentReasonCode6 Property

ClaimAdjustmentReasonCode6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► ClaimAdjustmentReasonCode6
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimAdjustmentReasonCode6 { get; set; }
Public Property ClaimAdjustmentReasonCode6 As String
    Get
    Set
public:
property String^ ClaimAdjustmentReasonCode6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► MonetaryAmount4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► MonetaryAmount5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► MonetaryAmount6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► Quantity1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► Quantity2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► Quantity3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► Quantity4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► Quantity5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► Quantity6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CAS ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CL1 Class

CL1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CL1
Declaration Syntax
C# Visual Basic Visual C++
public class CL1 : DocumentSegment
Public Class CL1 _
    Inherits DocumentSegment
public ref class CL1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CL1()()()() | Initializes a new instance of the CL1 class
 | AdmissionSourceCode |
 | AdmissionTypeCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NursingHomeResidentialStatusCode |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientStatusCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CL1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CL1 Constructor

CL1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CL1 ► CL1()()()()
Initializes a new instance of the CL1 class
Declaration Syntax
C# Visual Basic Visual C++
public CL1()
Public Sub New
public:
CL1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdmissionSourceCode Property

AdmissionSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CL1 ► AdmissionSourceCode
Declaration Syntax
C# Visual Basic Visual C++
public string AdmissionSourceCode { get; set; }
Public Property AdmissionSourceCode As String
    Get
    Set
public:
property String^ AdmissionSourceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdmissionTypeCode Property

AdmissionTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CL1 ► AdmissionTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string AdmissionTypeCode { get; set; }
Public Property AdmissionTypeCode As String
    Get
    Set
public:
property String^ AdmissionTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CL1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NursingHomeResidentialStatusCode Property

NursingHomeResidentialStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CL1 ► NursingHomeResidentialStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string NursingHomeResidentialStatusCode { get; set; }
Public Property NursingHomeResidentialStatusCode As String
    Get
    Set
public:
property String^ NursingHomeResidentialStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PatientStatusCode Property

PatientStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CL1 ► PatientStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string PatientStatusCode { get; set; }
Public Property PatientStatusCode As String
    Get
    Set
public:
property String^ PatientStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CL1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CLM Class

CLM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM
Declaration Syntax
C# Visual Basic Visual C++
public class CLM : DocumentSegment
Public Class CLM _
    Inherits DocumentSegment
public ref class CLM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLM()()()() | Initializes a new instance of the CLM class
 | AssignmentOrPlanParticipationCode |
 | ClaimFilingIndicatorCode |
 | ClaimStatusCode |
 | ClaimStatusReasonCode |
 | ClaimSubmitterIdentifier |
 | DelayReasonCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareServiceLocation |
 | LevelOfServiceCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NonInstitutionalClaimTypeCode |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientSignatureSourceCode |
 | ProviderAgreementCode |
 | RelatedCausesInformation |
 | ReleaseOfInformationCode |
 | SpecialProgramCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 |
 | YesNoConditionOrResponseCode2 |
 | YesNoConditionOrResponseCode3 |
 | YesNoConditionOrResponseCode4 |
 | YesNoConditionOrResponseCode5 |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLM

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CLM Constructor

CLM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► CLM()()()()
Initializes a new instance of the CLM class
Declaration Syntax
C# Visual Basic Visual C++
public CLM()
Public Sub New
public:
CLM()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AssignmentOrPlanParticipationCode Property

AssignmentOrPlanParticipationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► AssignmentOrPlanParticipationCode
Declaration Syntax
C# Visual Basic Visual C++
public string AssignmentOrPlanParticipationCode { get; set; }
Public Property AssignmentOrPlanParticipationCode As String
    Get
    Set
public:
property String^ AssignmentOrPlanParticipationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► ClaimFilingIndicatorCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► ClaimStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimStatusReasonCode Property

ClaimStatusReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► ClaimStatusReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusReasonCode { get; set; }
Public Property ClaimStatusReasonCode As String
    Get
    Set
public:
property String^ ClaimStatusReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimSubmitterIdentifier Property

ClaimSubmitterIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► ClaimSubmitterIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmitterIdentifier { get; set; }
Public Property ClaimSubmitterIdentifier As String
    Get
    Set
public:
property String^ ClaimSubmitterIdentifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DelayReasonCode Property

DelayReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► DelayReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string DelayReasonCode { get; set; }
Public Property DelayReasonCode As String
    Get
    Set
public:
property String^ DelayReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareServiceLocation Property

HealthCareServiceLocation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► HealthCareServiceLocation
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareServiceLocation HealthCareServiceLocation { get; set; }
Public Property HealthCareServiceLocation As HealthCareServiceLocation
    Get
    Set
public:
property HealthCareServiceLocation^ HealthCareServiceLocation {
    HealthCareServiceLocation^ get ();
    void set (HealthCareServiceLocation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LevelOfServiceCode Property

LevelOfServiceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► LevelOfServiceCode
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfServiceCode { get; set; }
Public Property LevelOfServiceCode As String
    Get
    Set
public:
property String^ LevelOfServiceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NonInstitutionalClaimTypeCode Property

NonInstitutionalClaimTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► NonInstitutionalClaimTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string NonInstitutionalClaimTypeCode { get; set; }
Public Property NonInstitutionalClaimTypeCode As String
    Get
    Set
public:
property String^ NonInstitutionalClaimTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PatientSignatureSourceCode Property

PatientSignatureSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► PatientSignatureSourceCode
Declaration Syntax
C# Visual Basic Visual C++
public string PatientSignatureSourceCode { get; set; }
Public Property PatientSignatureSourceCode As String
    Get
    Set
public:
property String^ PatientSignatureSourceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► ProviderAgreementCode
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RelatedCausesInformation Property

RelatedCausesInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► RelatedCausesInformation
Declaration Syntax
C# Visual Basic Visual C++
public RelatedCausesInformation RelatedCausesInformation { get; set; }
Public Property RelatedCausesInformation As RelatedCausesInformation
    Get
    Set
public:
property RelatedCausesInformation^ RelatedCausesInformation {
    RelatedCausesInformation^ get ();
    void set (RelatedCausesInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReleaseOfInformationCode Property

ReleaseOfInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► ReleaseOfInformationCode
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseOfInformationCode { get; set; }
Public Property ReleaseOfInformationCode As String
    Get
    Set
public:
property String^ ReleaseOfInformationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SpecialProgramCode Property

SpecialProgramCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► SpecialProgramCode
Declaration Syntax
C# Visual Basic Visual C++
public string SpecialProgramCode { get; set; }
Public Property SpecialProgramCode As String
    Get
    Set
public:
property String^ SpecialProgramCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► YesNoConditionOrResponseCode1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► YesNoConditionOrResponseCode2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► YesNoConditionOrResponseCode3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode4 Property

YesNoConditionOrResponseCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► YesNoConditionOrResponseCode4
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode4 { get; set; }
Public Property YesNoConditionOrResponseCode4 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode5 Property

YesNoConditionOrResponseCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLM ► YesNoConditionOrResponseCode5
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode5 { get; set; }
Public Property YesNoConditionOrResponseCode5 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CLP Class

CLP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP
Declaration Syntax
C# Visual Basic Visual C++
public class CLP : DocumentSegment
Public Class CLP _
    Inherits DocumentSegment
public ref class CLP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CLP()()()() | Initializes a new instance of the CLP class
 | ClaimFilingIndicatorCode |
 | ClaimFrequencyTypeCode |
 | ClaimStatusCode |
 | ClaimSubmitterIdentifier |
 | DiagnosisRelatedGroupCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientStatusCode |
 | Percentage |
 | Quantity |
 | ReferenceIdentification |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CLP

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CLP Constructor

CLP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► CLP()()()()
Initializes a new instance of the CLP class
Declaration Syntax
C# Visual Basic Visual C++
public CLP()
Public Sub New
public:
CLP()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► ClaimFilingIndicatorCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimFrequencyTypeCode Property

ClaimFrequencyTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► ClaimFrequencyTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFrequencyTypeCode { get; set; }
Public Property ClaimFrequencyTypeCode As String
    Get
    Set
public:
property String^ ClaimFrequencyTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimStatusCode Property

ClaimStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► ClaimStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimStatusCode { get; set; }
Public Property ClaimStatusCode As String
    Get
    Set
public:
property String^ ClaimStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimSubmitterIdentifier Property

ClaimSubmitterIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► ClaimSubmitterIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmitterIdentifier { get; set; }
Public Property ClaimSubmitterIdentifier As String
    Get
    Set
public:
property String^ ClaimSubmitterIdentifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DiagnosisRelatedGroupCode Property

DiagnosisRelatedGroupCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► DiagnosisRelatedGroupCode
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisRelatedGroupCode { get; set; }
Public Property DiagnosisRelatedGroupCode As String
    Get
    Set
public:
property String^ DiagnosisRelatedGroupCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► FacilityCodeValue
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PatientStatusCode Property

PatientStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► PatientStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string PatientStatusCode { get; set; }
Public Property PatientStatusCode As String
    Get
    Set
public:
property String^ PatientStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Percentage Property

Percentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► Percentage
Declaration Syntax
C# Visual Basic Visual C++
public string Percentage { get; set; }
Public Property Percentage As String
    Get
    Set
public:
property String^ Percentage {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CLP ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CN1 Class

CN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1
Declaration Syntax
C# Visual Basic Visual C++
public class CN1 : DocumentSegment
Public Class CN1 _
    Inherits DocumentSegment
public ref class CN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CN1()()()() | Initializes a new instance of the CN1 class
 | ContractTypeCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent |
 | ReferenceIdentification |
 | TermsDiscountPercent |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionIdentifier |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CN1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CN1 Constructor

CN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► CN1()()()()
Initializes a new instance of the CN1 class
Declaration Syntax
C# Visual Basic Visual C++
public CN1()
Public Sub New
public:
CN1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContractTypeCode Property

ContractTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► ContractTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ContractTypeCode { get; set; }
Public Property ContractTypeCode As String
    Get
    Set
public:
property String^ ContractTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► Percent
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TermsDiscountPercent Property

TermsDiscountPercent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► TermsDiscountPercent
Declaration Syntax
C# Visual Basic Visual C++
public string TermsDiscountPercent { get; set; }
Public Property TermsDiscountPercent As String
    Get
    Set
public:
property String^ TermsDiscountPercent {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► VersionIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CN1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


COB Class

COB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► COB
Declaration Syntax
C# Visual Basic Visual C++
public class COB : DocumentSegment
Public Class COB _
    Inherits DocumentSegment
public ref class COB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | COB()()()() | Initializes a new instance of the COB class
 | CoordinationOfBenefitsCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PayerResponsibilitySequenceNumberCode |
 | ReferenceIdentification |
 | ServiceTypeCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | COB

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


COB Constructor

COB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► COB ► COB()()()()
Initializes a new instance of the COB class
Declaration Syntax
C# Visual Basic Visual C++
public COB()
Public Sub New
public:
COB()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CoordinationOfBenefitsCode Property

CoordinationOfBenefitsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► COB ► CoordinationOfBenefitsCode
Declaration Syntax
C# Visual Basic Visual C++
public string CoordinationOfBenefitsCode { get; set; }
Public Property CoordinationOfBenefitsCode As String
    Get
    Set
public:
property String^ CoordinationOfBenefitsCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► COB ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PayerResponsibilitySequenceNumberCode Property

PayerResponsibilitySequenceNumberCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► COB ► PayerResponsibilitySequenceNumberCode
Declaration Syntax
C# Visual Basic Visual C++
public string PayerResponsibilitySequenceNumberCode { get; set; }
Public Property PayerResponsibilitySequenceNumberCode As String
    Get
    Set
public:
property String^ PayerResponsibilitySequenceNumberCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► COB ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► COB ► ServiceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► COB ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeDiagnosticCodePointer Class

CompositeDiagnosticCodePointer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeDiagnosticCodePointer
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeDiagnosticCodePointer : CompositeElement
Public Class CompositeDiagnosticCodePointer _
    Inherits CompositeElement
public ref class CompositeDiagnosticCodePointer : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeDiagnosticCodePointer()()()() | Initializes a new instance of the CompositeDiagnosticCodePointer class
 | DiagnosisCodePointer1 |
 | DiagnosisCodePointer2 |
 | DiagnosisCodePointer3 |
 | DiagnosisCodePointer4 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | CompositeDiagnosticCodePointer

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeDiagnosticCodePointer Constructor

CompositeDiagnosticCodePointer Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeDiagnosticCodePointer ► CompositeDiagnosticCodePointer()()()()
Initializes a new instance of the CompositeDiagnosticCodePointer class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer()
Public Sub New
public:
CompositeDiagnosticCodePointer()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DiagnosisCodePointer1 Property

DiagnosisCodePointer1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeDiagnosticCodePointer ► DiagnosisCodePointer1
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer1 { get; set; }
Public Property DiagnosisCodePointer1 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DiagnosisCodePointer2 Property

DiagnosisCodePointer2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeDiagnosticCodePointer ► DiagnosisCodePointer2
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer2 { get; set; }
Public Property DiagnosisCodePointer2 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DiagnosisCodePointer3 Property

DiagnosisCodePointer3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeDiagnosticCodePointer ► DiagnosisCodePointer3
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer3 { get; set; }
Public Property DiagnosisCodePointer3 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DiagnosisCodePointer4 Property

DiagnosisCodePointer4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeDiagnosticCodePointer ► DiagnosisCodePointer4
Declaration Syntax
C# Visual Basic Visual C++
public string DiagnosisCodePointer4 { get; set; }
Public Property DiagnosisCodePointer4 As String
    Get
    Set
public:
property String^ DiagnosisCodePointer4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeDiagnosticCodePointer ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Class

CompositeMedicalProcedureIdentifier Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeMedicalProcedureIdentifier : CompositeElement
Public Class CompositeMedicalProcedureIdentifier _
    Inherits CompositeElement
public ref class CompositeMedicalProcedureIdentifier : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeMedicalProcedureIdentifier()()()() | Initializes a new instance of the CompositeMedicalProcedureIdentifier class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcedureModifier1 |
 | ProcedureModifier2 |
 | ProcedureModifier3 |
 | ProcedureModifier4 |
 | ProductServiceID1 |
 | ProductServiceID2 |
 | ProductServiceIDQualifier |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | CompositeMedicalProcedureIdentifier

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Constructor

CompositeMedicalProcedureIdentifier Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► CompositeMedicalProcedureIdentifier()()()()
Initializes a new instance of the CompositeMedicalProcedureIdentifier class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier()
Public Sub New
public:
CompositeMedicalProcedureIdentifier()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProcedureModifier1 Property

ProcedureModifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► ProcedureModifier1
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier1 { get; set; }
Public Property ProcedureModifier1 As String
    Get
    Set
public:
property String^ ProcedureModifier1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProcedureModifier2 Property

ProcedureModifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► ProcedureModifier2
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier2 { get; set; }
Public Property ProcedureModifier2 As String
    Get
    Set
public:
property String^ ProcedureModifier2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProcedureModifier3 Property

ProcedureModifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► ProcedureModifier3
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier3 { get; set; }
Public Property ProcedureModifier3 As String
    Get
    Set
public:
property String^ ProcedureModifier3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProcedureModifier4 Property

ProcedureModifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► ProcedureModifier4
Declaration Syntax
C# Visual Basic Visual C++
public string ProcedureModifier4 { get; set; }
Public Property ProcedureModifier4 As String
    Get
    Set
public:
property String^ ProcedureModifier4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► ProductServiceID1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► ProductServiceID2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeMedicalProcedureIdentifier ► ProductServiceIDQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeUnitOfMeasure Class

CompositeUnitOfMeasure Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure
Declaration Syntax
C# Visual Basic Visual C++
public class CompositeUnitOfMeasure : CompositeElement
Public Class CompositeUnitOfMeasure _
    Inherits CompositeElement
public ref class CompositeUnitOfMeasure : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompositeUnitOfMeasure()()()() | Initializes a new instance of the CompositeUnitOfMeasure class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exponent1 |
 | Exponent2 |
 | Exponent3 |
 | Exponent4 |
 | Exponent5 |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Multiplier1 |
 | Multiplier2 |
 | Multiplier3 |
 | Multiplier4 |
 | Multiplier5 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | UnitOrBasisForMeasurementCode1 |
 | UnitOrBasisForMeasurementCode2 |
 | UnitOrBasisForMeasurementCode3 |
 | UnitOrBasisForMeasurementCode4 |
 | UnitOrBasisForMeasurementCode5 |
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | CompositeUnitOfMeasure

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeUnitOfMeasure Constructor

CompositeUnitOfMeasure Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► CompositeUnitOfMeasure()()()()
Initializes a new instance of the CompositeUnitOfMeasure class
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure()
Public Sub New
public:
CompositeUnitOfMeasure()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Exponent1 Property

Exponent1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Exponent1
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent1 { get; set; }
Public Property Exponent1 As String
    Get
    Set
public:
property String^ Exponent1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Exponent2 Property

Exponent2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Exponent2
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent2 { get; set; }
Public Property Exponent2 As String
    Get
    Set
public:
property String^ Exponent2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Exponent3 Property

Exponent3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Exponent3
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent3 { get; set; }
Public Property Exponent3 As String
    Get
    Set
public:
property String^ Exponent3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Exponent4 Property

Exponent4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Exponent4
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent4 { get; set; }
Public Property Exponent4 As String
    Get
    Set
public:
property String^ Exponent4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Exponent5 Property

Exponent5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Exponent5
Declaration Syntax
C# Visual Basic Visual C++
public string Exponent5 { get; set; }
Public Property Exponent5 As String
    Get
    Set
public:
property String^ Exponent5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Multiplier1 Property

Multiplier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Multiplier1
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier1 { get; set; }
Public Property Multiplier1 As String
    Get
    Set
public:
property String^ Multiplier1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Multiplier2 Property

Multiplier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Multiplier2
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier2 { get; set; }
Public Property Multiplier2 As String
    Get
    Set
public:
property String^ Multiplier2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Multiplier3 Property

Multiplier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Multiplier3
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier3 { get; set; }
Public Property Multiplier3 As String
    Get
    Set
public:
property String^ Multiplier3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Multiplier4 Property

Multiplier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Multiplier4
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier4 { get; set; }
Public Property Multiplier4 As String
    Get
    Set
public:
property String^ Multiplier4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Multiplier5 Property

Multiplier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► Multiplier5
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier5 { get; set; }
Public Property Multiplier5 As String
    Get
    Set
public:
property String^ Multiplier5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode3 Property

UnitOrBasisForMeasurementCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode3
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode3 { get; set; }
Public Property UnitOrBasisForMeasurementCode3 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode4 Property

UnitOrBasisForMeasurementCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode4
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode4 { get; set; }
Public Property UnitOrBasisForMeasurementCode4 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode5 Property

UnitOrBasisForMeasurementCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CompositeUnitOfMeasure ► UnitOrBasisForMeasurementCode5
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode5 { get; set; }
Public Property UnitOrBasisForMeasurementCode5 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContextIndentification Class

ContextIndentification Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ContextIndentification
Declaration Syntax
C# Visual Basic Visual C++
public class ContextIndentification : CompositeElement
Public Class ContextIndentification _
    Inherits CompositeElement
public ref class ContextIndentification : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ContextIndentification()()()() | Initializes a new instance of the ContextIndentification class
 | ContextName |
 | ContextReference |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | ContextIndentification

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContextIndentification Constructor

ContextIndentification Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ContextIndentification ► ContextIndentification()()()()
Initializes a new instance of the ContextIndentification class
Declaration Syntax
C# Visual Basic Visual C++
public ContextIndentification()
Public Sub New
public:
ContextIndentification()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContextName Property

ContextName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ContextIndentification ► ContextName
Declaration Syntax
C# Visual Basic Visual C++
public string ContextName { get; set; }
Public Property ContextName As String
    Get
    Set
public:
property String^ ContextName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContextReference Property

ContextReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ContextIndentification ► ContextReference
Declaration Syntax
C# Visual Basic Visual C++
public string ContextReference { get; set; }
Public Property ContextReference As String
    Get
    Set
public:
property String^ ContextReference {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ContextIndentification ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CR1 Class

CR1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1
Declaration Syntax
C# Visual Basic Visual C++
public class CR1 : DocumentSegment
Public Class CR1 _
    Inherits DocumentSegment
public ref class CR1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR1()()()() | Initializes a new instance of the CR1 class
 | Address1 |
 | Address2 |
 | AmbulanceTransportCode1 |
 | AmbulanceTransportReasonCode |
 | Description1 |
 | Description2 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode1 |
 | UnitOrBasisForMeasurementCode2 |
 | Weight |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CR1 Constructor

CR1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► CR1()()()()
Initializes a new instance of the CR1 class
Declaration Syntax
C# Visual Basic Visual C++
public CR1()
Public Sub New
public:
CR1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Address1 Property

Address1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► Address1
Declaration Syntax
C# Visual Basic Visual C++
public string Address1 { get; set; }
Public Property Address1 As String
    Get
    Set
public:
property String^ Address1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Address2 Property

Address2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► Address2
Declaration Syntax
C# Visual Basic Visual C++
public string Address2 { get; set; }
Public Property Address2 As String
    Get
    Set
public:
property String^ Address2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AmbulanceTransportCode1 Property

AmbulanceTransportCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► AmbulanceTransportCode1
Declaration Syntax
C# Visual Basic Visual C++
public string AmbulanceTransportCode1 { get; set; }
Public Property AmbulanceTransportCode1 As String
    Get
    Set
public:
property String^ AmbulanceTransportCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AmbulanceTransportReasonCode Property

AmbulanceTransportReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► AmbulanceTransportReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string AmbulanceTransportReasonCode { get; set; }
Public Property AmbulanceTransportReasonCode As String
    Get
    Set
public:
property String^ AmbulanceTransportReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► Description1
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► Description2
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode1 Property

UnitOrBasisForMeasurementCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► UnitOrBasisForMeasurementCode1
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode1 { get; set; }
Public Property UnitOrBasisForMeasurementCode1 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode2 Property

UnitOrBasisForMeasurementCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► UnitOrBasisForMeasurementCode2
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode2 { get; set; }
Public Property UnitOrBasisForMeasurementCode2 As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► Weight
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CR2 Class

CR2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2
Declaration Syntax
C# Visual Basic Visual C++
public class CR2 : DocumentSegment
Public Class CR2 _
    Inherits DocumentSegment
public ref class CR2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR2()()()() | Initializes a new instance of the CR2 class
 | Count |
 | Description1 |
 | Description2 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NatureOfConditionCode |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 |
 | Quantity2 |
 | Quantity3 |
 | SubluxationLevelCode1 |
 | SubluxationLevelCode2 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 |
 | YesNoConditionOrResponseCode2 |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR2

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CR2 Constructor

CR2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► CR2()()()()
Initializes a new instance of the CR2 class
Declaration Syntax
C# Visual Basic Visual C++
public CR2()
Public Sub New
public:
CR2()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Count Property

Count Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► Count
Declaration Syntax
C# Visual Basic Visual C++
public string Count { get; set; }
Public Property Count As String
    Get
    Set
public:
property String^ Count {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► Description1
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► Description2
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NatureOfConditionCode Property

NatureOfConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► NatureOfConditionCode
Declaration Syntax
C# Visual Basic Visual C++
public string NatureOfConditionCode { get; set; }
Public Property NatureOfConditionCode As String
    Get
    Set
public:
property String^ NatureOfConditionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► Quantity1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► Quantity2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► Quantity3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SubluxationLevelCode1 Property

SubluxationLevelCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► SubluxationLevelCode1
Declaration Syntax
C# Visual Basic Visual C++
public string SubluxationLevelCode1 { get; set; }
Public Property SubluxationLevelCode1 As String
    Get
    Set
public:
property String^ SubluxationLevelCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SubluxationLevelCode2 Property

SubluxationLevelCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► SubluxationLevelCode2
Declaration Syntax
C# Visual Basic Visual C++
public string SubluxationLevelCode2 { get; set; }
Public Property SubluxationLevelCode2 As String
    Get
    Set
public:
property String^ SubluxationLevelCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► UnitOrBasisForMeasurementCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► YesNoConditionOrResponseCode1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR2 ► YesNoConditionOrResponseCode2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CR3 Class

CR3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3
Declaration Syntax
C# Visual Basic Visual C++
public class CR3 : DocumentSegment
Public Class CR3 _
    Inherits DocumentSegment
public ref class CR3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CR3()()()() | Initializes a new instance of the CR3 class
 | CertificationTypeCode |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsulinDependentCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CR3

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CR3 Constructor

CR3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3 ► CR3()()()()
Initializes a new instance of the CR3 class
Declaration Syntax
C# Visual Basic Visual C++
public CR3()
Public Sub New
public:
CR3()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CertificationTypeCode Property

CertificationTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3 ► CertificationTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string CertificationTypeCode { get; set; }
Public Property CertificationTypeCode As String
    Get
    Set
public:
property String^ CertificationTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3 ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InsulinDependentCode Property

InsulinDependentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3 ► InsulinDependentCode
Declaration Syntax
C# Visual Basic Visual C++
public string InsulinDependentCode { get; set; }
Public Property InsulinDependentCode As String
    Get
    Set
public:
property String^ InsulinDependentCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3 ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3 ► UnitOrBasisForMeasurementCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CR3 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CRC Class

CRC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC
Declaration Syntax
C# Visual Basic Visual C++
public class CRC : DocumentSegment
Public Class CRC _
    Inherits DocumentSegment
public ref class CRC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CRC()()()() | Initializes a new instance of the CRC class
 | CodeCategory |
 | ConditionIndicator1 |
 | ConditionIndicator2 |
 | ConditionIndicator3 |
 | ConditionIndicator4 |
 | ConditionIndicator5 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CRC

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CRC Constructor

CRC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► CRC()()()()
Initializes a new instance of the CRC class
Declaration Syntax
C# Visual Basic Visual C++
public CRC()
Public Sub New
public:
CRC()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► CodeCategory
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ConditionIndicator1 Property

ConditionIndicator1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► ConditionIndicator1
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator1 { get; set; }
Public Property ConditionIndicator1 As String
    Get
    Set
public:
property String^ ConditionIndicator1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ConditionIndicator2 Property

ConditionIndicator2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► ConditionIndicator2
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator2 { get; set; }
Public Property ConditionIndicator2 As String
    Get
    Set
public:
property String^ ConditionIndicator2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ConditionIndicator3 Property

ConditionIndicator3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► ConditionIndicator3
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator3 { get; set; }
Public Property ConditionIndicator3 As String
    Get
    Set
public:
property String^ ConditionIndicator3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ConditionIndicator4 Property

ConditionIndicator4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► ConditionIndicator4
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator4 { get; set; }
Public Property ConditionIndicator4 As String
    Get
    Set
public:
property String^ ConditionIndicator4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ConditionIndicator5 Property

ConditionIndicator5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► ConditionIndicator5
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionIndicator5 { get; set; }
Public Property ConditionIndicator5 As String
    Get
    Set
public:
property String^ ConditionIndicator5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CRC ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CTP Class

CTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP
Declaration Syntax
C# Visual Basic Visual C++
public class CTP : DocumentSegment
Public Class CTP _
    Inherits DocumentSegment
public ref class CTP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CTP()()()() | Initializes a new instance of the CTP class
 | BasisOfUnitPriceCode |
 | ClassOfTradeCode |
 | CompositeUnitOfMeasure |
 | ConditionValue |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | MultiplePriceQuantity |
 | Multiplier |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PriceIdentifierCode |
 | PriceMultiplierQualifier |
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitPrice |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CTP

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CTP Constructor

CTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► CTP()()()()
Initializes a new instance of the CTP class
Declaration Syntax
C# Visual Basic Visual C++
public CTP()
Public Sub New
public:
CTP()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BasisOfUnitPriceCode Property

BasisOfUnitPriceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► BasisOfUnitPriceCode
Declaration Syntax
C# Visual Basic Visual C++
public string BasisOfUnitPriceCode { get; set; }
Public Property BasisOfUnitPriceCode As String
    Get
    Set
public:
property String^ BasisOfUnitPriceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClassOfTradeCode Property

ClassOfTradeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► ClassOfTradeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClassOfTradeCode { get; set; }
Public Property ClassOfTradeCode As String
    Get
    Set
public:
property String^ ClassOfTradeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeUnitOfMeasure Property

CompositeUnitOfMeasure Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► CompositeUnitOfMeasure
Declaration Syntax
C# Visual Basic Visual C++
public CompositeUnitOfMeasure CompositeUnitOfMeasure { get; set; }
Public Property CompositeUnitOfMeasure As CompositeUnitOfMeasure
    Get
    Set
public:
property CompositeUnitOfMeasure^ CompositeUnitOfMeasure {
    CompositeUnitOfMeasure^ get ();
    void set (CompositeUnitOfMeasure^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ConditionValue Property

ConditionValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► ConditionValue
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionValue { get; set; }
Public Property ConditionValue As String
    Get
    Set
public:
property String^ ConditionValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MultiplePriceQuantity Property

MultiplePriceQuantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► MultiplePriceQuantity
Declaration Syntax
C# Visual Basic Visual C++
public string MultiplePriceQuantity { get; set; }
Public Property MultiplePriceQuantity As String
    Get
    Set
public:
property String^ MultiplePriceQuantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Multiplier Property

Multiplier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► Multiplier
Declaration Syntax
C# Visual Basic Visual C++
public string Multiplier { get; set; }
Public Property Multiplier As String
    Get
    Set
public:
property String^ Multiplier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PriceIdentifierCode Property

PriceIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► PriceIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string PriceIdentifierCode { get; set; }
Public Property PriceIdentifierCode As String
    Get
    Set
public:
property String^ PriceIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PriceMultiplierQualifier Property

PriceMultiplierQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► PriceMultiplierQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string PriceMultiplierQualifier { get; set; }
Public Property PriceMultiplierQualifier As String
    Get
    Set
public:
property String^ PriceMultiplierQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitPrice Property

UnitPrice Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► UnitPrice
Declaration Syntax
C# Visual Basic Visual C++
public string UnitPrice { get; set; }
Public Property UnitPrice As String
    Get
    Set
public:
property String^ UnitPrice {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTP ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CTX Class

CTX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX
Declaration Syntax
C# Visual Basic Visual C++
public class CTX : DocumentSegment
Public Class CTX _
    Inherits DocumentSegment
public ref class CTX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CTX()()()() | Initializes a new instance of the CTX class
 | ContextIndentification |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInSegment |
 | ReferenceInSegment |
 | SegmentIDCode |
 | SegmentPositionInTransactionSet |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CTX

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CTX Constructor

CTX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► CTX()()()()
Initializes a new instance of the CTX class
Declaration Syntax
C# Visual Basic Visual C++
public CTX()
Public Sub New
public:
CTX()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContextIndentification Property

ContextIndentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► ContextIndentification
Declaration Syntax
C# Visual Basic Visual C++
public ContextIndentification ContextIndentification { get; set; }
Public Property ContextIndentification As ContextIndentification
    Get
    Set
public:
property ContextIndentification^ ContextIndentification {
    ContextIndentification^ get ();
    void set (ContextIndentification^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► LoopIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PositionInSegment Property

PositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► PositionInSegment
Declaration Syntax
C# Visual Basic Visual C++
public PositionInSegment PositionInSegment { get; set; }
Public Property PositionInSegment As PositionInSegment
    Get
    Set
public:
property PositionInSegment^ PositionInSegment {
    PositionInSegment^ get ();
    void set (PositionInSegment^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceInSegment Property

ReferenceInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► ReferenceInSegment
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceInSegment ReferenceInSegment { get; set; }
Public Property ReferenceInSegment As ReferenceInSegment
    Get
    Set
public:
property ReferenceInSegment^ ReferenceInSegment {
    ReferenceInSegment^ get ();
    void set (ReferenceInSegment^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► SegmentIDCode
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SegmentPositionInTransactionSet Property

SegmentPositionInTransactionSet Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► SegmentPositionInTransactionSet
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentPositionInTransactionSet { get; set; }
Public Property SegmentPositionInTransactionSet As String
    Get
    Set
public:
property String^ SegmentPositionInTransactionSet {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CTX ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CUR Class

CUR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CUR
Declaration Syntax
C# Visual Basic Visual C++
public class CUR : DocumentSegment
Public Class CUR _
    Inherits DocumentSegment
public ref class CUR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CUR()()()() | Initializes a new instance of the CUR class
 | CurrencyCode |
 | EntityIdentifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | CUR

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CUR Constructor

CUR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CUR ► CUR()()()()
Initializes a new instance of the CUR class
Declaration Syntax
C# Visual Basic Visual C++
public CUR()
Public Sub New
public:
CUR()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CUR ► CurrencyCode
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CUR ► EntityIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CUR ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► CUR ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DMG Class

DMG Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DMG
Declaration Syntax
C# Visual Basic Visual C++
public class DMG : DocumentSegment
Public Class DMG _
    Inherits DocumentSegment
public ref class DMG : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DMG()()()() | Initializes a new instance of the DMG class
 | DateTimePeriod |
 | DateTimePeriodFormatQualifier |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GenderCode |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaritalStatusCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DMG

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DMG Constructor

DMG Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DMG ► DMG()()()()
Initializes a new instance of the DMG class
Declaration Syntax
C# Visual Basic Visual C++
public DMG()
Public Sub New
public:
DMG()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DMG ► DateTimePeriod
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DMG ► DateTimePeriodFormatQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GenderCode Property

GenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DMG ► GenderCode
Declaration Syntax
C# Visual Basic Visual C++
public string GenderCode { get; set; }
Public Property GenderCode As String
    Get
    Set
public:
property String^ GenderCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DMG ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MaritalStatusCode Property

MaritalStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DMG ► MaritalStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string MaritalStatusCode { get; set; }
Public Property MaritalStatusCode As String
    Get
    Set
public:
property String^ MaritalStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DMG ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DN1 Class

DN1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN1
Declaration Syntax
C# Visual Basic Visual C++
public class DN1 : DocumentSegment
Public Class DN1 _
    Inherits DocumentSegment
public ref class DN1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DN1()()()() | Initializes a new instance of the DN1 class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 |
 | Quantity2 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DN1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DN1 Constructor

DN1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN1 ► DN1()()()()
Initializes a new instance of the DN1 class
Declaration Syntax
C# Visual Basic Visual C++
public DN1()
Public Sub New
public:
DN1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN1 ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN1 ► Quantity1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN1 ► Quantity2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN1 ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DN2 Class

DN2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN2
Declaration Syntax
C# Visual Basic Visual C++
public class DN2 : DocumentSegment
Public Class DN2 _
    Inherits DocumentSegment
public ref class DN2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DN2()()()() | Initializes a new instance of the DN2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToothNumber |
 | ToothStatusCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DN2

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DN2 Constructor

DN2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN2 ► DN2()()()()
Initializes a new instance of the DN2 class
Declaration Syntax
C# Visual Basic Visual C++
public DN2()
Public Sub New
public:
DN2()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN2 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothNumber Property

ToothNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN2 ► ToothNumber
Declaration Syntax
C# Visual Basic Visual C++
public string ToothNumber { get; set; }
Public Property ToothNumber As String
    Get
    Set
public:
property String^ ToothNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothStatusCode Property

ToothStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN2 ► ToothStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string ToothStatusCode { get; set; }
Public Property ToothStatusCode As String
    Get
    Set
public:
property String^ ToothStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DN2 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DSB Class

DSB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB
Declaration Syntax
C# Visual Basic Visual C++
public class DSB : DocumentSegment
Public Class DSB _
    Inherits DocumentSegment
public ref class DSB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSB()()()() | Initializes a new instance of the DSB class
 | DisabilityTypeCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MedicalCodeValue |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupationCode |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductOptionCode |
 | ProductServiceIDQualifier |
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | WorkIntensityCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DSB

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DSB Constructor

DSB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► DSB()()()()
Initializes a new instance of the DSB class
Declaration Syntax
C# Visual Basic Visual C++
public DSB()
Public Sub New
public:
DSB()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DisabilityTypeCode Property

DisabilityTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► DisabilityTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string DisabilityTypeCode { get; set; }
Public Property DisabilityTypeCode As String
    Get
    Set
public:
property String^ DisabilityTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MedicalCodeValue Property

MedicalCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► MedicalCodeValue
Declaration Syntax
C# Visual Basic Visual C++
public string MedicalCodeValue { get; set; }
Public Property MedicalCodeValue As String
    Get
    Set
public:
property String^ MedicalCodeValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OccupationCode Property

OccupationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► OccupationCode
Declaration Syntax
C# Visual Basic Visual C++
public string OccupationCode { get; set; }
Public Property OccupationCode As String
    Get
    Set
public:
property String^ OccupationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductOptionCode Property

ProductOptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► ProductOptionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOptionCode { get; set; }
Public Property ProductOptionCode As String
    Get
    Set
public:
property String^ ProductOptionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► ProductServiceIDQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


WorkIntensityCode Property

WorkIntensityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► WorkIntensityCode
Declaration Syntax
C# Visual Basic Visual C++
public string WorkIntensityCode { get; set; }
Public Property WorkIntensityCode As String
    Get
    Set
public:
property String^ WorkIntensityCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DSB ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DTM Class

DTM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM
Declaration Syntax
C# Visual Basic Visual C++
public class DTM : DocumentSegment
Public Class DTM _
    Inherits DocumentSegment
public ref class DTM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DTM()()()() | Initializes a new instance of the DTM class
 | Date |
 | DateTimePeriod |
 | DateTimePeriodFormatQualifier |
 | DateTimeQualifier |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time |
 | TimeCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DTM

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DTM Constructor

DTM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► DTM()()()()
Initializes a new instance of the DTM class
Declaration Syntax
C# Visual Basic Visual C++
public DTM()
Public Sub New
public:
DTM()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► DateTimePeriod
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► DateTimePeriodFormatQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► DateTimeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► Time
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TimeCode Property

TimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► TimeCode
Declaration Syntax
C# Visual Basic Visual C++
public string TimeCode { get; set; }
Public Property TimeCode As String
    Get
    Set
public:
property String^ TimeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTM ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DTP Class

DTP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTP
Declaration Syntax
C# Visual Basic Visual C++
public class DTP : DocumentSegment
Public Class DTP _
    Inherits DocumentSegment
public ref class DTP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DTP()()()() | Initializes a new instance of the DTP class
 | DateTimePeriod |
 | DateTimePeriodFormatQualifier |
 | DateTimeQualifier |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | DTP

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DTP Constructor

DTP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTP ► DTP()()()()
Initializes a new instance of the DTP class
Declaration Syntax
C# Visual Basic Visual C++
public DTP()
Public Sub New
public:
DTP()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTP ► DateTimePeriod
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTP ► DateTimePeriodFormatQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimeQualifier Property

DateTimeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTP ► DateTimeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimeQualifier { get; set; }
Public Property DateTimeQualifier As String
    Get
    Set
public:
property String^ DateTimeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTP ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► DTP ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EB Class

EB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB
Declaration Syntax
C# Visual Basic Visual C++
public class EB : DocumentSegment
Public Class EB _
    Inherits DocumentSegment
public ref class EB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EB()()()() | Initializes a new instance of the EB class
 | CompositeDiagnosticCodePointer |
 | CompositeMedicalProcedureIdentifier |
 | CoverageLevelCode |
 | EligibilityOrBenefitInformationCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceTypeCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percentage |
 | PlanCoverageDescription |
 | Quantity |
 | QuantityQualifier |
 | ServiceTypeCode |
 | TimePeriodQualifier |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 |
 | YesNoConditionOrResponseCode2 |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EB

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EB Constructor

EB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► EB()()()()
Initializes a new instance of the EB class
Declaration Syntax
C# Visual Basic Visual C++
public EB()
Public Sub New
public:
EB()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeDiagnosticCodePointer Property

CompositeDiagnosticCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► CompositeDiagnosticCodePointer
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer CompositeDiagnosticCodePointer { get; set; }
Public Property CompositeDiagnosticCodePointer As CompositeDiagnosticCodePointer
    Get
    Set
public:
property CompositeDiagnosticCodePointer^ CompositeDiagnosticCodePointer {
    CompositeDiagnosticCodePointer^ get ();
    void set (CompositeDiagnosticCodePointer^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► CompositeMedicalProcedureIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► CoverageLevelCode
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EligibilityOrBenefitInformationCode Property

EligibilityOrBenefitInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► EligibilityOrBenefitInformationCode
Declaration Syntax
C# Visual Basic Visual C++
public string EligibilityOrBenefitInformationCode { get; set; }
Public Property EligibilityOrBenefitInformationCode As String
    Get
    Set
public:
property String^ EligibilityOrBenefitInformationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► InsuranceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Percentage Property

Percentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► Percentage
Declaration Syntax
C# Visual Basic Visual C++
public string Percentage { get; set; }
Public Property Percentage As String
    Get
    Set
public:
property String^ Percentage {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► PlanCoverageDescription
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► QuantityQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► ServiceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► TimePeriodQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► YesNoConditionOrResponseCode1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EB ► YesNoConditionOrResponseCode2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EC Class

EC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC
Declaration Syntax
C# Visual Basic Visual C++
public class EC : DocumentSegment
Public Class EC _
    Inherits DocumentSegment
public ref class EC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EC()()()() | Initializes a new instance of the EC class
 | EmploymentClassCode1 |
 | EmploymentClassCode2 |
 | EmploymentClassCode3 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InformationStatusCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OccupationCode |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percentage |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EC

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EC Constructor

EC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► EC()()()()
Initializes a new instance of the EC class
Declaration Syntax
C# Visual Basic Visual C++
public EC()
Public Sub New
public:
EC()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EmploymentClassCode1 Property

EmploymentClassCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► EmploymentClassCode1
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode1 { get; set; }
Public Property EmploymentClassCode1 As String
    Get
    Set
public:
property String^ EmploymentClassCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EmploymentClassCode2 Property

EmploymentClassCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► EmploymentClassCode2
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode2 { get; set; }
Public Property EmploymentClassCode2 As String
    Get
    Set
public:
property String^ EmploymentClassCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EmploymentClassCode3 Property

EmploymentClassCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► EmploymentClassCode3
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentClassCode3 { get; set; }
Public Property EmploymentClassCode3 As String
    Get
    Set
public:
property String^ EmploymentClassCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► InformationStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OccupationCode Property

OccupationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► OccupationCode
Declaration Syntax
C# Visual Basic Visual C++
public string OccupationCode { get; set; }
Public Property OccupationCode As String
    Get
    Set
public:
property String^ OccupationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Percentage Property

Percentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► Percentage
Declaration Syntax
C# Visual Basic Visual C++
public string Percentage { get; set; }
Public Property Percentage As String
    Get
    Set
public:
property String^ Percentage {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EC ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EQ Class

EQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ
Declaration Syntax
C# Visual Basic Visual C++
public class EQ : DocumentSegment
Public Class EQ _
    Inherits DocumentSegment
public ref class EQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EQ()()()() | Initializes a new instance of the EQ class
 | CompositeDiagnosticCodePointer |
 | CompositeMedicalProcedureIdentifier |
 | CoverageLevelCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceTypeCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ServiceTypeCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | EQ

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EQ Constructor

EQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ ► EQ()()()()
Initializes a new instance of the EQ class
Declaration Syntax
C# Visual Basic Visual C++
public EQ()
Public Sub New
public:
EQ()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeDiagnosticCodePointer Property

CompositeDiagnosticCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ ► CompositeDiagnosticCodePointer
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer CompositeDiagnosticCodePointer { get; set; }
Public Property CompositeDiagnosticCodePointer As CompositeDiagnosticCodePointer
    Get
    Set
public:
property CompositeDiagnosticCodePointer^ CompositeDiagnosticCodePointer {
    CompositeDiagnosticCodePointer^ get ();
    void set (CompositeDiagnosticCodePointer^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ ► CompositeMedicalProcedureIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ ► CoverageLevelCode
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ ► InsuranceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ ► ServiceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► EQ ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FRM Class

FRM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM
Declaration Syntax
C# Visual Basic Visual C++
public class FRM : DocumentSegment
Public Class FRM _
    Inherits DocumentSegment
public ref class FRM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FRM()()()() | Initializes a new instance of the FRM class
 | AssignedIdentification |
 | Date |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percent |
 | ReferenceIdentification |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | FRM

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FRM Constructor

FRM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM ► FRM()()()()
Initializes a new instance of the FRM class
Declaration Syntax
C# Visual Basic Visual C++
public FRM()
Public Sub New
public:
FRM()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM ► AssignedIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Percent Property

Percent Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM ► Percent
Declaration Syntax
C# Visual Basic Visual C++
public string Percent { get; set; }
Public Property Percent As String
    Get
    Set
public:
property String^ Percent {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► FRM ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GE Class

GE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GE
Declaration Syntax
C# Visual Basic Visual C++
public class GE : DocumentSegment
Public Class GE _
    Inherits DocumentSegment
public ref class GE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GE()()()() | Initializes a new instance of the GE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfTransactionSetsIncluded |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GE

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GE Constructor

GE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GE ► GE()()()()
Initializes a new instance of the GE class
Declaration Syntax
C# Visual Basic Visual C++
public GE()
Public Sub New
public:
GE()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GE ► GroupControlNumber
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GE ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NumberOfTransactionSetsIncluded Property

NumberOfTransactionSetsIncluded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GE ► NumberOfTransactionSetsIncluded
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfTransactionSetsIncluded { get; set; }
Public Property NumberOfTransactionSetsIncluded As String
    Get
    Set
public:
property String^ NumberOfTransactionSetsIncluded {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GE ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GS Class

GS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS
Declaration Syntax
C# Visual Basic Visual C++
public class GS : DocumentSegment
Public Class GS _
    Inherits DocumentSegment
public ref class GS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GS()()()() | Initializes a new instance of the GS class
 | ApplicationReceiverCode |
 | ApplicationSenderCode |
 | Date |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FunctionalIdentifierCode |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GroupControlNumber |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ResponsibleAgencyCode |
 | Time |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | VersionReleaseIndustryIdentifierCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | GS

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GS Constructor

GS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► GS()()()()
Initializes a new instance of the GS class
Declaration Syntax
C# Visual Basic Visual C++
public GS()
Public Sub New
public:
GS()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ApplicationReceiverCode Property

ApplicationReceiverCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► ApplicationReceiverCode
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationReceiverCode { get; set; }
Public Property ApplicationReceiverCode As String
    Get
    Set
public:
property String^ ApplicationReceiverCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ApplicationSenderCode Property

ApplicationSenderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► ApplicationSenderCode
Declaration Syntax
C# Visual Basic Visual C++
public string ApplicationSenderCode { get; set; }
Public Property ApplicationSenderCode As String
    Get
    Set
public:
property String^ ApplicationSenderCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FunctionalIdentifierCode Property

FunctionalIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► FunctionalIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string FunctionalIdentifierCode { get; set; }
Public Property FunctionalIdentifierCode As String
    Get
    Set
public:
property String^ FunctionalIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GroupControlNumber Property

GroupControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► GroupControlNumber
Declaration Syntax
C# Visual Basic Visual C++
public string GroupControlNumber { get; set; }
Public Property GroupControlNumber As String
    Get
    Set
public:
property String^ GroupControlNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ResponsibleAgencyCode Property

ResponsibleAgencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► ResponsibleAgencyCode
Declaration Syntax
C# Visual Basic Visual C++
public string ResponsibleAgencyCode { get; set; }
Public Property ResponsibleAgencyCode As String
    Get
    Set
public:
property String^ ResponsibleAgencyCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► Time
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


VersionReleaseIndustryIdentifierCode Property

VersionReleaseIndustryIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► VersionReleaseIndustryIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string VersionReleaseIndustryIdentifierCode { get; set; }
Public Property VersionReleaseIndustryIdentifierCode As String
    Get
    Set
public:
property String^ VersionReleaseIndustryIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► GS ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HCP Class

HCP Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP
Declaration Syntax
C# Visual Basic Visual C++
public class HCP : DocumentSegment
Public Class HCP _
    Inherits DocumentSegment
public ref class HCP : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HCP()()()() | Initializes a new instance of the HCP class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExceptionCode |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PolicyComplianceCode |
 | PricingMethodology |
 | ProductServiceID1 |
 | ProductServiceID2 |
 | ProductServiceIDQualifier |
 | Quantity |
 | Rate |
 | ReferenceIdentification1 |
 | ReferenceIdentification2 |
 | RejectReasonCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HCP

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HCP Constructor

HCP Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► HCP()()()()
Initializes a new instance of the HCP class
Declaration Syntax
C# Visual Basic Visual C++
public HCP()
Public Sub New
public:
HCP()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ExceptionCode Property

ExceptionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► ExceptionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ExceptionCode { get; set; }
Public Property ExceptionCode As String
    Get
    Set
public:
property String^ ExceptionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PolicyComplianceCode Property

PolicyComplianceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► PolicyComplianceCode
Declaration Syntax
C# Visual Basic Visual C++
public string PolicyComplianceCode { get; set; }
Public Property PolicyComplianceCode As String
    Get
    Set
public:
property String^ PolicyComplianceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PricingMethodology Property

PricingMethodology Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► PricingMethodology
Declaration Syntax
C# Visual Basic Visual C++
public string PricingMethodology { get; set; }
Public Property PricingMethodology As String
    Get
    Set
public:
property String^ PricingMethodology {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► ProductServiceID1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► ProductServiceID2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier Property

ProductServiceIDQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► ProductServiceIDQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier { get; set; }
Public Property ProductServiceIDQualifier As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Rate Property

Rate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► Rate
Declaration Syntax
C# Visual Basic Visual C++
public string Rate { get; set; }
Public Property Rate As String
    Get
    Set
public:
property String^ Rate {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► ReferenceIdentification1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► ReferenceIdentification2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RejectReasonCode Property

RejectReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► RejectReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string RejectReasonCode { get; set; }
Public Property RejectReasonCode As String
    Get
    Set
public:
property String^ RejectReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► UnitOrBasisForMeasurementCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HCP ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HD Class

HD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD
Declaration Syntax
C# Visual Basic Visual C++
public class HD : DocumentSegment
Public Class HD _
    Inherits DocumentSegment
public ref class HD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HD()()()() | Initializes a new instance of the HD class
 | Count1 |
 | Count2 |
 | CoverageLevelCode |
 | DrugHouseCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InsuranceLineCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode |
 | MaintenanceTypeCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanCoverageDescription |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnderwritingDecisionCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 |
 | YesNoConditionOrResponseCode2 |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HD

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HD Constructor

HD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► HD()()()()
Initializes a new instance of the HD class
Declaration Syntax
C# Visual Basic Visual C++
public HD()
Public Sub New
public:
HD()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Count1 Property

Count1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► Count1
Declaration Syntax
C# Visual Basic Visual C++
public string Count1 { get; set; }
Public Property Count1 As String
    Get
    Set
public:
property String^ Count1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Count2 Property

Count2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► Count2
Declaration Syntax
C# Visual Basic Visual C++
public string Count2 { get; set; }
Public Property Count2 As String
    Get
    Set
public:
property String^ Count2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CoverageLevelCode Property

CoverageLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► CoverageLevelCode
Declaration Syntax
C# Visual Basic Visual C++
public string CoverageLevelCode { get; set; }
Public Property CoverageLevelCode As String
    Get
    Set
public:
property String^ CoverageLevelCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DrugHouseCode Property

DrugHouseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► DrugHouseCode
Declaration Syntax
C# Visual Basic Visual C++
public string DrugHouseCode { get; set; }
Public Property DrugHouseCode As String
    Get
    Set
public:
property String^ DrugHouseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InsuranceLineCode Property

InsuranceLineCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► InsuranceLineCode
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceLineCode { get; set; }
Public Property InsuranceLineCode As String
    Get
    Set
public:
property String^ InsuranceLineCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► MaintenanceReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► MaintenanceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► PlanCoverageDescription
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnderwritingDecisionCode Property

UnderwritingDecisionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► UnderwritingDecisionCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnderwritingDecisionCode { get; set; }
Public Property UnderwritingDecisionCode As String
    Get
    Set
public:
property String^ UnderwritingDecisionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► YesNoConditionOrResponseCode1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HD ► YesNoConditionOrResponseCode2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareClaimStatus Class

HealthCareClaimStatus Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareClaimStatus
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareClaimStatus : CompositeElement
Public Class HealthCareClaimStatus _
    Inherits CompositeElement
public ref class HealthCareClaimStatus : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareClaimStatus()()()() | Initializes a new instance of the HealthCareClaimStatus class
 | CodeListQualifierCode |
 | EntityIdentifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndustryCode1 |
 | IndustryCode2 |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | HealthCareClaimStatus

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareClaimStatus Constructor

HealthCareClaimStatus Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareClaimStatus ► HealthCareClaimStatus()()()()
Initializes a new instance of the HealthCareClaimStatus class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus()
Public Sub New
public:
HealthCareClaimStatus()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareClaimStatus ► CodeListQualifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareClaimStatus ► EntityIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareClaimStatus ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareClaimStatus ► IndustryCode1
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndustryCode2 Property

IndustryCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareClaimStatus ► IndustryCode2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode2 { get; set; }
Public Property IndustryCode2 As String
    Get
    Set
public:
property String^ IndustryCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation Class

HealthCareCodeInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareCodeInformation : CompositeElement
Public Class HealthCareCodeInformation _
    Inherits CompositeElement
public ref class HealthCareCodeInformation : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareCodeInformation()()()() | Initializes a new instance of the HealthCareCodeInformation class
 | CodeListQualifierCode |
 | DateTimePeriod |
 | DateTimePeriodFormatQualifier |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndustryCode1 |
 | IndustryCode2 |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Quantity |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | VersionIdentifier |
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | CompositeElement
 |  | HealthCareCodeInformation

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation Constructor

HealthCareCodeInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► HealthCareCodeInformation()()()()
Initializes a new instance of the HealthCareCodeInformation class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation()
Public Sub New
public:
HealthCareCodeInformation()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► CodeListQualifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► DateTimePeriod
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► DateTimePeriodFormatQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndustryCode1 Property

IndustryCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► IndustryCode1
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode1 { get; set; }
Public Property IndustryCode1 As String
    Get
    Set
public:
property String^ IndustryCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndustryCode2 Property

IndustryCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► IndustryCode2
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode2 { get; set; }
Public Property IndustryCode2 As String
    Get
    Set
public:
property String^ IndustryCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


VersionIdentifier Property

VersionIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► VersionIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public string VersionIdentifier { get; set; }
Public Property VersionIdentifier As String
    Get
    Set
public:
property String^ VersionIdentifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareCodeInformation ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareServiceLocation Class

HealthCareServiceLocation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareServiceLocation
Declaration Syntax
C# Visual Basic Visual C++
public class HealthCareServiceLocation : CompositeElement
Public Class HealthCareServiceLocation _
    Inherits CompositeElement
public ref class HealthCareServiceLocation : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HealthCareServiceLocation()()()() | Initializes a new instance of the HealthCareServiceLocation class
 | ClaimFrequencyTypeCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeQualifier |
 | FacilityCodeValue |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | HealthCareServiceLocation

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareServiceLocation Constructor

HealthCareServiceLocation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareServiceLocation ► HealthCareServiceLocation()()()()
Initializes a new instance of the HealthCareServiceLocation class
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareServiceLocation()
Public Sub New
public:
HealthCareServiceLocation()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimFrequencyTypeCode Property

ClaimFrequencyTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareServiceLocation ► ClaimFrequencyTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFrequencyTypeCode { get; set; }
Public Property ClaimFrequencyTypeCode As String
    Get
    Set
public:
property String^ ClaimFrequencyTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FacilityCodeQualifier Property

FacilityCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareServiceLocation ► FacilityCodeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeQualifier { get; set; }
Public Property FacilityCodeQualifier As String
    Get
    Set
public:
property String^ FacilityCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareServiceLocation ► FacilityCodeValue
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HealthCareServiceLocation ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HI Class

HI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI
Declaration Syntax
C# Visual Basic Visual C++
public class HI : DocumentSegment
Public Class HI _
    Inherits DocumentSegment
public ref class HI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HI()()()() | Initializes a new instance of the HI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareCodeInformation1 |
 | HealthCareCodeInformation10 |
 | HealthCareCodeInformation11 |
 | HealthCareCodeInformation12 |
 | HealthCareCodeInformation2 |
 | HealthCareCodeInformation3 |
 | HealthCareCodeInformation4 |
 | HealthCareCodeInformation5 |
 | HealthCareCodeInformation6 |
 | HealthCareCodeInformation7 |
 | HealthCareCodeInformation8 |
 | HealthCareCodeInformation9 |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HI

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HI Constructor

HI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HI()()()()
Initializes a new instance of the HI class
Declaration Syntax
C# Visual Basic Visual C++
public HI()
Public Sub New
public:
HI()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation1 Property

HealthCareCodeInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation1
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation1 { get; set; }
Public Property HealthCareCodeInformation1 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation1 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation10 Property

HealthCareCodeInformation10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation10
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation10 { get; set; }
Public Property HealthCareCodeInformation10 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation10 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation11 Property

HealthCareCodeInformation11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation11
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation11 { get; set; }
Public Property HealthCareCodeInformation11 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation11 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation12 Property

HealthCareCodeInformation12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation12
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation12 { get; set; }
Public Property HealthCareCodeInformation12 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation12 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation2 Property

HealthCareCodeInformation2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation2
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation2 { get; set; }
Public Property HealthCareCodeInformation2 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation2 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation3 Property

HealthCareCodeInformation3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation3
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation3 { get; set; }
Public Property HealthCareCodeInformation3 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation3 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation4 Property

HealthCareCodeInformation4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation4
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation4 { get; set; }
Public Property HealthCareCodeInformation4 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation4 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation5 Property

HealthCareCodeInformation5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation5
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation5 { get; set; }
Public Property HealthCareCodeInformation5 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation5 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation6 Property

HealthCareCodeInformation6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation6
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation6 { get; set; }
Public Property HealthCareCodeInformation6 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation6 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation7 Property

HealthCareCodeInformation7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation7
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation7 { get; set; }
Public Property HealthCareCodeInformation7 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation7 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation8 Property

HealthCareCodeInformation8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation8
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation8 { get; set; }
Public Property HealthCareCodeInformation8 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation8 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareCodeInformation9 Property

HealthCareCodeInformation9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► HealthCareCodeInformation9
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareCodeInformation HealthCareCodeInformation9 { get; set; }
Public Property HealthCareCodeInformation9 As HealthCareCodeInformation
    Get
    Set
public:
property HealthCareCodeInformation^ HealthCareCodeInformation9 {
    HealthCareCodeInformation^ get ();
    void set (HealthCareCodeInformation^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HI ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HL Class

HL Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HL
Declaration Syntax
C# Visual Basic Visual C++
public class HL : DocumentSegment
Public Class HL _
    Inherits DocumentSegment
public ref class HL : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HL()()()() | Initializes a new instance of the HL class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HierarchicalChildCode |
 | HierarchicalIDNumber |
 | HierarchicalLevelCode |
 | HierarchicalParentIDNumber |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HL

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HL Constructor

HL Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HL ► HL()()()()
Initializes a new instance of the HL class
Declaration Syntax
C# Visual Basic Visual C++
public HL()
Public Sub New
public:
HL()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HierarchicalChildCode Property

HierarchicalChildCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HL ► HierarchicalChildCode
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalChildCode { get; set; }
Public Property HierarchicalChildCode As String
    Get
    Set
public:
property String^ HierarchicalChildCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HierarchicalIDNumber Property

HierarchicalIDNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HL ► HierarchicalIDNumber
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalIDNumber { get; set; }
Public Property HierarchicalIDNumber As String
    Get
    Set
public:
property String^ HierarchicalIDNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HierarchicalLevelCode Property

HierarchicalLevelCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HL ► HierarchicalLevelCode
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalLevelCode { get; set; }
Public Property HierarchicalLevelCode As String
    Get
    Set
public:
property String^ HierarchicalLevelCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HierarchicalParentIDNumber Property

HierarchicalParentIDNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HL ► HierarchicalParentIDNumber
Declaration Syntax
C# Visual Basic Visual C++
public string HierarchicalParentIDNumber { get; set; }
Public Property HierarchicalParentIDNumber As String
    Get
    Set
public:
property String^ HierarchicalParentIDNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HL ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HL ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HLH Class

HLH Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH
Declaration Syntax
C# Visual Basic Visual C++
public class HLH : DocumentSegment
Public Class HLH _
    Inherits DocumentSegment
public ref class HLH : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HLH()()()() | Initializes a new instance of the HLH class
 | CurrentHealthConditionCode |
 | Description1 |
 | Description2 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthRelatedCode |
 | Height |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Weight1 |
 | Weight2 |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HLH

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HLH Constructor

HLH Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► HLH()()()()
Initializes a new instance of the HLH class
Declaration Syntax
C# Visual Basic Visual C++
public HLH()
Public Sub New
public:
HLH()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CurrentHealthConditionCode Property

CurrentHealthConditionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► CurrentHealthConditionCode
Declaration Syntax
C# Visual Basic Visual C++
public string CurrentHealthConditionCode { get; set; }
Public Property CurrentHealthConditionCode As String
    Get
    Set
public:
property String^ CurrentHealthConditionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description1 Property

Description1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► Description1
Declaration Syntax
C# Visual Basic Visual C++
public string Description1 { get; set; }
Public Property Description1 As String
    Get
    Set
public:
property String^ Description1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description2 Property

Description2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► Description2
Declaration Syntax
C# Visual Basic Visual C++
public string Description2 { get; set; }
Public Property Description2 As String
    Get
    Set
public:
property String^ Description2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthRelatedCode Property

HealthRelatedCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► HealthRelatedCode
Declaration Syntax
C# Visual Basic Visual C++
public string HealthRelatedCode { get; set; }
Public Property HealthRelatedCode As String
    Get
    Set
public:
property String^ HealthRelatedCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Height Property

Height Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► Height
Declaration Syntax
C# Visual Basic Visual C++
public string Height { get; set; }
Public Property Height As String
    Get
    Set
public:
property String^ Height {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Weight1 Property

Weight1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► Weight1
Declaration Syntax
C# Visual Basic Visual C++
public string Weight1 { get; set; }
Public Property Weight1 As String
    Get
    Set
public:
property String^ Weight1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Weight2 Property

Weight2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► Weight2
Declaration Syntax
C# Visual Basic Visual C++
public string Weight2 { get; set; }
Public Property Weight2 As String
    Get
    Set
public:
property String^ Weight2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HLH ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HSD Class

HSD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD
Declaration Syntax
C# Visual Basic Visual C++
public class HSD : DocumentSegment
Public Class HSD _
    Inherits DocumentSegment
public ref class HSD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HSD()()()() | Initializes a new instance of the HSD class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfPeriods |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity |
 | QuantityQualifier |
 | SampleSelectionModulus |
 | ShipDeliveryOrCalendarPatternCode |
 | ShipDeliveryPatternTimeCode |
 | TimePeriodQualifier |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | HSD

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HSD Constructor

HSD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► HSD()()()()
Initializes a new instance of the HSD class
Declaration Syntax
C# Visual Basic Visual C++
public HSD()
Public Sub New
public:
HSD()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NumberOfPeriods Property

NumberOfPeriods Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► NumberOfPeriods
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfPeriods { get; set; }
Public Property NumberOfPeriods As String
    Get
    Set
public:
property String^ NumberOfPeriods {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► QuantityQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SampleSelectionModulus Property

SampleSelectionModulus Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► SampleSelectionModulus
Declaration Syntax
C# Visual Basic Visual C++
public string SampleSelectionModulus { get; set; }
Public Property SampleSelectionModulus As String
    Get
    Set
public:
property String^ SampleSelectionModulus {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ShipDeliveryOrCalendarPatternCode Property

ShipDeliveryOrCalendarPatternCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► ShipDeliveryOrCalendarPatternCode
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryOrCalendarPatternCode { get; set; }
Public Property ShipDeliveryOrCalendarPatternCode As String
    Get
    Set
public:
property String^ ShipDeliveryOrCalendarPatternCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ShipDeliveryPatternTimeCode Property

ShipDeliveryPatternTimeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► ShipDeliveryPatternTimeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ShipDeliveryPatternTimeCode { get; set; }
Public Property ShipDeliveryPatternTimeCode As String
    Get
    Set
public:
property String^ ShipDeliveryPatternTimeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TimePeriodQualifier Property

TimePeriodQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► TimePeriodQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string TimePeriodQualifier { get; set; }
Public Property TimePeriodQualifier As String
    Get
    Set
public:
property String^ TimePeriodQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► UnitOrBasisForMeasurementCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► HSD ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ICM Class

ICM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM
Declaration Syntax
C# Visual Basic Visual C++
public class ICM : DocumentSegment
Public Class ICM _
    Inherits DocumentSegment
public ref class ICM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ICM()()()() | Initializes a new instance of the ICM class
 | CurrencyCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationIdentifier |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity |
 | SalaryGrade |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ICM

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ICM Constructor

ICM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► ICM()()()()
Initializes a new instance of the ICM class
Declaration Syntax
C# Visual Basic Visual C++
public ICM()
Public Sub New
public:
ICM()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CurrencyCode Property

CurrencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► CurrencyCode
Declaration Syntax
C# Visual Basic Visual C++
public string CurrencyCode { get; set; }
Public Property CurrencyCode As String
    Get
    Set
public:
property String^ CurrencyCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► FrequencyCode
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LocationIdentifier Property

LocationIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► LocationIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public string LocationIdentifier { get; set; }
Public Property LocationIdentifier As String
    Get
    Set
public:
property String^ LocationIdentifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SalaryGrade Property

SalaryGrade Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► SalaryGrade
Declaration Syntax
C# Visual Basic Visual C++
public string SalaryGrade { get; set; }
Public Property SalaryGrade As String
    Get
    Set
public:
property String^ SalaryGrade {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ICM ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IDC Class

IDC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IDC
Declaration Syntax
C# Visual Basic Visual C++
public class IDC : DocumentSegment
Public Class IDC _
    Inherits DocumentSegment
public ref class IDC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IDC()()()() | Initializes a new instance of the IDC class
 | ActionCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCardTypeCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PlanCoverageDescription |
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IDC

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IDC Constructor

IDC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IDC ► IDC()()()()
Initializes a new instance of the IDC class
Declaration Syntax
C# Visual Basic Visual C++
public IDC()
Public Sub New
public:
IDC()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IDC ► ActionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCardTypeCode Property

IdentificationCardTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IDC ► IdentificationCardTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCardTypeCode { get; set; }
Public Property IdentificationCardTypeCode As String
    Get
    Set
public:
property String^ IdentificationCardTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IDC ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PlanCoverageDescription Property

PlanCoverageDescription Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IDC ► PlanCoverageDescription
Declaration Syntax
C# Visual Basic Visual C++
public string PlanCoverageDescription { get; set; }
Public Property PlanCoverageDescription As String
    Get
    Set
public:
property String^ PlanCoverageDescription {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IDC ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IDC ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IEA Class

IEA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IEA
Declaration Syntax
C# Visual Basic Visual C++
public class IEA : DocumentSegment
Public Class IEA _
    Inherits DocumentSegment
public ref class IEA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IEA()()()() | Initializes a new instance of the IEA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeControlNumber |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfIncludedFunctionalGroups |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IEA

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IEA Constructor

IEA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IEA ► IEA()()()()
Initializes a new instance of the IEA class
Declaration Syntax
C# Visual Basic Visual C++
public IEA()
Public Sub New
public:
IEA()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IEA ► InterchangeControlNumber
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As String
    Get
    Set
public:
property String^ InterchangeControlNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IEA ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NumberOfIncludedFunctionalGroups Property

NumberOfIncludedFunctionalGroups Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IEA ► NumberOfIncludedFunctionalGroups
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfIncludedFunctionalGroups { get; set; }
Public Property NumberOfIncludedFunctionalGroups As String
    Get
    Set
public:
property String^ NumberOfIncludedFunctionalGroups {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IEA ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


III Class

III Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III
Declaration Syntax
C# Visual Basic Visual C++
public class III : DocumentSegment
Public Class III _
    Inherits DocumentSegment
public ref class III : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | III()()()() | Initializes a new instance of the III class
 | CodeCategory |
 | CodeListQualifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeformMessageText |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity |
 | SurfaceLayerPositionCode1 |
 | SurfaceLayerPositionCode2 |
 | SurfaceLayerPositionCode3 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | III

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


III Constructor

III Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► III()()()()
Initializes a new instance of the III class
Declaration Syntax
C# Visual Basic Visual C++
public III()
Public Sub New
public:
III()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CodeCategory Property

CodeCategory Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► CodeCategory
Declaration Syntax
C# Visual Basic Visual C++
public string CodeCategory { get; set; }
Public Property CodeCategory As String
    Get
    Set
public:
property String^ CodeCategory {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► CodeListQualifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FreeformMessageText Property

FreeformMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► FreeformMessageText
Declaration Syntax
C# Visual Basic Visual C++
public string FreeformMessageText { get; set; }
Public Property FreeformMessageText As String
    Get
    Set
public:
property String^ FreeformMessageText {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► IndustryCode
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SurfaceLayerPositionCode1 Property

SurfaceLayerPositionCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► SurfaceLayerPositionCode1
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode1 { get; set; }
Public Property SurfaceLayerPositionCode1 As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SurfaceLayerPositionCode2 Property

SurfaceLayerPositionCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► SurfaceLayerPositionCode2
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode2 { get; set; }
Public Property SurfaceLayerPositionCode2 As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SurfaceLayerPositionCode3 Property

SurfaceLayerPositionCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► SurfaceLayerPositionCode3
Declaration Syntax
C# Visual Basic Visual C++
public string SurfaceLayerPositionCode3 { get; set; }
Public Property SurfaceLayerPositionCode3 As String
    Get
    Set
public:
property String^ SurfaceLayerPositionCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► III ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IK3 Class

IK3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK3
Declaration Syntax
C# Visual Basic Visual C++
public class IK3 : DocumentSegment
Public Class IK3 _
    Inherits DocumentSegment
public ref class IK3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IK3()()()() | Initializes a new instance of the IK3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationSegmentSyntaxErrorCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | SegmentIDCode |
 | SegmentPositionInTransactionSet |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IK3

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IK3 Constructor

IK3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK3 ► IK3()()()()
Initializes a new instance of the IK3 class
Declaration Syntax
C# Visual Basic Visual C++
public IK3()
Public Sub New
public:
IK3()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ImplementationSegmentSyntaxErrorCode Property

ImplementationSegmentSyntaxErrorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK3 ► ImplementationSegmentSyntaxErrorCode
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationSegmentSyntaxErrorCode { get; set; }
Public Property ImplementationSegmentSyntaxErrorCode As String
    Get
    Set
public:
property String^ ImplementationSegmentSyntaxErrorCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK3 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK3 ► LoopIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SegmentIDCode Property

SegmentIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK3 ► SegmentIDCode
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentIDCode { get; set; }
Public Property SegmentIDCode As String
    Get
    Set
public:
property String^ SegmentIDCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SegmentPositionInTransactionSet Property

SegmentPositionInTransactionSet Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK3 ► SegmentPositionInTransactionSet
Declaration Syntax
C# Visual Basic Visual C++
public string SegmentPositionInTransactionSet { get; set; }
Public Property SegmentPositionInTransactionSet As String
    Get
    Set
public:
property String^ SegmentPositionInTransactionSet {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK3 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IK4 Class

IK4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK4
Declaration Syntax
C# Visual Basic Visual C++
public class IK4 : DocumentSegment
Public Class IK4 _
    Inherits DocumentSegment
public ref class IK4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IK4()()()() | Initializes a new instance of the IK4 class
 | CopyOfBadDataElement |
 | DataElementReferenceNumber |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationDataElementSyntaxErrorCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PositionInSegment |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IK4

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IK4 Constructor

IK4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK4 ► IK4()()()()
Initializes a new instance of the IK4 class
Declaration Syntax
C# Visual Basic Visual C++
public IK4()
Public Sub New
public:
IK4()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CopyOfBadDataElement Property

CopyOfBadDataElement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK4 ► CopyOfBadDataElement
Declaration Syntax
C# Visual Basic Visual C++
public string CopyOfBadDataElement { get; set; }
Public Property CopyOfBadDataElement As String
    Get
    Set
public:
property String^ CopyOfBadDataElement {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DataElementReferenceNumber Property

DataElementReferenceNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK4 ► DataElementReferenceNumber
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber { get; set; }
Public Property DataElementReferenceNumber As String
    Get
    Set
public:
property String^ DataElementReferenceNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ImplementationDataElementSyntaxErrorCode Property

ImplementationDataElementSyntaxErrorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK4 ► ImplementationDataElementSyntaxErrorCode
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationDataElementSyntaxErrorCode { get; set; }
Public Property ImplementationDataElementSyntaxErrorCode As String
    Get
    Set
public:
property String^ ImplementationDataElementSyntaxErrorCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK4 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PositionInSegment Property

PositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK4 ► PositionInSegment
Declaration Syntax
C# Visual Basic Visual C++
public PositionInSegment PositionInSegment { get; set; }
Public Property PositionInSegment As PositionInSegment
    Get
    Set
public:
property PositionInSegment^ PositionInSegment {
    PositionInSegment^ get ();
    void set (PositionInSegment^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK4 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IK5 Class

IK5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5
Declaration Syntax
C# Visual Basic Visual C++
public class IK5 : DocumentSegment
Public Class IK5 _
    Inherits DocumentSegment
public ref class IK5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IK5()()()() | Initializes a new instance of the IK5 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationTransactionSetSyntaxErrorCode1 |
 | ImplementationTransactionSetSyntaxErrorCode2 |
 | ImplementationTransactionSetSyntaxErrorCode3 |
 | ImplementationTransactionSetSyntaxErrorCode4 |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetAcknowledgmentCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | IK5

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IK5 Constructor

IK5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5 ► IK5()()()()
Initializes a new instance of the IK5 class
Declaration Syntax
C# Visual Basic Visual C++
public IK5()
Public Sub New
public:
IK5()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ImplementationTransactionSetSyntaxErrorCode1 Property

ImplementationTransactionSetSyntaxErrorCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5 ► ImplementationTransactionSetSyntaxErrorCode1
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationTransactionSetSyntaxErrorCode1 { get; set; }
Public Property ImplementationTransactionSetSyntaxErrorCode1 As String
    Get
    Set
public:
property String^ ImplementationTransactionSetSyntaxErrorCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ImplementationTransactionSetSyntaxErrorCode2 Property

ImplementationTransactionSetSyntaxErrorCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5 ► ImplementationTransactionSetSyntaxErrorCode2
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationTransactionSetSyntaxErrorCode2 { get; set; }
Public Property ImplementationTransactionSetSyntaxErrorCode2 As String
    Get
    Set
public:
property String^ ImplementationTransactionSetSyntaxErrorCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ImplementationTransactionSetSyntaxErrorCode3 Property

ImplementationTransactionSetSyntaxErrorCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5 ► ImplementationTransactionSetSyntaxErrorCode3
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationTransactionSetSyntaxErrorCode3 { get; set; }
Public Property ImplementationTransactionSetSyntaxErrorCode3 As String
    Get
    Set
public:
property String^ ImplementationTransactionSetSyntaxErrorCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ImplementationTransactionSetSyntaxErrorCode4 Property

ImplementationTransactionSetSyntaxErrorCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5 ► ImplementationTransactionSetSyntaxErrorCode4
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationTransactionSetSyntaxErrorCode4 { get; set; }
Public Property ImplementationTransactionSetSyntaxErrorCode4 As String
    Get
    Set
public:
property String^ ImplementationTransactionSetSyntaxErrorCode4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionSetAcknowledgmentCode Property

TransactionSetAcknowledgmentCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5 ► TransactionSetAcknowledgmentCode
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetAcknowledgmentCode { get; set; }
Public Property TransactionSetAcknowledgmentCode As String
    Get
    Set
public:
property String^ TransactionSetAcknowledgmentCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► IK5 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


INS Class

INS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS
Declaration Syntax
C# Visual Basic Visual C++
public class INS : DocumentSegment
Public Class INS _
    Inherits DocumentSegment
public ref class INS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | INS()()()() | Initializes a new instance of the INS class
 | BenefitStatusCode |
 | CityName |
 | ConfidentialityCode |
 | ConsolidatedOmnibusBudgetReconciliationAct |
 | CountryCode |
 | DateTimePeriod |
 | DateTimePeriodFormatQualifier |
 | EmploymentStatusCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode |
 | MaintenanceTypeCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | Number |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | StateOrProvinceCode |
 | StudentStatusCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 |
 | YesNoConditionOrResponseCode2 |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | INS

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


INS Constructor

INS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► INS()()()()
Initializes a new instance of the INS class
Declaration Syntax
C# Visual Basic Visual C++
public INS()
Public Sub New
public:
INS()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


BenefitStatusCode Property

BenefitStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► BenefitStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string BenefitStatusCode { get; set; }
Public Property BenefitStatusCode As String
    Get
    Set
public:
property String^ BenefitStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► CityName
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ConfidentialityCode Property

ConfidentialityCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► ConfidentialityCode
Declaration Syntax
C# Visual Basic Visual C++
public string ConfidentialityCode { get; set; }
Public Property ConfidentialityCode As String
    Get
    Set
public:
property String^ ConfidentialityCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ConsolidatedOmnibusBudgetReconciliationAct Property

ConsolidatedOmnibusBudgetReconciliationAct Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► ConsolidatedOmnibusBudgetReconciliationAct
Declaration Syntax
C# Visual Basic Visual C++
public string ConsolidatedOmnibusBudgetReconciliationAct { get; set; }
Public Property ConsolidatedOmnibusBudgetReconciliationAct As String
    Get
    Set
public:
property String^ ConsolidatedOmnibusBudgetReconciliationAct {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► CountryCode
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► DateTimePeriod
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► DateTimePeriodFormatQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► EmploymentStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► IndividualRelationshipCode
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► MaintenanceReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MaintenanceTypeCode Property

MaintenanceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► MaintenanceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceTypeCode { get; set; }
Public Property MaintenanceTypeCode As String
    Get
    Set
public:
property String^ MaintenanceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Number Property

Number Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► Number
Declaration Syntax
C# Visual Basic Visual C++
public string Number { get; set; }
Public Property Number As String
    Get
    Set
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► StateOrProvinceCode
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


StudentStatusCode Property

StudentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► StudentStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string StudentStatusCode { get; set; }
Public Property StudentStatusCode As String
    Get
    Set
public:
property String^ StudentStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► YesNoConditionOrResponseCode1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► INS ► YesNoConditionOrResponseCode2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ISA Class

ISA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA
Declaration Syntax
C# Visual Basic Visual C++
public class ISA : DocumentSegment
Public Class ISA _
    Inherits DocumentSegment
public ref class ISA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ISA()()()() | Initializes a new instance of the ISA class
 | AcknowledgmentRequested |
 | AuthorizationInformation |
 | AuthorizationInformationQualifier |
 | ComponentElementSeparator |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | InterchangeControlNumber |
 | InterchangeControlVersionNumber |
 | InterchangeDate |
 | InterchangeIDQualifier1 |
 | InterchangeIDQualifier2 |
 | InterchangeReceiverID |
 | InterchangeSenderID |
 | InterchangeTime |
 | InterchangeUsageIndicator |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RepetitionSeparator |
 | SecurityInformation |
 | SecurityInformationQualifier |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ISA

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ISA Constructor

ISA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► ISA()()()()
Initializes a new instance of the ISA class
Declaration Syntax
C# Visual Basic Visual C++
public ISA()
Public Sub New
public:
ISA()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AcknowledgmentRequested Property

AcknowledgmentRequested Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► AcknowledgmentRequested
Declaration Syntax
C# Visual Basic Visual C++
public string AcknowledgmentRequested { get; set; }
Public Property AcknowledgmentRequested As String
    Get
    Set
public:
property String^ AcknowledgmentRequested {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AuthorizationInformation Property

AuthorizationInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► AuthorizationInformation
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationInformation { get; set; }
Public Property AuthorizationInformation As String
    Get
    Set
public:
property String^ AuthorizationInformation {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AuthorizationInformationQualifier Property

AuthorizationInformationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► AuthorizationInformationQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string AuthorizationInformationQualifier { get; set; }
Public Property AuthorizationInformationQualifier As String
    Get
    Set
public:
property String^ AuthorizationInformationQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ComponentElementSeparator Property

ComponentElementSeparator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► ComponentElementSeparator
Declaration Syntax
C# Visual Basic Visual C++
public string ComponentElementSeparator { get; set; }
Public Property ComponentElementSeparator As String
    Get
    Set
public:
property String^ ComponentElementSeparator {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeControlNumber Property

InterchangeControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeControlNumber
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlNumber { get; set; }
Public Property InterchangeControlNumber As String
    Get
    Set
public:
property String^ InterchangeControlNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeControlVersionNumber Property

InterchangeControlVersionNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeControlVersionNumber
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeControlVersionNumber { get; set; }
Public Property InterchangeControlVersionNumber As String
    Get
    Set
public:
property String^ InterchangeControlVersionNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeDate Property

InterchangeDate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeDate
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeDate { get; set; }
Public Property InterchangeDate As String
    Get
    Set
public:
property String^ InterchangeDate {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeIDQualifier1 Property

InterchangeIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeIDQualifier1
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeIDQualifier1 { get; set; }
Public Property InterchangeIDQualifier1 As String
    Get
    Set
public:
property String^ InterchangeIDQualifier1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeIDQualifier2 Property

InterchangeIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeIDQualifier2
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeIDQualifier2 { get; set; }
Public Property InterchangeIDQualifier2 As String
    Get
    Set
public:
property String^ InterchangeIDQualifier2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeReceiverID Property

InterchangeReceiverID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeReceiverID
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeReceiverID { get; set; }
Public Property InterchangeReceiverID As String
    Get
    Set
public:
property String^ InterchangeReceiverID {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeSenderID Property

InterchangeSenderID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeSenderID
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeSenderID { get; set; }
Public Property InterchangeSenderID As String
    Get
    Set
public:
property String^ InterchangeSenderID {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeTime Property

InterchangeTime Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeTime
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeTime { get; set; }
Public Property InterchangeTime As String
    Get
    Set
public:
property String^ InterchangeTime {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InterchangeUsageIndicator Property

InterchangeUsageIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► InterchangeUsageIndicator
Declaration Syntax
C# Visual Basic Visual C++
public string InterchangeUsageIndicator { get; set; }
Public Property InterchangeUsageIndicator As String
    Get
    Set
public:
property String^ InterchangeUsageIndicator {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RepetitionSeparator Property

RepetitionSeparator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► RepetitionSeparator
Declaration Syntax
C# Visual Basic Visual C++
public string RepetitionSeparator { get; set; }
Public Property RepetitionSeparator As String
    Get
    Set
public:
property String^ RepetitionSeparator {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SecurityInformation Property

SecurityInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► SecurityInformation
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityInformation { get; set; }
Public Property SecurityInformation As String
    Get
    Set
public:
property String^ SecurityInformation {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SecurityInformationQualifier Property

SecurityInformationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► SecurityInformationQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string SecurityInformationQualifier { get; set; }
Public Property SecurityInformationQualifier As String
    Get
    Set
public:
property String^ SecurityInformationQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ISA ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


K3 Class

K3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► K3
Declaration Syntax
C# Visual Basic Visual C++
public class K3 : DocumentSegment
Public Class K3 _
    Inherits DocumentSegment
public ref class K3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | K3()()()() | Initializes a new instance of the K3 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FixedFormatInformation |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | RecordFormatCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | K3

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


K3 Constructor

K3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► K3 ► K3()()()()
Initializes a new instance of the K3 class
Declaration Syntax
C# Visual Basic Visual C++
public K3()
Public Sub New
public:
K3()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FixedFormatInformation Property

FixedFormatInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► K3 ► FixedFormatInformation
Declaration Syntax
C# Visual Basic Visual C++
public string FixedFormatInformation { get; set; }
Public Property FixedFormatInformation As String
    Get
    Set
public:
property String^ FixedFormatInformation {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► K3 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RecordFormatCode Property

RecordFormatCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► K3 ► RecordFormatCode
Declaration Syntax
C# Visual Basic Visual C++
public string RecordFormatCode { get; set; }
Public Property RecordFormatCode As String
    Get
    Set
public:
property String^ RecordFormatCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► K3 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LE Class

LE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LE
Declaration Syntax
C# Visual Basic Visual C++
public class LE : DocumentSegment
Public Class LE _
    Inherits DocumentSegment
public ref class LE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LE()()()() | Initializes a new instance of the LE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LE

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LE Constructor

LE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LE ► LE()()()()
Initializes a new instance of the LE class
Declaration Syntax
C# Visual Basic Visual C++
public LE()
Public Sub New
public:
LE()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LE ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LE ► LoopIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LE ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LIN Class

LIN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN
Declaration Syntax
C# Visual Basic Visual C++
public class LIN : DocumentSegment
Public Class LIN _
    Inherits DocumentSegment
public ref class LIN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LIN()()()() | Initializes a new instance of the LIN class
 | AssignedIdentification |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID1 |
 | ProductServiceID10 |
 | ProductServiceID11 |
 | ProductServiceID12 |
 | ProductServiceID13 |
 | ProductServiceID14 |
 | ProductServiceID15 |
 | ProductServiceID2 |
 | ProductServiceID3 |
 | ProductServiceID4 |
 | ProductServiceID5 |
 | ProductServiceID6 |
 | ProductServiceID7 |
 | ProductServiceID8 |
 | ProductServiceID9 |
 | ProductServiceIDQualifier1 |
 | ProductServiceIDQualifier10 |
 | ProductServiceIDQualifier11 |
 | ProductServiceIDQualifier12 |
 | ProductServiceIDQualifier13 |
 | ProductServiceIDQualifier14 |
 | ProductServiceIDQualifier15 |
 | ProductServiceIDQualifier2 |
 | ProductServiceIDQualifier3 |
 | ProductServiceIDQualifier4 |
 | ProductServiceIDQualifier5 |
 | ProductServiceIDQualifier6 |
 | ProductServiceIDQualifier7 |
 | ProductServiceIDQualifier8 |
 | ProductServiceIDQualifier9 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LIN

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LIN Constructor

LIN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► LIN()()()()
Initializes a new instance of the LIN class
Declaration Syntax
C# Visual Basic Visual C++
public LIN()
Public Sub New
public:
LIN()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AssignedIdentification Property

AssignedIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► AssignedIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedIdentification { get; set; }
Public Property AssignedIdentification As String
    Get
    Set
public:
property String^ AssignedIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID1 Property

ProductServiceID1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID1 { get; set; }
Public Property ProductServiceID1 As String
    Get
    Set
public:
property String^ ProductServiceID1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID10 Property

ProductServiceID10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID10 { get; set; }
Public Property ProductServiceID10 As String
    Get
    Set
public:
property String^ ProductServiceID10 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID11 Property

ProductServiceID11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID11 { get; set; }
Public Property ProductServiceID11 As String
    Get
    Set
public:
property String^ ProductServiceID11 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID12 Property

ProductServiceID12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID12 { get; set; }
Public Property ProductServiceID12 As String
    Get
    Set
public:
property String^ ProductServiceID12 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID13 Property

ProductServiceID13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID13 { get; set; }
Public Property ProductServiceID13 As String
    Get
    Set
public:
property String^ ProductServiceID13 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID14 Property

ProductServiceID14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID14 { get; set; }
Public Property ProductServiceID14 As String
    Get
    Set
public:
property String^ ProductServiceID14 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID15 Property

ProductServiceID15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID15 { get; set; }
Public Property ProductServiceID15 As String
    Get
    Set
public:
property String^ ProductServiceID15 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID2 Property

ProductServiceID2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID2 { get; set; }
Public Property ProductServiceID2 As String
    Get
    Set
public:
property String^ ProductServiceID2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID3 Property

ProductServiceID3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID3 { get; set; }
Public Property ProductServiceID3 As String
    Get
    Set
public:
property String^ ProductServiceID3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID4 Property

ProductServiceID4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID4 { get; set; }
Public Property ProductServiceID4 As String
    Get
    Set
public:
property String^ ProductServiceID4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID5 Property

ProductServiceID5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID5 { get; set; }
Public Property ProductServiceID5 As String
    Get
    Set
public:
property String^ ProductServiceID5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID6 Property

ProductServiceID6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID6 { get; set; }
Public Property ProductServiceID6 As String
    Get
    Set
public:
property String^ ProductServiceID6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID7 Property

ProductServiceID7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID7 { get; set; }
Public Property ProductServiceID7 As String
    Get
    Set
public:
property String^ ProductServiceID7 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID8 Property

ProductServiceID8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID8 { get; set; }
Public Property ProductServiceID8 As String
    Get
    Set
public:
property String^ ProductServiceID8 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID9 Property

ProductServiceID9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceID9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID9 { get; set; }
Public Property ProductServiceID9 As String
    Get
    Set
public:
property String^ ProductServiceID9 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier1 Property

ProductServiceIDQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier1
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier1 { get; set; }
Public Property ProductServiceIDQualifier1 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier10 Property

ProductServiceIDQualifier10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier10
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier10 { get; set; }
Public Property ProductServiceIDQualifier10 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier10 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier11 Property

ProductServiceIDQualifier11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier11
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier11 { get; set; }
Public Property ProductServiceIDQualifier11 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier11 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier12 Property

ProductServiceIDQualifier12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier12
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier12 { get; set; }
Public Property ProductServiceIDQualifier12 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier12 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier13 Property

ProductServiceIDQualifier13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier13
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier13 { get; set; }
Public Property ProductServiceIDQualifier13 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier13 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier14 Property

ProductServiceIDQualifier14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier14
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier14 { get; set; }
Public Property ProductServiceIDQualifier14 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier14 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier15 Property

ProductServiceIDQualifier15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier15
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier15 { get; set; }
Public Property ProductServiceIDQualifier15 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier15 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier2 Property

ProductServiceIDQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier2
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier2 { get; set; }
Public Property ProductServiceIDQualifier2 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier3 Property

ProductServiceIDQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier3
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier3 { get; set; }
Public Property ProductServiceIDQualifier3 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier4 Property

ProductServiceIDQualifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier4
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier4 { get; set; }
Public Property ProductServiceIDQualifier4 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier5 Property

ProductServiceIDQualifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier5
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier5 { get; set; }
Public Property ProductServiceIDQualifier5 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier6 Property

ProductServiceIDQualifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier6
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier6 { get; set; }
Public Property ProductServiceIDQualifier6 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier7 Property

ProductServiceIDQualifier7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier7
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier7 { get; set; }
Public Property ProductServiceIDQualifier7 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier7 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier8 Property

ProductServiceIDQualifier8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier8
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier8 { get; set; }
Public Property ProductServiceIDQualifier8 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier8 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceIDQualifier9 Property

ProductServiceIDQualifier9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► ProductServiceIDQualifier9
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceIDQualifier9 { get; set; }
Public Property ProductServiceIDQualifier9 As String
    Get
    Set
public:
property String^ ProductServiceIDQualifier9 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LIN ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LQ Class

LQ Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LQ
Declaration Syntax
C# Visual Basic Visual C++
public class LQ : DocumentSegment
Public Class LQ _
    Inherits DocumentSegment
public ref class LQ : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LQ()()()() | Initializes a new instance of the LQ class
 | CodeListQualifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndustryCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LQ

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LQ Constructor

LQ Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LQ ► LQ()()()()
Initializes a new instance of the LQ class
Declaration Syntax
C# Visual Basic Visual C++
public LQ()
Public Sub New
public:
LQ()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LQ ► CodeListQualifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndustryCode Property

IndustryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LQ ► IndustryCode
Declaration Syntax
C# Visual Basic Visual C++
public string IndustryCode { get; set; }
Public Property IndustryCode As String
    Get
    Set
public:
property String^ IndustryCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LQ ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LQ ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LS Class

LS Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LS
Declaration Syntax
C# Visual Basic Visual C++
public class LS : DocumentSegment
Public Class LS _
    Inherits DocumentSegment
public ref class LS : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LS()()()() | Initializes a new instance of the LS class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LoopIdentifierCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LS

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LS Constructor

LS Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LS ► LS()()()()
Initializes a new instance of the LS class
Declaration Syntax
C# Visual Basic Visual C++
public LS()
Public Sub New
public:
LS()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LS ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LoopIdentifierCode Property

LoopIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LS ► LoopIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string LoopIdentifierCode { get; set; }
Public Property LoopIdentifierCode As String
    Get
    Set
public:
property String^ LoopIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LS ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LUI Class

LUI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI
Declaration Syntax
C# Visual Basic Visual C++
public class LUI : DocumentSegment
Public Class LUI _
    Inherits DocumentSegment
public ref class LUI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LUI()()()() | Initializes a new instance of the LUI class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode |
 | IdentificationCodeQualifier |
 | LanguageProficiencyIndicator |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UseOfLanguageIndicator |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LUI

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LUI Constructor

LUI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI ► LUI()()()()
Initializes a new instance of the LUI class
Declaration Syntax
C# Visual Basic Visual C++
public LUI()
Public Sub New
public:
LUI()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI ► IdentificationCode
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI ► IdentificationCodeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LanguageProficiencyIndicator Property

LanguageProficiencyIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI ► LanguageProficiencyIndicator
Declaration Syntax
C# Visual Basic Visual C++
public string LanguageProficiencyIndicator { get; set; }
Public Property LanguageProficiencyIndicator As String
    Get
    Set
public:
property String^ LanguageProficiencyIndicator {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UseOfLanguageIndicator Property

UseOfLanguageIndicator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI ► UseOfLanguageIndicator
Declaration Syntax
C# Visual Basic Visual C++
public string UseOfLanguageIndicator { get; set; }
Public Property UseOfLanguageIndicator As String
    Get
    Set
public:
property String^ UseOfLanguageIndicator {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LUI ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LX Class

LX Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LX
Declaration Syntax
C# Visual Basic Visual C++
public class LX : DocumentSegment
Public Class LX _
    Inherits DocumentSegment
public ref class LX : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LX()()()() | Initializes a new instance of the LX class
 | AssignedNumber |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | LX

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LX Constructor

LX Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LX ► LX()()()()
Initializes a new instance of the LX class
Declaration Syntax
C# Visual Basic Visual C++
public LX()
Public Sub New
public:
LX()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LX ► AssignedNumber
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LX ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► LX ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MEA Class

MEA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MEA
Declaration Syntax
C# Visual Basic Visual C++
public class MEA : DocumentSegment
Public Class MEA _
    Inherits DocumentSegment
public ref class MEA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MEA()()()() | Initializes a new instance of the MEA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MeasurementQualifier |
 | MeasurementReferenceIDCode |
 | MeasurementValue |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MEA

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MEA Constructor

MEA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MEA ► MEA()()()()
Initializes a new instance of the MEA class
Declaration Syntax
C# Visual Basic Visual C++
public MEA()
Public Sub New
public:
MEA()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MEA ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MeasurementQualifier Property

MeasurementQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MEA ► MeasurementQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementQualifier { get; set; }
Public Property MeasurementQualifier As String
    Get
    Set
public:
property String^ MeasurementQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MeasurementReferenceIDCode Property

MeasurementReferenceIDCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MEA ► MeasurementReferenceIDCode
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementReferenceIDCode { get; set; }
Public Property MeasurementReferenceIDCode As String
    Get
    Set
public:
property String^ MeasurementReferenceIDCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MeasurementValue Property

MeasurementValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MEA ► MeasurementValue
Declaration Syntax
C# Visual Basic Visual C++
public string MeasurementValue { get; set; }
Public Property MeasurementValue As String
    Get
    Set
public:
property String^ MeasurementValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MEA ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MIA Class

MIA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA
Declaration Syntax
C# Visual Basic Visual C++
public class MIA : DocumentSegment
Public Class MIA _
    Inherits DocumentSegment
public ref class MIA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MIA()()()() | Initializes a new instance of the MIA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount10 |
 | MonetaryAmount11 |
 | MonetaryAmount12 |
 | MonetaryAmount13 |
 | MonetaryAmount14 |
 | MonetaryAmount15 |
 | MonetaryAmount16 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | MonetaryAmount4 |
 | MonetaryAmount5 |
 | MonetaryAmount6 |
 | MonetaryAmount7 |
 | MonetaryAmount8 |
 | MonetaryAmount9 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 |
 | Quantity2 |
 | Quantity3 |
 | ReferenceIdentification1 |
 | ReferenceIdentification2 |
 | ReferenceIdentification3 |
 | ReferenceIdentification4 |
 | ReferenceIdentification5 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MIA

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MIA Constructor

MIA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MIA()()()()
Initializes a new instance of the MIA class
Declaration Syntax
C# Visual Basic Visual C++
public MIA()
Public Sub New
public:
MIA()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount12 Property

MonetaryAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount12 { get; set; }
Public Property MonetaryAmount12 As String
    Get
    Set
public:
property String^ MonetaryAmount12 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount13 Property

MonetaryAmount13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount13 { get; set; }
Public Property MonetaryAmount13 As String
    Get
    Set
public:
property String^ MonetaryAmount13 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount14 Property

MonetaryAmount14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount14 { get; set; }
Public Property MonetaryAmount14 As String
    Get
    Set
public:
property String^ MonetaryAmount14 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount15 Property

MonetaryAmount15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount15 { get; set; }
Public Property MonetaryAmount15 As String
    Get
    Set
public:
property String^ MonetaryAmount15 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount16 Property

MonetaryAmount16 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount16
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount16 { get; set; }
Public Property MonetaryAmount16 As String
    Get
    Set
public:
property String^ MonetaryAmount16 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► MonetaryAmount9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► Quantity1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► Quantity2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► Quantity3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► ReferenceIdentification1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► ReferenceIdentification2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► ReferenceIdentification3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification4 Property

ReferenceIdentification4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► ReferenceIdentification4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification4 { get; set; }
Public Property ReferenceIdentification4 As String
    Get
    Set
public:
property String^ ReferenceIdentification4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification5 Property

ReferenceIdentification5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► ReferenceIdentification5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification5 { get; set; }
Public Property ReferenceIdentification5 As String
    Get
    Set
public:
property String^ ReferenceIdentification5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MIA ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MOA Class

MOA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA
Declaration Syntax
C# Visual Basic Visual C++
public class MOA : DocumentSegment
Public Class MOA _
    Inherits DocumentSegment
public ref class MOA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MOA()()()() | Initializes a new instance of the MOA class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Percentage |
 | ReferenceIdentification1 |
 | ReferenceIdentification2 |
 | ReferenceIdentification3 |
 | ReferenceIdentification4 |
 | ReferenceIdentification5 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MOA

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MOA Constructor

MOA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► MOA()()()()
Initializes a new instance of the MOA class
Declaration Syntax
C# Visual Basic Visual C++
public MOA()
Public Sub New
public:
MOA()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Percentage Property

Percentage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► Percentage
Declaration Syntax
C# Visual Basic Visual C++
public string Percentage { get; set; }
Public Property Percentage As String
    Get
    Set
public:
property String^ Percentage {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► ReferenceIdentification1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► ReferenceIdentification2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification3 Property

ReferenceIdentification3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► ReferenceIdentification3
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification3 { get; set; }
Public Property ReferenceIdentification3 As String
    Get
    Set
public:
property String^ ReferenceIdentification3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification4 Property

ReferenceIdentification4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► ReferenceIdentification4
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification4 { get; set; }
Public Property ReferenceIdentification4 As String
    Get
    Set
public:
property String^ ReferenceIdentification4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification5 Property

ReferenceIdentification5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► ReferenceIdentification5
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification5 { get; set; }
Public Property ReferenceIdentification5 As String
    Get
    Set
public:
property String^ ReferenceIdentification5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MOA ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MPI Class

MPI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI
Declaration Syntax
C# Visual Basic Visual C++
public class MPI : DocumentSegment
Public Class MPI _
    Inherits DocumentSegment
public ref class MPI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MPI()()()() | Initializes a new instance of the MPI class
 | DateTimePeriod |
 | DateTimePeriodFormatQualifier |
 | Description |
 | EmploymentStatusCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | GovernmentServiceAffiliationCode |
 | InformationStatusCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MilitaryServiceRankCode |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | MPI

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MPI Constructor

MPI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► MPI()()()()
Initializes a new instance of the MPI class
Declaration Syntax
C# Visual Basic Visual C++
public MPI()
Public Sub New
public:
MPI()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► DateTimePeriod
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► DateTimePeriodFormatQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► EmploymentStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GovernmentServiceAffiliationCode Property

GovernmentServiceAffiliationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► GovernmentServiceAffiliationCode
Declaration Syntax
C# Visual Basic Visual C++
public string GovernmentServiceAffiliationCode { get; set; }
Public Property GovernmentServiceAffiliationCode As String
    Get
    Set
public:
property String^ GovernmentServiceAffiliationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InformationStatusCode Property

InformationStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► InformationStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string InformationStatusCode { get; set; }
Public Property InformationStatusCode As String
    Get
    Set
public:
property String^ InformationStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MilitaryServiceRankCode Property

MilitaryServiceRankCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► MilitaryServiceRankCode
Declaration Syntax
C# Visual Basic Visual C++
public string MilitaryServiceRankCode { get; set; }
Public Property MilitaryServiceRankCode As String
    Get
    Set
public:
property String^ MilitaryServiceRankCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► MPI ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


N1 Class

N1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1
Declaration Syntax
C# Visual Basic Visual C++
public class N1 : DocumentSegment
Public Class N1 _
    Inherits DocumentSegment
public ref class N1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N1()()()() | Initializes a new instance of the N1 class
 | EntityIdentifierCode1 |
 | EntityIdentifierCode2 |
 | EntityRelationshipCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode |
 | IdentificationCodeQualifier |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


N1 Constructor

N1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► N1()()()()
Initializes a new instance of the N1 class
Declaration Syntax
C# Visual Basic Visual C++
public N1()
Public Sub New
public:
N1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityIdentifierCode1 Property

EntityIdentifierCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► EntityIdentifierCode1
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode1 { get; set; }
Public Property EntityIdentifierCode1 As String
    Get
    Set
public:
property String^ EntityIdentifierCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityIdentifierCode2 Property

EntityIdentifierCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► EntityIdentifierCode2
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode2 { get; set; }
Public Property EntityIdentifierCode2 As String
    Get
    Set
public:
property String^ EntityIdentifierCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityRelationshipCode Property

EntityRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► EntityRelationshipCode
Declaration Syntax
C# Visual Basic Visual C++
public string EntityRelationshipCode { get; set; }
Public Property EntityRelationshipCode As String
    Get
    Set
public:
property String^ EntityRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► IdentificationCode
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► IdentificationCodeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


N3 Class

N3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N3
Declaration Syntax
C# Visual Basic Visual C++
public class N3 : DocumentSegment
Public Class N3 _
    Inherits DocumentSegment
public ref class N3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N3()()()() | Initializes a new instance of the N3 class
 | AddressInformation1 |
 | AddressInformation2 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N3

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


N3 Constructor

N3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N3 ► N3()()()()
Initializes a new instance of the N3 class
Declaration Syntax
C# Visual Basic Visual C++
public N3()
Public Sub New
public:
N3()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AddressInformation1 Property

AddressInformation1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N3 ► AddressInformation1
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation1 { get; set; }
Public Property AddressInformation1 As String
    Get
    Set
public:
property String^ AddressInformation1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AddressInformation2 Property

AddressInformation2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N3 ► AddressInformation2
Declaration Syntax
C# Visual Basic Visual C++
public string AddressInformation2 { get; set; }
Public Property AddressInformation2 As String
    Get
    Set
public:
property String^ AddressInformation2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N3 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N3 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


N4 Class

N4 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4
Declaration Syntax
C# Visual Basic Visual C++
public class N4 : DocumentSegment
Public Class N4 _
    Inherits DocumentSegment
public ref class N4 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | N4()()()() | Initializes a new instance of the N4 class
 | CityName |
 | CountryCode |
 | CountrySubdivisionCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | LocationQualifier1 |
 | LocationQualifier2 |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode |
 | StateOrProvinceCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | N4

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


N4 Constructor

N4 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► N4()()()()
Initializes a new instance of the N4 class
Declaration Syntax
C# Visual Basic Visual C++
public N4()
Public Sub New
public:
N4()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CityName Property

CityName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► CityName
Declaration Syntax
C# Visual Basic Visual C++
public string CityName { get; set; }
Public Property CityName As String
    Get
    Set
public:
property String^ CityName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► CountryCode
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CountrySubdivisionCode Property

CountrySubdivisionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► CountrySubdivisionCode
Declaration Syntax
C# Visual Basic Visual C++
public string CountrySubdivisionCode { get; set; }
Public Property CountrySubdivisionCode As String
    Get
    Set
public:
property String^ CountrySubdivisionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LocationQualifier1 Property

LocationQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► LocationQualifier1
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier1 { get; set; }
Public Property LocationQualifier1 As String
    Get
    Set
public:
property String^ LocationQualifier1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LocationQualifier2 Property

LocationQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► LocationQualifier2
Declaration Syntax
C# Visual Basic Visual C++
public string LocationQualifier2 { get; set; }
Public Property LocationQualifier2 As String
    Get
    Set
public:
property String^ LocationQualifier2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► PostalCode
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► StateOrProvinceCode
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► N4 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NM1 Class

NM1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1
Declaration Syntax
C# Visual Basic Visual C++
public class NM1 : DocumentSegment
Public Class NM1 _
    Inherits DocumentSegment
public ref class NM1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NM1()()()() | Initializes a new instance of the NM1 class
 | EntityIdentifierCode |
 | EntityTypeQualifier |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstName |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode |
 | IdentificationCodeQualifier |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MiddleName |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NameLastOrOrganizationName |
 | NamePrefix |
 | NameSuffix |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NM1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NM1 Constructor

NM1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► NM1()()()()
Initializes a new instance of the NM1 class
Declaration Syntax
C# Visual Basic Visual C++
public NM1()
Public Sub New
public:
NM1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► EntityIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityTypeQualifier Property

EntityTypeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► EntityTypeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string EntityTypeQualifier { get; set; }
Public Property EntityTypeQualifier As String
    Get
    Set
public:
property String^ EntityTypeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FirstName Property

FirstName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► FirstName
Declaration Syntax
C# Visual Basic Visual C++
public string FirstName { get; set; }
Public Property FirstName As String
    Get
    Set
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► IdentificationCode
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► IdentificationCodeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MiddleName Property

MiddleName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► MiddleName
Declaration Syntax
C# Visual Basic Visual C++
public string MiddleName { get; set; }
Public Property MiddleName As String
    Get
    Set
public:
property String^ MiddleName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NameLastOrOrganizationName Property

NameLastOrOrganizationName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► NameLastOrOrganizationName
Declaration Syntax
C# Visual Basic Visual C++
public string NameLastOrOrganizationName { get; set; }
Public Property NameLastOrOrganizationName As String
    Get
    Set
public:
property String^ NameLastOrOrganizationName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NamePrefix Property

NamePrefix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► NamePrefix
Declaration Syntax
C# Visual Basic Visual C++
public string NamePrefix { get; set; }
Public Property NamePrefix As String
    Get
    Set
public:
property String^ NamePrefix {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NameSuffix Property

NameSuffix Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► NameSuffix
Declaration Syntax
C# Visual Basic Visual C++
public string NameSuffix { get; set; }
Public Property NameSuffix As String
    Get
    Set
public:
property String^ NameSuffix {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NM1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NTE Class

NTE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NTE
Declaration Syntax
C# Visual Basic Visual C++
public class NTE : DocumentSegment
Public Class NTE _
    Inherits DocumentSegment
public ref class NTE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NTE()()()() | Initializes a new instance of the NTE class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NoteReferenceCode |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | NTE

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NTE Constructor

NTE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NTE ► NTE()()()()
Initializes a new instance of the NTE class
Declaration Syntax
C# Visual Basic Visual C++
public NTE()
Public Sub New
public:
NTE()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NTE ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NTE ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NoteReferenceCode Property

NoteReferenceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NTE ► NoteReferenceCode
Declaration Syntax
C# Visual Basic Visual C++
public string NoteReferenceCode { get; set; }
Public Property NoteReferenceCode As String
    Get
    Set
public:
property String^ NoteReferenceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► NTE ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OI Class

OI Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI
Declaration Syntax
C# Visual Basic Visual C++
public class OI : DocumentSegment
Public Class OI _
    Inherits DocumentSegment
public ref class OI : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OI()()()() | Initializes a new instance of the OI class
 | ClaimFilingIndicatorCode |
 | ClaimSubmissionReasonCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientSignatureSourceCode |
 | ProviderAgreementCode |
 | ReleaseOfInformationCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | OI

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OI Constructor

OI Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► OI()()()()
Initializes a new instance of the OI class
Declaration Syntax
C# Visual Basic Visual C++
public OI()
Public Sub New
public:
OI()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► ClaimFilingIndicatorCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimSubmissionReasonCode Property

ClaimSubmissionReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► ClaimSubmissionReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimSubmissionReasonCode { get; set; }
Public Property ClaimSubmissionReasonCode As String
    Get
    Set
public:
property String^ ClaimSubmissionReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PatientSignatureSourceCode Property

PatientSignatureSourceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► PatientSignatureSourceCode
Declaration Syntax
C# Visual Basic Visual C++
public string PatientSignatureSourceCode { get; set; }
Public Property PatientSignatureSourceCode As String
    Get
    Set
public:
property String^ PatientSignatureSourceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► ProviderAgreementCode
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReleaseOfInformationCode Property

ReleaseOfInformationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► ReleaseOfInformationCode
Declaration Syntax
C# Visual Basic Visual C++
public string ReleaseOfInformationCode { get; set; }
Public Property ReleaseOfInformationCode As String
    Get
    Set
public:
property String^ ReleaseOfInformationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OI ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OralCavityDesign Class

OralCavityDesign Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OralCavityDesign
Declaration Syntax
C# Visual Basic Visual C++
public class OralCavityDesign : CompositeElement
Public Class OralCavityDesign _
    Inherits CompositeElement
public ref class OralCavityDesign : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OralCavityDesign()()()() | Initializes a new instance of the OralCavityDesign class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OralCavityDesignCode1 |
 | OralCavityDesignCode2 |
 | OralCavityDesignCode3 |
 | OralCavityDesignCode4 |
 | OralCavityDesignCode5 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | OralCavityDesign

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OralCavityDesign Constructor

OralCavityDesign Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OralCavityDesign ► OralCavityDesign()()()()
Initializes a new instance of the OralCavityDesign class
Declaration Syntax
C# Visual Basic Visual C++
public OralCavityDesign()
Public Sub New
public:
OralCavityDesign()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OralCavityDesign ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OralCavityDesignCode1 Property

OralCavityDesignCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OralCavityDesign ► OralCavityDesignCode1
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode1 { get; set; }
Public Property OralCavityDesignCode1 As String
    Get
    Set
public:
property String^ OralCavityDesignCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OralCavityDesignCode2 Property

OralCavityDesignCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OralCavityDesign ► OralCavityDesignCode2
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode2 { get; set; }
Public Property OralCavityDesignCode2 As String
    Get
    Set
public:
property String^ OralCavityDesignCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OralCavityDesignCode3 Property

OralCavityDesignCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OralCavityDesign ► OralCavityDesignCode3
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode3 { get; set; }
Public Property OralCavityDesignCode3 As String
    Get
    Set
public:
property String^ OralCavityDesignCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OralCavityDesignCode4 Property

OralCavityDesignCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OralCavityDesign ► OralCavityDesignCode4
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode4 { get; set; }
Public Property OralCavityDesignCode4 As String
    Get
    Set
public:
property String^ OralCavityDesignCode4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OralCavityDesignCode5 Property

OralCavityDesignCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► OralCavityDesign ► OralCavityDesignCode5
Declaration Syntax
C# Visual Basic Visual C++
public string OralCavityDesignCode5 { get; set; }
Public Property OralCavityDesignCode5 As String
    Get
    Set
public:
property String^ OralCavityDesignCode5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PAT Class

PAT Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT
Declaration Syntax
C# Visual Basic Visual C++
public class PAT : DocumentSegment
Public Class PAT _
    Inherits DocumentSegment
public ref class PAT : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PAT()()()() | Initializes a new instance of the PAT class
 | DateTimePeriod |
 | DateTimePeriodFormatQualifier |
 | EmploymentStatusCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PatientLocationCode |
 | StudentStatusCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode |
 | Weight |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PAT

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PAT Constructor

PAT Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► PAT()()()()
Initializes a new instance of the PAT class
Declaration Syntax
C# Visual Basic Visual C++
public PAT()
Public Sub New
public:
PAT()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriod Property

DateTimePeriod Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► DateTimePeriod
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriod { get; set; }
Public Property DateTimePeriod As String
    Get
    Set
public:
property String^ DateTimePeriod {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DateTimePeriodFormatQualifier Property

DateTimePeriodFormatQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► DateTimePeriodFormatQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string DateTimePeriodFormatQualifier { get; set; }
Public Property DateTimePeriodFormatQualifier As String
    Get
    Set
public:
property String^ DateTimePeriodFormatQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► EmploymentStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► IndividualRelationshipCode
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PatientLocationCode Property

PatientLocationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► PatientLocationCode
Declaration Syntax
C# Visual Basic Visual C++
public string PatientLocationCode { get; set; }
Public Property PatientLocationCode As String
    Get
    Set
public:
property String^ PatientLocationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


StudentStatusCode Property

StudentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► StudentStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string StudentStatusCode { get; set; }
Public Property StudentStatusCode As String
    Get
    Set
public:
property String^ StudentStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► UnitOrBasisForMeasurementCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Weight Property

Weight Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► Weight
Declaration Syntax
C# Visual Basic Visual C++
public string Weight { get; set; }
Public Property Weight As String
    Get
    Set
public:
property String^ Weight {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PAT ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PER Class

PER Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER
Declaration Syntax
C# Visual Basic Visual C++
public class PER : DocumentSegment
Public Class PER _
    Inherits DocumentSegment
public ref class PER : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PER()()()() | Initializes a new instance of the PER class
 | CommunicationNumber1 |
 | CommunicationNumber2 |
 | CommunicationNumber3 |
 | CommunicationNumberQualifier1 |
 | CommunicationNumberQualifier2 |
 | CommunicationNumberQualifier3 |
 | ContactFunctionCode |
 | ContactInquiryReference |
 | ContactName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PER

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PER Constructor

PER Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► PER()()()()
Initializes a new instance of the PER class
Declaration Syntax
C# Visual Basic Visual C++
public PER()
Public Sub New
public:
PER()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CommunicationNumber1 Property

CommunicationNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► CommunicationNumber1
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber1 { get; set; }
Public Property CommunicationNumber1 As String
    Get
    Set
public:
property String^ CommunicationNumber1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CommunicationNumber2 Property

CommunicationNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► CommunicationNumber2
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber2 { get; set; }
Public Property CommunicationNumber2 As String
    Get
    Set
public:
property String^ CommunicationNumber2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CommunicationNumber3 Property

CommunicationNumber3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► CommunicationNumber3
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber3 { get; set; }
Public Property CommunicationNumber3 As String
    Get
    Set
public:
property String^ CommunicationNumber3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CommunicationNumberQualifier1 Property

CommunicationNumberQualifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► CommunicationNumberQualifier1
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier1 { get; set; }
Public Property CommunicationNumberQualifier1 As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CommunicationNumberQualifier2 Property

CommunicationNumberQualifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► CommunicationNumberQualifier2
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier2 { get; set; }
Public Property CommunicationNumberQualifier2 As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CommunicationNumberQualifier3 Property

CommunicationNumberQualifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► CommunicationNumberQualifier3
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumberQualifier3 { get; set; }
Public Property CommunicationNumberQualifier3 As String
    Get
    Set
public:
property String^ CommunicationNumberQualifier3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContactFunctionCode Property

ContactFunctionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► ContactFunctionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ContactFunctionCode { get; set; }
Public Property ContactFunctionCode As String
    Get
    Set
public:
property String^ ContactFunctionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContactInquiryReference Property

ContactInquiryReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► ContactInquiryReference
Declaration Syntax
C# Visual Basic Visual C++
public string ContactInquiryReference { get; set; }
Public Property ContactInquiryReference As String
    Get
    Set
public:
property String^ ContactInquiryReference {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ContactName Property

ContactName Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► ContactName
Declaration Syntax
C# Visual Basic Visual C++
public string ContactName { get; set; }
Public Property ContactName As String
    Get
    Set
public:
property String^ ContactName {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PER ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PLA Class

PLA Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA
Declaration Syntax
C# Visual Basic Visual C++
public class PLA : DocumentSegment
Public Class PLA _
    Inherits DocumentSegment
public ref class PLA : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLA()()()() | Initializes a new instance of the PLA class
 | ActionCode |
 | Date |
 | EntityIdentifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MaintenanceReasonCode |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Time |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLA

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PLA Constructor

PLA Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA ► PLA()()()()
Initializes a new instance of the PLA class
Declaration Syntax
C# Visual Basic Visual C++
public PLA()
Public Sub New
public:
PLA()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA ► ActionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA ► EntityIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MaintenanceReasonCode Property

MaintenanceReasonCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA ► MaintenanceReasonCode
Declaration Syntax
C# Visual Basic Visual C++
public string MaintenanceReasonCode { get; set; }
Public Property MaintenanceReasonCode As String
    Get
    Set
public:
property String^ MaintenanceReasonCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Time Property

Time Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA ► Time
Declaration Syntax
C# Visual Basic Visual C++
public string Time { get; set; }
Public Property Time As String
    Get
    Set
public:
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLA ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PLB Class

PLB Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB
Declaration Syntax
C# Visual Basic Visual C++
public class PLB : DocumentSegment
Public Class PLB _
    Inherits DocumentSegment
public ref class PLB : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PLB()()()() | Initializes a new instance of the PLB class
 | AdjustmentIdentifier1 |
 | AdjustmentIdentifier2 |
 | AdjustmentIdentifier3 |
 | AdjustmentIdentifier4 |
 | AdjustmentIdentifier5 |
 | AdjustmentIdentifier6 |
 | Date |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | MonetaryAmount4 |
 | MonetaryAmount5 |
 | MonetaryAmount6 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PLB

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PLB Constructor

PLB Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► PLB()()()()
Initializes a new instance of the PLB class
Declaration Syntax
C# Visual Basic Visual C++
public PLB()
Public Sub New
public:
PLB()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentIdentifier1 Property

AdjustmentIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► AdjustmentIdentifier1
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier1 { get; set; }
Public Property AdjustmentIdentifier1 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier1 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentIdentifier2 Property

AdjustmentIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► AdjustmentIdentifier2
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier2 { get; set; }
Public Property AdjustmentIdentifier2 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier2 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentIdentifier3 Property

AdjustmentIdentifier3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► AdjustmentIdentifier3
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier3 { get; set; }
Public Property AdjustmentIdentifier3 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier3 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentIdentifier4 Property

AdjustmentIdentifier4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► AdjustmentIdentifier4
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier4 { get; set; }
Public Property AdjustmentIdentifier4 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier4 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentIdentifier5 Property

AdjustmentIdentifier5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► AdjustmentIdentifier5
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier5 { get; set; }
Public Property AdjustmentIdentifier5 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier5 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AdjustmentIdentifier6 Property

AdjustmentIdentifier6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► AdjustmentIdentifier6
Declaration Syntax
C# Visual Basic Visual C++
public AdjustmentIdentifier AdjustmentIdentifier6 { get; set; }
Public Property AdjustmentIdentifier6 As AdjustmentIdentifier
    Get
    Set
public:
property AdjustmentIdentifier^ AdjustmentIdentifier6 {
    AdjustmentIdentifier^ get ();
    void set (AdjustmentIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► MonetaryAmount4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► MonetaryAmount5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► MonetaryAmount6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PLB ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PositionInSegment Class

PositionInSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PositionInSegment
Declaration Syntax
C# Visual Basic Visual C++
public class PositionInSegment : CompositeElement
Public Class PositionInSegment _
    Inherits CompositeElement
public ref class PositionInSegment : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PositionInSegment()()()() | Initializes a new instance of the PositionInSegment class
 | ComponentDataElementPositionInComposite |
 | ElementPositionInSegment |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RepeatingDataElementPosition |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | PositionInSegment

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PositionInSegment Constructor

PositionInSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PositionInSegment ► PositionInSegment()()()()
Initializes a new instance of the PositionInSegment class
Declaration Syntax
C# Visual Basic Visual C++
public PositionInSegment()
Public Sub New
public:
PositionInSegment()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ComponentDataElementPositionInComposite Property

ComponentDataElementPositionInComposite Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PositionInSegment ► ComponentDataElementPositionInComposite
Declaration Syntax
C# Visual Basic Visual C++
public string ComponentDataElementPositionInComposite { get; set; }
Public Property ComponentDataElementPositionInComposite As String
    Get
    Set
public:
property String^ ComponentDataElementPositionInComposite {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ElementPositionInSegment Property

ElementPositionInSegment Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PositionInSegment ► ElementPositionInSegment
Declaration Syntax
C# Visual Basic Visual C++
public string ElementPositionInSegment { get; set; }
Public Property ElementPositionInSegment As String
    Get
    Set
public:
property String^ ElementPositionInSegment {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PositionInSegment ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RepeatingDataElementPosition Property

RepeatingDataElementPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PositionInSegment ► RepeatingDataElementPosition
Declaration Syntax
C# Visual Basic Visual C++
public string RepeatingDataElementPosition { get; set; }
Public Property RepeatingDataElementPosition As String
    Get
    Set
public:
property String^ RepeatingDataElementPosition {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PRV Class

PRV Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV
Declaration Syntax
C# Visual Basic Visual C++
public class PRV : DocumentSegment
Public Class PRV _
    Inherits DocumentSegment
public ref class PRV : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PRV()()()() | Initializes a new instance of the PRV class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProviderCode |
 | ProviderOrganizationCode |
 | ProviderSpecialtyInformation |
 | ReferenceIdentification |
 | ReferenceIdentificationQualifier |
 | StateOrProvinceCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PRV

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PRV Constructor

PRV Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► PRV()()()()
Initializes a new instance of the PRV class
Declaration Syntax
C# Visual Basic Visual C++
public PRV()
Public Sub New
public:
PRV()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProviderCode Property

ProviderCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► ProviderCode
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderCode { get; set; }
Public Property ProviderCode As String
    Get
    Set
public:
property String^ ProviderCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProviderOrganizationCode Property

ProviderOrganizationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► ProviderOrganizationCode
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderOrganizationCode { get; set; }
Public Property ProviderOrganizationCode As String
    Get
    Set
public:
property String^ ProviderOrganizationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProviderSpecialtyInformation Property

ProviderSpecialtyInformation Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► ProviderSpecialtyInformation
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderSpecialtyInformation { get; set; }
Public Property ProviderSpecialtyInformation As String
    Get
    Set
public:
property String^ ProviderSpecialtyInformation {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► ReferenceIdentificationQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► StateOrProvinceCode
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PRV ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PS1 Class

PS1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PS1
Declaration Syntax
C# Visual Basic Visual C++
public class PS1 : DocumentSegment
Public Class PS1 _
    Inherits DocumentSegment
public ref class PS1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PS1()()()() | Initializes a new instance of the PS1 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification |
 | StateOrProvinceCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PS1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PS1 Constructor

PS1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PS1 ► PS1()()()()
Initializes a new instance of the PS1 class
Declaration Syntax
C# Visual Basic Visual C++
public PS1()
Public Sub New
public:
PS1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PS1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PS1 ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PS1 ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PS1 ► StateOrProvinceCode
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PS1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PWK Class

PWK Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK
Declaration Syntax
C# Visual Basic Visual C++
public class PWK : DocumentSegment
Public Class PWK _
    Inherits DocumentSegment
public ref class PWK : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PWK()()()() | Initializes a new instance of the PWK class
 | EntityIdentifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode |
 | IdentificationCodeQualifier |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportCopiesNeeded |
 | ReportTransmissionCode |
 | ReportTypeCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | PWK

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PWK Constructor

PWK Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► PWK()()()()
Initializes a new instance of the PWK class
Declaration Syntax
C# Visual Basic Visual C++
public PWK()
Public Sub New
public:
PWK()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EntityIdentifierCode Property

EntityIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► EntityIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string EntityIdentifierCode { get; set; }
Public Property EntityIdentifierCode As String
    Get
    Set
public:
property String^ EntityIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► IdentificationCode
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCodeQualifier Property

IdentificationCodeQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► IdentificationCodeQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCodeQualifier { get; set; }
Public Property IdentificationCodeQualifier As String
    Get
    Set
public:
property String^ IdentificationCodeQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReportCopiesNeeded Property

ReportCopiesNeeded Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► ReportCopiesNeeded
Declaration Syntax
C# Visual Basic Visual C++
public string ReportCopiesNeeded { get; set; }
Public Property ReportCopiesNeeded As String
    Get
    Set
public:
property String^ ReportCopiesNeeded {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReportTransmissionCode Property

ReportTransmissionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► ReportTransmissionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTransmissionCode { get; set; }
Public Property ReportTransmissionCode As String
    Get
    Set
public:
property String^ ReportTransmissionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReportTypeCode Property

ReportTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► ReportTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTypeCode { get; set; }
Public Property ReportTypeCode As String
    Get
    Set
public:
property String^ ReportTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► PWK ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


QTY Class

QTY Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► QTY
Declaration Syntax
C# Visual Basic Visual C++
public class QTY : DocumentSegment
Public Class QTY _
    Inherits DocumentSegment
public ref class QTY : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | QTY()()()() | Initializes a new instance of the QTY class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity |
 | QuantityQualifier |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | QTY

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


QTY Constructor

QTY Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► QTY ► QTY()()()()
Initializes a new instance of the QTY class
Declaration Syntax
C# Visual Basic Visual C++
public QTY()
Public Sub New
public:
QTY()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► QTY ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► QTY ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


QuantityQualifier Property

QuantityQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► QTY ► QuantityQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string QuantityQualifier { get; set; }
Public Property QuantityQualifier As String
    Get
    Set
public:
property String^ QuantityQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► QTY ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RDM Class

RDM Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RDM
Declaration Syntax
C# Visual Basic Visual C++
public class RDM : DocumentSegment
Public Class RDM _
    Inherits DocumentSegment
public ref class RDM : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RDM()()()() | Initializes a new instance of the RDM class
 | CommunicationNumber |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReportTransmissionCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | RDM

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RDM Constructor

RDM Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RDM ► RDM()()()()
Initializes a new instance of the RDM class
Declaration Syntax
C# Visual Basic Visual C++
public RDM()
Public Sub New
public:
RDM()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CommunicationNumber Property

CommunicationNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RDM ► CommunicationNumber
Declaration Syntax
C# Visual Basic Visual C++
public string CommunicationNumber { get; set; }
Public Property CommunicationNumber As String
    Get
    Set
public:
property String^ CommunicationNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RDM ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RDM ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReportTransmissionCode Property

ReportTransmissionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RDM ► ReportTransmissionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ReportTransmissionCode { get; set; }
Public Property ReportTransmissionCode As String
    Get
    Set
public:
property String^ ReportTransmissionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RDM ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


REF Class

REF Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► REF
Declaration Syntax
C# Visual Basic Visual C++
public class REF : DocumentSegment
Public Class REF _
    Inherits DocumentSegment
public ref class REF : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | REF()()()() | Initializes a new instance of the REF class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification |
 | ReferenceIdentificationQualifier |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | REF

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


REF Constructor

REF Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► REF ► REF()()()()
Initializes a new instance of the REF class
Declaration Syntax
C# Visual Basic Visual C++
public REF()
Public Sub New
public:
REF()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► REF ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► REF ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► REF ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentificationQualifier Property

ReferenceIdentificationQualifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► REF ► ReferenceIdentificationQualifier
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentificationQualifier { get; set; }
Public Property ReferenceIdentificationQualifier As String
    Get
    Set
public:
property String^ ReferenceIdentificationQualifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► REF ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceInSegment Class

ReferenceInSegment Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ReferenceInSegment
Declaration Syntax
C# Visual Basic Visual C++
public class ReferenceInSegment : CompositeElement
Public Class ReferenceInSegment _
    Inherits CompositeElement
public ref class ReferenceInSegment : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReferenceInSegment()()()() | Initializes a new instance of the ReferenceInSegment class
 | DataElementReferenceNumber1 |
 | DataElementReferenceNumber2 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | ReferenceInSegment

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceInSegment Constructor

ReferenceInSegment Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ReferenceInSegment ► ReferenceInSegment()()()()
Initializes a new instance of the ReferenceInSegment class
Declaration Syntax
C# Visual Basic Visual C++
public ReferenceInSegment()
Public Sub New
public:
ReferenceInSegment()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DataElementReferenceNumber1 Property

DataElementReferenceNumber1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ReferenceInSegment ► DataElementReferenceNumber1
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber1 { get; set; }
Public Property DataElementReferenceNumber1 As String
    Get
    Set
public:
property String^ DataElementReferenceNumber1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


DataElementReferenceNumber2 Property

DataElementReferenceNumber2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ReferenceInSegment ► DataElementReferenceNumber2
Declaration Syntax
C# Visual Basic Visual C++
public string DataElementReferenceNumber2 { get; set; }
Public Property DataElementReferenceNumber2 As String
    Get
    Set
public:
property String^ DataElementReferenceNumber2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ReferenceInSegment ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RelatedCausesInformation Class

RelatedCausesInformation Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RelatedCausesInformation
Declaration Syntax
C# Visual Basic Visual C++
public class RelatedCausesInformation : CompositeElement
Public Class RelatedCausesInformation _
    Inherits CompositeElement
public ref class RelatedCausesInformation : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RelatedCausesInformation()()()() | Initializes a new instance of the RelatedCausesInformation class
 | CountryCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RelatedCausesCode1 |
 | RelatedCausesCode2 |
 | RelatedCausesCode3 |
 | StateOrProvinceCode |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | RelatedCausesInformation

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RelatedCausesInformation Constructor

RelatedCausesInformation Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RelatedCausesInformation ► RelatedCausesInformation()()()()
Initializes a new instance of the RelatedCausesInformation class
Declaration Syntax
C# Visual Basic Visual C++
public RelatedCausesInformation()
Public Sub New
public:
RelatedCausesInformation()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CountryCode Property

CountryCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RelatedCausesInformation ► CountryCode
Declaration Syntax
C# Visual Basic Visual C++
public string CountryCode { get; set; }
Public Property CountryCode As String
    Get
    Set
public:
property String^ CountryCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RelatedCausesInformation ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RelatedCausesCode1 Property

RelatedCausesCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RelatedCausesInformation ► RelatedCausesCode1
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode1 { get; set; }
Public Property RelatedCausesCode1 As String
    Get
    Set
public:
property String^ RelatedCausesCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RelatedCausesCode2 Property

RelatedCausesCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RelatedCausesInformation ► RelatedCausesCode2
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode2 { get; set; }
Public Property RelatedCausesCode2 As String
    Get
    Set
public:
property String^ RelatedCausesCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RelatedCausesCode3 Property

RelatedCausesCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RelatedCausesInformation ► RelatedCausesCode3
Declaration Syntax
C# Visual Basic Visual C++
public string RelatedCausesCode3 { get; set; }
Public Property RelatedCausesCode3 As String
    Get
    Set
public:
property String^ RelatedCausesCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


StateOrProvinceCode Property

StateOrProvinceCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► RelatedCausesInformation ► StateOrProvinceCode
Declaration Syntax
C# Visual Basic Visual C++
public string StateOrProvinceCode { get; set; }
Public Property StateOrProvinceCode As String
    Get
    Set
public:
property String^ StateOrProvinceCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SBR Class

SBR Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR
Declaration Syntax
C# Visual Basic Visual C++
public class SBR : DocumentSegment
Public Class SBR _
    Inherits DocumentSegment
public ref class SBR : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SBR()()()() | Initializes a new instance of the SBR class
 | ClaimFilingIndicatorCode |
 | CoordinationOfBenefitsCode |
 | EmploymentStatusCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IndividualRelationshipCode |
 | InsuranceTypeCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PayerResponsibilitySequenceNumberCode |
 | ReferenceIdentification |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SBR

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SBR Constructor

SBR Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► SBR()()()()
Initializes a new instance of the SBR class
Declaration Syntax
C# Visual Basic Visual C++
public SBR()
Public Sub New
public:
SBR()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ClaimFilingIndicatorCode Property

ClaimFilingIndicatorCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► ClaimFilingIndicatorCode
Declaration Syntax
C# Visual Basic Visual C++
public string ClaimFilingIndicatorCode { get; set; }
Public Property ClaimFilingIndicatorCode As String
    Get
    Set
public:
property String^ ClaimFilingIndicatorCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CoordinationOfBenefitsCode Property

CoordinationOfBenefitsCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► CoordinationOfBenefitsCode
Declaration Syntax
C# Visual Basic Visual C++
public string CoordinationOfBenefitsCode { get; set; }
Public Property CoordinationOfBenefitsCode As String
    Get
    Set
public:
property String^ CoordinationOfBenefitsCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


EmploymentStatusCode Property

EmploymentStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► EmploymentStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string EmploymentStatusCode { get; set; }
Public Property EmploymentStatusCode As String
    Get
    Set
public:
property String^ EmploymentStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IndividualRelationshipCode Property

IndividualRelationshipCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► IndividualRelationshipCode
Declaration Syntax
C# Visual Basic Visual C++
public string IndividualRelationshipCode { get; set; }
Public Property IndividualRelationshipCode As String
    Get
    Set
public:
property String^ IndividualRelationshipCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


InsuranceTypeCode Property

InsuranceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► InsuranceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string InsuranceTypeCode { get; set; }
Public Property InsuranceTypeCode As String
    Get
    Set
public:
property String^ InsuranceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► Name
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PayerResponsibilitySequenceNumberCode Property

PayerResponsibilitySequenceNumberCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► PayerResponsibilitySequenceNumberCode
Declaration Syntax
C# Visual Basic Visual C++
public string PayerResponsibilitySequenceNumberCode { get; set; }
Public Property PayerResponsibilitySequenceNumberCode As String
    Get
    Set
public:
property String^ PayerResponsibilitySequenceNumberCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SBR ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SE Class

SE Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SE
Declaration Syntax
C# Visual Basic Visual C++
public class SE : DocumentSegment
Public Class SE _
    Inherits DocumentSegment
public ref class SE : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SE()()()() | Initializes a new instance of the SE class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NumberOfIncludedSegments |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SE

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SE Constructor

SE Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SE ► SE()()()()
Initializes a new instance of the SE class
Declaration Syntax
C# Visual Basic Visual C++
public SE()
Public Sub New
public:
SE()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SE ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NumberOfIncludedSegments Property

NumberOfIncludedSegments Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SE ► NumberOfIncludedSegments
Declaration Syntax
C# Visual Basic Visual C++
public string NumberOfIncludedSegments { get; set; }
Public Property NumberOfIncludedSegments As String
    Get
    Set
public:
property String^ NumberOfIncludedSegments {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SE ► TransactionSetControlNumber
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SE ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ST Class

ST Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ST
Declaration Syntax
C# Visual Basic Visual C++
public class ST : DocumentSegment
Public Class ST _
    Inherits DocumentSegment
public ref class ST : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ST()()()() | Initializes a new instance of the ST class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | ImplementationConventionReference |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TransactionSetControlNumber |
 | TransactionSetIdentifierCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | ST

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ST Constructor

ST Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ST ► ST()()()()
Initializes a new instance of the ST class
Declaration Syntax
C# Visual Basic Visual C++
public ST()
Public Sub New
public:
ST()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ImplementationConventionReference Property

ImplementationConventionReference Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ST ► ImplementationConventionReference
Declaration Syntax
C# Visual Basic Visual C++
public string ImplementationConventionReference { get; set; }
Public Property ImplementationConventionReference As String
    Get
    Set
public:
property String^ ImplementationConventionReference {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ST ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionSetControlNumber Property

TransactionSetControlNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ST ► TransactionSetControlNumber
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetControlNumber { get; set; }
Public Property TransactionSetControlNumber As String
    Get
    Set
public:
property String^ TransactionSetControlNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TransactionSetIdentifierCode Property

TransactionSetIdentifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ST ► TransactionSetIdentifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string TransactionSetIdentifierCode { get; set; }
Public Property TransactionSetIdentifierCode As String
    Get
    Set
public:
property String^ TransactionSetIdentifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ST ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


STC Class

STC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC
Declaration Syntax
C# Visual Basic Visual C++
public class STC : DocumentSegment
Public Class STC _
    Inherits DocumentSegment
public ref class STC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | STC()()()() | Initializes a new instance of the STC class
 | ActionCode |
 | CheckNumber |
 | Date1 |
 | Date2 |
 | Date3 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FreeFormMessageText |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareClaimStatus1 |
 | HealthCareClaimStatus2 |
 | HealthCareClaimStatus3 |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PaymentMethodCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | STC

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


STC Constructor

STC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► STC()()()()
Initializes a new instance of the STC class
Declaration Syntax
C# Visual Basic Visual C++
public STC()
Public Sub New
public:
STC()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ActionCode Property

ActionCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► ActionCode
Declaration Syntax
C# Visual Basic Visual C++
public string ActionCode { get; set; }
Public Property ActionCode As String
    Get
    Set
public:
property String^ ActionCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CheckNumber Property

CheckNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► CheckNumber
Declaration Syntax
C# Visual Basic Visual C++
public string CheckNumber { get; set; }
Public Property CheckNumber As String
    Get
    Set
public:
property String^ CheckNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date1 Property

Date1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► Date1
Declaration Syntax
C# Visual Basic Visual C++
public string Date1 { get; set; }
Public Property Date1 As String
    Get
    Set
public:
property String^ Date1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date2 Property

Date2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► Date2
Declaration Syntax
C# Visual Basic Visual C++
public string Date2 { get; set; }
Public Property Date2 As String
    Get
    Set
public:
property String^ Date2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date3 Property

Date3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► Date3
Declaration Syntax
C# Visual Basic Visual C++
public string Date3 { get; set; }
Public Property Date3 As String
    Get
    Set
public:
property String^ Date3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FreeFormMessageText Property

FreeFormMessageText Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► FreeFormMessageText
Declaration Syntax
C# Visual Basic Visual C++
public string FreeFormMessageText { get; set; }
Public Property FreeFormMessageText As String
    Get
    Set
public:
property String^ FreeFormMessageText {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareClaimStatus1 Property

HealthCareClaimStatus1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► HealthCareClaimStatus1
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus1 { get; set; }
Public Property HealthCareClaimStatus1 As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus1 {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareClaimStatus2 Property

HealthCareClaimStatus2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► HealthCareClaimStatus2
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus2 { get; set; }
Public Property HealthCareClaimStatus2 As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus2 {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareClaimStatus3 Property

HealthCareClaimStatus3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► HealthCareClaimStatus3
Declaration Syntax
C# Visual Basic Visual C++
public HealthCareClaimStatus HealthCareClaimStatus3 { get; set; }
Public Property HealthCareClaimStatus3 As HealthCareClaimStatus
    Get
    Set
public:
property HealthCareClaimStatus^ HealthCareClaimStatus3 {
    HealthCareClaimStatus^ get ();
    void set (HealthCareClaimStatus^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PaymentMethodCode Property

PaymentMethodCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► PaymentMethodCode
Declaration Syntax
C# Visual Basic Visual C++
public string PaymentMethodCode { get; set; }
Public Property PaymentMethodCode As String
    Get
    Set
public:
property String^ PaymentMethodCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► STC ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SV1 Class

SV1 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1
Declaration Syntax
C# Visual Basic Visual C++
public class SV1 : DocumentSegment
Public Class SV1 _
    Inherits DocumentSegment
public ref class SV1 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV1()()()() | Initializes a new instance of the SV1 class
 | CompositeDiagnosticCodePointer |
 | CompositeMedicalProcedureIdentifier |
 | CopayStatusCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | HealthCareProfessionalShortageAreaCode |
 | LevelOfCareCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | MultipleProcedureCode |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NationalOrLocalAssignedReviewValue |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PostalCode |
 | ProviderAgreementCode |
 | Quantity |
 | ReferenceIdentification |
 | ReviewCode |
 | ServiceTypeCode |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode1 |
 | YesNoConditionOrResponseCode2 |
 | YesNoConditionOrResponseCode3 |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV1

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SV1 Constructor

SV1 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► SV1()()()()
Initializes a new instance of the SV1 class
Declaration Syntax
C# Visual Basic Visual C++
public SV1()
Public Sub New
public:
SV1()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeDiagnosticCodePointer Property

CompositeDiagnosticCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► CompositeDiagnosticCodePointer
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer CompositeDiagnosticCodePointer { get; set; }
Public Property CompositeDiagnosticCodePointer As CompositeDiagnosticCodePointer
    Get
    Set
public:
property CompositeDiagnosticCodePointer^ CompositeDiagnosticCodePointer {
    CompositeDiagnosticCodePointer^ get ();
    void set (CompositeDiagnosticCodePointer^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► CompositeMedicalProcedureIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CopayStatusCode Property

CopayStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► CopayStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string CopayStatusCode { get; set; }
Public Property CopayStatusCode As String
    Get
    Set
public:
property String^ CopayStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► FacilityCodeValue
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


HealthCareProfessionalShortageAreaCode Property

HealthCareProfessionalShortageAreaCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► HealthCareProfessionalShortageAreaCode
Declaration Syntax
C# Visual Basic Visual C++
public string HealthCareProfessionalShortageAreaCode { get; set; }
Public Property HealthCareProfessionalShortageAreaCode As String
    Get
    Set
public:
property String^ HealthCareProfessionalShortageAreaCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LevelOfCareCode Property

LevelOfCareCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► LevelOfCareCode
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfCareCode { get; set; }
Public Property LevelOfCareCode As String
    Get
    Set
public:
property String^ LevelOfCareCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MultipleProcedureCode Property

MultipleProcedureCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► MultipleProcedureCode
Declaration Syntax
C# Visual Basic Visual C++
public string MultipleProcedureCode { get; set; }
Public Property MultipleProcedureCode As String
    Get
    Set
public:
property String^ MultipleProcedureCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NationalOrLocalAssignedReviewValue Property

NationalOrLocalAssignedReviewValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► NationalOrLocalAssignedReviewValue
Declaration Syntax
C# Visual Basic Visual C++
public string NationalOrLocalAssignedReviewValue { get; set; }
Public Property NationalOrLocalAssignedReviewValue As String
    Get
    Set
public:
property String^ NationalOrLocalAssignedReviewValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PostalCode Property

PostalCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► PostalCode
Declaration Syntax
C# Visual Basic Visual C++
public string PostalCode { get; set; }
Public Property PostalCode As String
    Get
    Set
public:
property String^ PostalCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► ProviderAgreementCode
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReviewCode Property

ReviewCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► ReviewCode
Declaration Syntax
C# Visual Basic Visual C++
public string ReviewCode { get; set; }
Public Property ReviewCode As String
    Get
    Set
public:
property String^ ReviewCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ServiceTypeCode Property

ServiceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► ServiceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceTypeCode { get; set; }
Public Property ServiceTypeCode As String
    Get
    Set
public:
property String^ ServiceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► UnitOrBasisForMeasurementCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode1 Property

YesNoConditionOrResponseCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► YesNoConditionOrResponseCode1
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode1 { get; set; }
Public Property YesNoConditionOrResponseCode1 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode2 Property

YesNoConditionOrResponseCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► YesNoConditionOrResponseCode2
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode2 { get; set; }
Public Property YesNoConditionOrResponseCode2 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode3 Property

YesNoConditionOrResponseCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV1 ► YesNoConditionOrResponseCode3
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode3 { get; set; }
Public Property YesNoConditionOrResponseCode3 As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SV2 Class

SV2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2
Declaration Syntax
C# Visual Basic Visual C++
public class SV2 : DocumentSegment
Public Class SV2 _
    Inherits DocumentSegment
public ref class SV2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV2()()()() | Initializes a new instance of the SV2 class
 | CompositeMedicalProcedureIdentifier |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | LevelOfCareCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | NursingHomeResidentialStatusCode |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductOrServiceID |
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode |
 | UnitRate |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV2

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SV2 Constructor

SV2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► SV2()()()()
Initializes a new instance of the SV2 class
Declaration Syntax
C# Visual Basic Visual C++
public SV2()
Public Sub New
public:
SV2()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► CompositeMedicalProcedureIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


LevelOfCareCode Property

LevelOfCareCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► LevelOfCareCode
Declaration Syntax
C# Visual Basic Visual C++
public string LevelOfCareCode { get; set; }
Public Property LevelOfCareCode As String
    Get
    Set
public:
property String^ LevelOfCareCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


NursingHomeResidentialStatusCode Property

NursingHomeResidentialStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► NursingHomeResidentialStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string NursingHomeResidentialStatusCode { get; set; }
Public Property NursingHomeResidentialStatusCode As String
    Get
    Set
public:
property String^ NursingHomeResidentialStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductOrServiceID Property

ProductOrServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► ProductOrServiceID
Declaration Syntax
C# Visual Basic Visual C++
public string ProductOrServiceID { get; set; }
Public Property ProductOrServiceID As String
    Get
    Set
public:
property String^ ProductOrServiceID {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► UnitOrBasisForMeasurementCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitRate Property

UnitRate Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► UnitRate
Declaration Syntax
C# Visual Basic Visual C++
public string UnitRate { get; set; }
Public Property UnitRate As String
    Get
    Set
public:
property String^ UnitRate {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV2 ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SV3 Class

SV3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3
Declaration Syntax
C# Visual Basic Visual C++
public class SV3 : DocumentSegment
Public Class SV3 _
    Inherits DocumentSegment
public ref class SV3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV3()()()() | Initializes a new instance of the SV3 class
 | CompositeDiagnosticCodePointer |
 | CompositeMedicalProcedureIdentifier |
 | CopayStatusCode |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OralCavityDesign |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProsthesisCrownOrInlayCode |
 | ProviderAgreementCode |
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
 | YesNoConditionOrResponseCode |
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV3

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SV3 Constructor

SV3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► SV3()()()()
Initializes a new instance of the SV3 class
Declaration Syntax
C# Visual Basic Visual C++
public SV3()
Public Sub New
public:
SV3()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeDiagnosticCodePointer Property

CompositeDiagnosticCodePointer Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► CompositeDiagnosticCodePointer
Declaration Syntax
C# Visual Basic Visual C++
public CompositeDiagnosticCodePointer CompositeDiagnosticCodePointer { get; set; }
Public Property CompositeDiagnosticCodePointer As CompositeDiagnosticCodePointer
    Get
    Set
public:
property CompositeDiagnosticCodePointer^ CompositeDiagnosticCodePointer {
    CompositeDiagnosticCodePointer^ get ();
    void set (CompositeDiagnosticCodePointer^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► CompositeMedicalProcedureIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CopayStatusCode Property

CopayStatusCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► CopayStatusCode
Declaration Syntax
C# Visual Basic Visual C++
public string CopayStatusCode { get; set; }
Public Property CopayStatusCode As String
    Get
    Set
public:
property String^ CopayStatusCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Description Property

Description Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► Description
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► FacilityCodeValue
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OralCavityDesign Property

OralCavityDesign Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► OralCavityDesign
Declaration Syntax
C# Visual Basic Visual C++
public OralCavityDesign OralCavityDesign { get; set; }
Public Property OralCavityDesign As OralCavityDesign
    Get
    Set
public:
property OralCavityDesign^ OralCavityDesign {
    OralCavityDesign^ get ();
    void set (OralCavityDesign^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProsthesisCrownOrInlayCode Property

ProsthesisCrownOrInlayCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► ProsthesisCrownOrInlayCode
Declaration Syntax
C# Visual Basic Visual C++
public string ProsthesisCrownOrInlayCode { get; set; }
Public Property ProsthesisCrownOrInlayCode As String
    Get
    Set
public:
property String^ ProsthesisCrownOrInlayCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProviderAgreementCode Property

ProviderAgreementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► ProviderAgreementCode
Declaration Syntax
C# Visual Basic Visual C++
public string ProviderAgreementCode { get; set; }
Public Property ProviderAgreementCode As String
    Get
    Set
public:
property String^ ProviderAgreementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


YesNoConditionOrResponseCode Property

YesNoConditionOrResponseCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV3 ► YesNoConditionOrResponseCode
Declaration Syntax
C# Visual Basic Visual C++
public string YesNoConditionOrResponseCode { get; set; }
Public Property YesNoConditionOrResponseCode As String
    Get
    Set
public:
property String^ YesNoConditionOrResponseCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SV5 Class

SV5 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5
Declaration Syntax
C# Visual Basic Visual C++
public class SV5 : DocumentSegment
Public Class SV5 _
    Inherits DocumentSegment
public ref class SV5 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SV5()()()() | Initializes a new instance of the SV5 class
 | CompositeMedicalProcedureIdentifier |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FrequencyCode |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | PrognosisCode |
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | UnitOrBasisForMeasurementCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SV5

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SV5 Constructor

SV5 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► SV5()()()()
Initializes a new instance of the SV5 class
Declaration Syntax
C# Visual Basic Visual C++
public SV5()
Public Sub New
public:
SV5()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► CompositeMedicalProcedureIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FrequencyCode Property

FrequencyCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► FrequencyCode
Declaration Syntax
C# Visual Basic Visual C++
public string FrequencyCode { get; set; }
Public Property FrequencyCode As String
    Get
    Set
public:
property String^ FrequencyCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


PrognosisCode Property

PrognosisCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► PrognosisCode
Declaration Syntax
C# Visual Basic Visual C++
public string PrognosisCode { get; set; }
Public Property PrognosisCode As String
    Get
    Set
public:
property String^ PrognosisCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UnitOrBasisForMeasurementCode Property

UnitOrBasisForMeasurementCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► UnitOrBasisForMeasurementCode
Declaration Syntax
C# Visual Basic Visual C++
public string UnitOrBasisForMeasurementCode { get; set; }
Public Property UnitOrBasisForMeasurementCode As String
    Get
    Set
public:
property String^ UnitOrBasisForMeasurementCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SV5 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SVC Class

SVC Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC
Declaration Syntax
C# Visual Basic Visual C++
public class SVC : DocumentSegment
Public Class SVC _
    Inherits DocumentSegment
public ref class SVC : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SVC()()()() | Initializes a new instance of the SVC class
 | CompositeMedicalProcedureIdentifier1 |
 | CompositeMedicalProcedureIdentifier2 |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount2 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID |
 | Quantity1 |
 | Quantity2 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SVC

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SVC Constructor

SVC Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► SVC()()()()
Initializes a new instance of the SVC class
Declaration Syntax
C# Visual Basic Visual C++
public SVC()
Public Sub New
public:
SVC()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier1 Property

CompositeMedicalProcedureIdentifier1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► CompositeMedicalProcedureIdentifier1
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier1 { get; set; }
Public Property CompositeMedicalProcedureIdentifier1 As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier1 {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier2 Property

CompositeMedicalProcedureIdentifier2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► CompositeMedicalProcedureIdentifier2
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier2 { get; set; }
Public Property CompositeMedicalProcedureIdentifier2 As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier2 {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► ProductServiceID
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► Quantity1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► Quantity2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVC ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SVD Class

SVD Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD
Declaration Syntax
C# Visual Basic Visual C++
public class SVD : DocumentSegment
Public Class SVD _
    Inherits DocumentSegment
public ref class SVD : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SVD()()()() | Initializes a new instance of the SVD class
 | AssignedNumber |
 | CompositeMedicalProcedureIdentifier |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | IdentificationCode |
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ProductServiceID |
 | Quantity |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | SVD

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


SVD Constructor

SVD Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► SVD()()()()
Initializes a new instance of the SVD class
Declaration Syntax
C# Visual Basic Visual C++
public SVD()
Public Sub New
public:
SVD()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


AssignedNumber Property

AssignedNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► AssignedNumber
Declaration Syntax
C# Visual Basic Visual C++
public string AssignedNumber { get; set; }
Public Property AssignedNumber As String
    Get
    Set
public:
property String^ AssignedNumber {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CompositeMedicalProcedureIdentifier Property

CompositeMedicalProcedureIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► CompositeMedicalProcedureIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public CompositeMedicalProcedureIdentifier CompositeMedicalProcedureIdentifier { get; set; }
Public Property CompositeMedicalProcedureIdentifier As CompositeMedicalProcedureIdentifier
    Get
    Set
public:
property CompositeMedicalProcedureIdentifier^ CompositeMedicalProcedureIdentifier {
    CompositeMedicalProcedureIdentifier^ get ();
    void set (CompositeMedicalProcedureIdentifier^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


IdentificationCode Property

IdentificationCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► IdentificationCode
Declaration Syntax
C# Visual Basic Visual C++
public string IdentificationCode { get; set; }
Public Property IdentificationCode As String
    Get
    Set
public:
property String^ IdentificationCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount Property

MonetaryAmount Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► MonetaryAmount
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount { get; set; }
Public Property MonetaryAmount As String
    Get
    Set
public:
property String^ MonetaryAmount {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ProductServiceID Property

ProductServiceID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► ProductServiceID
Declaration Syntax
C# Visual Basic Visual C++
public string ProductServiceID { get; set; }
Public Property ProductServiceID As String
    Get
    Set
public:
property String^ ProductServiceID {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity Property

Quantity Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► Quantity
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity { get; set; }
Public Property Quantity As String
    Get
    Set
public:
property String^ Quantity {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► SVD ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TOO Class

TOO Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TOO
Declaration Syntax
C# Visual Basic Visual C++
public class TOO : DocumentSegment
Public Class TOO _
    Inherits DocumentSegment
public ref class TOO : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TOO()()()() | Initializes a new instance of the TOO class
 | CodeListQualifierCode |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ToothCode |
 | ToothSurface |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TOO

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TOO Constructor

TOO Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TOO ► TOO()()()()
Initializes a new instance of the TOO class
Declaration Syntax
C# Visual Basic Visual C++
public TOO()
Public Sub New
public:
TOO()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


CodeListQualifierCode Property

CodeListQualifierCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TOO ► CodeListQualifierCode
Declaration Syntax
C# Visual Basic Visual C++
public string CodeListQualifierCode { get; set; }
Public Property CodeListQualifierCode As String
    Get
    Set
public:
property String^ CodeListQualifierCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TOO ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothCode Property

ToothCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TOO ► ToothCode
Declaration Syntax
C# Visual Basic Visual C++
public string ToothCode { get; set; }
Public Property ToothCode As String
    Get
    Set
public:
property String^ ToothCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothSurface Property

ToothSurface Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TOO ► ToothSurface
Declaration Syntax
C# Visual Basic Visual C++
public ToothSurface ToothSurface { get; set; }
Public Property ToothSurface As ToothSurface
    Get
    Set
public:
property ToothSurface^ ToothSurface {
    ToothSurface^ get ();
    void set (ToothSurface^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TOO ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothSurface Class

ToothSurface Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ToothSurface
Declaration Syntax
C# Visual Basic Visual C++
public class ToothSurface : CompositeElement
Public Class ToothSurface _
    Inherits CompositeElement
public ref class ToothSurface : public CompositeElement
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ToothSurface()()()() | Initializes a new instance of the ToothSurface class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetString(Char) | (Overrides CompositeElement.GetString(Char).)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToothSurfaceCode1 |
 | ToothSurfaceCode2 |
 | ToothSurfaceCode3 |
 | ToothSurfaceCode4 |
 | ToothSurfaceCode5 |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
 | Write(Char, List<(Of <<'(String>)>>)) | (Inherited from CompositeElement.)
Inheritance Hierarchy
Object
 | CompositeElement
 |  | ToothSurface

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothSurface Constructor

ToothSurface Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ToothSurface ► ToothSurface()()()()
Initializes a new instance of the ToothSurface class
Declaration Syntax
C# Visual Basic Visual C++
public ToothSurface()
Public Sub New
public:
ToothSurface()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


GetString Method (compElemSep)

GetString Method (compElemSep)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ToothSurface ► GetString(Char)
Declaration Syntax
C# Visual Basic Visual C++
public override string GetString(
    char compElemSep
)
Public Overrides Function GetString ( _
    compElemSep As Char _
) As String
public:
virtual String^ GetString(
    wchar_t compElemSep
) override
Parameters
compElemSep (Char)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothSurfaceCode1 Property

ToothSurfaceCode1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ToothSurface ► ToothSurfaceCode1
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode1 { get; set; }
Public Property ToothSurfaceCode1 As String
    Get
    Set
public:
property String^ ToothSurfaceCode1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothSurfaceCode2 Property

ToothSurfaceCode2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ToothSurface ► ToothSurfaceCode2
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode2 { get; set; }
Public Property ToothSurfaceCode2 As String
    Get
    Set
public:
property String^ ToothSurfaceCode2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothSurfaceCode3 Property

ToothSurfaceCode3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ToothSurface ► ToothSurfaceCode3
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode3 { get; set; }
Public Property ToothSurfaceCode3 As String
    Get
    Set
public:
property String^ ToothSurfaceCode3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothSurfaceCode4 Property

ToothSurfaceCode4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ToothSurface ► ToothSurfaceCode4
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode4 { get; set; }
Public Property ToothSurfaceCode4 As String
    Get
    Set
public:
property String^ ToothSurfaceCode4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ToothSurfaceCode5 Property

ToothSurfaceCode5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► ToothSurface ► ToothSurfaceCode5
Declaration Syntax
C# Visual Basic Visual C++
public string ToothSurfaceCode5 { get; set; }
Public Property ToothSurfaceCode5 As String
    Get
    Set
public:
property String^ ToothSurfaceCode5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TRN Class

TRN Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TRN
Declaration Syntax
C# Visual Basic Visual C++
public class TRN : DocumentSegment
Public Class TRN _
    Inherits DocumentSegment
public ref class TRN : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TRN()()()() | Initializes a new instance of the TRN class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | OriginatingCompanyIdentifier |
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | ReferenceIdentification1 |
 | ReferenceIdentification2 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | TraceTypeCode |
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TRN

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TRN Constructor

TRN Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TRN ► TRN()()()()
Initializes a new instance of the TRN class
Declaration Syntax
C# Visual Basic Visual C++
public TRN()
Public Sub New
public:
TRN()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TRN ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


OriginatingCompanyIdentifier Property

OriginatingCompanyIdentifier Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TRN ► OriginatingCompanyIdentifier
Declaration Syntax
C# Visual Basic Visual C++
public string OriginatingCompanyIdentifier { get; set; }
Public Property OriginatingCompanyIdentifier As String
    Get
    Set
public:
property String^ OriginatingCompanyIdentifier {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification1 Property

ReferenceIdentification1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TRN ► ReferenceIdentification1
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification1 { get; set; }
Public Property ReferenceIdentification1 As String
    Get
    Set
public:
property String^ ReferenceIdentification1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification2 Property

ReferenceIdentification2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TRN ► ReferenceIdentification2
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification2 { get; set; }
Public Property ReferenceIdentification2 As String
    Get
    Set
public:
property String^ ReferenceIdentification2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TraceTypeCode Property

TraceTypeCode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TRN ► TraceTypeCode
Declaration Syntax
C# Visual Basic Visual C++
public string TraceTypeCode { get; set; }
Public Property TraceTypeCode As String
    Get
    Set
public:
property String^ TraceTypeCode {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TRN ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TS2 Class

TS2 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2
Declaration Syntax
C# Visual Basic Visual C++
public class TS2 : DocumentSegment
Public Class TS2 _
    Inherits DocumentSegment
public ref class TS2 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TS2()()()() | Initializes a new instance of the TS2 class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount10 |
 | MonetaryAmount11 |
 | MonetaryAmount12 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | MonetaryAmount4 |
 | MonetaryAmount5 |
 | MonetaryAmount6 |
 | MonetaryAmount7 |
 | MonetaryAmount8 |
 | MonetaryAmount9 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 |
 | Quantity2 |
 | Quantity3 |
 | Quantity4 |
 | Quantity5 |
 | Quantity6 |
 | Quantity7 |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TS2

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TS2 Constructor

TS2 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► TS2()()()()
Initializes a new instance of the TS2 class
Declaration Syntax
C# Visual Basic Visual C++
public TS2()
Public Sub New
public:
TS2()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount12 Property

MonetaryAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount12 { get; set; }
Public Property MonetaryAmount12 As String
    Get
    Set
public:
property String^ MonetaryAmount12 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► MonetaryAmount9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Quantity1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Quantity2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity3 Property

Quantity3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Quantity3
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity3 { get; set; }
Public Property Quantity3 As String
    Get
    Set
public:
property String^ Quantity3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity4 Property

Quantity4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Quantity4
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity4 { get; set; }
Public Property Quantity4 As String
    Get
    Set
public:
property String^ Quantity4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity5 Property

Quantity5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Quantity5
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity5 { get; set; }
Public Property Quantity5 As String
    Get
    Set
public:
property String^ Quantity5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity6 Property

Quantity6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Quantity6
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity6 { get; set; }
Public Property Quantity6 As String
    Get
    Set
public:
property String^ Quantity6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity7 Property

Quantity7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Quantity7
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity7 { get; set; }
Public Property Quantity7 As String
    Get
    Set
public:
property String^ Quantity7 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS2 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TS3 Class

TS3 Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3
Declaration Syntax
C# Visual Basic Visual C++
public class TS3 : DocumentSegment
Public Class TS3 _
    Inherits DocumentSegment
public ref class TS3 : public DocumentSegment
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TS3()()()() | Initializes a new instance of the TS3 class
 | Date |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FacilityCodeValue |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(LightWeightElement) | Gets the value. (Inherited from DocumentSegment.)
 | Load(LightWeightSegment) | (Overrides DocumentSegment.Load(LightWeightSegment).)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonetaryAmount1 |
 | MonetaryAmount10 |
 | MonetaryAmount11 |
 | MonetaryAmount12 |
 | MonetaryAmount13 |
 | MonetaryAmount14 |
 | MonetaryAmount15 |
 | MonetaryAmount16 |
 | MonetaryAmount17 |
 | MonetaryAmount18 |
 | MonetaryAmount19 |
 | MonetaryAmount2 |
 | MonetaryAmount3 |
 | MonetaryAmount4 |
 | MonetaryAmount5 |
 | MonetaryAmount6 |
 | MonetaryAmount7 |
 | MonetaryAmount8 |
 | MonetaryAmount9 |
 | Name | Gets or sets the name. (Inherited from DocumentSegment.)
 | PadDataValue(Int32, Int32, String, Char) | (Inherited from DocumentSegment.)
 | Quantity1 |
 | Quantity2 |
 | ReferenceIdentification |
 | ToString()()()() | Returns a String that represents this instance. (Inherited from DocumentSegment.)
 | Write(WriteArguments) | (Overrides DocumentSegment.Write(WriteArguments).)
 | WriteToBuffer(WriteArguments) | Writes to buffer. (Inherited from DocumentSegment.)
Inheritance Hierarchy
Object
 | DocumentSegment
 |  | TS3

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


TS3 Constructor

TS3 Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► TS3()()()()
Initializes a new instance of the TS3 class
Declaration Syntax
C# Visual Basic Visual C++
public TS3()
Public Sub New
public:
TS3()

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Date Property

Date Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► Date
Declaration Syntax
C# Visual Basic Visual C++
public string Date { get; set; }
Public Property Date As String
    Get
    Set
public:
property String^ Date {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


FacilityCodeValue Property

FacilityCodeValue Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► FacilityCodeValue
Declaration Syntax
C# Visual Basic Visual C++
public string FacilityCodeValue { get; set; }
Public Property FacilityCodeValue As String
    Get
    Set
public:
property String^ FacilityCodeValue {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Load Method (segment)

Load Method (segment)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► Load(LightWeightSegment)
Declaration Syntax
C# Visual Basic Visual C++
public override void Load(
    LightWeightSegment segment
)
Public Overrides Sub Load ( _
    segment As LightWeightSegment _
)
public:
virtual void Load(
    LightWeightSegment^ segment
) override
Parameters
segment (LightWeightSegment)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount1 Property

MonetaryAmount1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount1
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount1 { get; set; }
Public Property MonetaryAmount1 As String
    Get
    Set
public:
property String^ MonetaryAmount1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount10 Property

MonetaryAmount10 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount10
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount10 { get; set; }
Public Property MonetaryAmount10 As String
    Get
    Set
public:
property String^ MonetaryAmount10 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount11 Property

MonetaryAmount11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount11
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount11 { get; set; }
Public Property MonetaryAmount11 As String
    Get
    Set
public:
property String^ MonetaryAmount11 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount12 Property

MonetaryAmount12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount12
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount12 { get; set; }
Public Property MonetaryAmount12 As String
    Get
    Set
public:
property String^ MonetaryAmount12 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount13 Property

MonetaryAmount13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount13
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount13 { get; set; }
Public Property MonetaryAmount13 As String
    Get
    Set
public:
property String^ MonetaryAmount13 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount14 Property

MonetaryAmount14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount14
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount14 { get; set; }
Public Property MonetaryAmount14 As String
    Get
    Set
public:
property String^ MonetaryAmount14 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount15 Property

MonetaryAmount15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount15
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount15 { get; set; }
Public Property MonetaryAmount15 As String
    Get
    Set
public:
property String^ MonetaryAmount15 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount16 Property

MonetaryAmount16 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount16
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount16 { get; set; }
Public Property MonetaryAmount16 As String
    Get
    Set
public:
property String^ MonetaryAmount16 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount17 Property

MonetaryAmount17 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount17
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount17 { get; set; }
Public Property MonetaryAmount17 As String
    Get
    Set
public:
property String^ MonetaryAmount17 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount18 Property

MonetaryAmount18 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount18
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount18 { get; set; }
Public Property MonetaryAmount18 As String
    Get
    Set
public:
property String^ MonetaryAmount18 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount19 Property

MonetaryAmount19 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount19
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount19 { get; set; }
Public Property MonetaryAmount19 As String
    Get
    Set
public:
property String^ MonetaryAmount19 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount2 Property

MonetaryAmount2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount2
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount2 { get; set; }
Public Property MonetaryAmount2 As String
    Get
    Set
public:
property String^ MonetaryAmount2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount3 Property

MonetaryAmount3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount3
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount3 { get; set; }
Public Property MonetaryAmount3 As String
    Get
    Set
public:
property String^ MonetaryAmount3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount4 Property

MonetaryAmount4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount4
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount4 { get; set; }
Public Property MonetaryAmount4 As String
    Get
    Set
public:
property String^ MonetaryAmount4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount5 Property

MonetaryAmount5 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount5
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount5 { get; set; }
Public Property MonetaryAmount5 As String
    Get
    Set
public:
property String^ MonetaryAmount5 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount6 Property

MonetaryAmount6 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount6
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount6 { get; set; }
Public Property MonetaryAmount6 As String
    Get
    Set
public:
property String^ MonetaryAmount6 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount7 Property

MonetaryAmount7 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount7
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount7 { get; set; }
Public Property MonetaryAmount7 As String
    Get
    Set
public:
property String^ MonetaryAmount7 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount8 Property

MonetaryAmount8 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount8
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount8 { get; set; }
Public Property MonetaryAmount8 As String
    Get
    Set
public:
property String^ MonetaryAmount8 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


MonetaryAmount9 Property

MonetaryAmount9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► MonetaryAmount9
Declaration Syntax
C# Visual Basic Visual C++
public string MonetaryAmount9 { get; set; }
Public Property MonetaryAmount9 As String
    Get
    Set
public:
property String^ MonetaryAmount9 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity1 Property

Quantity1 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► Quantity1
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity1 { get; set; }
Public Property Quantity1 As String
    Get
    Set
public:
property String^ Quantity1 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Quantity2 Property

Quantity2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► Quantity2
Declaration Syntax
C# Visual Basic Visual C++
public string Quantity2 { get; set; }
Public Property Quantity2 As String
    Get
    Set
public:
property String^ Quantity2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


ReferenceIdentification Property

ReferenceIdentification Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► ReferenceIdentification
Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceIdentification { get; set; }
Public Property ReferenceIdentification As String
    Get
    Set
public:
property String^ ReferenceIdentification {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Write Method (w)

Write Method (w)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12.IG5010.Segments ► TS3 ► Write(WriteArguments)
Declaration Syntax
C# Visual Basic Visual C++
public override void Write(
    WriteArguments w
)
Public Overrides Sub Write ( _
    w As WriteArguments _
)
public:
virtual void Write(
    WriteArguments^ w
) override
Parameters
w (WriteArguments)

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


RDPCrystalEDILibrary.Rules Namespace

RDPCrystalEDILibrary.Rules Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.Rules
Namespace RDPCrystalEDILibrary.Rules
namespace RDPCrystalEDILibrary.Rules
Types
All Types Classes
Icon | Type | Description
 | Condition |
 | ElementListNode |
 | ElementPositionNode |
 | ErrorNode |
 | GeneralRule |
 | GeneralSelfRule |
 | IfStatement |
 | Indexer |
 | IndexerList |
 | IntegerList |
 | Lexer |
 | LocalCode |
 | Node |
 | RegexMatcher |
 | SegmentPositionNode |
 | StringList |
 | TokenDefinition |
 | Tokens |
 | UsageNode |


Condition Class

Condition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition
Declaration Syntax
C# Visual Basic Visual C++
public class Condition : Node
Public Class Condition _
    Inherits Node
public ref class Condition : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Condition(String, Int32) | Initializes a new instance of the Condition class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | ElementPosition |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Evaluate(FoundSegmentCollection) |
 | Evaluate(Dictionary<(Of <<'(Int32, String>)>>)) | Used for Self Rules
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FirstOpPosition |
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | operands |
 | Operator |
 | operators |
 | SecondOpPosition |
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Value |
Inheritance Hierarchy
Object
 | Node
 |  | Condition

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Condition Constructor (text, depth)

Condition Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Condition(String, Int32)
Initializes a new instance of the Condition class
Declaration Syntax
C# Visual Basic Visual C++
public Condition(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
Condition(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPosition Property

ElementPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► ElementPosition
Declaration Syntax
C# Visual Basic Visual C++
public ElementPositionNode ElementPosition { get; set; }
Public Property ElementPosition As ElementPositionNode
    Get
    Set
public:
property ElementPositionNode^ ElementPosition {
    ElementPositionNode^ get ();
    void set (ElementPositionNode^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Evaluate Method

Evaluate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Evaluate()()()()
Members
Icon | Member | Description
 | Evaluate(FoundSegmentCollection) |
 | Evaluate(Dictionary<(Of <<'(Int32, String>)>>)) | Used for Self Rules

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Evaluate Method (foundSegments)

Evaluate Method (foundSegments)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Evaluate(FoundSegmentCollection)
Declaration Syntax
C# Visual Basic Visual C++
public bool Evaluate(
    FoundSegmentCollection foundSegments
)
Public Function Evaluate ( _
    foundSegments As FoundSegmentCollection _
) As Boolean
public:
bool Evaluate(
    FoundSegmentCollection^ foundSegments
)
Parameters
foundSegments (FoundSegmentCollection)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Evaluate Method (foundElements)

Evaluate Method (foundElements)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Evaluate(Dictionary<(Of <<'(Int32, String>)>>))
Used for Self Rules
Declaration Syntax
C# Visual Basic Visual C++
public bool Evaluate(
    Dictionary<int, string> foundElements
)
Public Function Evaluate ( _
    foundElements As Dictionary(Of Integer, String) _
) As Boolean
public:
bool Evaluate(
    Dictionary<int, String^>^ foundElements
)
Parameters
foundElements (Dictionary <(Of <(<' Int32, String >)>)>)
Return Value

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FirstOpPosition Property

FirstOpPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► FirstOpPosition
Declaration Syntax
C# Visual Basic Visual C++
public SegmentPositionNode FirstOpPosition { get; set; }
Public Property FirstOpPosition As SegmentPositionNode
    Get
    Set
public:
property SegmentPositionNode^ FirstOpPosition {
    SegmentPositionNode^ get ();
    void set (SegmentPositionNode^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


operands Field

operands Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► operands
Declaration Syntax
C# Visual Basic Visual C++
public List<Condition> operands
Public operands As List(Of Condition)
public:
List<Condition^>^ operands

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Operator Property

Operator Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Operator
Declaration Syntax
C# Visual Basic Visual C++
public RuleOperator Operator { get; set; }
Public Property Operator As RuleOperator
    Get
    Set
public:
property RuleOperator Operator {
    RuleOperator get ();
    void set (RuleOperator value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


operators Field

operators Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► operators
Declaration Syntax
C# Visual Basic Visual C++
public List<string> operators
Public operators As List(Of String)
public:
List<String^>^ operators

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SecondOpPosition Property

SecondOpPosition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► SecondOpPosition
Declaration Syntax
C# Visual Basic Visual C++
public SegmentPositionNode SecondOpPosition { get; set; }
Public Property SecondOpPosition As SegmentPositionNode
    Get
    Set
public:
property SegmentPositionNode^ SecondOpPosition {
    SegmentPositionNode^ get ();
    void set (SegmentPositionNode^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Value Property

Value Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Condition ► Value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementListNode Class

ElementListNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementListNode
Declaration Syntax
C# Visual Basic Visual C++
public class ElementListNode : Node
Public Class ElementListNode _
    Inherits Node
public ref class ElementListNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementListNode(String, Int32) | Initializes a new instance of the ElementListNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | ElementListNode

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementListNode Constructor (text, depth)

ElementListNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementListNode ► ElementListNode(String, Int32)
Initializes a new instance of the ElementListNode class
Declaration Syntax
C# Visual Basic Visual C++
public ElementListNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
ElementListNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementListNode ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementListNode ► Values
Declaration Syntax
C# Visual Basic Visual C++
public List<int> Values
Public Values As List(Of Integer)
public:
List<int>^ Values

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPositionNode Class

ElementPositionNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementPositionNode
Declaration Syntax
C# Visual Basic Visual C++
public class ElementPositionNode : Node
Public Class ElementPositionNode _
    Inherits Node
public ref class ElementPositionNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ElementPositionNode(String, Int32) | Initializes a new instance of the ElementPositionNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | ElementPositionNode

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPositionNode Constructor (text, depth)

ElementPositionNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementPositionNode ► ElementPositionNode(String, Int32)
Initializes a new instance of the ElementPositionNode class
Declaration Syntax
C# Visual Basic Visual C++
public ElementPositionNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
ElementPositionNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Index Field

Index Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementPositionNode ► Index
Declaration Syntax
C# Visual Basic Visual C++
public int Index
Public Index As Integer
public:
int Index

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ElementPositionNode ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ErrorNode Class

ErrorNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode
Declaration Syntax
C# Visual Basic Visual C++
public class ErrorNode : Node
Public Class ErrorNode _
    Inherits Node
public ref class ErrorNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorNode(String, Int32) | Initializes a new instance of the ErrorNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | EDIMessage |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageString |
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | ErrorNode

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ErrorNode Constructor (text, depth)

ErrorNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode ► ErrorNode(String, Int32)
Initializes a new instance of the ErrorNode class
Declaration Syntax
C# Visual Basic Visual C++
public ErrorNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
ErrorNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EDIMessage Property

EDIMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode ► EDIMessage
Declaration Syntax
C# Visual Basic Visual C++
public EDIValidationMessage EDIMessage { get; set; }
Public Property EDIMessage As EDIValidationMessage
    Get
    Set
public:
property EDIValidationMessage EDIMessage {
    EDIValidationMessage get ();
    void set (EDIValidationMessage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MessageString Property

MessageString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode ► MessageString
Declaration Syntax
C# Visual Basic Visual C++
public string MessageString { get; set; }
Public Property MessageString As String
    Get
    Set
public:
property String^ MessageString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► ErrorNode ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralRule Class

GeneralRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule
Declaration Syntax
C# Visual Basic Visual C++
public class GeneralRule : Node
Public Class GeneralRule _
    Inherits Node
public ref class GeneralRule : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeneralRule(String, Int32) | Initializes a new instance of the GeneralRule class
 | Defs | (Inherited from Node.)
 | DepSegmentPositionNode |
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IfStatement |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | GeneralRule

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralRule Constructor (text, depth)

GeneralRule Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule ► GeneralRule(String, Int32)
Initializes a new instance of the GeneralRule class
Declaration Syntax
C# Visual Basic Visual C++
public GeneralRule(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
GeneralRule(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DepSegmentPositionNode Property

DepSegmentPositionNode Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule ► DepSegmentPositionNode
Declaration Syntax
C# Visual Basic Visual C++
public SegmentPositionNode DepSegmentPositionNode { get; set; }
Public Property DepSegmentPositionNode As SegmentPositionNode
    Get
    Set
public:
property SegmentPositionNode^ DepSegmentPositionNode {
    SegmentPositionNode^ get ();
    void set (SegmentPositionNode^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IfStatement Property

IfStatement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule ► IfStatement
Declaration Syntax
C# Visual Basic Visual C++
public IfStatement IfStatement { get; set; }
Public Property IfStatement As IfStatement
    Get
    Set
public:
property IfStatement^ IfStatement {
    IfStatement^ get ();
    void set (IfStatement^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralRule ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralSelfRule Class

GeneralSelfRule Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule
Declaration Syntax
C# Visual Basic Visual C++
public class GeneralSelfRule : Node
Public Class GeneralSelfRule _
    Inherits Node
public ref class GeneralSelfRule : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GeneralSelfRule(String, Int32) | Initializes a new instance of the GeneralSelfRule class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IfStatement |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Symbol |
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | GeneralSelfRule

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GeneralSelfRule Constructor (text, depth)

GeneralSelfRule Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule ► GeneralSelfRule(String, Int32)
Initializes a new instance of the GeneralSelfRule class
Declaration Syntax
C# Visual Basic Visual C++
public GeneralSelfRule(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
GeneralSelfRule(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IfStatement Property

IfStatement Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule ► IfStatement
Declaration Syntax
C# Visual Basic Visual C++
public IfStatement IfStatement { get; set; }
Public Property IfStatement As IfStatement
    Get
    Set
public:
property IfStatement^ IfStatement {
    IfStatement^ get ();
    void set (IfStatement^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Symbol Property

Symbol Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule ► Symbol
Declaration Syntax
C# Visual Basic Visual C++
public string Symbol { get; set; }
Public Property Symbol As String
    Get
    Set
public:
property String^ Symbol {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► GeneralSelfRule ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IfStatement Class

IfStatement Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement
Declaration Syntax
C# Visual Basic Visual C++
public class IfStatement : Node
Public Class IfStatement _
    Inherits Node
public ref class IfStatement : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IfStatement(String, Int32) | Initializes a new instance of the IfStatement class
 | Condition |
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | False |
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | True |
Inheritance Hierarchy
Object
 | Node
 |  | IfStatement

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IfStatement Constructor (text, depth)

IfStatement Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► IfStatement(String, Int32)
Initializes a new instance of the IfStatement class
Declaration Syntax
C# Visual Basic Visual C++
public IfStatement(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
IfStatement(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Condition Property

Condition Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► Condition
Declaration Syntax
C# Visual Basic Visual C++
public Condition Condition { get; set; }
Public Property Condition As Condition
    Get
    Set
public:
property Condition^ Condition {
    Condition^ get ();
    void set (Condition^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


False Property

False Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► False
Declaration Syntax
C# Visual Basic Visual C++
public Node False { get; set; }
Public Property False As Node
    Get
    Set
public:
property Node^ False {
    Node^ get ();
    void set (Node^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


True Property

True Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IfStatement ► True
Declaration Syntax
C# Visual Basic Visual C++
public Node True { get; set; }
Public Property True As Node
    Get
    Set
public:
property Node^ True {
    Node^ get ();
    void set (Node^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Indexer Class

Indexer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Indexer
Declaration Syntax
C# Visual Basic Visual C++
public class Indexer : Node
Public Class Indexer _
    Inherits Node
public ref class Indexer : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Indexer(String, Int32) | Initializes a new instance of the Indexer class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Index |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Inherited from Node.)
 | ToString()()()() | (Inherited from Node.)
Inheritance Hierarchy
Object
 | Node
 |  | Indexer

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Indexer Constructor (text, depth)

Indexer Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Indexer ► Indexer(String, Int32)
Initializes a new instance of the Indexer class
Declaration Syntax
C# Visual Basic Visual C++
public Indexer(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
Indexer(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Index Field

Index Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Indexer ► Index
Declaration Syntax
C# Visual Basic Visual C++
public int Index
Public Index As Integer
public:
int Index

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IndexerList Class

IndexerList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IndexerList
Declaration Syntax
C# Visual Basic Visual C++
public class IndexerList : Node
Public Class IndexerList _
    Inherits Node
public ref class IndexerList : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IndexerList(String, Int32) | Initializes a new instance of the IndexerList class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Inherited from Node.)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | IndexerList

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IndexerList Constructor (text, depth)

IndexerList Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IndexerList ► IndexerList(String, Int32)
Initializes a new instance of the IndexerList class
Declaration Syntax
C# Visual Basic Visual C++
public IndexerList(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
IndexerList(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IndexerList ► Values
Declaration Syntax
C# Visual Basic Visual C++
public List<int> Values
Public Values As List(Of Integer)
public:
List<int>^ Values

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IntegerList Class

IntegerList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IntegerList
Declaration Syntax
C# Visual Basic Visual C++
public class IntegerList : Node
Public Class IntegerList _
    Inherits Node
public ref class IntegerList : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | IntegerList(String, Int32) | Initializes a new instance of the IntegerList class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Inherited from Node.)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | IntegerList

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IntegerList Constructor (text, depth)

IntegerList Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IntegerList ► IntegerList(String, Int32)
Initializes a new instance of the IntegerList class
Declaration Syntax
C# Visual Basic Visual C++
public IntegerList(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
IntegerList(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► IntegerList ► Values
Declaration Syntax
C# Visual Basic Visual C++
public List<int> Values
Public Values As List(Of Integer)
public:
List<int>^ Values

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Lexer Class

Lexer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer
Declaration Syntax
C# Visual Basic Visual C++
public sealed class Lexer : IDisposable
Public NotInheritable Class Lexer _
    Implements IDisposable
public ref class Lexer sealed : IDisposable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Lexer(TextReader, List<(Of <<'(TokenDefinition>)>>)) | Initializes a new instance of the Lexer class
 | Dispose()()()() | Releases all resources used by the Lexer
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LineNumber |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Next()()()() |
 | Position |
 | Token |
 | TokenContents |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
Lexer

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Lexer Constructor (reader, tokenDefinitions)

Lexer Constructor (reader, tokenDefinitions)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Lexer(TextReader, List<(Of <<'(TokenDefinition>)>>))
Initializes a new instance of the Lexer class
Declaration Syntax
C# Visual Basic Visual C++
public Lexer(
    TextReader reader,
    List<TokenDefinition> tokenDefinitions
)
Public Sub New ( _
    reader As TextReader, _
    tokenDefinitions As List(Of TokenDefinition) _
)
public:
Lexer(
    TextReader^ reader,
    List<TokenDefinition^>^ tokenDefinitions
)
Parameters
reader (TextReader)
tokenDefinitions (List <(Of <(<' TokenDefinition >)>)>)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Dispose()()()()
Releases all resources used by the Lexer
Declaration Syntax
C# Visual Basic Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LineNumber Property

LineNumber Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► LineNumber
Declaration Syntax
C# Visual Basic Visual C++
public int LineNumber { get; private set; }
Public Property LineNumber As Integer
    Get
    Private Set
public:
property int LineNumber {
    int get ();
    private: void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Next Method

Next Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Next()()()()
Declaration Syntax
C# Visual Basic Visual C++
public bool Next()
Public Function Next As Boolean
public:
bool Next()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Position Property

Position Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Position
Declaration Syntax
C# Visual Basic Visual C++
public int Position { get; private set; }
Public Property Position As Integer
    Get
    Private Set
public:
property int Position {
    int get ();
    private: void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Token Property

Token Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► Token
Declaration Syntax
C# Visual Basic Visual C++
public Object Token { get; private set; }
Public Property Token As Object
    Get
    Private Set
public:
property Object^ Token {
    Object^ get ();
    private: void set (Object^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TokenContents Property

TokenContents Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Lexer ► TokenContents
Declaration Syntax
C# Visual Basic Visual C++
public string TokenContents { get; private set; }
Public Property TokenContents As String
    Get
    Private Set
public:
property String^ TokenContents {
    String^ get ();
    private: void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LocalCode Class

LocalCode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► LocalCode
Declaration Syntax
C# Visual Basic Visual C++
public class LocalCode : Node
Public Class LocalCode _
    Inherits Node
public ref class LocalCode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocalCode(String, Int32) | Initializes a new instance of the LocalCode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | LocalCode

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LocalCode Constructor (text, depth)

LocalCode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► LocalCode ► LocalCode(String, Int32)
Initializes a new instance of the LocalCode class
Declaration Syntax
C# Visual Basic Visual C++
public LocalCode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
LocalCode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► LocalCode ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► LocalCode ► Values
Declaration Syntax
C# Visual Basic Visual C++
public HashSet<string> Values
Public Values As HashSet(Of String)
public:
HashSet<String^>^ Values

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Node Class

Node Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node
Declaration Syntax
C# Visual Basic Visual C++
public class Node
Public Class Node
public ref class Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Node(String, Int32) | Initializes a new instance of the Node class
 | Defs |
 | Depth | Depth is used only for printing out data to the console for debugging
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator
 | Sequence |
 | Text |
 | ToRuleString()()()() |
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
 | Node
 |  | Condition
 |  | ElementListNode
 |  | ElementPositionNode
 |  | ErrorNode
 |  | GeneralRule
 |  | GeneralSelfRule
 |  | IfStatement
 |  | Indexer
 |  | IndexerList
 |  | IntegerList
 |  | LocalCode
 |  | SegmentPositionNode
 |  | StringList
 |  | UsageNode

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Node Constructor (text, depth)

Node Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Node(String, Int32)
Initializes a new instance of the Node class
Declaration Syntax
C# Visual Basic Visual C++
public Node(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
Node(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Defs Field

Defs Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Defs
Declaration Syntax
C# Visual Basic Visual C++
protected List<TokenDefinition> Defs
Protected Defs As List(Of TokenDefinition)
protected:
List<TokenDefinition^>^ Defs

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Depth Property

Depth Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Depth
Depth is used only for printing out data to the console for debugging
Declaration Syntax
C# Visual Basic Visual C++
public int Depth { get; set; }
Public Property Depth As Integer
    Get
    Set
public:
property int Depth {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Name Property

Name Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Name
Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Sequence Field

Sequence Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Sequence
Declaration Syntax
C# Visual Basic Visual C++
protected List<string> Sequence
Protected Sequence As List(Of String)
protected:
List<String^>^ Sequence

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Text Property

Text Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public virtual string ToRuleString()
Public Overridable Function ToRuleString As String
public:
virtual String^ ToRuleString()

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Node ► ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RegexMatcher Class

RegexMatcher Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► RegexMatcher
Declaration Syntax
C# Visual Basic Visual C++
public sealed class RegexMatcher
Public NotInheritable Class RegexMatcher
public ref class RegexMatcher sealed
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RegexMatcher(String) | Initializes a new instance of the RegexMatcher class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Match(String) |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | (Overrides Object.ToString()()()().)
Inheritance Hierarchy
Object
RegexMatcher

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RegexMatcher Constructor (regex)

RegexMatcher Constructor (regex)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► RegexMatcher ► RegexMatcher(String)
Initializes a new instance of the RegexMatcher class
Declaration Syntax
C# Visual Basic Visual C++
public RegexMatcher(
    string regex
)
Public Sub New ( _
    regex As String _
)
public:
RegexMatcher(
    String^ regex
)
Parameters
regex (String)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Match Method (text)

Match Method (text)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► RegexMatcher ► Match(String)
Declaration Syntax
C# Visual Basic Visual C++
public int Match(
    string text
)
Public Function Match ( _
    text As String _
) As Integer
public:
int Match(
    String^ text
)
Parameters
text (String)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToString Method

ToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► RegexMatcher ► ToString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentPositionNode Class

SegmentPositionNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode
Declaration Syntax
C# Visual Basic Visual C++
public class SegmentPositionNode : Node
Public Class SegmentPositionNode _
    Inherits Node
public ref class SegmentPositionNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SegmentPositionNode(String, Int32) | Initializes a new instance of the SegmentPositionNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | ElementPosition |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | SegmentPositionNode

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentPositionNode Constructor (text, depth)

SegmentPositionNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode ► SegmentPositionNode(String, Int32)
Initializes a new instance of the SegmentPositionNode class
Declaration Syntax
C# Visual Basic Visual C++
public SegmentPositionNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
SegmentPositionNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementPosition Field

ElementPosition Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode ► ElementPosition
Declaration Syntax
C# Visual Basic Visual C++
public ElementPosition ElementPosition
Public ElementPosition As ElementPosition
public:
ElementPosition^ ElementPosition

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► SegmentPositionNode ► Values
Declaration Syntax
C# Visual Basic Visual C++
public List<int> Values
Public Values As List(Of Integer)
public:
List<int>^ Values

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


StringList Class

StringList Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► StringList
Declaration Syntax
C# Visual Basic Visual C++
public class StringList : Node
Public Class StringList _
    Inherits Node
public ref class StringList : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StringList(String, Int32) | Initializes a new instance of the StringList class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Inherited from Node.)
 | ToString()()()() | (Inherited from Node.)
 | Values |
Inheritance Hierarchy
Object
 | Node
 |  | StringList

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


StringList Constructor (text, depth)

StringList Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► StringList ► StringList(String, Int32)
Initializes a new instance of the StringList class
Declaration Syntax
C# Visual Basic Visual C++
public StringList(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
StringList(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Values Field

Values Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► StringList ► Values
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Values
Public Values As List(Of String)
public:
List<String^>^ Values

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TokenDefinition Class

TokenDefinition Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► TokenDefinition
Declaration Syntax
C# Visual Basic Visual C++
public sealed class TokenDefinition
Public NotInheritable Class TokenDefinition
public ref class TokenDefinition sealed
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TokenDefinition(String, Object) | Initializes a new instance of the TokenDefinition class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Matcher |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Token |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
TokenDefinition

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


TokenDefinition Constructor (regex, token)

TokenDefinition Constructor (regex, token)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► TokenDefinition ► TokenDefinition(String, Object)
Initializes a new instance of the TokenDefinition class
Declaration Syntax
C# Visual Basic Visual C++
public TokenDefinition(
    string regex,
    Object token
)
Public Sub New ( _
    regex As String, _
    token As Object _
)
public:
TokenDefinition(
    String^ regex,
    Object^ token
)
Parameters
regex (String)
token (Object)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Matcher Field

Matcher Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► TokenDefinition ► Matcher
Declaration Syntax
C# Visual Basic Visual C++
public readonly RegexMatcher Matcher
Public ReadOnly Matcher As RegexMatcher
public:
initonly RegexMatcher^ Matcher

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Token Field

Token Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► TokenDefinition ► Token
Declaration Syntax
C# Visual Basic Visual C++
public readonly Object Token
Public ReadOnly Token As Object
public:
initonly Object^ Token

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Tokens Class

Tokens Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens
Declaration Syntax
C# Visual Basic Visual C++
public static class Tokens
Public NotInheritable Class Tokens
public ref class Tokens abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AND |
 | COMMA |
 | CompositeElementHasWrongValue |
 | CompositeElementMissing |
 | CompositeElementNotRecommended |
 | CompositeElementNotUsed |
 | CompositeElementRecommended |
 | CONDITION |
 | DEFAULT |
 | DOT |
 | ElementHasWrongValue |
 | ELEMENTLIST |
 | ElementMissing |
 | ElementNotRecommended |
 | ElementNotUsed |
 | ElementRecommended |
 | ELEMPOS |
 | ELSE |
 | END |
 | EQUAL |
 | EQUALS |
 | ERROR |
 | FLOAT |
 | GREATERTHAN |
 | GREATERTHANOREQUALTO |
 | IF |
 | IFSTATEMENT |
 | INDEXER |
 | INT |
 | INTEGERINDEXLIST |
 | INTEGERLIST |
 | LEFT |
 | LEFTBRACKET |
 | LESSTHAN |
 | LESSTHANOREQUALTO |
 | LOCALCODE |
 | NOTEQUAL |
 | NOTRECOMMENDED |
 | NOTUSED |
 | NULL |
 | OPTIONAL |
 | OR |
 | RECOMMENDED |
 | REQUIRED |
 | RIGHT |
 | RIGHTBRACKET |
 | SegmentMissing |
 | SegmentNotRecommended |
 | SegmentNotUsed |
 | SegmentRecommended |
 | SEGPOS |
 | SEMICOLON |
 | SPACE |
 | STRING |
 | STRINGLIST |
 | SYMBOL |
 | THEN |
 | USAGE |
Inheritance Hierarchy
Object
Tokens

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AND Field

AND Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► AND
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition AND
Public Shared AND As TokenDefinition
public:
static TokenDefinition^ AND

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


COMMA Field

COMMA Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► COMMA
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition COMMA
Public Shared COMMA As TokenDefinition
public:
static TokenDefinition^ COMMA

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementHasWrongValue Field

CompositeElementHasWrongValue Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementHasWrongValue
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementHasWrongValue
Public Shared CompositeElementHasWrongValue As TokenDefinition
public:
static TokenDefinition^ CompositeElementHasWrongValue

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementMissing Field

CompositeElementMissing Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementMissing
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementMissing
Public Shared CompositeElementMissing As TokenDefinition
public:
static TokenDefinition^ CompositeElementMissing

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementNotRecommended Field

CompositeElementNotRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementNotRecommended
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementNotRecommended
Public Shared CompositeElementNotRecommended As TokenDefinition
public:
static TokenDefinition^ CompositeElementNotRecommended

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementNotUsed Field

CompositeElementNotUsed Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementNotUsed
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementNotUsed
Public Shared CompositeElementNotUsed As TokenDefinition
public:
static TokenDefinition^ CompositeElementNotUsed

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CompositeElementRecommended Field

CompositeElementRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CompositeElementRecommended
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CompositeElementRecommended
Public Shared CompositeElementRecommended As TokenDefinition
public:
static TokenDefinition^ CompositeElementRecommended

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CONDITION Field

CONDITION Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► CONDITION
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition CONDITION
Public Shared CONDITION As TokenDefinition
public:
static TokenDefinition^ CONDITION

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DEFAULT Field

DEFAULT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► DEFAULT
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition DEFAULT
Public Shared DEFAULT As TokenDefinition
public:
static TokenDefinition^ DEFAULT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


DOT Field

DOT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► DOT
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition DOT
Public Shared DOT As TokenDefinition
public:
static TokenDefinition^ DOT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementHasWrongValue Field

ElementHasWrongValue Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementHasWrongValue
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementHasWrongValue
Public Shared ElementHasWrongValue As TokenDefinition
public:
static TokenDefinition^ ElementHasWrongValue

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ELEMENTLIST Field

ELEMENTLIST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ELEMENTLIST
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ELEMENTLIST
Public Shared ELEMENTLIST As TokenDefinition
public:
static TokenDefinition^ ELEMENTLIST

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementMissing Field

ElementMissing Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementMissing
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementMissing
Public Shared ElementMissing As TokenDefinition
public:
static TokenDefinition^ ElementMissing

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNotRecommended Field

ElementNotRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementNotRecommended
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementNotRecommended
Public Shared ElementNotRecommended As TokenDefinition
public:
static TokenDefinition^ ElementNotRecommended

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementNotUsed Field

ElementNotUsed Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementNotUsed
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementNotUsed
Public Shared ElementNotUsed As TokenDefinition
public:
static TokenDefinition^ ElementNotUsed

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ElementRecommended Field

ElementRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ElementRecommended
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ElementRecommended
Public Shared ElementRecommended As TokenDefinition
public:
static TokenDefinition^ ElementRecommended

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ELEMPOS Field

ELEMPOS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ELEMPOS
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ELEMPOS
Public Shared ELEMPOS As TokenDefinition
public:
static TokenDefinition^ ELEMPOS

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ELSE Field

ELSE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ELSE
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ELSE
Public Shared ELSE As TokenDefinition
public:
static TokenDefinition^ ELSE

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


END Field

END Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► END
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition END
Public Shared END As TokenDefinition
public:
static TokenDefinition^ END

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EQUAL Field

EQUAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► EQUAL
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition EQUAL
Public Shared EQUAL As TokenDefinition
public:
static TokenDefinition^ EQUAL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


EQUALS Field

EQUALS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► EQUALS
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition EQUALS
Public Shared EQUALS As TokenDefinition
public:
static TokenDefinition^ EQUALS

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ERROR Field

ERROR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► ERROR
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition ERROR
Public Shared ERROR As TokenDefinition
public:
static TokenDefinition^ ERROR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


FLOAT Field

FLOAT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► FLOAT
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition FLOAT
Public Shared FLOAT As TokenDefinition
public:
static TokenDefinition^ FLOAT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GREATERTHAN Field

GREATERTHAN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► GREATERTHAN
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition GREATERTHAN
Public Shared GREATERTHAN As TokenDefinition
public:
static TokenDefinition^ GREATERTHAN

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GREATERTHANOREQUALTO Field

GREATERTHANOREQUALTO Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► GREATERTHANOREQUALTO
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition GREATERTHANOREQUALTO
Public Shared GREATERTHANOREQUALTO As TokenDefinition
public:
static TokenDefinition^ GREATERTHANOREQUALTO

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IF Field

IF Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► IF
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition IF
Public Shared IF As TokenDefinition
public:
static TokenDefinition^ IF

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IFSTATEMENT Field

IFSTATEMENT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► IFSTATEMENT
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition IFSTATEMENT
Public Shared IFSTATEMENT As TokenDefinition
public:
static TokenDefinition^ IFSTATEMENT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


INDEXER Field

INDEXER Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► INDEXER
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition INDEXER
Public Shared INDEXER As TokenDefinition
public:
static TokenDefinition^ INDEXER

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


INT Field

INT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► INT
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition INT
Public Shared INT As TokenDefinition
public:
static TokenDefinition^ INT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


INTEGERINDEXLIST Field

INTEGERINDEXLIST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► INTEGERINDEXLIST
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition INTEGERINDEXLIST
Public Shared INTEGERINDEXLIST As TokenDefinition
public:
static TokenDefinition^ INTEGERINDEXLIST

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


INTEGERLIST Field

INTEGERLIST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► INTEGERLIST
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition INTEGERLIST
Public Shared INTEGERLIST As TokenDefinition
public:
static TokenDefinition^ INTEGERLIST

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LEFT Field

LEFT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LEFT
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LEFT
Public Shared LEFT As TokenDefinition
public:
static TokenDefinition^ LEFT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LEFTBRACKET Field

LEFTBRACKET Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LEFTBRACKET
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LEFTBRACKET
Public Shared LEFTBRACKET As TokenDefinition
public:
static TokenDefinition^ LEFTBRACKET

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LESSTHAN Field

LESSTHAN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LESSTHAN
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LESSTHAN
Public Shared LESSTHAN As TokenDefinition
public:
static TokenDefinition^ LESSTHAN

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LESSTHANOREQUALTO Field

LESSTHANOREQUALTO Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LESSTHANOREQUALTO
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LESSTHANOREQUALTO
Public Shared LESSTHANOREQUALTO As TokenDefinition
public:
static TokenDefinition^ LESSTHANOREQUALTO

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


LOCALCODE Field

LOCALCODE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► LOCALCODE
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition LOCALCODE
Public Shared LOCALCODE As TokenDefinition
public:
static TokenDefinition^ LOCALCODE

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NOTEQUAL Field

NOTEQUAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTEQUAL
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTEQUAL
Public Shared NOTEQUAL As TokenDefinition
public:
static TokenDefinition^ NOTEQUAL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NOTRECOMMENDED Field

NOTRECOMMENDED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTRECOMMENDED
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTRECOMMENDED
Public Shared NOTRECOMMENDED As TokenDefinition
public:
static TokenDefinition^ NOTRECOMMENDED

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NOTUSED Field

NOTUSED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NOTUSED
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NOTUSED
Public Shared NOTUSED As TokenDefinition
public:
static TokenDefinition^ NOTUSED

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


NULL Field

NULL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► NULL
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition NULL
Public Shared NULL As TokenDefinition
public:
static TokenDefinition^ NULL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OPTIONAL Field

OPTIONAL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► OPTIONAL
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition OPTIONAL
Public Shared OPTIONAL As TokenDefinition
public:
static TokenDefinition^ OPTIONAL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


OR Field

OR Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► OR
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition OR
Public Shared OR As TokenDefinition
public:
static TokenDefinition^ OR

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RECOMMENDED Field

RECOMMENDED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► RECOMMENDED
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition RECOMMENDED
Public Shared RECOMMENDED As TokenDefinition
public:
static TokenDefinition^ RECOMMENDED

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


REQUIRED Field

REQUIRED Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► REQUIRED
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition REQUIRED
Public Shared REQUIRED As TokenDefinition
public:
static TokenDefinition^ REQUIRED

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RIGHT Field

RIGHT Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► RIGHT
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition RIGHT
Public Shared RIGHT As TokenDefinition
public:
static TokenDefinition^ RIGHT

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RIGHTBRACKET Field

RIGHTBRACKET Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► RIGHTBRACKET
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition RIGHTBRACKET
Public Shared RIGHTBRACKET As TokenDefinition
public:
static TokenDefinition^ RIGHTBRACKET

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentMissing Field

SegmentMissing Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SegmentMissing
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SegmentMissing
Public Shared SegmentMissing As TokenDefinition
public:
static TokenDefinition^ SegmentMissing

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentNotRecommended Field

SegmentNotRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SegmentNotRecommended
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SegmentNotRecommended
Public Shared SegmentNotRecommended As TokenDefinition
public:
static TokenDefinition^ SegmentNotRecommended

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentNotUsed Field

SegmentNotUsed Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SegmentNotUsed
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SegmentNotUsed
Public Shared SegmentNotUsed As TokenDefinition
public:
static TokenDefinition^ SegmentNotUsed

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SegmentRecommended Field

SegmentRecommended Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SegmentRecommended
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SegmentRecommended
Public Shared SegmentRecommended As TokenDefinition
public:
static TokenDefinition^ SegmentRecommended

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SEGPOS Field

SEGPOS Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SEGPOS
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SEGPOS
Public Shared SEGPOS As TokenDefinition
public:
static TokenDefinition^ SEGPOS

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SEMICOLON Field

SEMICOLON Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SEMICOLON
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SEMICOLON
Public Shared SEMICOLON As TokenDefinition
public:
static TokenDefinition^ SEMICOLON

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SPACE Field

SPACE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SPACE
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SPACE
Public Shared SPACE As TokenDefinition
public:
static TokenDefinition^ SPACE

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


STRING Field

STRING Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► STRING
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition STRING
Public Shared STRING As TokenDefinition
public:
static TokenDefinition^ STRING

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


STRINGLIST Field

STRINGLIST Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► STRINGLIST
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition STRINGLIST
Public Shared STRINGLIST As TokenDefinition
public:
static TokenDefinition^ STRINGLIST

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SYMBOL Field

SYMBOL Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► SYMBOL
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition SYMBOL
Public Shared SYMBOL As TokenDefinition
public:
static TokenDefinition^ SYMBOL

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


THEN Field

THEN Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► THEN
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition THEN
Public Shared THEN As TokenDefinition
public:
static TokenDefinition^ THEN

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


USAGE Field

USAGE Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► Tokens ► USAGE
Declaration Syntax
C# Visual Basic Visual C++
public static TokenDefinition USAGE
Public Shared USAGE As TokenDefinition
public:
static TokenDefinition^ USAGE

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UsageNode Class

UsageNode Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► UsageNode
Declaration Syntax
C# Visual Basic Visual C++
public class UsageNode : Node
Public Class UsageNode _
    Inherits Node
public ref class UsageNode : public Node
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UsageNode(String, Int32) | Initializes a new instance of the UsageNode class
 | Defs | (Inherited from Node.)
 | Depth | Depth is used only for printing out data to the console for debugging (Inherited from Node.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Used to assign a name to this class. It's faster to check what type this class is with a string name rather than the 'is' operator (Inherited from Node.)
 | Sequence | (Inherited from Node.)
 | Text | (Inherited from Node.)
 | ToRuleString()()()() | (Overrides Node.ToRuleString()()()().)
 | ToString()()()() | (Inherited from Node.)
 | Usage |
Inheritance Hierarchy
Object
 | Node
 |  | UsageNode

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UsageNode Constructor (text, depth)

UsageNode Constructor (text, depth)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► UsageNode ► UsageNode(String, Int32)
Initializes a new instance of the UsageNode class
Declaration Syntax
C# Visual Basic Visual C++
public UsageNode(
    string text,
    int depth
)
Public Sub New ( _
    text As String, _
    depth As Integer _
)
public:
UsageNode(
    String^ text,
    int depth
)
Parameters
text (String)
depth (Int32)

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ToRuleString Method

ToRuleString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► UsageNode ► ToRuleString()()()()
Declaration Syntax
C# Visual Basic Visual C++
public override string ToRuleString()
Public Overrides Function ToRuleString As String
public:
virtual String^ ToRuleString() override

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Usage Property

Usage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Rules ► UsageNode ► Usage
Declaration Syntax
C# Visual Basic Visual C++
public Usage Usage { get; set; }
Public Property Usage As Usage
    Get
    Set
public:
property Usage Usage {
    Usage get ();
    void set (Usage value);
}

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RDPCrystalEDILibrary.UI.Winforms Namespace

RDPCrystalEDILibrary.UI.Winforms Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.UI.Winforms
Namespace RDPCrystalEDILibrary.UI.Winforms
namespace RDPCrystalEDILibrary.UI.Winforms
Types
All Types Classes
Icon | Type | Description
 | EDINodeSelectedEventArgs |
 | HCFAFormData |
 | TreeGenerator |


EDINodeSelectedEventArgs Class

EDINodeSelectedEventArgs Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► EDINodeSelectedEventArgs
Declaration Syntax
C# Visual Basic Visual C++
public class EDINodeSelectedEventArgs : EventArgs
Public Class EDINodeSelectedEventArgs _
    Inherits EventArgs
public ref class EDINodeSelectedEventArgs : public EventArgs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SelectedObject |
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | EDINodeSelectedEventArgs

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


SelectedObject Property

SelectedObject Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► EDINodeSelectedEventArgs ► SelectedObject
Declaration Syntax
C# Visual Basic Visual C++
public Object SelectedObject { get; set; }
Public Property SelectedObject As Object
    Get
    Set
public:
property Object^ SelectedObject {
    Object^ get ();
    void set (Object^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


HCFAFormData Class

HCFAFormData Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData
Declaration Syntax
C# Visual Basic Visual C++
public class HCFAFormData
Public Class HCFAFormData
public ref class HCFAFormData
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HCFAFormData()()()() | Initializes a new instance of the HCFAFormData class
 | Box0a |
 | Box0b |
 | Box0c |
 | Box0d |
 | Box0e |
 | Box0f |
 | Box0g |
 | Box10Aa |
 | Box10Ab |
 | Box10b3 |
 | Box10Ba |
 | Box10Bb |
 | Box10Ca |
 | Box10Cb |
 | Box11 |
 | Box11A |
 | Box11Ab |
 | Box11Ac |
 | Box11b |
 | Box11c |
 | Box11Da |
 | Box11Db |
 | Box12 |
 | Box12b |
 | Box13 |
 | Box14 |
 | Box15 |
 | Box16a |
 | Box16b |
 | Box17 |
 | Box17a |
 | Box18a |
 | Box18b |
 | Box19 |
 | Box1a |
 | Box2 |
 | Box20Aa |
 | Box20Ab |
 | Box20b |
 | Box21a |
 | Box21b |
 | Box21c |
 | Box21d |
 | Box22a |
 | Box22b |
 | Box23 |
 | Box241a |
 | Box241aa |
 | Box241b |
 | Box241c |
 | Box241da |
 | Box241db |
 | Box241e |
 | Box241f |
 | Box241g |
 | Box241h |
 | Box241i |
 | Box241j |
 | Box241k |
 | Box242a |
 | Box242aa |
 | Box242b |
 | Box242c |
 | Box242da |
 | Box242db |
 | Box242e |
 | Box242f |
 | Box242g |
 | Box242h |
 | Box242i |
 | Box242j |
 | Box242k |
 | Box243a |
 | Box243aa |
 | Box243b |
 | Box243c |
 | Box243da |
 | Box243db |
 | Box243e |
 | Box243f |
 | Box243g |
 | Box243h |
 | Box243i |
 | Box243j |
 | Box243k |
 | Box244a |
 | Box244aa |
 | Box244b |
 | Box244c |
 | Box244da |
 | Box244db |
 | Box244e |
 | Box244f |
 | Box244g |
 | Box244h |
 | Box244i |
 | Box244j |
 | Box244k |
 | Box245a |
 | Box245aa |
 | Box245b |
 | Box245c |
 | Box245da |
 | Box245db |
 | Box245e |
 | Box245f |
 | Box245g |
 | Box245h |
 | Box245i |
 | Box245j |
 | Box245k |
 | Box246a |
 | Box246aa |
 | Box246b |
 | Box246c |
 | Box246da |
 | Box246db |
 | Box246e |
 | Box246f |
 | Box246g |
 | Box246h |
 | Box246i |
 | Box246j |
 | Box246k |
 | Box25 |
 | Box25a |
 | Box25b |
 | Box26 |
 | Box27a |
 | Box27b |
 | Box28 |
 | Box29 |
 | Box30 |
 | Box31 |
 | Box32 |
 | Box33 |
 | Box33a |
 | Box33b |
 | Box3a |
 | Box3b |
 | Box3c |
 | Box4 |
 | Box5a |
 | Box5b |
 | Box5c |
 | Box5d |
 | Box5e |
 | Box6a |
 | Box6b |
 | Box6c |
 | Box6d |
 | Box7a |
 | Box7b |
 | Box7c |
 | Box7d |
 | Box7e |
 | Box8Aa |
 | Box8Ab |
 | Box8Ac |
 | Box8Ba |
 | Box8Bb |
 | Box8Bc |
 | Box9 |
 | Box9a |
 | Box9Ba |
 | Box9Bb |
 | Box9Bc |
 | Box9c |
 | Box9d |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()()() | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | id |
 | ID |
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Inheritance Hierarchy
Object
HCFAFormData

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


HCFAFormData Constructor

HCFAFormData Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► HCFAFormData()()()()
Initializes a new instance of the HCFAFormData class
Declaration Syntax
C# Visual Basic Visual C++
public HCFAFormData()
Public Sub New
public:
HCFAFormData()

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box0a Property

Box0a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box0a
Declaration Syntax
C# Visual Basic Visual C++
public bool Box0a { get; set; }
Public Property Box0a As Boolean
    Get
    Set
public:
property bool Box0a {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box0b Property

Box0b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box0b
Declaration Syntax
C# Visual Basic Visual C++
public bool Box0b { get; set; }
Public Property Box0b As Boolean
    Get
    Set
public:
property bool Box0b {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box0c Property

Box0c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box0c
Declaration Syntax
C# Visual Basic Visual C++
public bool Box0c { get; set; }
Public Property Box0c As Boolean
    Get
    Set
public:
property bool Box0c {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box0d Property

Box0d Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box0d
Declaration Syntax
C# Visual Basic Visual C++
public bool Box0d { get; set; }
Public Property Box0d As Boolean
    Get
    Set
public:
property bool Box0d {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box0e Property

Box0e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box0e
Declaration Syntax
C# Visual Basic Visual C++
public bool Box0e { get; set; }
Public Property Box0e As Boolean
    Get
    Set
public:
property bool Box0e {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box0f Property

Box0f Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box0f
Declaration Syntax
C# Visual Basic Visual C++
public bool Box0f { get; set; }
Public Property Box0f As Boolean
    Get
    Set
public:
property bool Box0f {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box0g Property

Box0g Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box0g
Declaration Syntax
C# Visual Basic Visual C++
public bool Box0g { get; set; }
Public Property Box0g As Boolean
    Get
    Set
public:
property bool Box0g {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box10Aa Property

Box10Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box10Aa
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Aa { get; set; }
Public Property Box10Aa As Boolean
    Get
    Set
public:
property bool Box10Aa {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box10Ab Property

Box10Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box10Ab
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Ab { get; set; }
Public Property Box10Ab As Boolean
    Get
    Set
public:
property bool Box10Ab {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box10b3 Property

Box10b3 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box10b3
Declaration Syntax
C# Visual Basic Visual C++
public string Box10b3 { get; set; }
Public Property Box10b3 As String
    Get
    Set
public:
property String^ Box10b3 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box10Ba Property

Box10Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box10Ba
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Ba { get; set; }
Public Property Box10Ba As Boolean
    Get
    Set
public:
property bool Box10Ba {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box10Bb Property

Box10Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box10Bb
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Bb { get; set; }
Public Property Box10Bb As Boolean
    Get
    Set
public:
property bool Box10Bb {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box10Ca Property

Box10Ca Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box10Ca
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Ca { get; set; }
Public Property Box10Ca As Boolean
    Get
    Set
public:
property bool Box10Ca {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box10Cb Property

Box10Cb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box10Cb
Declaration Syntax
C# Visual Basic Visual C++
public bool Box10Cb { get; set; }
Public Property Box10Cb As Boolean
    Get
    Set
public:
property bool Box10Cb {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box11 Property

Box11 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box11
Declaration Syntax
C# Visual Basic Visual C++
public string Box11 { get; set; }
Public Property Box11 As String
    Get
    Set
public:
property String^ Box11 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box11A Property

Box11A Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box11A
Declaration Syntax
C# Visual Basic Visual C++
public string Box11A { get; set; }
Public Property Box11A As String
    Get
    Set
public:
property String^ Box11A {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box11Ab Property

Box11Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box11Ab
Declaration Syntax
C# Visual Basic Visual C++
public bool Box11Ab { get; set; }
Public Property Box11Ab As Boolean
    Get
    Set
public:
property bool Box11Ab {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box11Ac Property

Box11Ac Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box11Ac
Declaration Syntax
C# Visual Basic Visual C++
public bool Box11Ac { get; set; }
Public Property Box11Ac As Boolean
    Get
    Set
public:
property bool Box11Ac {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box11b Property

Box11b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box11b
Declaration Syntax
C# Visual Basic Visual C++
public string Box11b { get; set; }
Public Property Box11b As String
    Get
    Set
public:
property String^ Box11b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box11c Property

Box11c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box11c
Declaration Syntax
C# Visual Basic Visual C++
public string Box11c { get; set; }
Public Property Box11c As String
    Get
    Set
public:
property String^ Box11c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box11Da Property

Box11Da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box11Da
Declaration Syntax
C# Visual Basic Visual C++
public bool Box11Da { get; set; }
Public Property Box11Da As Boolean
    Get
    Set
public:
property bool Box11Da {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box11Db Property

Box11Db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box11Db
Declaration Syntax
C# Visual Basic Visual C++
public bool Box11Db { get; set; }
Public Property Box11Db As Boolean
    Get
    Set
public:
property bool Box11Db {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box12 Property

Box12 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box12
Declaration Syntax
C# Visual Basic Visual C++
public string Box12 { get; set; }
Public Property Box12 As String
    Get
    Set
public:
property String^ Box12 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box12b Property

Box12b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box12b
Declaration Syntax
C# Visual Basic Visual C++
public string Box12b { get; set; }
Public Property Box12b As String
    Get
    Set
public:
property String^ Box12b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box13 Property

Box13 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box13
Declaration Syntax
C# Visual Basic Visual C++
public string Box13 { get; set; }
Public Property Box13 As String
    Get
    Set
public:
property String^ Box13 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box14 Property

Box14 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box14
Declaration Syntax
C# Visual Basic Visual C++
public string Box14 { get; set; }
Public Property Box14 As String
    Get
    Set
public:
property String^ Box14 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box15 Property

Box15 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box15
Declaration Syntax
C# Visual Basic Visual C++
public string Box15 { get; set; }
Public Property Box15 As String
    Get
    Set
public:
property String^ Box15 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box16a Property

Box16a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box16a
Declaration Syntax
C# Visual Basic Visual C++
public string Box16a { get; set; }
Public Property Box16a As String
    Get
    Set
public:
property String^ Box16a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box16b Property

Box16b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box16b
Declaration Syntax
C# Visual Basic Visual C++
public string Box16b { get; set; }
Public Property Box16b As String
    Get
    Set
public:
property String^ Box16b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box17 Property

Box17 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box17
Declaration Syntax
C# Visual Basic Visual C++
public string Box17 { get; set; }
Public Property Box17 As String
    Get
    Set
public:
property String^ Box17 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box17a Property

Box17a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box17a
Declaration Syntax
C# Visual Basic Visual C++
public string Box17a { get; set; }
Public Property Box17a As String
    Get
    Set
public:
property String^ Box17a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box18a Property

Box18a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box18a
Declaration Syntax
C# Visual Basic Visual C++
public string Box18a { get; set; }
Public Property Box18a As String
    Get
    Set
public:
property String^ Box18a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box18b Property

Box18b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box18b
Declaration Syntax
C# Visual Basic Visual C++
public string Box18b { get; set; }
Public Property Box18b As String
    Get
    Set
public:
property String^ Box18b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box19 Property

Box19 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box19
Declaration Syntax
C# Visual Basic Visual C++
public string Box19 { get; set; }
Public Property Box19 As String
    Get
    Set
public:
property String^ Box19 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box1a Property

Box1a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box1a
Declaration Syntax
C# Visual Basic Visual C++
public string Box1a { get; set; }
Public Property Box1a As String
    Get
    Set
public:
property String^ Box1a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box2 Property

Box2 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box2
Declaration Syntax
C# Visual Basic Visual C++
public string Box2 { get; set; }
Public Property Box2 As String
    Get
    Set
public:
property String^ Box2 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box20Aa Property

Box20Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box20Aa
Declaration Syntax
C# Visual Basic Visual C++
public bool Box20Aa { get; set; }
Public Property Box20Aa As Boolean
    Get
    Set
public:
property bool Box20Aa {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box20Ab Property

Box20Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box20Ab
Declaration Syntax
C# Visual Basic Visual C++
public bool Box20Ab { get; set; }
Public Property Box20Ab As Boolean
    Get
    Set
public:
property bool Box20Ab {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box20b Property

Box20b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box20b
Declaration Syntax
C# Visual Basic Visual C++
public string Box20b { get; set; }
Public Property Box20b As String
    Get
    Set
public:
property String^ Box20b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box21a Property

Box21a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box21a
Declaration Syntax
C# Visual Basic Visual C++
public string Box21a { get; set; }
Public Property Box21a As String
    Get
    Set
public:
property String^ Box21a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box21b Property

Box21b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box21b
Declaration Syntax
C# Visual Basic Visual C++
public string Box21b { get; set; }
Public Property Box21b As String
    Get
    Set
public:
property String^ Box21b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box21c Property

Box21c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box21c
Declaration Syntax
C# Visual Basic Visual C++
public string Box21c { get; set; }
Public Property Box21c As String
    Get
    Set
public:
property String^ Box21c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box21d Property

Box21d Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box21d
Declaration Syntax
C# Visual Basic Visual C++
public string Box21d { get; set; }
Public Property Box21d As String
    Get
    Set
public:
property String^ Box21d {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box22a Property

Box22a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box22a
Declaration Syntax
C# Visual Basic Visual C++
public string Box22a { get; set; }
Public Property Box22a As String
    Get
    Set
public:
property String^ Box22a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box22b Property

Box22b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box22b
Declaration Syntax
C# Visual Basic Visual C++
public string Box22b { get; set; }
Public Property Box22b As String
    Get
    Set
public:
property String^ Box22b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box23 Property

Box23 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box23
Declaration Syntax
C# Visual Basic Visual C++
public string Box23 { get; set; }
Public Property Box23 As String
    Get
    Set
public:
property String^ Box23 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241a Property

Box241a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241a
Declaration Syntax
C# Visual Basic Visual C++
public string Box241a { get; set; }
Public Property Box241a As String
    Get
    Set
public:
property String^ Box241a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241aa Property

Box241aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241aa
Declaration Syntax
C# Visual Basic Visual C++
public string Box241aa { get; set; }
Public Property Box241aa As String
    Get
    Set
public:
property String^ Box241aa {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241b Property

Box241b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241b
Declaration Syntax
C# Visual Basic Visual C++
public string Box241b { get; set; }
Public Property Box241b As String
    Get
    Set
public:
property String^ Box241b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241c Property

Box241c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241c
Declaration Syntax
C# Visual Basic Visual C++
public string Box241c { get; set; }
Public Property Box241c As String
    Get
    Set
public:
property String^ Box241c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241da Property

Box241da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241da
Declaration Syntax
C# Visual Basic Visual C++
public string Box241da { get; set; }
Public Property Box241da As String
    Get
    Set
public:
property String^ Box241da {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241db Property

Box241db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241db
Declaration Syntax
C# Visual Basic Visual C++
public string Box241db { get; set; }
Public Property Box241db As String
    Get
    Set
public:
property String^ Box241db {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241e Property

Box241e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241e
Declaration Syntax
C# Visual Basic Visual C++
public string Box241e { get; set; }
Public Property Box241e As String
    Get
    Set
public:
property String^ Box241e {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241f Property

Box241f Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241f
Declaration Syntax
C# Visual Basic Visual C++
public string Box241f { get; set; }
Public Property Box241f As String
    Get
    Set
public:
property String^ Box241f {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241g Property

Box241g Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241g
Declaration Syntax
C# Visual Basic Visual C++
public string Box241g { get; set; }
Public Property Box241g As String
    Get
    Set
public:
property String^ Box241g {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241h Property

Box241h Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241h
Declaration Syntax
C# Visual Basic Visual C++
public string Box241h { get; set; }
Public Property Box241h As String
    Get
    Set
public:
property String^ Box241h {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241i Property

Box241i Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241i
Declaration Syntax
C# Visual Basic Visual C++
public string Box241i { get; set; }
Public Property Box241i As String
    Get
    Set
public:
property String^ Box241i {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241j Property

Box241j Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241j
Declaration Syntax
C# Visual Basic Visual C++
public string Box241j { get; set; }
Public Property Box241j As String
    Get
    Set
public:
property String^ Box241j {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box241k Property

Box241k Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box241k
Declaration Syntax
C# Visual Basic Visual C++
public string Box241k { get; set; }
Public Property Box241k As String
    Get
    Set
public:
property String^ Box241k {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242a Property

Box242a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242a
Declaration Syntax
C# Visual Basic Visual C++
public string Box242a { get; set; }
Public Property Box242a As String
    Get
    Set
public:
property String^ Box242a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242aa Property

Box242aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242aa
Declaration Syntax
C# Visual Basic Visual C++
public string Box242aa { get; set; }
Public Property Box242aa As String
    Get
    Set
public:
property String^ Box242aa {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242b Property

Box242b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242b
Declaration Syntax
C# Visual Basic Visual C++
public string Box242b { get; set; }
Public Property Box242b As String
    Get
    Set
public:
property String^ Box242b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242c Property

Box242c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242c
Declaration Syntax
C# Visual Basic Visual C++
public string Box242c { get; set; }
Public Property Box242c As String
    Get
    Set
public:
property String^ Box242c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242da Property

Box242da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242da
Declaration Syntax
C# Visual Basic Visual C++
public string Box242da { get; set; }
Public Property Box242da As String
    Get
    Set
public:
property String^ Box242da {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242db Property

Box242db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242db
Declaration Syntax
C# Visual Basic Visual C++
public string Box242db { get; set; }
Public Property Box242db As String
    Get
    Set
public:
property String^ Box242db {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242e Property

Box242e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242e
Declaration Syntax
C# Visual Basic Visual C++
public string Box242e { get; set; }
Public Property Box242e As String
    Get
    Set
public:
property String^ Box242e {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242f Property

Box242f Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242f
Declaration Syntax
C# Visual Basic Visual C++
public string Box242f { get; set; }
Public Property Box242f As String
    Get
    Set
public:
property String^ Box242f {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242g Property

Box242g Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242g
Declaration Syntax
C# Visual Basic Visual C++
public string Box242g { get; set; }
Public Property Box242g As String
    Get
    Set
public:
property String^ Box242g {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242h Property

Box242h Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242h
Declaration Syntax
C# Visual Basic Visual C++
public string Box242h { get; set; }
Public Property Box242h As String
    Get
    Set
public:
property String^ Box242h {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242i Property

Box242i Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242i
Declaration Syntax
C# Visual Basic Visual C++
public string Box242i { get; set; }
Public Property Box242i As String
    Get
    Set
public:
property String^ Box242i {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242j Property

Box242j Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242j
Declaration Syntax
C# Visual Basic Visual C++
public string Box242j { get; set; }
Public Property Box242j As String
    Get
    Set
public:
property String^ Box242j {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box242k Property

Box242k Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box242k
Declaration Syntax
C# Visual Basic Visual C++
public string Box242k { get; set; }
Public Property Box242k As String
    Get
    Set
public:
property String^ Box242k {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243a Property

Box243a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243a
Declaration Syntax
C# Visual Basic Visual C++
public string Box243a { get; set; }
Public Property Box243a As String
    Get
    Set
public:
property String^ Box243a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243aa Property

Box243aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243aa
Declaration Syntax
C# Visual Basic Visual C++
public string Box243aa { get; set; }
Public Property Box243aa As String
    Get
    Set
public:
property String^ Box243aa {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243b Property

Box243b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243b
Declaration Syntax
C# Visual Basic Visual C++
public string Box243b { get; set; }
Public Property Box243b As String
    Get
    Set
public:
property String^ Box243b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243c Property

Box243c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243c
Declaration Syntax
C# Visual Basic Visual C++
public string Box243c { get; set; }
Public Property Box243c As String
    Get
    Set
public:
property String^ Box243c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243da Property

Box243da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243da
Declaration Syntax
C# Visual Basic Visual C++
public string Box243da { get; set; }
Public Property Box243da As String
    Get
    Set
public:
property String^ Box243da {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243db Property

Box243db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243db
Declaration Syntax
C# Visual Basic Visual C++
public string Box243db { get; set; }
Public Property Box243db As String
    Get
    Set
public:
property String^ Box243db {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243e Property

Box243e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243e
Declaration Syntax
C# Visual Basic Visual C++
public string Box243e { get; set; }
Public Property Box243e As String
    Get
    Set
public:
property String^ Box243e {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243f Property

Box243f Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243f
Declaration Syntax
C# Visual Basic Visual C++
public string Box243f { get; set; }
Public Property Box243f As String
    Get
    Set
public:
property String^ Box243f {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243g Property

Box243g Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243g
Declaration Syntax
C# Visual Basic Visual C++
public string Box243g { get; set; }
Public Property Box243g As String
    Get
    Set
public:
property String^ Box243g {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243h Property

Box243h Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243h
Declaration Syntax
C# Visual Basic Visual C++
public string Box243h { get; set; }
Public Property Box243h As String
    Get
    Set
public:
property String^ Box243h {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243i Property

Box243i Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243i
Declaration Syntax
C# Visual Basic Visual C++
public string Box243i { get; set; }
Public Property Box243i As String
    Get
    Set
public:
property String^ Box243i {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243j Property

Box243j Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243j
Declaration Syntax
C# Visual Basic Visual C++
public string Box243j { get; set; }
Public Property Box243j As String
    Get
    Set
public:
property String^ Box243j {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box243k Property

Box243k Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box243k
Declaration Syntax
C# Visual Basic Visual C++
public string Box243k { get; set; }
Public Property Box243k As String
    Get
    Set
public:
property String^ Box243k {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244a Property

Box244a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244a
Declaration Syntax
C# Visual Basic Visual C++
public string Box244a { get; set; }
Public Property Box244a As String
    Get
    Set
public:
property String^ Box244a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244aa Property

Box244aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244aa
Declaration Syntax
C# Visual Basic Visual C++
public string Box244aa { get; set; }
Public Property Box244aa As String
    Get
    Set
public:
property String^ Box244aa {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244b Property

Box244b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244b
Declaration Syntax
C# Visual Basic Visual C++
public string Box244b { get; set; }
Public Property Box244b As String
    Get
    Set
public:
property String^ Box244b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244c Property

Box244c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244c
Declaration Syntax
C# Visual Basic Visual C++
public string Box244c { get; set; }
Public Property Box244c As String
    Get
    Set
public:
property String^ Box244c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244da Property

Box244da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244da
Declaration Syntax
C# Visual Basic Visual C++
public string Box244da { get; set; }
Public Property Box244da As String
    Get
    Set
public:
property String^ Box244da {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244db Property

Box244db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244db
Declaration Syntax
C# Visual Basic Visual C++
public string Box244db { get; set; }
Public Property Box244db As String
    Get
    Set
public:
property String^ Box244db {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244e Property

Box244e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244e
Declaration Syntax
C# Visual Basic Visual C++
public string Box244e { get; set; }
Public Property Box244e As String
    Get
    Set
public:
property String^ Box244e {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244f Property

Box244f Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244f
Declaration Syntax
C# Visual Basic Visual C++
public string Box244f { get; set; }
Public Property Box244f As String
    Get
    Set
public:
property String^ Box244f {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244g Property

Box244g Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244g
Declaration Syntax
C# Visual Basic Visual C++
public string Box244g { get; set; }
Public Property Box244g As String
    Get
    Set
public:
property String^ Box244g {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244h Property

Box244h Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244h
Declaration Syntax
C# Visual Basic Visual C++
public string Box244h { get; set; }
Public Property Box244h As String
    Get
    Set
public:
property String^ Box244h {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244i Property

Box244i Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244i
Declaration Syntax
C# Visual Basic Visual C++
public string Box244i { get; set; }
Public Property Box244i As String
    Get
    Set
public:
property String^ Box244i {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244j Property

Box244j Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244j
Declaration Syntax
C# Visual Basic Visual C++
public string Box244j { get; set; }
Public Property Box244j As String
    Get
    Set
public:
property String^ Box244j {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box244k Property

Box244k Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box244k
Declaration Syntax
C# Visual Basic Visual C++
public string Box244k { get; set; }
Public Property Box244k As String
    Get
    Set
public:
property String^ Box244k {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245a Property

Box245a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245a
Declaration Syntax
C# Visual Basic Visual C++
public string Box245a { get; set; }
Public Property Box245a As String
    Get
    Set
public:
property String^ Box245a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245aa Property

Box245aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245aa
Declaration Syntax
C# Visual Basic Visual C++
public string Box245aa { get; set; }
Public Property Box245aa As String
    Get
    Set
public:
property String^ Box245aa {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245b Property

Box245b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245b
Declaration Syntax
C# Visual Basic Visual C++
public string Box245b { get; set; }
Public Property Box245b As String
    Get
    Set
public:
property String^ Box245b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245c Property

Box245c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245c
Declaration Syntax
C# Visual Basic Visual C++
public string Box245c { get; set; }
Public Property Box245c As String
    Get
    Set
public:
property String^ Box245c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245da Property

Box245da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245da
Declaration Syntax
C# Visual Basic Visual C++
public string Box245da { get; set; }
Public Property Box245da As String
    Get
    Set
public:
property String^ Box245da {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245db Property

Box245db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245db
Declaration Syntax
C# Visual Basic Visual C++
public string Box245db { get; set; }
Public Property Box245db As String
    Get
    Set
public:
property String^ Box245db {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245e Property

Box245e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245e
Declaration Syntax
C# Visual Basic Visual C++
public string Box245e { get; set; }
Public Property Box245e As String
    Get
    Set
public:
property String^ Box245e {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245f Property

Box245f Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245f
Declaration Syntax
C# Visual Basic Visual C++
public string Box245f { get; set; }
Public Property Box245f As String
    Get
    Set
public:
property String^ Box245f {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245g Property

Box245g Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245g
Declaration Syntax
C# Visual Basic Visual C++
public string Box245g { get; set; }
Public Property Box245g As String
    Get
    Set
public:
property String^ Box245g {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245h Property

Box245h Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245h
Declaration Syntax
C# Visual Basic Visual C++
public string Box245h { get; set; }
Public Property Box245h As String
    Get
    Set
public:
property String^ Box245h {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245i Property

Box245i Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245i
Declaration Syntax
C# Visual Basic Visual C++
public string Box245i { get; set; }
Public Property Box245i As String
    Get
    Set
public:
property String^ Box245i {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245j Property

Box245j Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245j
Declaration Syntax
C# Visual Basic Visual C++
public string Box245j { get; set; }
Public Property Box245j As String
    Get
    Set
public:
property String^ Box245j {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box245k Property

Box245k Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box245k
Declaration Syntax
C# Visual Basic Visual C++
public string Box245k { get; set; }
Public Property Box245k As String
    Get
    Set
public:
property String^ Box245k {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246a Property

Box246a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246a
Declaration Syntax
C# Visual Basic Visual C++
public string Box246a { get; set; }
Public Property Box246a As String
    Get
    Set
public:
property String^ Box246a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246aa Property

Box246aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246aa
Declaration Syntax
C# Visual Basic Visual C++
public string Box246aa { get; set; }
Public Property Box246aa As String
    Get
    Set
public:
property String^ Box246aa {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246b Property

Box246b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246b
Declaration Syntax
C# Visual Basic Visual C++
public string Box246b { get; set; }
Public Property Box246b As String
    Get
    Set
public:
property String^ Box246b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246c Property

Box246c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246c
Declaration Syntax
C# Visual Basic Visual C++
public string Box246c { get; set; }
Public Property Box246c As String
    Get
    Set
public:
property String^ Box246c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246da Property

Box246da Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246da
Declaration Syntax
C# Visual Basic Visual C++
public string Box246da { get; set; }
Public Property Box246da As String
    Get
    Set
public:
property String^ Box246da {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246db Property

Box246db Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246db
Declaration Syntax
C# Visual Basic Visual C++
public string Box246db { get; set; }
Public Property Box246db As String
    Get
    Set
public:
property String^ Box246db {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246e Property

Box246e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246e
Declaration Syntax
C# Visual Basic Visual C++
public string Box246e { get; set; }
Public Property Box246e As String
    Get
    Set
public:
property String^ Box246e {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246f Property

Box246f Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246f
Declaration Syntax
C# Visual Basic Visual C++
public string Box246f { get; set; }
Public Property Box246f As String
    Get
    Set
public:
property String^ Box246f {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246g Property

Box246g Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246g
Declaration Syntax
C# Visual Basic Visual C++
public string Box246g { get; set; }
Public Property Box246g As String
    Get
    Set
public:
property String^ Box246g {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246h Property

Box246h Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246h
Declaration Syntax
C# Visual Basic Visual C++
public string Box246h { get; set; }
Public Property Box246h As String
    Get
    Set
public:
property String^ Box246h {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246i Property

Box246i Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246i
Declaration Syntax
C# Visual Basic Visual C++
public string Box246i { get; set; }
Public Property Box246i As String
    Get
    Set
public:
property String^ Box246i {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246j Property

Box246j Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246j
Declaration Syntax
C# Visual Basic Visual C++
public string Box246j { get; set; }
Public Property Box246j As String
    Get
    Set
public:
property String^ Box246j {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box246k Property

Box246k Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box246k
Declaration Syntax
C# Visual Basic Visual C++
public string Box246k { get; set; }
Public Property Box246k As String
    Get
    Set
public:
property String^ Box246k {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box25 Property

Box25 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box25
Declaration Syntax
C# Visual Basic Visual C++
public string Box25 { get; set; }
Public Property Box25 As String
    Get
    Set
public:
property String^ Box25 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box25a Property

Box25a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box25a
Declaration Syntax
C# Visual Basic Visual C++
public string Box25a { get; set; }
Public Property Box25a As String
    Get
    Set
public:
property String^ Box25a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box25b Property

Box25b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box25b
Declaration Syntax
C# Visual Basic Visual C++
public string Box25b { get; set; }
Public Property Box25b As String
    Get
    Set
public:
property String^ Box25b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box26 Property

Box26 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box26
Declaration Syntax
C# Visual Basic Visual C++
public string Box26 { get; set; }
Public Property Box26 As String
    Get
    Set
public:
property String^ Box26 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box27a Property

Box27a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box27a
Declaration Syntax
C# Visual Basic Visual C++
public bool Box27a { get; set; }
Public Property Box27a As Boolean
    Get
    Set
public:
property bool Box27a {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box27b Property

Box27b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box27b
Declaration Syntax
C# Visual Basic Visual C++
public bool Box27b { get; set; }
Public Property Box27b As Boolean
    Get
    Set
public:
property bool Box27b {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box28 Property

Box28 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box28
Declaration Syntax
C# Visual Basic Visual C++
public string Box28 { get; set; }
Public Property Box28 As String
    Get
    Set
public:
property String^ Box28 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box29 Property

Box29 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box29
Declaration Syntax
C# Visual Basic Visual C++
public string Box29 { get; set; }
Public Property Box29 As String
    Get
    Set
public:
property String^ Box29 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box30 Property

Box30 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box30
Declaration Syntax
C# Visual Basic Visual C++
public string Box30 { get; set; }
Public Property Box30 As String
    Get
    Set
public:
property String^ Box30 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box31 Property

Box31 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box31
Declaration Syntax
C# Visual Basic Visual C++
public string Box31 { get; set; }
Public Property Box31 As String
    Get
    Set
public:
property String^ Box31 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box32 Property

Box32 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box32
Declaration Syntax
C# Visual Basic Visual C++
public string Box32 { get; set; }
Public Property Box32 As String
    Get
    Set
public:
property String^ Box32 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box33 Property

Box33 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box33
Declaration Syntax
C# Visual Basic Visual C++
public string Box33 { get; set; }
Public Property Box33 As String
    Get
    Set
public:
property String^ Box33 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box33a Property

Box33a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box33a
Declaration Syntax
C# Visual Basic Visual C++
public string Box33a { get; set; }
Public Property Box33a As String
    Get
    Set
public:
property String^ Box33a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box33b Property

Box33b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box33b
Declaration Syntax
C# Visual Basic Visual C++
public string Box33b { get; set; }
Public Property Box33b As String
    Get
    Set
public:
property String^ Box33b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box3a Property

Box3a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box3a
Declaration Syntax
C# Visual Basic Visual C++
public string Box3a { get; set; }
Public Property Box3a As String
    Get
    Set
public:
property String^ Box3a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box3b Property

Box3b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box3b
Declaration Syntax
C# Visual Basic Visual C++
public bool Box3b { get; set; }
Public Property Box3b As Boolean
    Get
    Set
public:
property bool Box3b {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box3c Property

Box3c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box3c
Declaration Syntax
C# Visual Basic Visual C++
public bool Box3c { get; set; }
Public Property Box3c As Boolean
    Get
    Set
public:
property bool Box3c {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box4 Property

Box4 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box4
Declaration Syntax
C# Visual Basic Visual C++
public string Box4 { get; set; }
Public Property Box4 As String
    Get
    Set
public:
property String^ Box4 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box5a Property

Box5a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box5a
Declaration Syntax
C# Visual Basic Visual C++
public string Box5a { get; set; }
Public Property Box5a As String
    Get
    Set
public:
property String^ Box5a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box5b Property

Box5b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box5b
Declaration Syntax
C# Visual Basic Visual C++
public string Box5b { get; set; }
Public Property Box5b As String
    Get
    Set
public:
property String^ Box5b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box5c Property

Box5c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box5c
Declaration Syntax
C# Visual Basic Visual C++
public string Box5c { get; set; }
Public Property Box5c As String
    Get
    Set
public:
property String^ Box5c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box5d Property

Box5d Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box5d
Declaration Syntax
C# Visual Basic Visual C++
public string Box5d { get; set; }
Public Property Box5d As String
    Get
    Set
public:
property String^ Box5d {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box5e Property

Box5e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box5e
Declaration Syntax
C# Visual Basic Visual C++
public string Box5e { get; set; }
Public Property Box5e As String
    Get
    Set
public:
property String^ Box5e {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box6a Property

Box6a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box6a
Declaration Syntax
C# Visual Basic Visual C++
public bool Box6a { get; set; }
Public Property Box6a As Boolean
    Get
    Set
public:
property bool Box6a {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box6b Property

Box6b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box6b
Declaration Syntax
C# Visual Basic Visual C++
public bool Box6b { get; set; }
Public Property Box6b As Boolean
    Get
    Set
public:
property bool Box6b {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box6c Property

Box6c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box6c
Declaration Syntax
C# Visual Basic Visual C++
public bool Box6c { get; set; }
Public Property Box6c As Boolean
    Get
    Set
public:
property bool Box6c {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box6d Property

Box6d Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box6d
Declaration Syntax
C# Visual Basic Visual C++
public bool Box6d { get; set; }
Public Property Box6d As Boolean
    Get
    Set
public:
property bool Box6d {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box7a Property

Box7a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box7a
Declaration Syntax
C# Visual Basic Visual C++
public string Box7a { get; set; }
Public Property Box7a As String
    Get
    Set
public:
property String^ Box7a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box7b Property

Box7b Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box7b
Declaration Syntax
C# Visual Basic Visual C++
public string Box7b { get; set; }
Public Property Box7b As String
    Get
    Set
public:
property String^ Box7b {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box7c Property

Box7c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box7c
Declaration Syntax
C# Visual Basic Visual C++
public string Box7c { get; set; }
Public Property Box7c As String
    Get
    Set
public:
property String^ Box7c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box7d Property

Box7d Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box7d
Declaration Syntax
C# Visual Basic Visual C++
public string Box7d { get; set; }
Public Property Box7d As String
    Get
    Set
public:
property String^ Box7d {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box7e Property

Box7e Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box7e
Declaration Syntax
C# Visual Basic Visual C++
public string Box7e { get; set; }
Public Property Box7e As String
    Get
    Set
public:
property String^ Box7e {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box8Aa Property

Box8Aa Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box8Aa
Declaration Syntax
C# Visual Basic Visual C++
public bool Box8Aa { get; set; }
Public Property Box8Aa As Boolean
    Get
    Set
public:
property bool Box8Aa {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box8Ab Property

Box8Ab Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box8Ab
Declaration Syntax
C# Visual Basic Visual C++
public bool Box8Ab { get; set; }
Public Property Box8Ab As Boolean
    Get
    Set
public:
property bool Box8Ab {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box8Ac Property

Box8Ac Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box8Ac
Declaration Syntax
C# Visual Basic Visual C++
public bool Box8Ac { get; set; }
Public Property Box8Ac As Boolean
    Get
    Set
public:
property bool Box8Ac {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box8Ba Property

Box8Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box8Ba
Declaration Syntax
C# Visual Basic Visual C++
public bool Box8Ba { get; set; }
Public Property Box8Ba As Boolean
    Get
    Set
public:
property bool Box8Ba {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box8Bb Property

Box8Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box8Bb
Declaration Syntax
C# Visual Basic Visual C++
public bool Box8Bb { get; set; }
Public Property Box8Bb As Boolean
    Get
    Set
public:
property bool Box8Bb {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box8Bc Property

Box8Bc Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box8Bc
Declaration Syntax
C# Visual Basic Visual C++
public bool Box8Bc { get; set; }
Public Property Box8Bc As Boolean
    Get
    Set
public:
property bool Box8Bc {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box9 Property

Box9 Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box9
Declaration Syntax
C# Visual Basic Visual C++
public string Box9 { get; set; }
Public Property Box9 As String
    Get
    Set
public:
property String^ Box9 {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box9a Property

Box9a Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box9a
Declaration Syntax
C# Visual Basic Visual C++
public string Box9a { get; set; }
Public Property Box9a As String
    Get
    Set
public:
property String^ Box9a {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box9Ba Property

Box9Ba Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box9Ba
Declaration Syntax
C# Visual Basic Visual C++
public string Box9Ba { get; set; }
Public Property Box9Ba As String
    Get
    Set
public:
property String^ Box9Ba {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box9Bb Property

Box9Bb Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box9Bb
Declaration Syntax
C# Visual Basic Visual C++
public bool Box9Bb { get; set; }
Public Property Box9Bb As Boolean
    Get
    Set
public:
property bool Box9Bb {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box9Bc Property

Box9Bc Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box9Bc
Declaration Syntax
C# Visual Basic Visual C++
public bool Box9Bc { get; set; }
Public Property Box9Bc As Boolean
    Get
    Set
public:
property bool Box9Bc {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box9c Property

Box9c Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box9c
Declaration Syntax
C# Visual Basic Visual C++
public string Box9c { get; set; }
Public Property Box9c As String
    Get
    Set
public:
property String^ Box9c {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Box9d Property

Box9d Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► Box9d
Declaration Syntax
C# Visual Basic Visual C++
public string Box9d { get; set; }
Public Property Box9d As String
    Get
    Set
public:
property String^ Box9d {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


id Field

id Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► id
Declaration Syntax
C# Visual Basic Visual C++
protected int id
Protected id As Integer
protected:
int id

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ID Property

ID Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► HCFAFormData ► ID
Declaration Syntax
C# Visual Basic Visual C++
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
public:
property int ID {
    int get ();
    void set (int value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


TreeGenerator Class

TreeGenerator Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► TreeGenerator
Declaration Syntax
C# Visual Basic Visual C++
public static class TreeGenerator
Public NotInheritable Class TreeGenerator
public ref class TreeGenerator abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildEDIDocumentTree(EDIDocument, Boolean) | Builds the EDI document tree.
 | BuildRulesTree(EDIRulesReader) | Builds the rules tree.
 | BuildValidatedDataTree(EDIValidator) | Builds the validated data tree.
Inheritance Hierarchy
Object
TreeGenerator

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


BuildEDIDocumentTree Method (document, expandLoopNode)

BuildEDIDocumentTree Method (document, expandLoopNode)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► TreeGenerator ► BuildEDIDocumentTree(EDIDocument, Boolean)
Builds the EDI document tree.
Declaration Syntax
C# Visual Basic Visual C++
public static TreeNode BuildEDIDocumentTree(
    EDIDocument document,
    bool expandLoopNode
)
Public Shared Function BuildEDIDocumentTree ( _
    document As EDIDocument, _
    expandLoopNode As Boolean _
) As TreeNode
public:
static TreeNode^ BuildEDIDocumentTree(
    EDIDocument^ document,
    bool expandLoopNode
)
Parameters
document (EDIDocument)
The document.
expandLoopNode (Boolean)
if set to true [expand loop node].
Return Value

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


BuildRulesTree Method (reader)

BuildRulesTree Method (reader)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► TreeGenerator ► BuildRulesTree(EDIRulesReader)
Builds the rules tree.
Declaration Syntax
C# Visual Basic Visual C++
public static TreeNode BuildRulesTree(
    EDIRulesReader reader
)
Public Shared Function BuildRulesTree ( _
    reader As EDIRulesReader _
) As TreeNode
public:
static TreeNode^ BuildRulesTree(
    EDIRulesReader^ reader
)
Parameters
reader (EDIRulesReader)
The reader.
Return Value

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


BuildValidatedDataTree Method (validator)

BuildValidatedDataTree Method (validator)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms ► TreeGenerator ► BuildValidatedDataTree(EDIValidator)
Builds the validated data tree.
Declaration Syntax
C# Visual Basic Visual C++
public static TreeNode BuildValidatedDataTree(
    EDIValidator validator
)
Public Shared Function BuildValidatedDataTree ( _
    validator As EDIValidator _
) As TreeNode
public:
static TreeNode^ BuildValidatedDataTree(
    EDIValidator^ validator
)
Parameters
validator (EDIValidator)
The validator.
Return Value

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


RDPCrystalEDILibrary.UI.Winforms.Controls Namespace

RDPCrystalEDILibrary.UI.Winforms.Controls Namespace
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls
Declaration Syntax
C# Visual Basic Visual C++
namespace RDPCrystalEDILibrary.UI.Winforms.Controls
Namespace RDPCrystalEDILibrary.UI.Winforms.Controls
namespace RDPCrystalEDILibrary.UI.Winforms.Controls
Types
All Types Classes Delegates
Icon | Type | Description
 | EDIDocumentViewer | A high performance, low memory UI component that allows you to view your loaded documents in a hierarchical fashion
 | ValidationUnit..::..ErrorEvent |
 | ValidationUnit..::..ValidationButtonClickedEvent |
 | ValidationUnit..::..ValidationCompletedEvent |
 | ValidationUnit |


EDIDocumentViewer Class

EDIDocumentViewer Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer
A high performance, low memory UI component that allows you to view your loaded documents in a hierarchical fashion
Declaration Syntax
C# Visual Basic Visual C++
public class EDIDocumentViewer : UserControl
Public Class EDIDocumentViewer _
    Inherits UserControl
public ref class EDIDocumentViewer : public UserControl
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EDIDocumentViewer()()()() | Initializes a new instance of the EDIDocumentViewer class.
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
 | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
 | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
 | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
 | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates a handle for the control. (Inherited from Control.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DocumentCreator |
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
 | LoadDocument(EDILightWeightDocument) | Loads a EDILightWeightDocument into the EDIDocumentViewer
 | LoadDocument(EDIDocument) | Loads a EDIDocument into the EDIDocumentViewer
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NodeSelected | Occurs when a node is selected
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | Raises the FontChanged event. (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | Raises the HandleCreated event. (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | Raises the HandleDestroyed event. (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | Raises the TextChanged event. (Inherited from Control.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | EDIDocumentViewer

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


EDIDocumentViewer Constructor

EDIDocumentViewer Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► EDIDocumentViewer()()()()
Initializes a new instance of the EDIDocumentViewer class.
Declaration Syntax
C# Visual Basic Visual C++
public EDIDocumentViewer()
Public Sub New
public:
EDIDocumentViewer()

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


DocumentCreator Field

DocumentCreator Field
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► DocumentCreator
Declaration Syntax
C# Visual Basic Visual C++
public DocumentCreator DocumentCreator
Public DocumentCreator As DocumentCreator
public:
DocumentCreator DocumentCreator

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


LoadDocument Method

LoadDocument Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► LoadDocument()()()()
Members
Icon | Member | Description
 | LoadDocument(EDILightWeightDocument) | Loads a EDILightWeightDocument into the EDIDocumentViewer
 | LoadDocument(EDIDocument) | Loads a EDIDocument into the EDIDocumentViewer

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


LoadDocument Method (document)

LoadDocument Method (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► LoadDocument(EDIDocument)
Loads a EDIDocument into the EDIDocumentViewer
Declaration Syntax
C# Visual Basic Visual C++
public void LoadDocument(
    EDIDocument document
)
Public Sub LoadDocument ( _
    document As EDIDocument _
)
public:
void LoadDocument(
    EDIDocument^ document
)
Parameters
document (EDIDocument)
the document to load

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


LoadDocument Method (document)

LoadDocument Method (document)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► LoadDocument(EDILightWeightDocument)
Loads a EDILightWeightDocument into the EDIDocumentViewer
Declaration Syntax
C# Visual Basic Visual C++
public void LoadDocument(
    EDILightWeightDocument document
)
Public Sub LoadDocument ( _
    document As EDILightWeightDocument _
)
public:
void LoadDocument(
    EDILightWeightDocument^ document
)
Parameters
document (EDILightWeightDocument)
the document to load

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


NodeSelected Event

NodeSelected Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► NodeSelected
Occurs when a node is selected
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler<EDINodeSelectedEventArgs> NodeSelected
Public Event NodeSelected As EventHandler(Of EDINodeSelectedEventArgs)
public:
 event EventHandler<EDINodeSelectedEventArgs^>^ NodeSelected {
    void add (EventHandler<EDINodeSelectedEventArgs^>^ value);
    void remove (EventHandler<EDINodeSelectedEventArgs^>^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidationUnit Class

ValidationUnit Class
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit
Declaration Syntax
C# Visual Basic Visual C++
public sealed class ValidationUnit : UserControl
Public NotInheritable Class ValidationUnit _
    Inherits UserControl
public ref class ValidationUnit sealed : public UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidationUnit()()()() | Creates a new validation object
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AutoDetectDelimiters | If set the true then delimiters will be autodetected
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from UserControl.)
 | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
 | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
 | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
 | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border style of the user control. (Inherited from UserControl.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()()()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | CheckDataTypeRequirements | Check that elements values are correct for their specified data types
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::..ControlCollection. (Inherited from Control.)
 | ControlRemoved | Occurs when a control is removed from the Control..::..ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | CreateAccessibilityInstance()()()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()()()() | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
 | CreateControlsInstance()()()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()()()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()()()() | Creates a handle for the control. (Inherited from Control.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | Delimiters |
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()()()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component. (Inherited from Component.)
 | Disposed | Occurs when the component is disposed by a call to the Dispose()()()() method. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | EDIFile |
 | EDIFileBackColor |
 | EDIFileForeColor |
 | EDIFileType |
 | EDIRuleFile |
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorOccurred | Event raised when an unexpected error occurrs
 | ErrorTableBackColor |
 | ErrorTableForeColor | Forecolor color of Error table
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | ExportToCSV(String) | Export Errors and Warnings to Comma Separated File list
 | Finalize()()()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()()()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()()()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()()()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()()()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()()()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()()()() | Conceals the control from the user. (Inherited from Control.)
 | HideEDIFIleSection |
 | HideLoadDataSection |
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()()()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()()()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
 | LoadFile |
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | NumberOfErrors |
 | NumberOfWarnings |
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()()()() | Raises the CreateControl event. (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | Raises the FontChanged event. (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | Raises the HandleCreated event. (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | Raises the HandleDestroyed event. (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | Raises the Layout event. (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
 | OnPaint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnPaintBackground(PaintEventArgs) | Paints the background of the control. (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | Raises the TextChanged event. (Inherited from Control.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()()()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreventInfiniteLoopWhileSearching | If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()()()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()()()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
 | ResetBackColor()()()() | Resets the BackColor property to its default value. (Inherited from Control.)
 | ResetBindings()()()() | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
 | ResetCursor()()()() | Resets the Cursor property to its default value. (Inherited from Control.)
 | ResetFont()()()() | Resets the Font property to its default value. (Inherited from Control.)
 | ResetForeColor()()()() | Resets the ForeColor property to its default value. (Inherited from Control.)
 | ResetImeMode()()()() | Resets the ImeMode property to its default value. (Inherited from Control.)
 | ResetMouseEventArgs()()()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()()()() | Resets the RightToLeft property to its default value. (Inherited from Control.)
 | ResetText()()()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | ResumeLayout()()()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | Select()()()() | Activates the control. (Inherited from Control.)
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()()()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | Show()()()() | Displays the control to the user. (Inherited from Control.)
 | ShowErrorGridLines |
 | ShowFileGridLines | Show gridlines on the loaded file
 | ShowFileInputSection |
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | ShowProgressSection |
 | ShowWarningGridLines |
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuppressValidationCompleteMessage |
 | SuspendLayout()()()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | Raises the TextChanged event. (Inherited from UserControl.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TrackDownUnrecognizedLoops | If set to true then when a loop is unrecognized a search will be made if to see if a loop like that even exists in the EDI rules, if not an error will be generated
 | TrimString | String to ignore at between segment delimiters
 | Update()()()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()()()() | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
 | UpdateStyles()()()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()()()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()()()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | ValidateFile()()()() | Validate an EDI file
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | ValidationButtonClicked | Event raised when the validation button is clicked
 | ValidationCompleted | Event raised when validation has completed
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | WarningTableBackColor | Background color of Warning table
 | WarningTableForeColor |
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | ValidationUnit

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidationUnit Constructor

ValidationUnit Constructor
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationUnit()()()()
Creates a new validation object
Declaration Syntax
C# Visual Basic Visual C++
public ValidationUnit()
Public Sub New
public:
ValidationUnit()

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


AutoDetectDelimiters Property

AutoDetectDelimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► AutoDetectDelimiters
If set the true then delimiters will be autodetected
Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectDelimiters { get; set; }
Public Property AutoDetectDelimiters As Boolean
    Get
    Set
public:
property bool AutoDetectDelimiters {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


CheckDataTypeRequirements Property

CheckDataTypeRequirements Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► CheckDataTypeRequirements
Check that elements values are correct for their specified data types
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckDataTypeRequirements { get; set; }
Public Property CheckDataTypeRequirements As Boolean
    Get
    Set
public:
property bool CheckDataTypeRequirements {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Delimiters Property

Delimiters Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Delimiters
Declaration Syntax
C# Visual Basic Visual C++
public Delimiters Delimiters { get; set; }
Public Property Delimiters As Delimiters
    Get
    Set
public:
property Delimiters^ Delimiters {
    Delimiters^ get ();
    void set (Delimiters^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method (disposing)

Dispose Method (disposing)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Dispose(Boolean)
Clean up any resources being used.
Declaration Syntax
C# Visual Basic Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override
Parameters
disposing (Boolean)
true if managed resources should be disposed; otherwise, false.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


EDIFile Property

EDIFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIFile
Declaration Syntax
C# Visual Basic Visual C++
public string EDIFile { get; set; }
Public Property EDIFile As String
    Get
    Set
public:
property String^ EDIFile {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


EDIFileBackColor Property

EDIFileBackColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIFileBackColor
Declaration Syntax
C# Visual Basic Visual C++
public Color EDIFileBackColor { get; set; }
Public Property EDIFileBackColor As Color
    Get
    Set
public:
property Color EDIFileBackColor {
    Color get ();
    void set (Color value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


EDIFileForeColor Property

EDIFileForeColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIFileForeColor
Declaration Syntax
C# Visual Basic Visual C++
public Color EDIFileForeColor { get; set; }
Public Property EDIFileForeColor As Color
    Get
    Set
public:
property Color EDIFileForeColor {
    Color get ();
    void set (Color value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


EDIFileType Property

EDIFileType Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIFileType
Declaration Syntax
C# Visual Basic Visual C++
public FileType EDIFileType { get; set; }
Public Property EDIFileType As FileType
    Get
    Set
public:
property FileType EDIFileType {
    FileType get ();
    void set (FileType value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


EDIRuleFile Property

EDIRuleFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► EDIRuleFile
Declaration Syntax
C# Visual Basic Visual C++
public string EDIRuleFile { get; set; }
Public Property EDIRuleFile As String
    Get
    Set
public:
property String^ EDIRuleFile {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ErrorOccurred Event

ErrorOccurred Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ErrorOccurred
Event raised when an unexpected error occurrs
Declaration Syntax
C# Visual Basic Visual C++
public event ValidationUnit..::..ErrorEvent ErrorOccurred
Public Event ErrorOccurred As ValidationUnit..::..ErrorEvent
public:
 event ValidationUnit..::..ErrorEvent^ ErrorOccurred {
    void add (ValidationUnit..::..ErrorEvent^ value);
    void remove (ValidationUnit..::..ErrorEvent^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ErrorTableBackColor Property

ErrorTableBackColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ErrorTableBackColor
Declaration Syntax
C# Visual Basic Visual C++
public Color ErrorTableBackColor { get; set; }
Public Property ErrorTableBackColor As Color
    Get
    Set
public:
property Color ErrorTableBackColor {
    Color get ();
    void set (Color value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ErrorTableForeColor Property

ErrorTableForeColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ErrorTableForeColor
Forecolor color of Error table
Declaration Syntax
C# Visual Basic Visual C++
public Color ErrorTableForeColor { get; set; }
Public Property ErrorTableForeColor As Color
    Get
    Set
public:
property Color ErrorTableForeColor {
    Color get ();
    void set (Color value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ExportToCSV Method (filePath)

ExportToCSV Method (filePath)
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ExportToCSV(String)
Export Errors and Warnings to Comma Separated File list
Declaration Syntax
C# Visual Basic Visual C++
public void ExportToCSV(
    string filePath
)
Public Sub ExportToCSV ( _
    filePath As String _
)
public:
void ExportToCSV(
    String^ filePath
)
Parameters
filePath (String)
path and name of file

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


HideEDIFIleSection Property

HideEDIFIleSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► HideEDIFIleSection
Declaration Syntax
C# Visual Basic Visual C++
public bool HideEDIFIleSection { get; set; }
Public Property HideEDIFIleSection As Boolean
    Get
    Set
public:
property bool HideEDIFIleSection {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


HideLoadDataSection Property

HideLoadDataSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► HideLoadDataSection
Declaration Syntax
C# Visual Basic Visual C++
public bool HideLoadDataSection { get; set; }
Public Property HideLoadDataSection As Boolean
    Get
    Set
public:
property bool HideLoadDataSection {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


LoadFile Property

LoadFile Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► LoadFile
Declaration Syntax
C# Visual Basic Visual C++
public bool LoadFile { get; set; }
Public Property LoadFile As Boolean
    Get
    Set
public:
property bool LoadFile {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


NumberOfErrors Property

NumberOfErrors Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► NumberOfErrors
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfErrors { get; }
Public ReadOnly Property NumberOfErrors As Integer
    Get
public:
property int NumberOfErrors {
    int get ();
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


NumberOfWarnings Property

NumberOfWarnings Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► NumberOfWarnings
Declaration Syntax
C# Visual Basic Visual C++
public int NumberOfWarnings { get; }
Public ReadOnly Property NumberOfWarnings As Integer
    Get
public:
property int NumberOfWarnings {
    int get ();
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


PreventInfiniteLoopWhileSearching Property

PreventInfiniteLoopWhileSearching Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► PreventInfiniteLoopWhileSearching
If set to true then when a required loop is not found EDI Validator will try to detect when an infinite loop scenario may be occurring
Declaration Syntax
C# Visual Basic Visual C++
public bool PreventInfiniteLoopWhileSearching { get; set; }
Public Property PreventInfiniteLoopWhileSearching As Boolean
    Get
    Set
public:
property bool PreventInfiniteLoopWhileSearching {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ShowErrorGridLines Property

ShowErrorGridLines Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ShowErrorGridLines
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowErrorGridLines { get; set; }
Public Property ShowErrorGridLines As Boolean
    Get
    Set
public:
property bool ShowErrorGridLines {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ShowFileGridLines Property

ShowFileGridLines Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ShowFileGridLines
Show gridlines on the loaded file
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowFileGridLines { get; set; }
Public Property ShowFileGridLines As Boolean
    Get
    Set
public:
property bool ShowFileGridLines {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ShowFileInputSection Property

ShowFileInputSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ShowFileInputSection
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowFileInputSection { get; set; }
Public Property ShowFileInputSection As Boolean
    Get
    Set
public:
property bool ShowFileInputSection {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ShowProgressSection Property

ShowProgressSection Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ShowProgressSection
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowProgressSection { get; set; }
Public Property ShowProgressSection As Boolean
    Get
    Set
public:
property bool ShowProgressSection {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ShowWarningGridLines Property

ShowWarningGridLines Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ShowWarningGridLines
Declaration Syntax
C# Visual Basic Visual C++
public bool ShowWarningGridLines { get; set; }
Public Property ShowWarningGridLines As Boolean
    Get
    Set
public:
property bool ShowWarningGridLines {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


SuppressValidationCompleteMessage Property

SuppressValidationCompleteMessage Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► SuppressValidationCompleteMessage
Declaration Syntax
C# Visual Basic Visual C++
public bool SuppressValidationCompleteMessage { get; set; }
Public Property SuppressValidationCompleteMessage As Boolean
    Get
    Set
public:
property bool SuppressValidationCompleteMessage {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


TrackDownUnrecognizedLoops Property

TrackDownUnrecognizedLoops Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► TrackDownUnrecognizedLoops
If set to true then when a loop is unrecognized a search will be made if to see if a loop like that even exists in the EDI rules, if not an error will be generated
Declaration Syntax
C# Visual Basic Visual C++
public bool TrackDownUnrecognizedLoops { get; set; }
Public Property TrackDownUnrecognizedLoops As Boolean
    Get
    Set
public:
property bool TrackDownUnrecognizedLoops {
    bool get ();
    void set (bool value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


TrimString Property

TrimString Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► TrimString
String to ignore at between segment delimiters
Declaration Syntax
C# Visual Basic Visual C++
public string TrimString { get; set; }
Public Property TrimString As String
    Get
    Set
public:
property String^ TrimString {
    String^ get ();
    void set (String^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidateFile Method

ValidateFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidateFile()()()()
Validate an EDI file
Declaration Syntax
C# Visual Basic Visual C++
public void ValidateFile()
Public Sub ValidateFile
public:
void ValidateFile()

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidationButtonClicked Event

ValidationButtonClicked Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationButtonClicked
Event raised when the validation button is clicked
Declaration Syntax
C# Visual Basic Visual C++
public event ValidationUnit..::..ValidationButtonClickedEvent ValidationButtonClicked
Public Event ValidationButtonClicked As ValidationUnit..::..ValidationButtonClickedEvent
public:
 event ValidationUnit..::..ValidationButtonClickedEvent^ ValidationButtonClicked {
    void add (ValidationUnit..::..ValidationButtonClickedEvent^ value);
    void remove (ValidationUnit..::..ValidationButtonClickedEvent^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidationCompleted Event

ValidationCompleted Event
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationCompleted
Event raised when validation has completed
Declaration Syntax
C# Visual Basic Visual C++
public event ValidationUnit..::..ValidationCompletedEvent ValidationCompleted
Public Event ValidationCompleted As ValidationUnit..::..ValidationCompletedEvent
public:
 event ValidationUnit..::..ValidationCompletedEvent^ ValidationCompleted {
    void add (ValidationUnit..::..ValidationCompletedEvent^ value);
    void remove (ValidationUnit..::..ValidationCompletedEvent^ value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


WarningTableBackColor Property

WarningTableBackColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► WarningTableBackColor
Background color of Warning table
Declaration Syntax
C# Visual Basic Visual C++
public Color WarningTableBackColor { get; set; }
Public Property WarningTableBackColor As Color
    Get
    Set
public:
property Color WarningTableBackColor {
    Color get ();
    void set (Color value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


WarningTableForeColor Property

WarningTableForeColor Property
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► WarningTableForeColor
Declaration Syntax
C# Visual Basic Visual C++
public Color WarningTableForeColor { get; set; }
Public Property WarningTableForeColor As Color
    Get
    Set
public:
property Color WarningTableForeColor {
    Color get ();
    void set (Color value);
}

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidationUnit.ErrorEvent Delegate

ValidationUnit..::..ErrorEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationUnit..::..ErrorEvent
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ErrorEvent(
    Object sender,
    GeneralEventArgs e
)
Public Delegate Sub ErrorEvent ( _
    sender As Object, _
    e As GeneralEventArgs _
)
public delegate void ErrorEvent(
    Object^ sender,
    GeneralEventArgs^ e
)
Parameters
sender (Object)
e (GeneralEventArgs)

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidationUnit.ValidationButtonClickedEvent Delegate

ValidationUnit..::..ValidationButtonClickedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationUnit..::..ValidationButtonClickedEvent
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ValidationButtonClickedEvent(
    Object sender
)
Public Delegate Sub ValidationButtonClickedEvent ( _
    sender As Object _
)
public delegate void ValidationButtonClickedEvent(
    Object^ sender
)
Parameters
sender (Object)

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidationUnit.ValidationCompletedEvent Delegate

ValidationUnit..::..ValidationCompletedEvent Delegate
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidationUnit..::..ValidationCompletedEvent
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ValidationCompletedEvent(
    Object sender,
    ValidationEventsArgs e
)
Public Delegate Sub ValidationCompletedEvent ( _
    sender As Object, _
    e As ValidationEventsArgs _
)
public delegate void ValidationCompletedEvent(
    Object^ sender,
    ValidationEventsArgs^ e
)
Parameters
sender (Object)
e (ValidationEventsArgs)

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ConvertFromInvariantString Method

ConvertFromInvariantString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertFromInvariantString()()()()
Members
Icon | Member | Description
 | ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture.
 | ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


IsValid Method

IsValid Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► IsValid()()()()
Members
Icon | Member | Description
 | IsValid(Object) | Returns whether the given value object is valid for this type.
 | IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetStandardValuesSupported Method

GetStandardValuesSupported Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetStandardValuesSupported()()()()
Members
Icon | Member | Description
 | GetStandardValuesSupported()()()() | Returns whether this object supports a standard set of values that can be picked from a list.
 | GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementListConditionalConstraint ► GetElementOrdinalsString()()()()
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ResumeLayout Method

ResumeLayout Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ResumeLayout()()()()
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ConvertFrom Method

ConvertFrom Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertFrom()()()()
Members
Icon | Member | Description
 | ConvertFrom(Object) | Converts the given value to the type of this converter.
 | ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | Converts the given object to the type of this converter, using the specified context and culture information.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


PerformLayout Method

PerformLayout Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► PerformLayout()()()()
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


UpdateBounds Method

UpdateBounds Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► UpdateBounds()()()()
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Select Method

Select Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Select()()()()
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


RtlTranslateAlignment Method

RtlTranslateAlignment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► RtlTranslateAlignment()()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


GetStandardValues Method

GetStandardValues Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetStandardValues()()()()
Members
Icon | Member | Description
 | GetStandardValues()()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for.
 | GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


SetBounds Method

SetBounds Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► SetBounds()()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesCreator ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetCreateInstanceSupported Method

GetCreateInstanceSupported Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetCreateInstanceSupported()()()()
Members
Icon | Member | Description
 | GetCreateInstanceSupported()()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value.
 | GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Invalidate Method

Invalidate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


SetBounds Method

SetBounds Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► SetBounds()()()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ToEDIString Method

ToEDIString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12 ► X125010Document ► ToEDIString()()()()
Members
Icon | Member | Description
 | ToEDIString(WriteArguments) | Generate EDI data from the underlying document
 | ToEDIString(Delimiters) | Generate EDI data from the underlying document

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ConvertToString Method

ConvertToString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertToString()()()()
Members
Icon | Member | Description
 | ConvertToString(Object) | Converts the specified value to a string representation.
 | ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context.
 | ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GenerateEDIFile Method

GenerateEDIFile Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.Documents.X12 ► X125010Document ► GenerateEDIFile()()()()
Members
Icon | Member | Description
 | GenerateEDIFile(Delimiters, String) | Generate EDI data from the underlying document and writes it to a file
 | GenerateEDIFile(WriteArguments, String) | Generate EDI data from the underlying document

Assembly: RDPCrystalEDILibrary.Documents (Module: RDPCrystalEDILibrary.Documents) Version: 8.3.0.1 (8.3.0.1)


UpdateBounds Method

UpdateBounds Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► UpdateBounds()()()()
Members
Icon | Member | Description
 | UpdateBounds()()()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileJoiner ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ConvertFromString Method

ConvertFromString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertFromString()()()()
Members
Icon | Member | Description
 | ConvertFromString(String) | Converts the specified text to an object.
 | ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context.
 | ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RtlTranslateAlignment Method

RtlTranslateAlignment Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► RtlTranslateAlignment()()()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Validate Method

Validate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Validate()()()()
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Invoke Method

Invoke Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Invoke()()()()
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateSegmentLoop Method

CreateSegmentLoop Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► Loop ► CreateSegmentLoop()()()()
Members
Icon | Member | Description
 | CreateSegmentLoop(String, Int32, Int32, Usage, String) |
 | CreateSegmentLoop(String) |

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileSplitter ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Invalidate Method

Invalidate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Invalidate()()()()
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate()()()() | Invalidates the entire surface of the control and causes the control to be redrawn.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDILightWeightDocument ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ResumeLayout Method

ResumeLayout Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► ResumeLayout()()()()
Members
Icon | Member | Description
 | ResumeLayout()()()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


PerformLayout Method

PerformLayout Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► PerformLayout()()()()
Members
Icon | Member | Description
 | PerformLayout()()()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


GetChildAtPoint Method

GetChildAtPoint Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► GetChildAtPoint()()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides ContainerControl.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► AccessibilityNotifyClients()()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementConditionalConstraint ► GetElementOrdinalsString()()()()
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Select Method

Select Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Select()()()()
Members
Icon | Member | Description
 | Select(Boolean, Boolean) | (Overrides Control.Select(Boolean, Boolean).)
 | Select()()()() | Activates the control.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ConvertToInvariantString Method

ConvertToInvariantString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertToInvariantString()()()()
Members
Icon | Member | Description
 | ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation.
 | ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Invoke Method

Invoke Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Invoke()()()()
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIRulesReader ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CreateInstance Method

CreateInstance Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► CreateInstance()()()()
Members
Icon | Member | Description
 | CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object.
 | CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetChildAtPoint Method

GetChildAtPoint Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► GetChildAtPoint()()()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementRequiredConstraint ► GetElementOrdinalsString()()()()
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetPropertiesSupported Method

GetPropertiesSupported Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetPropertiesSupported()()()()
Members
Icon | Member | Description
 | GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Overrides TypeConverter.GetPropertiesSupported(ITypeDescriptorContext).)
 | GetPropertiesSupported()()()() | Returns whether this object supports properties.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


GetStandardValuesExclusive Method

GetStandardValuesExclusive Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetStandardValuesExclusive()()()()
Members
Icon | Member | Description
 | GetStandardValuesExclusive()()()() | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list.
 | GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()()() is an exclusive list of possible values, using the specified context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileScrubber ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► AccessibilityNotifyClients()()()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetProperties Method

GetProperties Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► GetProperties()()()()
Members
Icon | Member | Description
 | GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Overrides TypeConverter.GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[][]).)
 | GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter.
 | GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Scale Method

Scale Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► Scale()()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


CanConvertTo Method

CanConvertTo Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► CanConvertTo()()()()
Members
Icon | Member | Description
 | CanConvertTo(ITypeDescriptorContext, Type) | Returns whether this converter can convert the object to the specified type, using the specified context. (Overrides TypeConverter.CanConvertTo(ITypeDescriptorContext, Type).)
 | CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ConvertTo Method

ConvertTo Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► ConvertTo()()()()
Members
Icon | Member | Description
 | ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | Converts the given value object to the specified type, using the specified context and culture information. (Overrides TypeConverter.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
 | ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIFileLoader ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIDocument ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


RDPCrystalEDILibrary

RDPCrystalEDILibrary
RDPCrystalEDILibrary
Namespaces
Namespace | Description
RDPCrystalEDILibrary | RDPCrystal EDI Library
RDPCrystalEDILibrary.Documents |
RDPCrystalEDILibrary.Documents.X12 |
RDPCrystalEDILibrary.Documents.X12.IG5010.Segments |
RDPCrystalEDILibrary.Rules |
RDPCrystalEDILibrary.UI.Winforms |
RDPCrystalEDILibrary.UI.Winforms.Controls |


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► FormPrinter ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


CanConvertFrom Method

CanConvertFrom Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► GeneralTypeConverter ► CanConvertFrom()()()()
Members
Icon | Member | Description
 | CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter.
 | CanConvertFrom(ITypeDescriptorContext, Type) | Returns whether this converter can convert an object of the given type to the type of this converter, using the specified context.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


Validate Method

Validate Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Validate()()()()
Members
Icon | Member | Description
 | Validate()()()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


ValidateChildren Method

ValidateChildren Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► ValidateChildren()()()()
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► EDIValidator ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


GetElementOrdinalsString Method

GetElementOrdinalsString Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► ElementExclusionConstraint ► GetElementOrdinalsString()()()()
Members
Icon | Member | Description
 | GetElementOrdinalsString()()()() | Get a list of the element ordinals involved in the contraint as a space delimited list
 | GetElementOrdinalsString(Int32) | Get a list of the element ordinals involved in the contraint as a space delimited list

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


ValidateChildren Method

ValidateChildren Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► ValidateChildren()()()()
Members
Icon | Member | Description
 | ValidateChildren()()()() | (Overrides ContainerControl.ValidateChildren()()()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Scale Method

Scale Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► Scale()()()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete. Scales the control and any child controls.
 | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


BeginInvoke Method

BeginInvoke Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► EDIDocumentViewer ► BeginInvoke()()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


MemberwiseClone Method

MemberwiseClone Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTP ► MemberwiseClone()()()()
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()()() | Creates a shallow copy of the current Object.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)


BeginInvoke Method

BeginInvoke Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary.UI.Winforms.Controls ► ValidationUnit ► BeginInvoke()()()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()[][]) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.

Assembly: RDPCrystalEDILibrary.UI.Winforms (Module: RDPCrystalEDILibrary.UI.Winforms) Version: 8.3.0.1 (8.3.0.1)


Dispose Method

Dispose Method
RDPCrystalEDILibrary ► RDPCrystalEDILibrary ► HTTPS ► Dispose()()()()
Members
Icon | Member | Description
 | Dispose(Boolean) | Clean up any resources being used. (Overrides Component.Dispose(Boolean).)
 | Dispose()()()() | Releases all resources used by the Component.

Assembly: RDPCrystalEDILibrary (Module: RDPCrystalEDILibrary) Version: 8.3.0.1 (8.3.0.1)